1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

FAT32 Sticks lassen sich nicht mehr mounten unter KDE4

Dieses Thema im Forum "FreeBSD - Allgemein" wurde erstellt von Lance, 28 November 2017.

  1. Lance

    Lance Member

    Registriert seit:
    26 Oktober 2015
    Beiträge:
    364
    Hallo,

    hatte grad auf einem PC FreeBSD 11.1 frisch aufgesetzt und festgestellt, dass meine 2 FAT32-Sticks nicht mehr gemounted werden. Ich kenne das seit FBSD 10.X dass es ohne extra Zutun in irgendwelchen Configs ging. Der folgende Fehler taucht auf beim Versuch ihn zu mounten (KDE):

    Code:
    Beim Zugriff auf "STICK" ist ein Fehler aufgetreten, die Meldung lautet:
    org.freedesktop.Hal.Device.PermissionDeniedByPolicy: org.freedesktop.hal.storage.mount-removable no <-- (action, result)
    (habe das so abgetippt, C&P geht da nicht)

    Ich wundere mich wie gesagt, weil es früher immer ging. (auch bei 11.0 bin ich der meinung)

    LG Lance
     
  2. ralli

    ralli Well-Known Member

    Registriert seit:
    1 Juni 2012
    Beiträge:
    1.771
    Sieht ganz danach aus, das Du nicht die nötigen Rechte hast. Hast Du als normaler User gemounted oder als root?
     
  3. Lance

    Lance Member

    Registriert seit:
    26 Oktober 2015
    Beiträge:
    364
    Als "staff" user, was wie gesagt immer ging. Nach eintrag von vfs.usermount=1 ging es auch noch nicht.
    Sieht mir nach devfs.conf und konsorten aus. Kann es erst morgen testen.
     
  4. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.237
    falsche Policy für Wechselgeräte.
    Such mal danach, es gibt dazu auch Beschreibungen für FreeBSD, ziemlich alt zwar, aber vielleicht noch anwendbar. https://www.freebsd.org/gnome/docs/halfaq.html sagt etwas dazu, aber ich hatte das damals dann irgendwie anders gelöst und nicht nur einen User berechtigt.
    Ich meine sogar, dass es in den Ports damals eigene FreeBSD angepasste PolicyKits gab.
     
  5. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.135
    Wenn Du von FAT32-Sticks sprichst, die nicht mehr gemountet werden, heißt das denn, dass FAT16 wohl gemountet wird, oder auch nicht?
     
  6. bluescreen

    bluescreen verstört

    Registriert seit:
    3 Oktober 2005
    Beiträge:
    481
    Ort:
    /home
    Moin !

    Versuch es mal mit bearbeiten von :

    /usr/local/etc/PolicyKit/PolicyKit.conf

    In die Zeile in der root steht , den User hinzufügen !

    Hier mal meine :

    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

    <!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"
    "http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">

    <!-- See the manual page PolicyKit.conf(5) for file format -->

    <config version="0.1">
    <match action="org.freedesktop.hal.storage.mount-removable">
    <return result="yes"/>
    </match>
    <match action="org.freedesktop.hal.storage.mount-fixed">
    <return result="yes"/>
    </match>
    <match user="root|bluescreen">
    <return result="yes"/>
    </match>
    <define_admin_auth group="wheel"/>
    </config>


    Gruss
     
    Lance gefällt das.
  7. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.135
    Das wäre auch meine nächste Antwort gewesen, @bluescreen hat völlig recht. Pipesymbol | nicht vergessen. Bin mir nicht sicher, aber ich glaube, dass Dein Benutzer für HAL auch der Gruppe "operator" angehören sollte. Bei einer Frischinstallation füge ich daher meinen Benutzer immer den Gruppen "wheel" und "operator" hinzu.
    Lass mal hören, ob es geklappt hat, ich möchte vorsichtshalber nicht auf 11.1 upgraden, bevor ich mir sicher bin, dass alles so klappt wie bisher...
     
  8. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.237
    ich bin ziemlich sicher, dass man die Zeile mit den Usern auch weglassen kann und dann alle gehen. Es braucht nur die posoitive Antwort, also ein yes auf die Frage allow zu dem gewünschten Gerätetyp.
    Welchen man da genau will, kann mit lshal ansehen, Das bietet eine Option zum fortlaufenden Schreiben der Ausgabe. Dann sieht man, was erkannt und welche policy aufgerufen wird.
    Dann heißt es nur noch testen und so lange friemeln, bis es geht.
    Bis zum nächsten Hal-Update.
     
  9. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.237
  10. Lance

    Lance Member

    Registriert seit:
    26 Oktober 2015
    Beiträge:
    364
    Danke schonmal für die vielversprechenden Antworten! Morgen gegen 11 Uhr werde ich berichten.

    Schöne Grüße Lance
     
  11. Lance

    Lance Member

    Registriert seit:
    26 Oktober 2015
    Beiträge:
    364
    Guten Morgen,

    Leider ohne Erfolg. Weder das Auskommentieren oder Löschen der Zeile

    Code:
    <match user="root">
    noch das Einfügen und Anpassen bluescreens codes in die PolicyKit.conf brachte irgendeine Änderung. Ich vermute ich muss nach /usr/local/share/PolicyKit/policy und dort die Datei org.freedesktop.hal.storage.policy editieren.

    Ach noch etwas. Vielleicht habe ich bei der Installation von FreeBSD den "Fehler" gemacht, die User noch gleich nach der Installation hinzuzufügen anstatt nach dem ersten Reboot wie ich es sonst immer mache.

    EDIT: ich glaube meine Vermutung ist falsch, das sind wohl nur Definitionen, jedenfalls sieht der Eintrag zu den Removable Devices so aus:

    Code:
    <action id="org.freedesktop.hal.storage.mount-removable">
        <description>Mount file systems from removable drives.</description>
        <message>System policy prevents mounting removable media</message>
        <defaults>
          <allow_inactive>no</allow_inactive>
          <allow_active>yes</allow_active>
        </defaults>
      </action>
    
    EDIT2: War doch n Treffer, nach vertauschen von yes und no geht es jetzt!
     
    Zuletzt bearbeitet: 30 November 2017
  12. KobRheTilla

    KobRheTilla used register

    Registriert seit:
    20 Januar 2011
    Beiträge:
    1.184
    Das ist so ziemlich egal.

    Rob
     
  13. Lance

    Lance Member

    Registriert seit:
    26 Oktober 2015
    Beiträge:
    364
    Noch n Hinweis, hab die /usr/local/etc/PolicyKit/PolicyKit.conf auf den Standardeintrag zurückgesetzt, es funktioniert immer noch!

    (Der Standardeintrag war
    Code:
    <config version="0.1">
        <match user="root">
            <return result="yes"/>
        </match>
        <define_admin_auth group="wheel"/>
    </config>