1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

FreeBSD on bare metal Dell L502X

Dieses Thema im Forum "FreeBSD - Allgemein" wurde erstellt von schorsch_76, 14 Juni 2017.

  1. schorsch_76

    schorsch_76 Member

    Registriert seit:
    25 Dezember 2013
    Beiträge:
    64
    Hallo Kollegen,

    ich hab jetzt auf meinem Dell L502X (Sandy Bridge Generation) FreeBSD 11 auf einem Slice (Partition) installiert. Wie es scheint kann ich ZFS nur auf der ganzen Platte nutzen wenn ich davon booten will. Meine Experimente waren in einer VM. Ok, kein Thema dann eben UFS. Ich hab noch Win und Linux parallel installiert. Jetzt hab ich noch zwei kleinere Punkte bei denen ich einen Tipp in die richtige Richtung brauche:

    a) WLAN geht soweit, es ist nur beim Start nicht stabil das der wpa_supplicant mit dem AP verbindet. Bringe ich das Interface manuell hoch und starte dann nach ein paar sec den wpa_supplicant auf der Konsole geht es immer. Was kann ich hier machen?

    b) shutdown -h now: Das fährt den Rechner runter aber der Rechner bleibt an. An meinen Desktop Rechner schaltet das auch den Rechner ganz aus. Kann man hier was tricksen?

    Gruß
    Georg
     
  2. Rakor

    Rakor Moderator Mitarbeiter

    Registriert seit:
    17 September 2009
    Beiträge:
    2.007
    Ort:
    Mannheim
    a) kann sein, dass die Firmware noch nicht fertig ist. Ich glaube dafür gab es ne Option, dass er wartet.

    b) shutdown -p
    -p poweroff (Ausschalten)
    -h halt (nur runterfahren)
     
  3. mogbo

    mogbo Does it run under Windows? Who cares?

    Registriert seit:
    12 September 2016
    Beiträge:
    466
    Evtl ans Ende des Bootvorgangs schieben, sprich in die /etc/rc.local einbauen oder mit einem cronjob

    rc.local
    Code:
    /bin/sh /pfad/zum/script.sh &
    
    script.sh
    Code:
    #!/bin/sh
    sleep xy
    sh wpa_startkommando
    
    Workarounds die keiner gerne mag
     
  4. schorsch_76

    schorsch_76 Member

    Registriert seit:
    25 Dezember 2013
    Beiträge:
    64
    Danke! Das hat fuktioniert. Auch die rc.local hat funktioniert :)