1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Kann keine Datenbank erstellen/importieren mit mysql

Dieses Thema im Forum "FreeBSD - Anwendungen und Ports" wurde erstellt von cabriofahrer, 11 Februar 2018.

  1. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.219
    Ich möchte mich zu Trainingszwecken mit mysql beschäftigen und komme schon gleich zu Anfang nicht klar. Ich kann noch nichteinmal eine neue Datenbank erstellen. Hier ist, was ich soweit getan habe:

    #service mysql-server onestart

    In anderem Terminal dann:

    $mysql

    Code:
    $ mysql
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 7
    Server version: 5.6.38 Source distribution
    
    Copyright (c) 2000, 2017, Oracle and/or its affiliates. All rights reserved.
    
    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    mysql> create database employees;
    ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'employees'
    mysql> status
    --------------
    mysql  Ver 14.14 Distrib 5.6.38, for FreeBSD11.0 (amd64) using  EditLine wrapper
    
    Connection id:          7
    Current database:
    Current user:           werner@localhost
    SSL:                    Not in use
    Current pager:          more
    Using outfile:          ''
    Using delimiter:        ;
    Server version:         5.6.38 Source distribution
    Protocol version:       10
    Connection:             Localhost via UNIX socket
    Server characterset:    latin1
    Db     characterset:    latin1
    Client characterset:    latin1
    Conn.  characterset:    latin1
    UNIX socket:            /tmp/mysql.sock
    Uptime:                 15 min 43 sec
    
    Threads: 1  Questions: 31  Slow queries: 0  Opens: 67  Flush tables: 1  Open tables: 60  Queries per second avg: 0.032
    --------------
    
    mysql>
    Wie man sieht, kann ich keine Datenbank erstellen, siehe oben "create database employees;"

    Warum nicht? Ich nehme an, ich muss da noch vorher irgendetwas konfigurieren?
     
  2. Rakor

    Rakor Administrator Mitarbeiter

    Registriert seit:
    17 September 2009
    Beiträge:
    2.090
    Ort:
    Mannheim
    Steht doch da. Du hast keine Rechte. In mysql gibt es auch einen Benutzer 'root' der volle Rechte hat. Les dich mal in die Benutzer- und Rechtestruktur ein.
     
  3. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.219
    So etwas hatte ich mir gedacht. Leider weiß ich nicht, wonach ich genau suchen soll in dieser Masse von Informationen der MySQL-Seite. Wärst Du bitte so freundlich, mir hier die URL zum relevanten Kapitel zu posten?
     
  4. double-p

    double-p BOFH

    Registriert seit:
    6 September 2003
    Beiträge:
    729
    Ort:
    Buxtehude, Germany
  5. foxit

    foxit Moderator Mitarbeiter

    Registriert seit:
    4 Juli 2012
    Beiträge:
    1.484
    Ort:
    /home
    cabriofahrer gefällt das.
  6. KobRheTilla

    KobRheTilla used register

    Registriert seit:
    20 Januar 2011
    Beiträge:
    1.265
    @cabriofahrer Um dich als root zu verbinden, nutze einfach den Parameter -u root beim Aufruf des MySQL-Kommandozeilentools.
    Der vorangelegte root-Account hat kein Passwort, dieses solltest du auf jeden Fall setzen.

    Das Skript mysql_secure_installation nimmt dir da einiges an Arbeit ab - ist aber für den Betrieb als solchen nicht zwingend.

    Rob
     
    cabriofahrer gefällt das.
  7. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.219
    Wunderbar, hat geklappt! Ich konnte so auch eine Testdatenbank importieren und gleich einige Abfragen testen.

    Wie geht das genau?

    Wozu genau würde ich das denn brauchen, wenn "mysql -u root" schon geklappt hat?

    In dem von @foxit vorgeschlagenen Artikel findet sich folgender Eintrag für die /etc/rc.conf:

    Code:
    mysql_enable="YES"
    mysql_args="--bind-address=127.0.0.1"
    Ich nehme an, der Eintrag mit der computereigenen IP ist auch nicht nötig, wenn es bei mir mit "service mysql-server onestart" geklappt hat?
     
  8. foxit

    foxit Moderator Mitarbeiter

    Registriert seit:
    4 Juli 2012
    Beiträge:
    1.484
    Ort:
    /home
    Steht in dem Link von mir. Stichwort: "mysql_secure_installation"
    Beispiel: Im Internet setzt jemand einen MySQL Server auf und denkt: Ah super ich kann mich per root einloggen! Nein nichts ist super. Wenn du den Eintrag: "--bind-address=127.0.0.1" nicht machst, kann jeder im Netzwerk einfach ohne Passwort auf deine Datenbank zugreifen und einen DB Drop Befehl ausführen. Darum sollte man immer zuerst "mysql_secure_installation" starten und ein Passwort für "root" setzen. Ja auch im lokalen Netzwerk finde ist das wichtig :)
    mysql_enable="YES" ist nötig, damit es per "service mysql-server start" funktioniert und die DB nach dem Reboot automatisch startet.
     
  9. KobRheTilla

    KobRheTilla used register

    Registriert seit:
    20 Januar 2011
    Beiträge:
    1.265
    Ich würde - wenn der daemon eh nur lokal laufen soll, definitiv die Option --skip-networking benutzen. Damit lauscht MySQL nur auf dem UNIX-Socket.

    Rob
     
  10. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.219
    Vielen Dank für Eure Hinweise! Habe jetzt das Skript mysql_secure_installation laufen lassen, die Einträge in die /etc/rc.conf hinzugefügt und kann nun mittles

    $mysql -u root -p

    den Betrieb starten. Es ist nur schade, dass diese Kleinigkeiten für den Anfang kaum dokumentiert sind. Das gehört eigentlich ins Handbook. Vielleicht kann man es wenigstens hier ins WIKI tun.
     
  11. Rakor

    Rakor Administrator Mitarbeiter

    Registriert seit:
    17 September 2009
    Beiträge:
    2.090
    Ort:
    Mannheim
    Feel free.... Wir sind um jeden User froh der das Wiki mit hilfreichen Artikeln versorgt.
     
  12. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.219
    Ich habe keine WIKI-Berechtigung. Auch fühle ich mich nicht ganz qualifiziert genug im Verhältnis zu anderen Mitgliedern hier...
     
  13. KobRheTilla

    KobRheTilla used register

    Registriert seit:
    20 Januar 2011
    Beiträge:
    1.265
    Finde ich nicht. Wenn man einen Dienst betreibt, muss man sich auch damit auseinandersetzen.
    Desweiteren ist bereits alles wohldokumentiert, z.B.: https://dev.mysql.com/doc/refman/5.7/en/postinstallation.html

    Man sollte immer ein wenig Verantwortungsbewusstsein mitbringen.

    Rob
     
    Illuminatus gefällt das.
  14. Yamagi

    Yamagi Possessed With Psi Powers Mitarbeiter

    Registriert seit:
    14 April 2004
    Beiträge:
    9.043
    Ort:
    Schleswig-Holstein
    Ich kann dich gerne für's Wiki freischalten. Ich brauche nur eine Mail-Adresse, gerne auch per PN und nicht öffentlich.
     
    cabriofahrer gefällt das.
  15. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.219
    Vielen Dank, @Yamagi! Leider finde ich keine Funktion für die Versendung einer Privatnachricht, wenn ich auf Dein Profil klicke?
     
  16. Yamagi

    Yamagi Possessed With Psi Powers Mitarbeiter

    Registriert seit:
    14 April 2004
    Beiträge:
    9.043
    Ort:
    Schleswig-Holstein