1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

NetBSD händisch installieren auf problematischer Hardware

Dieses Thema im Forum "NetBSD" wurde erstellt von bsfd, 21 August 2016.

  1. bsfd

    bsfd NetBSD User

    Registriert seit:
    4 Dezember 2013
    Beiträge:
    62
    Hallo, ich will es endlich angehen und NetBSD auch auf meinem Desktop installieren.
    Es gibt folgende Probleme:
    - Mit der Installation mit sysinst, zerreist es alle Platten im Rechner, er überschreibt alles und beachtet nicht meine Partitionierungen
    - Es handelt sich um eine Festplatte mit GPT, alle andere OS´s sind mit UEFI installiert
    - Die onboard 1Gbit Netzwerkkarte wird zwar erkannt, aber bezieht per DHCP nicht zutreffende Adressen und bei statischer Konfiguration funktioniert, wie auch per DHCP, das Netzwerk nicht.
    - Aber, die WLAN-Karten sollte funktionieren, zumindest irgendeine.

    Ich hätte dann vor, das NetBSD über den grub2-efi von Debian zu starten, obwohl NetBSD kein EFI unterstützt, es sollte ja trotzdem möglich sein?! Benötige ich noch irgendeine spezielle Boot-Partition dann für das NetBSD?

    Zu tun wäre:
    - NetBSD händisch installieren auf GPT
    - NetBSD booten können über Debian grub2-efi ( Gäbs noch andere Möglichkeiten? )

    Wie gehe ich am besten bei der Installation vor, was ist zu beachten und über weiterhelfende Links würde ich mich freuen.
    Ich habe es auch bisher NetBSD noch nicht händisch installiert.
     
  2. darktrym

    darktrym Fahnenträger

    Registriert seit:
    21 August 2006
    Beiträge:
    1.639
    Ort:
    Düsseldorf
    Ich müsste eigentlich schon weg sein, aber das könnte dein Problem betreffen.
     
  3. bsfd

    bsfd NetBSD User

    Registriert seit:
    4 Dezember 2013
    Beiträge:
    62
    Auf dieser problematischen Hardware funktioniert nun 8.0BETA soweit. Das Netzwerk muss einmal restartet werden und danach die Routen neu eingerichtet werden, DHCP funktioniert nicht richtig, bezieht falsche IPS die nicht funktionieren, aber statisch geht es mit einem networking restart und routen neu setzen.
    Ist ein ein AMD AM1 Kabini, auch kms funktioniert nun.
    Tolle Sache.