1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

NVIDIA 390.25 nicht als Paket vorhanden?

Dieses Thema im Forum "FreeBSD - Anwendungen und Ports" wurde erstellt von pit234a, 14 März 2018.

  1. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.492
    Nachdem ich erfahren habe, dass meine GraKA nicht mehr lange unterstützt wird, sehe ich mich gerade um, was ich denn kaufen möchte.
    Dabei erinnere ich mich an eine Empfehlung hier vor einigen Wochen, kann den Beitrag aber nunnicht finden. Da war die Rede (wenn ich mich recht erinnere) von einer NVIDIA 1050.
    Da habe ich dann mal kurz nachgesehen und finde die hier
    https://www.mindfactory.de/product_...-OC-2G-Aktiv-PCIe-3-0-x16--Retai_1125762.html
    die mir schon zusagen würde, soweit ich das nun sehe.

    Nun sehe ich auf den NVIDIA HP http://www.nvidia.de/Download/driverResults.aspx/130997/de dass der Treiber 390.25 für FreeBSD der passende sei, aber wenn ich mit pkg search nvidia nachsehe, erscheint der nicht als Paket.
    Irgendwas habe ich wohl falsch verstanden.

    Was mich ein wenig stört, ist das "Gamer" in der Beschreibung, denn ich will ja gar nicht damit spielen. Vielleicht gibt es dann ja noch eine bessere Empfehlung, nur sollte sie schon durchaus aktuell sein, denn ich will lange damit weiter arbeiten und nicht so bald schon wieder wechseln.
    Ich brauche (möchte) zwei Monitore anschließen können, am liebsten über HDMI oder DVI, habe aber auch passende Adapter von Display-Port zu HDMI.
    Die Auflösung, die ich derzeit (für die beiden Monitore zusammen) brauche, ist 3840 x 1080, aber sogar meine veraltete Karte kann schon deutlich mehr, so dass ich mit einer neueren Karte wohl jedenfalls noch Luft haben werde, wenn ich mal neue (größere) Monitore kaufe.

    Das eilt nun nicht.
    Aber ich bin verblüfft und verunsichert, dass ich den Treiber gar nicht als Paket finde, der bei NVIDIA für FreeBSD gelistet ist.
     
  2. marcel

    marcel Active Member

    Registriert seit:
    9 Juli 2017
    Beiträge:
    324
    Hi @pit234a,
    da kann ich Dich beruhigen:
    Code:
    # pkg search nvidia
    nvidia-driver-390.25  NVidia graphics card binary drivers for hardware OpenGL rendering
    nvidia-driver-304-304.137  NVidia graphics card binary drivers for hardware OpenGL rendering
    nvidia-driver-340-340.106  NVidia graphics card binary drivers for hardware OpenGL rendering
    nvidia-settings-384.59_1  Display Control Panel for X NVidia driver
    nvidia-texture-tools-2.0.8.1_9 Texture Tools with support for DirectX 10 texture formats
    nvidia-xconfig-384.59  Tool to manipulate X configuration files for the NVidia driver
    
     
  3. cla

    cla IRC: Qyx

    Registriert seit:
    24 August 2005
    Beiträge:
    415
    Man findet folgendes (https://www.freshports.org/x11/nvidia-driver/):
    "A package is not available for ports marked as: Ignore"
    "IGNORE: requires kernel source files in /usr/src"

    Wohl eher eine Architektur-/Politische Entscheidung?

    Der Treiber scheint aber ueber den Ports-Tree installierbar zu sein.
     
  4. thorwin

    thorwin Member

    Registriert seit:
    5 Mai 2009
    Beiträge:
    314
    Ort:
    Darmstadt, Germany
    Ist er und er läuft hier auch problemlos mit einer GTX 1050 (iirc nicht von Gigabyte aber das sollte egal sein)
     
  5. waldbaer59

    waldbaer59 New Member

    Registriert seit:
    25 Dezember 2017
    Beiträge:
    24
    Ich bin ja auch auf der Suche und erlaube mir, mich hier mit dranzuhängen. Etwas passiv Gekühltes wäre mir aber am liebsten...
     
  6. Sickboy

    Sickboy Müßiggänger

    Registriert seit:
    4 November 2006
    Beiträge:
    544
    Ort:
    Berlin
    Habe eine passiv gekühlte NVIDIA GeForce GT 610 (2x DVI) mit FreeBSD 11 am Laufen und bin zufrieden. Die hat aber schon ein paar Jahre auf dem Buckel.
     
  7. holgerw

    holgerw Well-Known Member

    Registriert seit:
    29 Februar 2016
    Beiträge:
    1.392
    Ort:
    Simtshausen - Hessen
    Hallo,

    ich habe nur passiv gekühlte Nvidia GT 710er Karten und die funktionieren mit dem aktuellen Nvidia-Treiber gut. Ich baue die Treiber und nehme den Linux Kram raus, weil ich ihn nicht brauche.
     
  8. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.492
    Aber bei mir:
    Code:
    pkg search nvidia
    nvidia-driver-384.98  NVidia graphics card binary drivers for hardware OpenGL rendering
    nvidia-driver-304-304.137  NVidia graphics card binary drivers for hardware OpenGL rendering
    nvidia-driver-340-340.104  NVidia graphics card binary drivers for hardware OpenGL rendering
    nvidia-settings-384.59_1  Display Control Panel for X NVidia driver
    nvidia-texture-tools-2.0.8.1_9 Texture Tools with support for DirectX 10 texture formats
    nvidia-xconfig-384.59  Tool to manipulate X configuration files for the NVidia driver
    Ich stehe auf Quarterly

    Das ist lästig, aber immerhin noch machbar. In meinem Ports-Tree finde ich derzeit:
    Code:
    /usr/ports/x11/nvidia-driver-304
    /usr/ports/x11/nvidia-driver-340
    /usr/ports/x11/nvidia-driver
    Was an der Aussagen überhaupt nicht so verstehen kann: die Aussage gilt für die anderen NVIDIA-Treiber ja auch. Wenn ich die bauen möchte, brauche ich /usr/src und Linux. Das ist eben lästig, weil ich das für gewöhnlich beides nicht brauche und nur für einen Port ist es viel Aufwand, vor allem mit der Aktualisierung.
     
  9. marcel

    marcel Active Member

    Registriert seit:
    9 Juli 2017
    Beiträge:
    324
    Ich benutze das latest Repo. Habe den Treiber ja auch per pkg in NomadBSD installiert.

    Der aktuellste Treiber befindet sich in /usr/ports/x11/nvidia-driver. Die Version siehst du in der Makefile.
     
  10. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.492
    mmhhm. Das ist dann eine Überlegung wert. Auf dem kleinen Asus nutze ich es auch problemlos. Vielleicht sollte ich dann umbauen.

    Danke für die Hinweise.
     
  11. Rakor

    Rakor Administrator Mitarbeiter

    Registriert seit:
    17 September 2009
    Beiträge:
    2.176
    Ort:
    Mannheim
    Ich meine "linux" war eine buildoption und man kann den Treiber auch ohne bauen... Bin mir aber nicht sicher.

    Edit: Jou
    LINUX=on: Linux compatibility support
     
  12. bluescreen

    bluescreen verstört

    Registriert seit:
    3 Oktober 2005
    Beiträge:
    517
    Ort:
    /home
    Läuft wunderbar ohne Linux-Gedöns !
     
  13. ralli

    ralli BSD Fanboy

    Registriert seit:
    1 Juni 2012
    Beiträge:
    2.339
    Da ich Nvidia Karten bis zur Geforce 1080 GTX im Einsatz hatte, kann ich das bestätigen. Wenn ich den Treiber selbst aus den Ports baute, immer ohne "Linux Gedöns". Nun in dem Rechner, den ich von meinem Sohn bekam, steckte ja eine Nvidia 1080 GTX. Auch wenn ich von der Leistungsfähigkeit überwältigt war, so kann ich heute von meinen Erfahrungen profitieren. Die ganze Serie 1050 bis 1080 ist ausschließlich für Gamer unter Windows gemacht. Für den normalen Desktop Gebrauch sind die völlig überdimensioniert. Der einzige Desktop, der einigermaßen 4 k tauglich ist, ist KDE. Alle anderen waren dazu nicht wirklich in der Lage. Aber was mich zusätzlich gestört hat, war die Leistungsaufnahme. Ich glaube, es waren 200 W und mehr. Und das hat mich bewogen, die interne GPU meiner Haswell Architektur zu benutzen. Die Karte ist verkauft, ich habe sie hier nicht angeboten, weil ich dachte, so ein Monster will eh niemand. Und seitdem bin ich generell zufrieden, denn ich ich mache ja kein CAD. Und mit OpenBSD und DragonFly wären sogar 4k UHD möglich, was ich aber für den normalen Einsatz nicht wirklich brauche. Mittlerweile arbeite ich mit FULL HD und das reicht mir einfach.
     
  14. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.492
    dem wollte ich zustimmen und gerade heute bot mir jemand eine NVIDIA ... 730 an, relativ günstig, wie ich finde.
    Aber ich werde weiter verwirrt.
    Wenn ich danach suche passen meine Suchergebnisse gar nicht zu dem angebotenen Produkt. Ich möchte ja (wenigstens) zwei Monitore daran betreiben und dafür auch zwei gleiche Ausgänge nutzen. Die mir angebotene Karte hatte vier gleiche Ausgänge (wie auf dem Bild zu sehen war) und zwar entweder HDMI oder Display-Port und sie war von NVIDIA. Die gefunden Karten bieten das nicht.
    Ich sehe aber, dass viele gefundenen Karten (trotz Suchbegriff NVIDIA) gar nicht von NVIDIA sind. Die benutzen wohl alle die gleichen Namen?

    Das scheint mir zu kompliziert zu sein und ich werde wohl irgendwas von NVIDIA kaufen und sehen, wie ich damit zu Recht komme.
    Die Preise rechtfertigen eine ausführliche Beschäftigung mit dem Thema gar nicht.

    Wenn ich dann nicht weiter komme, werde ich natürlich wieder fragen müssen.
    Die Frage nach dem 390.25 Treiber sollte dann natürlich nicht mehr auftauchen, das haben wir hier wohl geklärt.

    Dafür nochmals Dank an alle.
     
  15. Yamagi

    Yamagi Possessed With Psi Powers Mitarbeiter

    Registriert seit:
    14 April 2004
    Beiträge:
    9.182
    Ort:
    Schleswig-Holstein
    Nvidia baut selbst (bis auf einige Ausnahmen wie z.B. Erst-Editionen direkt nach dem Marktstart einer Serie) keine eigenen Grafikkarten, sondern eben nur GPUs. Aus den GPUs bauen dann Dritthersteller wie Asus, EVGA, Gigabyte, PNY und co. die Grafikkarten. Im Low-End-Bereich ist es ziemlich egal, aber die Grafikkarten der Hersteller unterscheiden sich trotz gleicher GPU teils schon sehr. Sie haben unterschiedliche Taktraten, verschiedene Mengen VRAM und vor allem verschiedene Kühler.

    Für FreeBSD kann man aber mangels Anwendungen, die nennenswert GPU-Leistung fordern, ganz einfach sagen: Kaufe die günstigste Grafikkarte, die den Zweck erfüllt und dabei einen möglichst leisen Lüfter hat. Fertig.

    Davon abgesehen ist es im Moment sowieso keine gute Zeit eine Grafikkarte der Mittelklasse und aufwärts zu kaufen. Die Preise sind durch den Mining-Schwachsinn völlig überdreht, Nvidia wird wohl in Richtung Mai eine neue Generation (Codename "Turing") starten und AMDs "Navi" wird dann wohl auch in nicht allzu ferner Zukunft kommen.
     
    pit234a gefällt das.
  16. mr44er

    mr44er Trödel-Troll

    Registriert seit:
    22 September 2013
    Beiträge:
    361
    Ort:
    Reichelsheim
    Der Vollständigkeit halber: Aber auch nur unter Last. Die ganze 1050er-1080er Reihe ist enorm sparsam, wenn sie runtergetaktet sind...aka normaler Desktopbetrieb. Die Geforce 8000er Reihe konnte nichtmal takten, die haben im Betrieb ständig 'gut Durst'.

    Wie Yamagi es sagt...wegen den ganzen Minern sind die Preise auf dem Mond. Die Empfehlung der 1050er kam wahrscheinlich von mir, ich habe die auch im Einsatz. Der 390.25 ist der richtige.
    Die solltest du auch günstig in der Bucht finden, da sie uninteressant ist fürs Minen. Tu dir aber einen Gefallen und kauf die 4GB-Version, das fällt preislich echt nicht ins Gewicht und weil Zukunft halt....

    Lass dich auch von dem 'Gamer mumbojumbo' nicht verwirren....die 1050er taugt nicht (mehr) zum Spielen von AAA-Titeln. Der Hintergrund, warum ich sie kaufte: Die 1050 Ti ist der Nachfolger der 750 Ti. Das Besondere der Karten ist, dass sie ohne weitere Stromversorgung auskommen. Sie sind auf die max. 75W begrenzt, den ein PCI-E Slot laut Spezifikation leisten kann. Und sie ist wirklich sparsam im Verbrauch.

    Ob ASUS, MSI oder GIGABYTE...das gibt sich nix. Die unterscheiden sich in den Farben vom Plastik und werden fürs overclocking oder bessere Kühlkörper beworben. Kann man getrost ignorieren....

    Edit: Habe gerade mal im ebay geschaut....selbst diese Karte kostet jetzt wesentlich mehr, als ich sie damals kaufte (150€). Mein Tipp: bezahle nicht mehr als 100€....außer du mußt nun eine Karte kaufen.
     
  17. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.492
    ja, es ist nicht eilig gewesen, aber manchmal habe ich keine Geduld und als ich heute in einem Laden eine GT 710 liegen sah und mich an Das Statement von @holgerw weiter oben erinnerte, da nahm sie kurz entschlossen mit und habe sie eben eingebaut. Alles gut.
    Nun brauche ich nur noch neue Lüfter.

    Nochmals Dank für die Unterstützung.
     
  18. turrican

    turrican Member

    Registriert seit:
    18 Januar 2018
    Beiträge:
    58
    Falls jemand noch ne nVidia Empfehlung für FreeBSD braucht: Hab vor ca nem halben Jahr ne MSI GT 1030 mit 2GB in nem Testrechner verbaut, der lief auch mal mit FreeBSD, funktionierte mit dem nvidia Treiber aus den Ports einwandfrei.
    Das elegante an der Karte ist, dass sie rein passiv gekühlt ist (kein Krach, braucht dafür aber auch etwas mehr als eine Slot-Breite) und keine extra Stromversorgung braucht.
    Kostet aktuell etwa 90-95 Euro.
     
  19. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.492
    Lass mich nochmal nach fassen.
    Hast du irgendwelche Optionen gegen das Tearing gesetzt?
    Kommt mich bei der neuen Karte deutlich schlimmer vor, als bei den alten, die ich bisher nutzte.
     
  20. holgerw

    holgerw Well-Known Member

    Registriert seit:
    29 Februar 2016
    Beiträge:
    1.392
    Ort:
    Simtshausen - Hessen
    Hallo @pit234a

    ich habe die nvidia-settings installiert, dort die Image Quality auf sehr hoch gesetzt und das war es. Allerdings nutze ich die Nvidia-Karte kaum zum Schauen irgendwelcher Videos, mir sind Fotos viel wichtiger, daher weiß ich zwar um den Begriff Tearing aber habe dem bei meinem Workflow keine Bedeutung beigemessen. Zumal es auch gut sein kann, dass bei meiner Sehbehinderung mir dieser Aspekt bei Videos nicht so auffallen würde.

    Aber vielleicht hilft Dir folgendes:
    https://devdiary.org/nvidia-tearing-beheben/
     
  21. holgerw

    holgerw Well-Known Member

    Registriert seit:
    29 Februar 2016
    Beiträge:
    1.392
    Ort:
    Simtshausen - Hessen
    Hallo @pit234a

    habe gerade hierüber mal das Tearing geprüft:
    https://www.testufo.com/stutter#demo=smooth&foreground=ffffff&background=000000&pps=1440
    nun bekomme ich einen Eindruck zu dieser doch störenden Begleiterscheinung, Abhilfe hat bei mir folgendes gebracht:
    Zunächst muss das Paket x11/nvidia-settings installiert werden.

    Dann bitte als User unter Deiner X-Session, sofern es bei Dir auch DFP-1 ist (siehst Du in der /var/log/Xorg.0.log) folgendes ausführen:
    Code:
    nvidia-settings --assign CurrentMetaMode="DFP-1: nvidia-auto-select { ForceCompositionPipeline = On }"
    Das bringt bei mir unter der Testseite deutliche Besserung.
     
  22. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.492
    Ich habe da auch angefangen zu testen, aber im Augenblick zu wenig Zeit dafür.
    Danke für den Hinweis, ich werde das weiter verfolgen, wenn ich wieder mehr Luft habe.
     
  23. mr44er

    mr44er Trödel-Troll

    Registriert seit:
    22 September 2013
    Beiträge:
    361
    Ort:
    Reichelsheim
    xorg.conf:

    An euch beide. :)

    Und wenn das läuft, im Firefox ergänzend:

    about:config

    "layers.acceleration.force-enabled" auf true stellen und FF neu starten.

    Mit "about:support" dann unter Abschnitt Graphics überprüfbar.
     
    pit234a und holgerw gefällt das.
  24. mr44er

    mr44er Trödel-Troll

    Registriert seit:
    22 September 2013
    Beiträge:
    361
    Ort:
    Reichelsheim
    Es soll wohl auch mit den nvidia-settings funktionieren. Ist dann unter 'advanced' zu finden.
     

    Anhänge:

    pit234a gefällt das.
  25. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.492
    OK, mein Rechner-Umbau ist nun vielleicht wirklich fertig, aber getestet habe ich noch nicht alles und das ist ja immer so, dass man erst im laufenden Betrieb noch das Ein oder Andere bemerkt. Jedenfalls hatte ich nun, nach einem erneuten Reboot, als erstes diese Sache angegangen. Ein Test mit nvidia-settings und Einschalten der ForceFullCompositionPipeline - Option stotterte der laufende Film zunächst seltsam. Dann aber wurde das Bild zunehmend besser und ich übernahm die Vorschläge von @mr44er in meine xorg.conf, habe das aber noch nicht neu gestartet.
    Zusätzlich habe ich mir dann meine mpv.conf nochmal angesehen. Die stammt ja noch von der alten GraKa und ich hatte damit einige Versuche durchgeführt, um eine möglichst optimierte Darstellung zu erhalten. Nun zeigt:
    Code:
    mpv --vo=help
    Available video outputs:
      opengl         : Extended OpenGL Renderer
      vdpau          : VDPAU with X11
      xv             : X11/Xv
      vaapi          : VA API with X11
      x11            : X11 (slow, old crap)
      null           : Null video output
      image          : Write video frames to image files
      tct            : true-color terminals
    
    das ist etwas unterschiedlich zu vorher, aber auch zuvor gab es bereits vdpau als Möglichkeit, die aber nie funktioniert hatte. Nun fing ich damit an (weil opengl zuvor eingestellt war) und erhielt spontan ein sehr gutes Resultat damit. Der Ressourcenverbrauch von mpv ist etwa bei der Hälfte gegenüber vorher und die Darstellung des einen bisher betrachteten Films ist sehr flüssig und sauber.
    Ich hoffe, dass dies über den nächsten Neustart dann erhalten bleibt und die xorg.conf so funktioniert.

    Jedenfalls werde ich da nicht mehr weiter suchen, denn ich bin mit dem derzeitigen Resultat zufrieden.
    Danke.