Owncloud -> PROPFIND Error 500 nach Update auf PHP 5.3.13

Dieses Thema im Forum "FreeBSD - Allgemein" wurde erstellt von testit, 23 Mai 2012.

  1. testit

    testit Member

    Registriert seit:
    1 August 2005
    Beiträge:
    496
    Hallo,

    nach einem Update von PHP 5.3 auf PHP 5.3.13 erhalte ich beim Versuch auf owncloud über einen webdav-client zuzugreifen, folgende Fehlermeldung:

    "PROPFIND /owncloud/files/webdav.php/ HTTP/1.1" 500 -

    Hat jemand eine Idee, woran das liegen könnte?
    Ich komme seit gestern in dieser Sache nicht weiter!


    Nette Grüße
    testit
  2. KobRheTilla

    KobRheTilla used register

    Registriert seit:
    20 Januar 2011
    Beiträge:
    354
    Hi,

    was sagt das Errorlog vom Apachen bzw. PHP?

    Rob
  3. testit

    testit Member

    Registriert seit:
    1 August 2005
    Beiträge:
    496
    Hi,

    im error.log tut sich diesbezüglich NICHTS!

    Der o.a. Eintrag stammt aus der access.log.

    Eine PHP-Error.log-Datei habe ich nicht finden können.


    Gruß
    testit
  4. christian83

    christian83 Member

    Registriert seit:
    18 Juli 2009
    Beiträge:
    418
  5. testit

    testit Member

    Registriert seit:
    1 August 2005
    Beiträge:
    496
    Hallo Christian,

    den Beitrag hatte ich heute auch schon gelesen.
    Bei mir schaut es unter FreeBSD 8.2 SO aus:

    Was mir nun auffällt ist, dass da steht
    php53-xml-5.3.13_1

    Ob das die Ursache sein könnte?
    Auf der anderen Seite wird XML einwandfrei als Extension unter phpinfo() ausgegeben!

    Die _1 habe ich auch bei folgenden Extensions:

    Wie schaut das denn bei DIR aus?

    Alles 5.3.13?

    Oder auch gemischt?

    Habe das alles aus den PORTS gebaut.

    PHP Version ist 5.3.13

    Danke und Gruß
    testit
    Zuletzt bearbeitet: 23 Mai 2012
  6. testit

    testit Member

    Registriert seit:
    1 August 2005
    Beiträge:
    496
    Hallo,

    bei mir stets aus dem PHP53-Extensionsport unter
    /usr/ports/lang/php53-extensions
    ein php53-xml-5.3.13_1
    gebaut und nicht ein php53-xml-5.3.13.

    Wie ist das denn bei Euch?

    Danke und Gruß
    testit
  7. christian83

    christian83 Member

    Registriert seit:
    18 Juli 2009
    Beiträge:
    418
    Die genauen Versionen bei mir kann ich nicht sagen wiel ich das ganze auf einem Webhosting nutze (Zeitmangel und keine Lust auf einen Server). Habe nur zufällig noch den Thread von oben im Kopf gehabt.

    Grüße
  8. testit

    testit Member

    Registriert seit:
    1 August 2005
    Beiträge:
    496
    Gelöst!

    Hallo,

    für diejenigen, die ebenfalls einmal mit diesem Problem konfrontiert sind:
    Der Fehler verschwand, nachdem ich in der php.ini memory_limit erhöht habe.

    Immerhin stand dieser Wert auf "satte" 30MB, was wohl nicht ausreichte.
    Habe ihn nun auf 200MB gestellt

    EDIT:

    Inzwischen habe ich herausgefunden, dass es definitiv NICHT allein an dem o.a. memory_limit-Wert liegt, sondern ganz offensichtlich an der PHP53-GD-Extension

    Wenn ich in der extensions.ini den Eintrag
    extension=gd.so
    herausnehme, verschwindert der PROPFIND 500 Error und es kann eine Verbindung mit einem WebDAV-Client hergestellt werden.

    Stellt sich nur noch die Frage, wie man das Ganze mit aktiviertem GD zum Laufen bringt, da GD für andere Applikationen benötigt wird.

    LÖSUNG:

    Es muss die DOM-Extension aktiviert werden:
    extension=dom.so


    Nette Grüße
    testit
    Zuletzt bearbeitet: 24 Mai 2012
  9. christian83

    christian83 Member

    Registriert seit:
    18 Juli 2009
    Beiträge:
    418
    Mhh musste man mal als Bug melden...

    Aber danke das du noch mal geschrieben hast an was es liegt.

    Grüße
  10. christian83

    christian83 Member

    Registriert seit:
    18 Juli 2009
    Beiträge:
    418
    Noch mal als Nachtrag:

    Klappt bei dir das anschauen von odf Dateien? Bei mir kommt nur z.B
    "loading /?app=files&getfile=ajax/download.php?files=firefox font.odt&dir=/Weiteres/Anleitungen"

    Scheinen auch andere zu haben. Leider konnte ich keine Lösung finden...

    Grüße