1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Probleme mit UEFI und Bootloader

Dieses Thema im Forum "FreeBSD - Installation" wurde erstellt von OlliP, 10 Januar 2018.

  1. OlliP

    OlliP New Member

    Registriert seit:
    10 Januar 2018
    Beiträge:
    5
    Hi zusammen,

    ich starte gerade mit FreeBSD und stolpere schon über die ersten Hürden. Mein FreeBSD ist installiert auf einer
    internen SSD mit 64 GB Kapazität.

    Ausgabe von gpart show:

    list 01.JPG

    Ich habe einen neuen Rechner, der in den BIOS Einstellungen für die Boot-Reihenfolge
    UEFI: Hard Disk :UEFI OS
    drin stehen hat.

    Wenn ich den Rechner starte klappt alles.

    Nun benötige ich natürlich (zumindest eine) weitere Festplatte.
    Wenn ich sie hinzufügeund einen restart durchführe, dann klappt der Restart bis zu dieser Meldung...


    list 02.JPG

    Nun komme ich nicht weiter. M.E. muss das FreeBSD von ada0p2 geladen werden.
    Wie kann ich das denn und wo kann ich das eintragen.

    Ich hoffe ihr könnt mir helfen.

    Vielen Dank

    Gruß

    OlliP
     
  2. Yamagi

    Yamagi Possessed With Psi Powers Mitarbeiter

    Registriert seit:
    14 April 2004
    Beiträge:
    9.182
    Ort:
    Schleswig-Holstein
    Hallo und willkommen in unserem kleinen Irrenhaus. :)
    Das Problem hier ist, dass FreeBSD (genauso wie z.B.) Linux die Festplatten dynamisch zuweist. Es kann dir also niemand garantieren, dass ada0 auch immer ada0 bleibt. Sobald du eine weitere Festplatte einbaust, besteht eine 50:50 Chance, dass er die neue Platte als ada0 zuweist und die alte Platte dann auf ada1 aufrückt. Dagegen helfen Labels, aber das führt nun zu weit. Wahrscheinlich reihct zum Booten ein:
    Code:
    ufs:/dev/ada1p2
    
    Im laufenden System kannst es denn in der 7etc/fstab permanent eintragen.
     
  3. OlliP

    OlliP New Member

    Registriert seit:
    10 Januar 2018
    Beiträge:
    5
    Hi,

    das verstehe ich nicht ... leider

    die fstab enthält bei einer Festplatte

    Device Mountpoint FSType options Dump Pass
    /dev/ada0p2 / ufs rw 1 1
    /dev/ada0p3 none swap sw 0 0

    Damit ist doch der Eintrag erst einmal richtig... Wird aber für meine Begriffe nicht gefunden.

    Wenn ich mit 2 Platten starte, dann kommt das 2. Bild ... ich gebe ufs:/dev/ada1p2 ein und der Boot-Vorgang wird vollendet (richtig!).


    Soll ich jetzt ufs:/dev/ada1p2 das in die /etc/fstab des gestarteten Systems eintragen???

    Gruß

    OlliP
     
  4. Fusselbär

    Fusselbär Makefile Voyeur

    Registriert seit:
    6 August 2004
    Beiträge:
    2.251
    Ort:
    Köln
    Vielleicht ist es auch mechanisch zu lösen. Die dazu gehängte Festplatte wird vom BIOS/UEFI wohl auf den ersten Platz gesetzt. Für FreeBSD ist die erste Festplatte ada0. Auf dem dem ersten Platz sitzt aber jetzt die neue Festplatte. Wenn man mal die Steckerplätze tauschen würde, also den Stecker der FreeBSD SSD in die Buchse auf dem Mainboard reinstecken, wo die neue Festplattte eingestpöpselt wurde und die Festplatte dann sinngemäß umgekehrt. Auch im BIOS/UEFI kann und sollte man mal schauen wie sich da die Startreihenfolge der Laufwerke einstellen lässt.

    Falls nichts umgestöpselt wird, dann wäre die Änderung in der /etc/fstab wohl in dieser Art notwendig, die Zeile:
    Code:
    /dev/ada0p2 / ufs rw 1 1
    
    müsste so geändert werden:
    Code:
    /dev/ada1p2 / ufs rw 1 1
    
    Mehr zu lesen gibt es im FreeBSD Handbuch, bei der Nomenklatur scheint es mir aber nicht mehr so ganz aktuell zu sein, dort wird noch das Beispiel mit dem s für Slices erläutert:
    https://www.freebsd.org/doc/de_DE.ISO8859-1/books/handbook/disk-organization.html
     
  5. OlliP

    OlliP New Member

    Registriert seit:
    10 Januar 2018
    Beiträge:
    5
    Nun hab ich mich bei LABEL eingelesen.

    Folgende Veränderungen habe ich durchgeführt:

    glabel label BASEsys /dev/ada1p2
    (für das System)
    glabel label SWAP /dev/ada1p3
    (für SWAP)

    und in der /etc/fstab

    Device Mountpoint FSType options Dump Pass
    /dev/label/BASEsys / ufs rw 1 1
    /dev/label/SWAP none swap sw 0 0

    Leider klappt das immer noch nicht, da beim Reboot das BASEsys nicht gemountet werden kann mit RC 19 (siehe Bild)

    list 03.JPG


    Könnt ihr mir weiterhelfen?

    vielen Dank


     
  6. OlliP

    OlliP New Member

    Registriert seit:
    10 Januar 2018
    Beiträge:
    5
    Problem gelöst!

    ich habe einen Tipfehler in der etc/fstab bei label gehabt.

    Deswegen konnte er den Namen/die Partition nicht finden.

    Korrigiert und alles klappt.

    Gruß

    OlliP