troubleshooting lock-up / keine icmp-response mehr

Dieses Thema im Forum "FreeBSD - Allgemein" wurde erstellt von performant, 17 April 2012.

  1. performant

    performant New Member

    Registriert seit:
    11 Februar 2010
    Beiträge:
    15
    Hi Leute,

    irgendwie komme ich beim debuggen meines FreeBSD8.0-RELEASE Heimservers nicht mehr weiter.

    Das Problem sind Lock-Ups bzw nicht mehr Antworten auf ping commands.

    Ich nehme an es liegt an samba, weil folgende Fehlermeldungen Seitenweise in /var/log/messages auftauchen:
    Code:
    APr 17 19:58:11 hermes smbd[17156]: [2012/04/17 19:58:11,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 19:58:11 hermes smbd[17156]:   Can't become connected user!
    Apr 17 19:58:42 hermes smbd[17158]: [2012/04/17 19:58:42,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 19:58:42 hermes smbd[17158]:   Can't become connected user!
    Apr 17 20:22:33 hermes smbd[17213]: [2012/04/17 20:22:33,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 20:22:33 hermes smbd[17213]:   Can't become connected user!
    Apr 17 20:45:38 hermes smbd[1011]: [2012/04/17 20:45:38,  0] smbd/server.c:342(smbd_accept_connection)
    Apr 17 20:45:39 hermes smbd[1011]:   open_sockets_smbd: accept: Software caused connection abort
    Apr 17 20:45:43 hermes smbd[17254]: [2012/04/17 20:45:43,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 20:45:43 hermes smbd[17254]:   Can't become connected user!
    Apr 17 21:10:17 hermes smbd[17296]: [2012/04/17 21:10:17,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 21:10:17 hermes smbd[17296]:   Can't become connected user!
    Apr 17 21:22:20 hermes smbd[17327]: [2012/04/17 21:22:20,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 21:22:20 hermes smbd[17327]:   Can't become connected user!
    Apr 17 21:33:40 hermes smbd[17347]: [2012/04/17 21:33:40,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 21:33:40 hermes smbd[17347]:   Can't become connected user!
    Apr 17 21:39:37 hermes smbd[17351]: [2012/04/17 21:39:37,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 21:39:37 hermes smbd[17351]:   Can't become connected user!
    Apr 17 21:47:47 hermes smbd[17369]: [2012/04/17 21:47:47,  0] smbd/service.c:932(make_connection_snum)
    Apr 17 21:47:47 hermes smbd[17369]:   Can't become connected user!
    
    ist schon ein Weilchen her dass ich mich das letzte Mal intensiver mit der Materie befasst habe, ev kann mich jemand in die richtige Richtung schubsen?
    Welche logs noch aufschlussreich wären vielleicht, oder wie ich sonst weiter troubleshooten kann

    thx
    performant
  2. j_t

    j_t New Member

    Registriert seit:
    21 Oktober 2003
    Beiträge:
    362
    Die obigen Fehlermeldungen werden kaum was mit dem Problem zu tun haben.
    Welche Netzwerkhardware ist verbaut? Ist im Fehlerfall lokal denn ansonsten noch alles funktional ausser dem Netzwerk?
  3. performant

    performant New Member

    Registriert seit:
    11 Februar 2010
    Beiträge:
    15
    Es ist ein RealTek Chip
    dmesg sagt:
    Code:
    re0: <RealTek 8168/8168B/8168C/8168CP/8168D/8168DP/8111B/8111C/8111CP PCIe Gigabit Ethernet>
    
    Auf den ersten Blick sah alles normal aus nur:
    Das Problem liess sich nur durch hard reset beheben.
    reboot command erfolglos, ich muss wohl beim nächsten Auftreten die Sache mal genauer anschauen?
  4. j_t

    j_t New Member

    Registriert seit:
    21 Oktober 2003
    Beiträge:
    362
    Also ein "ls" ging noch aber ein "reboot" nicht? Gab es Meldungen auf der Console?
  5. performant

    performant New Member

    Registriert seit:
    11 Februar 2010
    Beiträge:
    15
    Exakt!
    Nein, keine Meldungen auf der Konsole, auf jedenfall habe ich keine gesehen.
  6. makenoob

    makenoob Active OpenBSD User

    Registriert seit:
    5 Januar 2007
    Beiträge:
    1.373
    Wohnort:
    /Germany/Düsseldorf
    was sagt dmesg, wenn das auftritt?

    ich würde zusätzlich ein update auf 8.3 in erwägung ziehen bzw. eine andere netzwerkkarte testen.
  7. performant

    performant New Member

    Registriert seit:
    11 Februar 2010
    Beiträge:
    15
    ok, der Fehler ist nun wieder aufgetreten.
    Nein dmesg zeigt nichts an.
    Ich kann bestätigen dass sonst alles lokal läuft. Netzwerk geht einfach nicht.
    Ping auf localhost und die eigene IP funktioniert.
    Jemand eine Idee?
  8. unull

    unull Nervensäge

    Registriert seit:
    28 Februar 2005
    Beiträge:
    147
    Wohnort:
    ::1
    Falls die Netzwerkkarte das Problem ist, ist ein Blick in re(4) evtl. hilfreich, Abschnitt tunables and sysctl.
  9. performant

    performant New Member

    Registriert seit:
    11 Februar 2010
    Beiträge:
    15
    Danke für den Tip, ich habe noch mit verschiedenen Leuten gesprochen.

    Ich werde die Netzwerkkarte ersetzen.

    Vielen Dank für eure Hilfe.
  10. makenoob

    makenoob Active OpenBSD User

    Registriert seit:
    5 Januar 2007
    Beiträge:
    1.373
    Wohnort:
    /Germany/Düsseldorf
    aber ein update wäre trotzdem gut, die entwicklung ist seit 8.0 nicht stehengeblieben ;).
  11. performant

    performant New Member

    Registriert seit:
    11 Februar 2010
    Beiträge:
    15
    Klar, updaten werde ich auf jeden fall ;)