X server 1.10.6 / XDM

Dieses Thema im Forum "FreeBSD - Anwendungen und Ports" wurde erstellt von auge, 24 April 2012.

  1. auge

    auge Member

    Registriert seit:
    6 Mai 2003
    Beiträge:
    492
    Ort:
    --> Augsburg
    Hi,

    seit dem Xorg Update erscheint das XDM Login-Fenster nach einem Logout in 'schwarz' anstatt grau.

    Da ansonsten alles Bestens funktioniert lass ich das mal so, wollte es aber mal erwähnt haben.
    Ach ja, NVIDIA Karte verbaut, Treiber 295.40 und auf dem Laptop das gleiche Verhalten.

    Anhänge:

    • xdm1.jpg
      xdm1.jpg
      Dateigröße:
      924,9 KB
      Aufrufe:
      138
  2. Illuminatus

    Illuminatus in geheimer Mission

    Registriert seit:
    3 August 2003
    Beiträge:
    879
    das hatte mein FreeBSD 9.0 XDM mit Nvidia auch schon seit jeher gehabt. War jedoch meist nur unter Last bei einem Logout passiert und nicht konkret reproduzierbar. Würde es nicht direkt auf das Xorg Update schieben.
  3. auge

    auge Member

    Registriert seit:
    6 Mai 2003
    Beiträge:
    492
    Ort:
    --> Augsburg
    Hi Illuminatus,

    bei mir ist das 'immer' reproduzierbar und vorher hatte ich das Prolem 'nie'. Irgend ein Port den ich 'upgedatet' habe ist der Auslöser dafür, der Fehler kann natürlich auch woanders zu finden sein. Der 'nvidia-driver' wurde ja auch auf den aktuelllen Stand gebracht.

    Für folgende Ports wurden Packages gebaut und somit 'upgedatet':
    Code:
    
    -rw-r--r--  1 root  wheel      18183 Apr 22 20:04 glproto-1.4.15.tbz
    -rw-r--r--  1 root  wheel       4903 Apr 22 20:04 dmxproto-2.3.1.tbz
    -rw-r--r--  1 root  wheel      10356 Apr 22 20:04 dri2proto-2.6.tbz
    -rw-r--r--  1 root  wheel    1507906 Apr 22 20:05 libiconv-1.14.tbz
    -rw-r--r--  1 root  wheel     151178 Apr 22 20:05 libdrm-2.4.31_1.tbz
    -rw-r--r--  1 root  wheel   19380470 Apr 22 20:07 dri-7.11.2,2.tbz
    -rw-r--r--  1 root  wheel     283200 Apr 22 20:08 libGL-7.11.2.tbz
    -rw-r--r--  1 root  wheel     211476 Apr 22 20:09 libGLU-7.11.2.tbz
    -rw-r--r--  1 root  wheel     603301 Apr 22 20:09 libXt-1.1.1,1.tbz
    -rw-r--r--  1 root  wheel     733195 Apr 22 20:10 libXaw-1.0.9,2.tbz
    -rw-r--r--  1 root  wheel     135795 Apr 22 20:10 libXi-1.4.5,1.tbz
    -rw-r--r--  1 root  wheel     133452 Apr 22 20:11 libglut-7.11.2.tbz
    -rw-r--r--  1 root  wheel      18895 Apr 22 20:11 xdpyinfo-1.3.0.tbz
    -rw-r--r--  1 root  wheel       6394 Apr 22 20:11 xdriinfo-1.0.4.tbz
    -rw-r--r--  1 root  wheel     772005 Apr 22 20:13 xkeyboard-config-2.5.1.tbz
    -rw-r--r--  1 root  wheel    1800125 Apr 22 20:13 xorg-server-1.10.6,1.tbz
    -rw-r--r--  1 root  wheel      14716 Apr 22 20:14 xf86-input-keyboard-1.6.1.tbz
    -rw-r--r--  1 root  wheel      32689 Apr 22 20:14 xf86-input-mouse-1.7.1.tbz
    -rw-r--r--  1 root  wheel      57979 Apr 22 20:14 xf86-input-synaptics-1.5.0.tbz
    -rw-r--r--  1 root  wheel      98493 Apr 22 20:14 xf86-video-nv-2.1.18_1.tbz
    -rw-r--r--  1 root  wheel      18056 Apr 22 20:14 xf86-video-vesa-2.3.0_2.tbz
    -rw-r--r--  1 root  wheel      18131 Apr 22 20:14 xinit-1.3.2,1.tbz
    -rw-r--r--  1 root  wheel       3117 Apr 22 20:14 xorg-apps-7.5.2.tbz
    -rw-r--r--  1 root  wheel       3066 Apr 22 20:14 xorg-drivers-7.5.2.tbz
    -rw-r--r--  1 root  wheel      97013 Apr 22 20:14 help2man-1.40.9.tbz
    -rw-r--r--  1 root  wheel    2486527 Apr 22 20:16 mesa-demos-7.6.1.tbz
    -rw-r--r--  1 root  wheel   29691418 Apr 22 20:17 nvidia-driver-295.40.tbz
    -rw-r--r--  1 root  wheel      59998 Apr 22 20:17 xcb-proto-1.7.tbz
    -rw-r--r--  1 root  wheel       4080 Apr 22 20:17 xorg-7.5.2.tbz
    
    
    
    
  4. Illuminatus

    Illuminatus in geheimer Mission

    Registriert seit:
    3 August 2003
    Beiträge:
    879
    kannst du es mit dem Vesa Treiber auch reproduzieren? Würde gerne die Fehlerquelle eingrenzen, habe aber in den Logs noch nichts verwertbares gefunden.
  5. auge

    auge Member

    Registriert seit:
    6 Mai 2003
    Beiträge:
    492
    Ort:
    --> Augsburg
    Hi Illuminatus,

    mit dem VESA Treiber hast du 'Das Auge in der Pyramide' getroffen:)

    Da es mit dem VESA Treiber nicht nachvollziehbar ist, kann es wohl nur noch an NVIDIA liegen, oder?
  6. Illuminatus

    Illuminatus in geheimer Mission

    Registriert seit:
    3 August 2003
    Beiträge:
    879
    ich sehe auch das Problem zwischen nvidia und xdm. In der Vergangenheit gab es Changelogs von Nvidia Treiberversionen, welche z.B. Falschfarbeneffekte und Blockartefakte bei diversen Gnome und KDE Menüs aufführten. Möglicherweise wäre dieser Fall besser in einem Nvidia Supportforum aufgehoben.
  7. Illuminatus

    Illuminatus in geheimer Mission

    Registriert seit:
    3 August 2003
    Beiträge:
    879
    seit 304.43 habe ich das Problem nicht mehr. xdm wird korrekt dargestellt
  8. auge

    auge Member

    Registriert seit:
    6 Mai 2003
    Beiträge:
    492
    Ort:
    --> Augsburg
    ...ja mit der 304.43 ist der Fehler verschwunden. Ich hatte schon Grundsatzforschung betrieben und festgestellt, dass mit Version 295.06 der Fehler schon vorhanden war und bis 295.75 auch nicht behoben wurde.
    Der .43er hat ein kleines VT swiching Problem ( schaltet nicht gleich bzw 'login: wird versetzt angezeigt) das jedoch auch mit der aktuelleren .51 gelöst scheint. Ich würde sagen da lohnt sich ein Update.