Aktueller Inhalt von JonSvenJonsson

  1. J

    xorg 6.9 und radeon

    Ja bitte, und wenns geht die drm-cvs sourcen benutzten. cvs -z3 -d:pserver:anonymous@anoncvs.freedesktop.org:/cvs/dri co drm Den Patch den Du noch benötigst findest du auf der ersten Seite. Der r300-Treiber verweigert bei zu altem drm die Arbeit komplett, die cvs-sourcen des drm arbeiten...
  2. J

    xorg 6.9 und radeon

    dri-devel: PORTVERSION= 6.2.20050719 dri: PORTVERSION= 6.4.2 Sind nicht identisch :). Seit Xorg-6.9 in den ports ist, ist dri-devl hoffnungslos veraltet. Grüße Jon
  3. J

    xorg 6.9 und radeon

    Die neuen Mesa-Treiber sind in /usr/ports/dri, vorher bitte /usr/ports/dri-devel und ähnlichen alten Krams deinstallieren. Das Radeon drm-modul von 6-Stable sollte eigentlich ausreichen, ansonsten kannst Du die cvs-sources benutzen, Du brauchst allerdings noch nen Patch dafür, den findest Du...
  4. J

    xorg 6.9 und radeon

    Hab ne X800gto agp (r423), 3D-Beschleunigung läuft, bis jetzt noch keine Abstürze wegen 3D, aber die MesaLibs aus den Ports (6.4.2) sind etwas buggy, dh es funktioniert nicht jede 3D-"Anwendung", sprich Spiele. NWN läuft, UT2004 läuft nicht, Quake4 auch nicht. Mit MesaLibs aus cvs läuft UT2004...
  5. J

    3D Beschleunigung funktioniert nicht mehr

    Veraltetes libGL, r200_dri.so Gespann in linux compat ?. Kannst du die libGL, und r200_dri.so aus ner neuen Linux-Distri probieren ? (so ab Suse 10 hats da auch Xorg). Cheers Jon
  6. J

    CPU Optimierung?

    Wie reproduzierbar sind denn diese "Benchmark" Ergbenisse ? Bei mehrmaligen Lauf auf meinem System (6.1-prerelease, amd64) erhalte ich folgende Ergebnisse : 67108864 bytes transferred in 1.419678 secs (47270483 bytes/sec) 67108864 bytes transferred in 1.477740 secs (45413173 bytes/sec)...
  7. J

    3D Beschleunigung funktioniert nicht mehr

    Garnicht ?! Wenn's jetzt läuft ist doch alles ok. Hab halt nicht gesehen das du das Problem schon gelöst hattest :) . Aber der Tipp mit LIBGL_DEBUG hilft vielleicht beim nächstenmal. cheers Jon
  8. J

    3D Beschleunigung funktioniert nicht mehr

    Ok habe grad erst gesehen das Du das Problem gelöst hast. Wahrscheinlich hast Du auf Xorg-6.9 das Update gemacht. Xorg-6.9 benutzt libdrm-2, und wahrscheinlich war deine libGL (aus dem Mesa-Paket) damit nicht kompatibel. Naja alles nur Kaffeesatzleserei. cheers Jon setenv LIBGL_DEBUG...
  9. J

    r300-dri unter FreeBSD-Stable

    Hi ich habe die kompletten kernel-sourcen (per cvsup) von RELENG_6 geholt, und installiert.. Damit läuft dri bei mir (der radeon-drm treiber hat version 1.19). Gruß Jon
  10. J

    r300-dri unter FreeBSD-Stable

    Hi wenn du dein x-log anschaust und nach (EE) darin suchsts, findest du schnell den Grund warum 3D nicht mehr funktioniert :). (EE) RADEON(0): [dri] RADEONDRIScreenInit failed because of a version mismatch. AFAIK erstellt der dri-devel port auch ein "neues" veraltetes drm-kernel...
  11. J

    ati 3d rage pro

    Wenn bitte dann die ganze xorg-config, das bisserl was du gepostet hast reicht nur um mit Hilfe der Glaskugel zu spekulieren. Wieviel Speicher hat die Karte denn ? Davon hängt nämlich ab welche max Auflösung und Farbtiefe du verwenden kannst. Jon
  12. J

    r300-dri unter FreeBSD-Stable

    Eric Anholt hat wieder zugeschlagen und bittet um Tests: http://www.livejournal.com/users/anholt/ http://www.freebsd.org/cgi/cvsweb.cgi/ports/x11-servers/xorg-server-snap/ http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/dev/drm/
  13. J

    r300-dri unter FreeBSD-Stable

    Jo der xorrg-server-snap und der dri-devel-snap port haben die volle dri-unterstützung (einfach mal austesten, wenns klappt schön, wenn nicht läuft immer noch 2d). http://dri.freedesktop.org/wiki/ATIRadeon Grüße Jon
  14. J

    r300-dri unter FreeBSD-Stable

    Schau ob Du die ports installierts hast (ls /usr/ports), und ob sie auf dem neuesten Stand sind (es gibt im Wiki eine Seite die erklärt wie man das macht). Dann mach ein portupgrade -a, um alle installierten ports auf die neuesten Versionen zu bringen. Danach wechselst du auf der Console...
  15. J

    FreeBSD und ati radeon x800gto

    Nö :) PCI-Express Unterstützung ist im dri-bereich wohl noch recht neu, mag sein das es funktioniert, mag sein das es nicht funktioniert. Zumindestens unter linux scheint es zu laufen, im zweifelsfall einfach ausprobieren und /oder auf dri-devel nachfragen. cheers Jon
Oben