12.2 Upgrade - Problem #1 - Xorg ohne Tastatur

Rosendoktor

Well-Known Member
Hallo zusammen,

nach dem Upgrade von 12.1-RELEASE auf 12.2-RELEASE ist auf meinem PC die Tastatur unter Xorg futsch. Es geht gar nichts, auch die Maus nicht. Genau das gleiche ist bereits vor einem halben/ganzen Jahr auf einer 13.0-CURRENT Installation passiert und das Problem bis dato unlösbar.

Es geht NICHT mehr um die Umstellung devd zu udev, das hatte ich bereits (mit einigem Fluchen...) hinter mir.

Bei der Tastatur handelt es sich um eine "Microsoft Wireless Optical Desktop 2.1", eine ältere, schnurlose Tastatur/Maus Combo. An der Konsole funktionieren sowohl Tastatur als auch Maus einwandfrei, nur in Xorg geht gar nichts mehr.

Hier mal die Xorg.0.log eines Starts (mit Shutdown durch den Powerknopf, anderes geht nicht mehr):
Code:
[    43.366] 
X.Org X Server 1.20.9
X Protocol Version 11, Revision 0
[    43.366] Build Operating System: FreeBSD 12.1-RELEASE-p10 amd64 
[    43.366] Current Operating System: FreeBSD sirius 12.2-RELEASE FreeBSD 12.2-RELEASE IVYBRIDGE amd64
[    43.366] Build Date: 24 October 2020  01:56:28AM
[    43.366]  
[    43.366] Current version of pixman: 0.40.0
[    43.366]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    43.367] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    43.367] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Oct 30 17:08:55 2020
[    43.368] (==) Using config file: "/etc/X11/xorg.conf"
[    43.368] (==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
[    43.369] (==) ServerLayout "Layout0"
[    43.369] (**) |-->Screen "Screen0" (0)
[    43.369] (**) |   |-->Monitor "Monitor0"
[    43.369] (**) |   |-->Device "Device0"
[    43.369] (**) |-->Input Device "Keyboard0"
[    43.369] (**) |-->Input Device "Mouse0"
[    43.369] (==) Automatically adding devices
[    43.369] (==) Automatically enabling devices
[    43.369] (==) Not automatically adding GPU devices
[    43.369] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    43.373] (==) FontPath set to:
    /usr/local/share/fonts/misc/,
    /usr/local/share/fonts/TTF/,
    /usr/local/share/fonts/OTF/,
    /usr/local/share/fonts/Type1/,
    /usr/local/share/fonts/100dpi/,
    /usr/local/share/fonts/75dpi/,
    catalogue:/usr/local/etc/X11/fontpath.d
[    43.373] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[    43.373] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    43.373] (WW) Disabling Keyboard0
[    43.373] (WW) Disabling Mouse0
[    43.373] (II) Loader magic: 0x42e020
[    43.373] (II) Module ABI versions:
[    43.373]     X.Org ANSI C Emulation: 0.4
[    43.373]     X.Org Video Driver: 24.1
[    43.373]     X.Org XInput driver : 24.1
[    43.373]     X.Org Server Extension : 10.0
[    43.373] (--) PCI:*(1@0:0:0) 10de:1d01:1462:8c98 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/65536
[    43.373] (II) LoadModule: "glx"
[    43.374] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[    43.377] (II) Module glx: vendor="X.Org Foundation"
[    43.377]     compiled for 1.20.9, module version = 1.0.0
[    43.377]     ABI class: X.Org Server Extension, version 10.0
[    43.377] (II) LoadModule: "nvidia"
[    43.377] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[    43.386] (II) Module nvidia: vendor="NVIDIA Corporation"
[    43.386]     compiled for 1.6.99.901, module version = 1.0.0
[    43.386]     Module class: X.Org Video Driver
[    43.388] (II) NVIDIA dlloader X Driver  440.100  Fri May 29 08:13:34 UTC 2020
[    43.388] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    43.388] (--) Using syscons driver with X support (version 2.0)
[    43.388] (++) using VT number 9

[    43.390] (II) Loading sub module "fb"
[    43.390] (II) LoadModule: "fb"
[    43.390] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[    43.391] (II) Module fb: vendor="X.Org Foundation"
[    43.391]     compiled for 1.20.9, module version = 1.0.0
[    43.391]     ABI class: X.Org ANSI C Emulation, version 0.4
[    43.391] (II) Loading sub module "wfb"
[    43.391] (II) LoadModule: "wfb"
[    43.391] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[    43.392] (II) Module wfb: vendor="X.Org Foundation"
[    43.392]     compiled for 1.20.9, module version = 1.0.0
[    43.392]     ABI class: X.Org ANSI C Emulation, version 0.4
[    43.393] (II) Loading sub module "ramdac"
[    43.393] (II) LoadModule: "ramdac"
[    43.393] (II) Module "ramdac" already built-in
[    43.394] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    43.394] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    43.394] (==) NVIDIA(0): RGB weight 888
[    43.394] (==) NVIDIA(0): Default visual is TrueColor
[    43.394] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    43.394] (**) NVIDIA(0): Enabling 2D acceleration
[    43.394] (II) Loading sub module "glxserver_nvidia"
[    43.394] (II) LoadModule: "glxserver_nvidia"
[    43.395] (II) Loading /usr/local/lib/xorg/modules/extensions/libglxserver_nvidia.so
[    43.451] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[    43.451]     compiled for 1.6.99.901, module version = 1.0.0
[    43.451]     Module class: X.Org Server Extension
[    43.451] (II) NVIDIA GLX Module  440.100  Fri May 29 08:12:16 UTC 2020
[    43.455] (II) NVIDIA: The X server supports PRIME Render Offload.
[    44.219] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[    44.219] (--) NVIDIA(0):     DFP-0
[    44.219] (--) NVIDIA(0):     DFP-1
[    44.219] (--) NVIDIA(0):     DFP-2 (boot)
[    44.220] (II) NVIDIA(0): NVIDIA GPU GeForce GT 1030 (GP108-A) at PCI:1:0:0 (GPU-0)
[    44.220] (--) NVIDIA(0): Memory: 2097152 kBytes
[    44.220] (--) NVIDIA(0): VideoBIOS: 86.08.24.00.23
[    44.220] (II) NVIDIA(0): Detected PCI Express Link width: 4X
[    44.220] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    44.220] (--) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[    44.220] (--) NVIDIA(GPU-0): DFP-0: 1440.0 MHz maximum pixel clock
[    44.220] (--) NVIDIA(GPU-0): 
[    44.221] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    44.221] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    44.221] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    44.221] (--) NVIDIA(GPU-0): 
[    44.252] (--) NVIDIA(GPU-0): DELL S2719H (DFP-2): connected
[    44.252] (--) NVIDIA(GPU-0): DELL S2719H (DFP-2): Internal TMDS
[    44.252] (--) NVIDIA(GPU-0): DELL S2719H (DFP-2): 600.0 MHz maximum pixel clock
[    44.252] (--) NVIDIA(GPU-0): 
[    44.257] (==) NVIDIA(0): 
[    44.257] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    44.257] (==) NVIDIA(0):     will be used as the requested mode.
[    44.257] (==) NVIDIA(0): 
[    44.257] (II) NVIDIA(0): Validated MetaModes:
[    44.257] (II) NVIDIA(0):     "DFP-2:nvidia-auto-select"
[    44.257] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[    44.263] (--) NVIDIA(0): DPI set to (81, 80); computed from "UseEdidDpi" X config
[    44.263] (--) NVIDIA(0):     option
[    44.263] (II) NVIDIA: Reserving 24576.00 MB of virtual memory for indirect memory
[    44.263] (II) NVIDIA:     access.
[    44.287] (II) NVIDIA(0): Setting mode "DFP-2:nvidia-auto-select"
[    44.329] (==) NVIDIA(0): Disabling shared memory pixmaps
[    44.329] (==) NVIDIA(0): Backing store enabled
[    44.329] (==) NVIDIA(0): Silken mouse enabled
[    44.331] (**) NVIDIA(0): DPMS enabled
[    44.331] (II) Loading sub module "dri2"
[    44.331] (II) LoadModule: "dri2"
[    44.331] (II) Module "dri2" already built-in
[    44.331] (II) NVIDIA(0): [DRI2] Setup complete
[    44.331] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    44.331] (II) Initializing extension Generic Event Extension
[    44.332] (II) Initializing extension SHAPE
[    44.332] (II) Initializing extension MIT-SHM
[    44.332] (II) Initializing extension XInputExtension
[    44.333] (II) Initializing extension XTEST
[    44.333] (II) Initializing extension BIG-REQUESTS
[    44.333] (II) Initializing extension SYNC
[    44.334] (II) Initializing extension XKEYBOARD
[    44.334] (II) Initializing extension XC-MISC
[    44.334] (II) Initializing extension SECURITY
[    44.334] (II) Initializing extension XFIXES
[    44.334] (II) Initializing extension RENDER
[    44.334] (II) Initializing extension RANDR
[    44.335] (II) Initializing extension COMPOSITE
[    44.335] (II) Initializing extension DAMAGE
[    44.335] (II) Initializing extension MIT-SCREEN-SAVER
[    44.335] (II) Initializing extension DOUBLE-BUFFER
[    44.336] (II) Initializing extension RECORD
[    44.336] (II) Initializing extension DPMS
[    44.336] (II) Initializing extension Present
[    44.336] (II) Initializing extension DRI3
[    44.336] (II) Initializing extension X-Resource
[    44.336] (II) Initializing extension XVideo
[    44.337] (II) Initializing extension XVideo-MotionCompensation
[    44.337] (II) Initializing extension GLX
[    44.337] (II) Initializing extension GLX
[    44.337] (II) Indirect GLX disabled.
[    44.337] (II) GLX: Another vendor is already registered for screen 0
[    44.337] (II) Initializing extension XFree86-VidModeExtension
[    44.338] (II) Initializing extension XFree86-DGA
[    44.338] (II) Initializing extension XFree86-DRI
[    44.338] (II) Initializing extension DRI2
[    44.338] (II) Initializing extension NV-GLX
[    44.338] (II) Initializing extension NV-CONTROL
[    44.338] (II) Initializing extension XINERAMA
[    44.434] (II) config/udev: Adding input device System keyboard multiplexer (/dev/input/event0)
[    44.434] (**) System keyboard multiplexer: Applying InputClass "Evdev keyboard"
[    44.434] (**) System keyboard multiplexer: Applying InputClass "libinput keyboard catchall"
[    44.434] (**) System keyboard multiplexer: Applying InputClass "Keyboard0"
[    44.434] (II) LoadModule: "libinput"
[    44.434] (II) Loading /usr/local/lib/xorg/modules/input/libinput_drv.so
[    44.440] (II) Module libinput: vendor="X.Org Foundation"
[    44.440]     compiled for 1.20.9, module version = 0.30.0
[    44.440]     Module class: X.Org XInput Driver
[    44.440]     ABI class: X.Org XInput driver, version 24.1
[    44.440] (II) Using input driver 'libinput' for 'System keyboard multiplexer'
[    44.440] (**) System keyboard multiplexer: always reports core events
[    44.440] (**) Option "Device" "/dev/input/event0"
[    44.441] (**) Option "_source" "server/udev"
[    44.449] (II) event0  - System keyboard multiplexer: is tagged by udev as: Keyboard
[    44.449] (II) event0  - System keyboard multiplexer: device is a keyboard
[    44.449] (II) event0  - System keyboard multiplexer: device removed
[    44.449] (**) Option "config_info" "udev:/dev/input/event0"
[    44.449] (II) XINPUT: Adding extended input device "System keyboard multiplexer" (type: KEYBOARD, id 6)
[    44.449] (**) Option "xkb_rules" "evdev"
[    44.449] (**) Option "xkb_layout" "de"
[    44.474] (II) event0  - System keyboard multiplexer: is tagged by udev as: Keyboard
[    44.474] (II) event0  - System keyboard multiplexer: device is a keyboard
[    44.474] (II) config/udev: Adding input device System mouse (/dev/input/event1)
[    44.474] (**) System mouse: Applying InputClass "libinput pointer catchall"
[    44.474] (II) Using input driver 'libinput' for 'System mouse'
[    44.474] (**) System mouse: always reports core events
[    44.474] (**) Option "Device" "/dev/input/event1"
[    44.474] (**) Option "_source" "server/udev"
[    44.475] (II) event1  - System mouse: is tagged by udev as: Mouse
[    44.475] (II) event1  - System mouse: device is a pointer
[    44.475] (II) event1  - System mouse: device removed
[    44.475] (**) Option "config_info" "udev:/dev/input/event1"
[    44.475] (II) XINPUT: Adding extended input device "System mouse" (type: MOUSE, id 7)
[    44.475] (**) Option "AccelerationScheme" "none"
[    44.475] (**) System mouse: (accel) selected scheme none/0
[    44.475] (**) System mouse: (accel) acceleration factor: 2.000
[    44.475] (**) System mouse: (accel) acceleration threshold: 4
[    44.476] (II) event1  - System mouse: is tagged by udev as: Mouse
[    44.476] (II) event1  - System mouse: device is a pointer
[    44.476] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    44.476] (**) Power Button: Applying InputClass "Evdev keyboard"
[    44.476] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    44.476] (**) Power Button: Applying InputClass "Keyboard0"
[    44.476] (II) Using input driver 'libinput' for 'Power Button'
[    44.476] (**) Power Button: always reports core events
[    44.476] (**) Option "Device" "/dev/input/event2"
[    44.476] (**) Option "_source" "server/udev"
[    44.476] (II) event2  - Power Button: is tagged by udev as: Keyboard
[    44.477] (II) event2  - Power Button: device is a keyboard
[    44.477] (II) event2  - Power Button: device removed
[    44.477] (**) Option "config_info" "udev:/dev/input/event2"
[    44.477] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[    44.477] (**) Option "xkb_rules" "evdev"
[    44.477] (**) Option "xkb_layout" "de"
[    44.477] (II) event2  - Power Button: is tagged by udev as: Keyboard
[    44.477] (II) event2  - Power Button: device is a keyboard
[    44.478] (II) config/udev: Adding input device AT keyboard (/dev/input/event3)
[    44.478] (**) AT keyboard: Applying InputClass "Evdev keyboard"
[    44.478] (**) AT keyboard: Applying InputClass "libinput keyboard catchall"
[    44.478] (**) AT keyboard: Applying InputClass "Keyboard0"
[    44.478] (II) Using input driver 'libinput' for 'AT keyboard'
[    44.478] (**) AT keyboard: always reports core events
[    44.478] (**) Option "Device" "/dev/input/event3"
[    44.478] (**) Option "_source" "server/udev"
[    44.478] (II) event3  - AT keyboard: is tagged by udev as: Keyboard
[    44.478] (II) event3  - AT keyboard: device is a keyboard
[    44.478] (II) event3  - AT keyboard: device removed
[    44.478] (**) Option "config_info" "udev:/dev/input/event3"
[    44.478] (II) XINPUT: Adding extended input device "AT keyboard" (type: KEYBOARD, id 9)
[    44.478] (**) Option "xkb_rules" "evdev"
[    44.478] (**) Option "xkb_layout" "de"
[    44.479] (II) event3  - AT keyboard: is tagged by udev as: Keyboard
[    44.479] (II) event3  - AT keyboard: device is a keyboard
[    56.484] (II) event0  - System keyboard multiplexer: device removed
[    56.484] (II) event1  - System mouse: device removed
[    56.484] (II) event2  - Power Button: device removed
[    56.484] (II) event3  - AT keyboard: device removed
[    56.488] (II) UnloadModule: "libinput"
[    56.488] (II) UnloadModule: "libinput"
[    56.488] (II) UnloadModule: "libinput"
[    56.488] (II) UnloadModule: "libinput"
[    56.639] (II) NVIDIA(GPU-0): Deleting GPU-0
[    56.641] (II) Server terminated successfully (0). Closing log file.

xorg.conf
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.64


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputClass"

    # generated from default
    #Option           "Protocol" "standard"
    #Option           "XkbRules" "base"
    #Option           "XkbModel" "pc105"
    Identifier         "Keyboard0"
    MatchIsKeyboard    "on"
    Option         "XkbLayout" "de"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Ich bin ratlos. Und etwas frustriert... Jetzt sind alle 4 FreeBSD Installationen unbenutzbar.

Danke für Hilfe!

Robert
 

klimaschreck

Well-Known Member
Könntest du mal Input Device und Input Class herauskommentieren in der xorg.conf. Ich meine gelesen zu haben, dass das Keyboard nicht mehr konfiguriert werden darf.
 

serie300

Well-Known Member
Hmm

ich habe in /usr/local/etc/xorg.conf.d nur eine Datei mit
Code:
Section "InputClass"
    Identifier    "KeyboardDefaults"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "de"
Endsection
Kannst du auf den xorg.d Mechanismus umstellen? Ich glaube das ist, was aktuell von den X Entwicklern bevorzugt wird.
 

Andy_m4

Well-Known Member
Um meine Vorredner zu ergänzen:

Es macht generell Sinn bei Problemen mit X.org es mit einer leeren xorg.conf zu versuchen und die dann ggf. zu ergänzen.

Man kann auch mit
X -configure
sich X.org eine Autoerkennung durchführen lassen. Der schreibt dann eine xorg.conf die man als Basis für eine eigene Konfiguration nehmen kann.
 

mr44er

moderater Moderator
Teammitglied
Code:
[    43.368] (==) Using config file: "/etc/X11/xorg.conf"
[    43.368] (==) Using system config directory "/usr/local/share/X11/xorg.conf.d"

nvidia-xconfig benutzt zum Schreiben noch den alten Pfad /etc/X11/xorg.conf. Schieb die xorg.conf mal hier rein /usr/local/share/X11/xorg.conf.d
 

Rosendoktor

Well-Known Member
Danke für die Tips. Hab alle probiert.

Leider hilft das alles nichts. Egal was ich gemacht habe, die Tastatur und die Maus gehen nicht mehr in Xorg.

Hab eben testweise eine uralte, staubige, gammlige PS/2 Tastaur und eine Billigschrott China USB Maus drangestöpselt, die gehen beide sofort. Die will ich aber nicht mehr anfassen... bäh...

Mir scheint dass diese Microsoft Combo da einfach nicht mehr unterstützt wird. Ist mir eh zu ausladend auf dem begrenzten Platz da auch dem Schreibtisch.

Na gut, dann war's das vorerst mit FreeBSD auf dem PC, hol' ich mir eben eine neue Tastatur/Maus Combo. Da will ich mir aber was ordentliches aussuchen was dann auch sicher läuft und das wird etwas dauern.

Na dann, danke nochmal an alle, und auf ein Neues im nächsten Thread: "12.2 Upgrade - Problem #2 - Xorg auf X220 startet gar nicht mehr". Coming soon! :D
 

Rosendoktor

Well-Known Member
Ich nochmal... :rolleyes:

Hatte mir was ausgeguckt, eine schlanke Logitech Combo mit dem Logitech Unifying Receiver.

Bevor ich das bestelle wollte ich ausprobieren, ob die kleine Logitech K830 Multimedia Tastatur vom HTPC im Wohnzimmer, ebenfalls mit dem Logitech Unifying Receiver, denn mit FreeBSD 12.2 funktioniert.

Und, was ist? Ich kann damit ins BIOS/UEFI, kann GRUB bedienen, an der Kommandozeile in Debian und FreeBSD arbeiten, in Debian unter X arbeiten.

Aber nicht in FreeBSD unter X. :grumble:

Leute, das kann's doch echt nicht sein... Soll ich jetzt die olle PS/2 Tastatur putzen und die genauso olle PS/2 Maus die noch irgendwo in den Schubladen herumfliegt suchen, um mit FreeBSD 12.2 arbeiten zu können? Sorry... bin grad angefressen. :mad: Das ist jetzt das vierte oder fünfte mal hintereinander dass Essentielles kaputt geht bei einem Upgrade. Nix für Ungut... Windows 10 ist da ja auch nicht besser. :D Und das kostet sogar noch was... :ugly:

Hab eben auch noch x11-server/xorg-server mit der devd statt der udev Option compiliert und installiert, nix...

:confused::confused::confused:

Hat sonst niemand Probleme mit schnurlosen Tastatur/Maus Combos unter 12.2?
 

Yamagi

Possessed With Psi Powers
Teammitglied
Das ist doch garantiert das große X.org-Update aus dem Sommer. Hier wurde schon alles gesagt, aber noch mal kurz zusammengefasst:
  1. Sicherstellen, dass xf86-input-libinput installierst ist.
  2. In der xorg.conf oder der entsprechenden Datei unter xorg.conf.d/ die Driver-Zeile des Keyboard entfernen.
 

Rosendoktor

Well-Known Member
Das ist doch garantiert das große X.org-Update aus dem Sommer. Hier wurde schon alles gesagt, aber noch mal kurz zusammengefasst:
  1. Sicherstellen, dass xf86-input-libinput installierst ist.
  2. In der xorg.conf oder der entsprechenden Datei unter xorg.conf.d/ die Driver-Zeile des Keyboard entfernen.
Nein, ist es nicht. Das hatte ich längst erledigt. Zudem kam während des 12.1 zu 12.2 Upgrades gar kein Xorg Upgrade. Und wenn es das wäre, dann würden wohl auch keine PS/2 Tastatur und PS/2 Maus bzw. simple USB Maus funktionieren.

Die xf86-input-libinput ist installiert. In der xorg.conf is keine Driver Zeile mehr.

Trotzdem funktionieren beide Combos, die Microsoft und die Logitech, überhaupt nicht.

Installiert ist das hier:
Code:
root@sirius:~# pkg info | grep xf86
libXxf86dga-1.1.5              X DGA Extension
libXxf86vm-1.1.4_3             X Vidmode Extension
xf86-input-evdev-2.10.6_6      X.Org event device input driver
xf86-input-keyboard-1.9.0_4    X.Org keyboard input driver
xf86-input-libinput-0.30.0_1   X.Org libinput input driver
xf86-input-mouse-1.9.3_3       X.Org mouse input driver
xf86-video-scfb-0.0.5_2        X.Org syscons display driver
xf86-video-vesa-2.5.0          X.Org vesa display driver
xf86dga-1.0.3_1                Test program for the XFree86-DGA extension

Code:
root@sirius:/usr/local/share/X11/xorg.conf.d# ls -l
total 4
-rw-r--r--  1 root  wheel  1099 24 Okt. 04:16 10-evdev.conf
-rw-r--r--  1 root  wheel   152 31 Okt. 03:20 20-evdev-kbd.conf
-rw-r--r--  1 root  wheel  1429 24 Okt. 04:18 40-libinput.conf

Die xorg.conf enthält nur noch das für die Nvidia Karte nötige:
Code:
root@sirius:/etc/X11# cat xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.64

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
EndSection

Section "Files"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 

Rosendoktor

Well-Known Member
So, jetzt wird's schräg...

Also, direkt nach dem hochfahren hab' ich unter /dev/input das hier:
Code:
root@sirius:/dev/input# ls -l
total 0
crw-------  1 root  wheel   0xc 31 Okt. 16:23 event0
crw-------  1 root  wheel  0x29 31 Okt. 16:23 event1
crw-------  1 root  wheel  0x42 31 Okt. 16:23 event2
crw-------  1 root  wheel  0x4c 31 Okt. 16:23 event3
Tastatur und Maus funktionieren an der Konsole. Nach einem startx keine Tastatur, Mauszeiger in der Blidschirmmitte festgenagelt.

Dann ein Reboot. Tastatur und Maus funktionieren an der Konsole. Ich stecke das USB Empfängerdongle der Combo kurz ab und wieder an. Tastatur funktioniert an der Konsole, Maus nicht mehr.

Aber:
Code:
root@sirius:/dev/input# ls -l
total 0
crw-------  1 root  wheel    0xc 31 Okt. 16:32 event0
crw-------  1 root  wheel   0x29 31 Okt. 16:32 event1
crw-------  1 root  wheel   0x42 31 Okt. 16:32 event2
crw-------  1 root  wheel   0x4c 31 Okt. 16:32 event3
crw-------  1 root  wheel  0x115 31 Okt. 16:36 event4

Nach einem startx funktioniert plötzlich die Tastatur unter X. Nicht aber die Maus, es wird nicht mal ein Mauszeiger angezeigt.

:confused:
 

pit234a

Well-Known Member
kam während des 12.1 zu 12.2 Upgrades gar kein Xorg Upgrade
zu deinem Problem habe ich nicht viele Ideen. Aber, wenn ich das lese, würde ich vorschlagen, dass du zuerst auch mal noch einen pkg upgrade machst.
Das sollte zwar eigentlich nicht notwendig sein, aber ich habe mir das angewöhnt und mache das immer nach einem Release-Update.
 

Rosendoktor

Well-Known Member
zu deinem Problem habe ich nicht viele Ideen. Aber, wenn ich das lese, würde ich vorschlagen, dass du zuerst auch mal noch einen pkg upgrade machst.
Das sollte zwar eigentlich nicht notwendig sein, aber ich habe mir das angewöhnt und mache das immer nach einem Release-Update.
Hab ich gemacht, dabei wurden etwa 300 von 900 Paketen "reinstalled". Sicherheitshalber gerade eben noch ein pkg upgrade -f. Hat auch nichts gebracht.
 

Rosendoktor

Well-Known Member
So, Problem gelöst.

Aber der Reihe nach.

Mit dieser USB Combo (und wahrscheinlich allen USB Combos) hatte FreeBSD von Anfang an, das war noch 10.x, seine Probleme. Damals muste ich in der /etc/devd/usb.conf irgendwas anpassen damit die korrekt funktioniert. In 11.x war das dann wieder kaputt, stattdessen war der Workaround, den uhidd Daemon zu benutzen. Jetzt in 12.2 ist wohl der USB Mausteiber ums nicht mehr im Kernel, sondern muss als Modul geladen werden, was wohl bei einer reinen USB Maus automatisch passiert, nicht aber bei diesen Combos. Und den uhidd Daemon braucht's auch nicht mehr, der scheint eher zu stören.

Auf jeden Fall funktioniert es jetzt. Und es scheint endlich eine saubere Lösung ohne gefrickelte Workarounds zu sein. Bis auf das Laden des Maustreibers halt.

Danke Euch für die Tipps! Zumindest meine beiden 12.2 Installationen laufen nun wieder. :)
 

auge

Well-Known Member
Hi Rosendoktor,
hast du jetzt ein funktionierendes System, weches 'libinput' verwendet für Maus und Tastatur? Wenn Ja, könntest du deine xorg.conf ggf. xorg.conf.d/ zeigen. Auch wäre es wichtig zu wissen welchen Wert die Variabele 'kern.evdev.rcpt_mask' bei dir hat.
 
Oben