12.2, xfce4 und cursor

bsd4me

Well-Known Member
Moin moin,

nach dem Upgrade auf die neuesten packages geht das Cursor UP unter X11 nicht mehr. Ich nutze FreeBSD 12.2, xfce4 14.6 auf einem Lenovo W500. Vielleicht hat jemand eine Idee?

hier ein paar configs:

# /boot/loader.conf

vfs.root.mountfrom="zfs:zroot"
zfs_load="YES"
vfs.zfs.arc_max="1G"
pf_load="YES"
kern.racct.enable=1

# /etc/rc.conf

wlans_iwn0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"
ifconfig_wlan0_ipv6="inet6 accept_rtadv"
rtsold_enable="YES"
zfs_enable="YES"
defaultrouter="192.168.1.100"
hostname="sunshine"
keymap="de"
sshd_enable="YES"
ntpd_enable="YES"
sendmail_enable="NONE"
linux_enable="YES"
dbus_enable="YES"
nvidia_name="nvidia"
nvidia_modeset="nvidia-modeset"
devfs_system_ruleset="devfsrules_common"
gateway_enable="YES"
cloned_interfaces="bridge0 tap0"
ifconfig_bridge0="inet 192.168.2.100 netmask 255.255.255.0 addm wlan0 addm tap0"
kld_list="nvidia nvidia-modeset nmdm vmm"

# /etc/X11/xorf.conf

...
Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection
...


Vielen Dank für Mühe und Hilfe!! :) Norbert
 
Ich habe zwar keine Probleme mit den Cursortasten aber bei mir stand im Logfile nach dem Upgrade auf 4.16:

=====
Message from libxkbcommon-1.0.3:

--
If arrow keys don't work under X11 switch to legacy rules e.g.,

For sh/bash/ksh/zsh run and (optionally) add into ~/.profile:
export XKB_DEFAULT_RULES=xorg

For csh/tcsh run and (optionally) add into ~/.login:
setenv XKB_DEFAULT_RULES xorg
=====
 

bsd4me

Well-Known Member
es hat nichts gebracht, die UP Pfeiltaste tut es trotzdem nicht mehr - alles andere scheint zu funktionieren, ob mit oder ohne XKB_DEFAULT_RULES...
 

lme

FreeBSD Committer
Wenn ich mich recht erinnere, musst du statt 'Driver "keyboard'" jetzt 'Driver "kbd"' in der xorg.conf setzen, dann geht's wieder.
 
Hier ist meine Konfiguration. Ich habe es genau so erstellt, wie es im Handbuch in Kapitel "5.4.7.1. Keyboards"
beschrieben steht:
$ cat /usr/local/etc/X11/xorg.conf.d/keyboard-de.conf
Section "InputClass"
Identifier "KeyboardDefaults"
MatchIsKeyboard "on"
Option "XkbLayout" "de"
EndSection
$
 

Andy_m4

Well-Known Member
Wie ist es denn, wenn Du die Tastaturkonfiguration unter X.org völlig sein lässt?
In den allermeisten Fällen braucht man das doch gar nicht mehr.

Was ist eigentlich die Ausgabe von xev wenn man die Taste "Cursor Up" betätigt?
(wurde zwar schon mal gefragt, hast Du aber offenbar übersehen)
 

bsd4me

Well-Known Member
Kannst Du mal mit xev nachsehen ob Du überhaupt ein Event bekommst und wenn ja, welches?
beim cursor up bekomme ich mit xev folgendes:

FocusOut event, serial 37, synthetic NO, window 0x4000001,
mode NotifyGrab, detail NotifyAncestor

FocusOut event, serial 37, synthetic NO, window 0x4000001,
mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 37, synthetic NO, window 0x4000001,
mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
keys: 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

:)
 

bsd4me

Well-Known Member
Das scheint ein Bug zu sein den es schon mal gab und der gefixt wurde und mit XFCE 4.16 wieder zurück ist:
Bug 244290 - x11-wm/xfce4 does not see up arrow after reinstall
bzw.
Bug 244290 - x11-wm/xfce4 does not see up arrow after reinstall / Comment #51
jaaa!! das hat geholfen!! Danke!!

-- snip --
Keith Beattie 2021-01-04 18:18:47 UTC
FWIW, I had this exact issue but not until upgrading to XFCE 4.16
The fix I found was to hit "Reset to Defaults" in
XFCE Settings > Keyboard > Application Shortcuts
-- snip --

VG Norbert :) :)
 

bsd4me

Well-Known Member
es scheint aber so zu sein, dass man bei jedem Neustart der Festeroberfläche die Application Shortcuts erneut zurücksetzen müsste... mmhhmmmmm...
 
Oben