2TB HDD läuft fehlerfrei an billig SATA-Controler?

Hat jemand 2 TB Festplatte fehlerfrei an einem billig SATA-Controler (<25€) laufen?


  • Umfrageteilnehmer
    14

Wasp

Insektenspray-Gegner
Wo es eh eine simple (Um-)Frage ist, dachte ich, kann ich auch gleich eine draus machen:
Hat hier jemand eine 2 TB Festplatte an einem billigen SATA-Controler fehlerfrei(!) in betrieb? (Controler < 25 €)

Wenn ja, würde mich dringend die Konfiguration interessieren:
  • SATA-Controler
  • Chip des SATA-Controler
  • Festplatten

Nach zwei Fehlkäufen hofft auf rege (positive) Beteiligung,
Wasp
 
Zuletzt bearbeitet:

teuk

Well-Known Member
Hi,

hier laeuft eine 2TB Western Digital WDC WD20EADS per eSATA an einem siis(4) ExpressCard Controller mit SiI3531 Chipsatz (< EUR 20) seit gut sechs Monaten problemlos. Nur bei der Reihenfolge von Platte anschliessen und Treiber laden ist FreeBSD bisweilen etwas waehlerisch.

Aus reiner Neugierde: Was traten bei dir fuer Fehler auf?

teuk
 
Zuletzt bearbeitet:

Wasp

Insektenspray-Gegner
Hatte erst eine Karte mit VT6421a, dort kam es massiv zu fehlern. (Fehler weiß ich jetzt nicht mehr.) Darauf hin hatte ich auch eine SiI3531 mit zwei internen Ports. Unter FreeBSD 6.2 detached die Platte gelegentlich bei Schreibversuchen (s. http://www.bsdforen.de/showthread.php?t=24786), unter FreeBSD 7.3 läuft es besser, jedoch kommt es immer wieder auch hier zu den gleichen Schreibproblemen, nur daß sie nicht zum Einfrieren inkl. Neustart führen. Da aber auch unter Windows zwar zwei Platten, jedoch, (fälschlicherweise) zweimal die gleiche angezeigt wird, geh ich weiterhin von Hardwareproblemen aus.

Von einem SiI3114 wurde mir vom Händler (netterweise) auch abgeraten, da es mit 2 TB wohl auch hier zu problemen kommt. (Festplatten werden wohl garnicht oder zumindest falsch erkannt, etc..)
 

dettus

Bicycle User
ich persoenlich habe eigentlich keine probleme mit 2tb.
hier geb ich dir einfach mal meine dmesg, vielleicht hilft es dir ja bei der kaufentscheidung.

Code:
OpenBSD 4.7 (GENERIC.MP) #130: Wed Mar 17 20:48:50 MDT 2010
    deraadt@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 3487170560 (3325MB)
avail mem = 3387387904 (3230MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.5 @ 0x9f400 (52 entries)
bios0: vendor American Megatrends Inc. version "V1.6" date 09/24/2009
bios0: MICRO-STAR INTERNATIONAL CO.,LTD MS-7577
acpi0 at bios0: rev 0
acpi0: tables DSDT FACP APIC MCFG OEMB HPET SSDT
acpi0: wakeup devices PCE2(S4) PCE3(S4) PCE4(S4) PCE5(S4) PCE6(S4) PCE7(S4) PCE9(S4) PCEA(S4) PCEB(S4) PCEC(S4) SBAZ(S4) PS2K(S1) PS2M(S1) P0PC(S4) UHC1(S4) UHC2(S4) UHC3(S4) USB4(S4) UHC5(S4) UHC6(S4) UHC7(S4) PWRB(S1)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD Phenom(tm) II X4 965 Processor, 3400.59 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 16 4MB entries fully associative
cpu0: DTLB 48 4KB entries fully associative, 48 4MB entries fully associative
cpu0: apic clock running at 200MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: AMD Phenom(tm) II X4 965 Processor, 3400.17 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu1: ITLB 32 4KB entries fully associative, 16 4MB entries fully associative
cpu1: DTLB 48 4KB entries fully associative, 48 4MB entries fully associative
cpu2 at mainbus0: apid 2 (application processor)
cpu2: AMD Phenom(tm) II X4 965 Processor, 3400.17 MHz
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu2: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu2: ITLB 32 4KB entries fully associative, 16 4MB entries fully associative
cpu2: DTLB 48 4KB entries fully associative, 48 4MB entries fully associative
cpu3 at mainbus0: apid 3 (application processor)
cpu3: AMD Phenom(tm) II X4 965 Processor, 3400.17 MHz
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,MWAIT,CX16,NXE,MMXX,FFXSR,LONG,3DNOW2,3DNOW
cpu3: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 512KB 64b/line 16-way L2 cache
cpu3: ITLB 32 4KB entries fully associative, 16 4MB entries fully associative
cpu3: DTLB 48 4KB entries fully associative, 48 4MB entries fully associative
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 21, 24 pins
acpihpet0 at acpi0: 14318180 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (PCE2)
acpiprt2 at acpi0: bus -1 (PCE3)
acpiprt3 at acpi0: bus -1 (PCE4)
acpiprt4 at acpi0: bus 2 (PCE5)
acpiprt5 at acpi0: bus 3 (PCE6)
acpiprt6 at acpi0: bus 4 (PCE7)
acpiprt7 at acpi0: bus -1 (PCE9)
acpiprt8 at acpi0: bus -1 (PCEA)
acpiprt9 at acpi0: bus -1 (PCEB)
acpiprt10 at acpi0: bus -1 (PCEC)
acpiprt11 at acpi0: bus 5 (P0PC)
acpicpu0 at acpi0: PSS
acpicpu1 at acpi0: PSS
acpicpu2 at acpi0: PSS
acpicpu3 at acpi0: PSS
acpibtn0 at acpi0: PWRB
pci0 at mainbus0 bus 0
mem address conflict 0xe0000000/0x20000000
pchb0 at pci0 dev 0 function 0 vendor "ATI", unknown product 0x5956 rev 0x00
ppb0 at pci0 dev 2 function 0 "ATI RD790 PCIE" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "NVIDIA GeForce 7600 GT" rev 0xa1
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ppb1 at pci0 dev 5 function 0 vendor "ATI", unknown product 0x597b rev 0x00
pci2 at ppb1 bus 2
re0 at pci2 dev 0 function 0 "Realtek 8168" rev 0x03: RTL8168D/8111D (0x2800), apic 4 int 17 (irq 11), address 40:61:86:2f:28:bd
rgephy0 at re0 phy 7: RTL8169S/8110S PHY, rev. 2
ppb2 at pci0 dev 6 function 0 "ATI RD790 PCIE" rev 0x00
pci3 at ppb2 bus 3
re1 at pci3 dev 0 function 0 "Realtek 8168" rev 0x03: RTL8168D/8111D (0x2800), apic 4 int 18 (irq 10), address 40:61:86:2f:28:bc
rgephy1 at re1 phy 7: RTL8169S/8110S PHY, rev. 2
ppb3 at pci0 dev 7 function 0 vendor "ATI", unknown product 0x597d rev 0x00
pci4 at ppb3 bus 4
vendor "VIA", unknown product 0x3403 (class serial bus subclass Firewire, rev 0x00) at pci4 dev 0 function 0 not configured
ahci0 at pci0 dev 17 function 0 "ATI SBx00 SATA" rev 0x00: apic 4 int 22 (irq 10), AHCI 1.1
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, SAMSUNG HD103UJ, 1AA0> SCSI3 0/direct fixed
sd0: 953869MB, 512 bytes/sec, 1953525168 sec total
sd1 at scsibus0 targ 1 lun 0: <ATA, WDC WD20EADS-00R, 01.0> SCSI3 0/direct fixed
sd1: 1907729MB, 512 bytes/sec, 3907029168 sec total
sd2 at scsibus0 targ 3 lun 0: <ATA, WDC WD5000KS-00M, 07.0> SCSI3 0/direct fixed
sd2: 476940MB, 512 bytes/sec, 976773168 sec total
ohci0 at pci0 dev 18 function 0 "ATI SB700 USB" rev 0x00: apic 4 int 16 (irq 10), version 1.0, legacy support
ohci1 at pci0 dev 18 function 1 "ATI SB700 USB" rev 0x00: apic 4 int 16 (irq 10), version 1.0, legacy support
ehci0 at pci0 dev 18 function 2 "ATI SB700 USB2" rev 0x00: apic 4 int 17 (irq 11)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "ATI EHCI root hub" rev 2.00/1.00 addr 1
ohci2 at pci0 dev 19 function 0 "ATI SB700 USB" rev 0x00: apic 4 int 18 (irq 10), version 1.0, legacy support
ohci3 at pci0 dev 19 function 1 "ATI SB700 USB" rev 0x00: apic 4 int 18 (irq 10), version 1.0, legacy support
ehci1 at pci0 dev 19 function 2 "ATI SB700 USB2" rev 0x00: apic 4 int 19 (irq 7)
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "ATI EHCI root hub" rev 2.00/1.00 addr 1
piixpm0 at pci0 dev 20 function 0 "ATI SBx00 SMBus" rev 0x3c: SMI
iic0 at piixpm0
iic0: addr 0x28 01=0a 02=00 03=00 04=41 05=80 06=00 07=2b 3e=03 41=0a 42=00 43=00 44=01 45=80 46=00 47=2b 81=0a 82=00 83=00 84=01 85=80 86=00 87=2b c1=0a c2=00 c3=00 c4=01 c5=80 c6=00 c7=2b words 00=ff0a 01=0a00 02=0000 03=00ff 04=01ff 05=80ff 06=00ff 07=ffff
iic0: addr 0x2e 00=05 01=0f 02=00 03=40 04=5c 10=d1 11=87 12=79 13=7c 14=32 15=1f 16=0f 17=fe 18=0f 19=fe 1a=20 1b=20 1c=1d 1d=40 1e=b5 1f=02 21=00 23=00 25=00 27=00 28=64 29=5f 2a=64 2b=5f 2c=3c 2d=37 2e=00 30=00 31=f0 32=f0 33=00 34=00 35=00 36=30 5a=04 5b=10 5c=20 5d=19 5e=34 61=0a 62=94 63=07 64=00 65=00 66=00 67=0f 69=55 6a=64 6b=46 6c=64 6d=46 70=0f 74=00 80=0f 84=00 90=00 91=00 92=01 a0=46 a1=3c a2=32 a3=28 a5=d9 a6=b2 a7=99 a8=80 b0=46 b1=3c b2=32 b3=28 b5=d9 b6=b2 b7=99 b8=80 f0=00 f1=00 f2=00 f3=00 f4=00 f5=00 f6=38 f7=ef f8=01 f9=44 fa=00 ff=27 words 00=05ea 01=0fb7 02=0027 03=408b 04=5cc9 05=ffc2 06=ff7f 07=ff14
spdmem0 at iic0 addr 0x50: 2GB DDR3 SDRAM PC3-10600
spdmem1 at iic0 addr 0x51: 2GB DDR3 SDRAM PC3-10600
pciide0 at pci0 dev 20 function 1 "ATI SB700 IDE" rev 0x00: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
pcib0 at pci0 dev 20 function 3 "ATI SB700 ISA" rev 0x00
ppb4 at pci0 dev 20 function 4 "ATI SB600 PCI" rev 0x00
pci5 at ppb4 bus 5
eap0 at pci5 dev 6 function 0 "Ensoniq CT5880" rev 0x04: apic 4 int 22 (irq 10)
ac97: codec id 0x83847608 (SigmaTel STAC9708/11)
ac97: codec features 18 bit DAC, 18 bit ADC, SigmaTel 3D
audio0 at eap0
midi0 at eap0: <AudioPCI MIDI UART>
ohci4 at pci0 dev 20 function 5 "ATI SB700 USB" rev 0x00: apic 4 int 18 (irq 10), version 1.0, legacy support
pchb1 at pci0 dev 24 function 0 "AMD AMD64 10h HyperTransport" rev 0x00
pchb2 at pci0 dev 24 function 1 "AMD AMD64 10h Address Map" rev 0x00
pchb3 at pci0 dev 24 function 2 "AMD AMD64 10h DRAM Cfg" rev 0x00
km0 at pci0 dev 24 function 3 "AMD AMD64 10h Misc Cfg" rev 0x00
pchb4 at pci0 dev 24 function 4 "AMD AMD64 10h Link Cfg" rev 0x00
usb2 at ohci0: USB revision 1.0
uhub2 at usb2 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb3 at ohci1: USB revision 1.0
uhub3 at usb3 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb4 at ohci2: USB revision 1.0
uhub4 at usb4 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb5 at ohci3: USB revision 1.0
uhub5 at usb5 "ATI OHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com0: probed fifo depth: 15 bytes
pckbc0 at isa0 port 0x60/5
pcppi0 at isa0 port 0x61
midi1 at pcppi0: <PC speaker>
spkr0 at pcppi0
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
usb6 at ohci4: USB revision 1.0
uhub6 at usb6 "ATI OHCI root hub" rev 1.00/1.00 addr 1
mtrr: Pentium Pro MTRR support
umass0 at uhub1 port 5 configuration 1 interface 0 "Genesys USB Reader" rev 2.00/93.17 addr 2
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd3 at scsibus1 targ 1 lun 0: <Generic, STORAGE DEVICE, 9317> SCSI0 0/direct removable
sd3: drive offline
sd4 at scsibus1 targ 1 lun 1: <Generic, STORAGE DEVICE, 9317> SCSI0 0/direct removable
sd4: drive offline
uhidev0 at uhub2 port 1 configuration 1 interface 0 " USB Keyboard" rev 1.10/2.80 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 modifier keys, 6 key codes
wskbd0 at ukbd0: console keyboard, using wsdisplay0
uhidev1 at uhub2 port 1 configuration 1 interface 1 " USB Keyboard" rev 1.10/2.80 addr 2
uhidev1: iclass 3/0, 2 report ids
uhid0 at uhidev1 reportid 1: input=1, output=0, feature=0
uhid1 at uhidev1 reportid 2: input=3, output=0, feature=0
uhidev2 at uhub2 port 3 configuration 1 interface 0 "Logitech USB-PS/2 Optical Mouse" rev 2.00/11.10 addr 3
uhidev2: iclass 3/1
ums0 at uhidev2: 3 buttons, Z dir
wsmouse0 at ums0 mux 0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
root on sd0a swap on sd0b dump on sd0b
WARNING: / was not properly unmounted
umass1 at uhub1 port 3 configuration 1 interface 0 "Apple iPod" rev 2.00/0.02 addr 3
umass1: using SCSI over Bulk-Only
scsibus3 at umass1: 2 targets, initiator 0
sd5 at scsibus3 targ 1 lun 0: <Apple, iPod, 1.62> SCSI0 0/direct removable
sd5: 28615MB, 2048 bytes/sec, 14651280 sec total
sd5 detached
scsibus3 detached
umass1 detached

edit: ach, so, ja... ich habe ein MSI 790FX-GD70 mainboard.
 
Zuletzt bearbeitet:

Wasp

Insektenspray-Gegner
edit: ach, so, ja... ich habe ein MSI 790FX-GD70 mainboard.

Und wenn ich das richtig sehe, hast Du Deine Platten auch direkt am Mainboard, oder? ;)

Mir geht es um einen separaten Controler für PCI 2.2 für unter 25 Euro. Da konnte ich bis jetzt nichts brauchbares ausmachen und im Netz finde ich auch niemanden der so etwas am laufen hat -- daher die Umfrage.

Aber nett zu sehen, daß Dein AM3 so gut erkannt wird. Spiele inzwischen mit dem gedanken mir eine gebrauchte Kiste im bereich AM2(+) zuzulegen. Das Geld finde ich da inzwischen fast besser investiert, statt "soviel" in einem Uraltrechner nicht wiederverwertbar zu versenken.
 

teuk

Well-Known Member
Als kurzer Nachtrag zu meinem Post sei noch gesagt, dass ich die Platte immer nur mit FreeBSD 8.x und eSATA laufen hatte. Wenn ich nichts uebersehen habe, dann waren das bei dir immer Versionen <= 7.3.
 

Wasp

Insektenspray-Gegner
Ja das stimmt, hatte bisher nur FreeBSD 7.3 oder älter versucht. Da es allerdings auch unter Windows zu Kurriositäten kam, ging und gehe ich von einem Controler-Problem aus.

Da ich Auf der Platte von Beginn an Daten in UFS2 hatte, konnte/wollte ich von Windows aus niemals schreiben, allerdings wird, wie bereits gesagt, an beiden Ports des SiI3512 die selbe Platte erkannt, auch wenn zwei unterschiedliche Festplatten angeschlossen sind.
 
Oben