• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

3 Monitore bzw. 2 unterschiedliche GPUs

mr44er

Well-Known Member
Themenstarter #1
Moinsn!
Nachdem meine Versuche irgendwie gescheitert sind, habe ich wahrscheinlich was übersehen oder mir fehlt das Verständnis.

Ich möchte drei Monitore gleichzeitig in Betrieb nehmen. Aktuell nutze ich die onboard-Intel mit drm-kmod und zwei Monitoren. Einer am DVI, der andere hängt am Display-Port. Soweit ok.

Im Bios ist 'forciere onboard-GPU trotz eingesteckter GPU' aktiviert.

Wenn ich jetzt eine GPU einstecke, wird diese zwar laut console erkannt, ich kann sie aber nicht ansprechen. Was ist ab hier der weitere Schritt?

Ich habe hier noch ältere Radeons liegen, die laufen für sich alleine aber nichtmal stabil und ich weiß nicht, wie sich das verhält, wenn drm-kmod 2 GPUs mit unterschiedlichen Treibern versorgen muss.

Wenn ich meine nvidia dazustecke, dann bekomme ich leider nur darauf ein Bild.
 

mr44er

Well-Known Member
Themenstarter #2
Das ist zum Heulen. :ugly:

nvidia beißt sich mit mesa, kann ich mit leben. Also eine radeon reingeschraubt.

Die einfachste Konstellation klappt schon nicht.

Im Bios ist das primary display die onboard-intel. Dort einen 1280x1024er Monitor am DVI angeschlossen. (der bringt Bild, auf dem tippe ich gerade)
An der radeon ebenfalls einen 1280x1024er am DVI angeschlossen.

Code:
vgapci1@pci0:0:2:0:     class=0x030000 card=0x11d71734 chip=0x01528086 rev=0x09 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller'
    class      = display
    subclass   = VGA
    
vgapci0@pci0:1:0:0:     class=0x030000 card=0xe990174b chip=0x954f1002 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD/ATI]'
    device     = 'RV710 [Radeon HD 4350/4550]'
    class      = display
    subclass   = VGA
Code:
kld_list="/boot/modules/i915kms.ko /boot/modules/radeonkms.ko coretemp"
...
ugen2.3: <Logitech USB-PS/2 Optical Mouse> at usbus2
drmn1: <drmn> on vgapci1
vgapci1: child drmn1 requested pci_enable_io
vgapci1: child drmn1 requested pci_enable_io
[drm] Unable to create a private tmpfs mount, hugepage support will be disabled(-19).
Failed to add WC MTRR for [0xd0000000-0xdfffffff]: -22; performance may suffer
[drm] Got stolen memory base 0xafa00000, size 0x20000000
[drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[drm] Driver supports precise vblank timestamp query.
[drm] Connector VGA-1: get mode from tunables:
[drm] - kern.vt.fb.modes.VGA-1
[drm] - kern.vt.fb.default_mode
[drm] Connector HDMI-A-1: get mode from tunables:
[drm] - kern.vt.fb.modes.HDMI-A-1
[drm] - kern.vt.fb.default_mode
[drm] Connector DP-1: get mode from tunables:
[drm] - kern.vt.fb.modes.DP-1
[drm] - kern.vt.fb.default_mode
[drm] Connector HDMI-A-2: get mode from tunables:
[drm] - kern.vt.fb.modes.HDMI-A-2
[drm] - kern.vt.fb.default_mode
[drm] Connector DP-2: get mode from tunables:
[drm] - kern.vt.fb.modes.DP-2
[drm] - kern.vt.fb.default_mode
[drm] Initialized i915 1.6.0 20171222 for drmn1 on minor 0
VT: Replacing driver "vga" with new "fb".
start FB_INFO:
type=11 height=1024 width=1280 depth=32
cmsize=16 size=5242880
pbase=0xd0061000 vbase=0xfffff800d0061000
name=drmn1 flags=0x0 stride=5120 bpp=32
cmap[0]=0 cmap[1]=7f0000 cmap[2]=7f00 cmap[3]=c4a000
end FB_INFO
drmn1: fb0: inteldrmfb frame buffer device
sysctl_warn_reuse: can't re-use a leaf (compat.linuxkpi.modeset)!
[drm] radeon kernel modesetting enabled.
drmn0: <drmn> on vgapci0
vgapci0: child drmn0 requested pci_enable_io
vgapci0: child drmn0 requested pci_enable_io
sysctl_warn_reuse: can't re-use a leaf (hw.dri.debug)!
sysctl_warn_reuse: can't re-use a leaf (hw.dri.vblank_offdelay)!
sysctl_warn_reuse: can't re-use a leaf (hw.dri.timestamp_precision)!
[drm] initializing kernel modesetting (RV710 0x1002:0x954F 0x174B:0xE990 0x00).
[drm:radeon_device_init] Unable to find PCI I/O BAR
[drm:radeon_atombios_init] Unable to find PCI I/O BAR; using MMIO for ATOM IIO
ATOM BIOS: 11X
[drm] GPU not posted. posting now...
drmn0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
drmn0: GTT: 1024M 0x0000000020000000 - 0x000000005FFFFFFF
Failed to add WC MTRR for [0xe0000000-0xefffffff]: -22; performance may suffer
[drm] Detected VRAM RAM=512M, BAR=256M
[drm] RAM width 64bits DDR
[TTM] Zone kernel: Available graphics memory: 16448416 kiB
[TTM] Zone dma32: Available graphics memory: 2097152 kiB
[TTM] Initializing pool allocator
[drm] radeon: 512M of VRAM memory ready
[drm] radeon: 1024M of GTT memory ready.
[drm] Loading RV710 Microcode
drmn0: successfully loaded firmware image with name: radeon/RV710_pfp.bin
drmn0: successfully loaded firmware image with name: radeon/RV710_me.bin
drmn0: successfully loaded firmware image with name: radeon/R700_rlc.bin
drmn0: successfully loaded firmware image with name: radeon/RV710_smc.bin
[drm] Internal thermal controller with fan control
[drm] radeon: dpm initialized
drmn0: successfully loaded firmware image with name: radeon/RV710_uvd.bin
[drm] GART: num cpu pages 262144, num gpu pages 262144
[drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[drm] PCIE GART of 1024M enabled (table at 0x000000000014C000).
drmn0: WB enabled
drmn0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0x0xfffff80016d18c00
drmn0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0x0xfffff80016d18c0c
drmn0: fence driver on ring 5 use gpu addr 0x000000000005c598 and cpu addr 0x0xfffff800e005c598
[drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[drm] Driver supports precise vblank timestamp query.
drmn0: radeon: MSI limited to 32-bit
[drm] radeon: irq initialized.
[drm] ring test on 0 succeeded in 1 usecs
[drm] ring test on 3 succeeded in 3 usecs
[drm] ring test on 5 succeeded in 1 usecs
[drm] UVD initialized successfully.
[drm] ib test on ring 0 succeeded in 0 usecs
[drm] ib test on ring 3 succeeded in 0 usecs
[drm] ib test on ring 5 succeeded
[drm] Connector VGA-2: get mode from tunables:
[drm] - kern.vt.fb.modes.VGA-2
[drm] - kern.vt.fb.default_mode
[drm] Connector HDMI-A-3: get mode from tunables:
[drm] - kern.vt.fb.modes.HDMI-A-3
[drm] - kern.vt.fb.default_mode
[drm] Connector DVI-I-1: get mode from tunables:
[drm] - kern.vt.fb.modes.DVI-I-1
[drm] - kern.vt.fb.default_mode
[drm] Radeon Display Connectors
[drm] Connector 0:
[drm] VGA-2
[drm] DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
[drm] Encoders:
[drm] CRT2: INTERNAL_KLDSCP_DAC2
[drm] Connector 1:
[drm] HDMI-A-3
[drm] HPD1
[drm] DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
[drm] Encoders:
[drm] DFP1: INTERNAL_UNIPHY
[drm] Connector 2:
[drm] DVI-I-1
[drm] HPD4
[drm] DDC: 0x7f10 0x7f10 0x7f14 0x7f14 0x7f18 0x7f18 0x7f1c 0x7f1c
[drm] Encoders:
[drm] CRT1: INTERNAL_KLDSCP_DAC1
[drm] DFP2: INTERNAL_UNIPHY2
[drm] fb mappable at 0xE034D000
[drm] vram apper at 0xE0000000
[drm] size 5242880
[drm] fb depth is 24
[drm] pitch is 5120
start FB_INFO:
type=11 height=1024 width=1280 depth=32
cmsize=256 size=5242880
pbase=0xe034d000 vbase=0xfffff800e034d000
name=drmn0 flags=0x0 stride=5120 bpp=32
cmap[0]=0 cmap[1]=0 cmap[2]=0 cmap[3]=0
end FB_INFO
drmn0: fb1: radeondrmfb frame buffer device
[drm] Initialized radeon 2.50.0 20080528 for drmn0 on minor 1
coretemp0: <CPU On-Die Thermal Sensors> on cpu0
...

Sobald alle Treiber geladen werden, springt die Auflösung des Monitors an der Intel um, wie es soll. Der andere an der radeon wacht aus dem standby auf, zeigt aber schwarzes Bild.

Code:
$ ls -l /dev/dri
total 0
lrwxr-xr-x  1 root  wheel   8 21 Mai  19:22 card0 -> ../drm/0
lrwxr-xr-x  1 root  wheel   8 21 Mai  19:22 card1 -> ../drm/1
lrwxr-xr-x  1 root  wheel  10 21 Mai  19:22 renderD128 -> ../drm/128
lrwxr-xr-x  1 root  wheel  10 21 Mai  19:22 renderD129 -> ../drm/129
$
Section "ServerLayout"
Identifier "layout0"
Screen 0 "screen0"
Screen 1 "screen1" RightOf "Screen0"
EndSection

Section "Device"
Identifier "gpu-intel"
Driver "modesetting"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "monitor-intel"
Option "PreferredMode" "1280x1024"
Option "Position" "0 0"
Option "Primary" "true"
EndSection

Section "Screen"
Identifier "screen0"
Device "gpu-intel"
Monitor "monitor-intel"
EndSection

Section "Device"
Identifier "gpu-radeon"
Driver "modesetting"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "monitor-radeon"
Option "PreferredMode" "1280x1024"
Option "Position" "1280 0"
EndSection

Section "Screen"
Identifier "screen1"
Device "gpu-radeon"
Monitor "monitor-radeon"
EndSection

[ 41.828]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[ 41.828] X Protocol Version 11, Revision 0
[ 41.828] Build Operating System: FreeBSD 12.0-RELEASE-p3 amd64
[ 41.828] Current Operating System: FreeBSD work1 12.0-RELEASE-p3 FreeBSD 12.0-RELEASE-p3 GENERIC amd64
[ 41.828] Build Date: 02 April 2019 09:00:51AM
[ 41.828]
[ 41.828] Current version of pixman: 0.34.0
[ 41.828] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 41.828] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 41.829] (==) Log file: "/var/log/Xorg.0.log", Time: Tue May 21 17:23:06 2019
[ 41.881] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[ 41.881] (==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
[ 41.935] (==) ServerLayout "layout0"
[ 41.935] (**) |-->Screen "screen0" (0)
[ 41.935] (**) | |-->Monitor "monitor-intel"
[ 41.936] (**) | |-->Device "gpu-intel"
[ 41.936] (**) |-->Screen "screen1" (1)
[ 41.936] (**) | |-->Monitor "monitor-radeon"
[ 41.936] (**) | |-->Device "gpu-radeon"
[ 41.936] (EE) Screen Screen0 doesn't exist: deleting placement
[ 41.936] (==) Automatically adding devices
[ 41.936] (==) Automatically enabling devices
[ 41.936] (==) Not automatically adding GPU devices
[ 41.938] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 42.130] (==) FontPath set to:
/usr/local/share/fonts/misc/,
/usr/local/share/fonts/TTF/,
/usr/local/share/fonts/OTF/,
/usr/local/share/fonts/Type1/,
/usr/local/share/fonts/100dpi/,
/usr/local/share/fonts/75dpi/
[ 42.130] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[ 42.130] (II) The server relies on devd to provide the list of input devices.
If no devices become available, reconfigure devd or disable AutoAddDevices.
[ 42.130] (II) Loader magic: 0x411020
[ 42.130] (II) Module ABI versions:
[ 42.130] X.Org ANSI C Emulation: 0.4
[ 42.130] X.Org Video Driver: 20.0
[ 42.130] X.Org XInput driver : 22.1
[ 42.130] X.Org Server Extension : 9.0
[ 42.130] (!!) More than one possible primary device found
[ 42.130] (--) PCI: (0:0:2:0) 8086:0152:1734:11d7 rev 9, Mem @ 0xf7800000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/65536
[ 42.130] (--) PCI: (0:1:0:0) 1002:954f:174b:e990 rev 0, Mem @ 0xe0000000/268435456, 0xf7c20000/65536, I/O @ 0x0000e000/256, BIOS @ 0x????????/65536
[ 42.130] (--) PCI: (0:2:5:0) 109e:036e:0070:13eb rev 17, Mem @ 0xf0001000/4096
[ 42.130] (II) LoadModule: "glx"
[ 42.143] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[ 42.355] (II) Module glx: vendor="X.Org Foundation"
[ 42.355] compiled for 1.18.4, module version = 1.0.0
[ 42.355] ABI class: X.Org Server Extension, version 9.0
[ 42.355] (==) AIGLX enabled
[ 42.355] (II) LoadModule: "modesetting"
[ 42.366] (II) Loading /usr/local/lib/xorg/modules/drivers/modesetting_drv.so
[ 42.381] (II) Module modesetting: vendor="X.Org Foundation"
[ 42.381] compiled for 1.18.4, module version = 1.18.4
[ 42.381] Module class: X.Org Video Driver
[ 42.381] ABI class: X.Org Video Driver, version 20.0
[ 42.381] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 42.382] (--) Using syscons driver with X support (version 2.0)
[ 42.382] (--) using VT number 9

[ 42.404] (**) modeset(0): claimed PCI slot 0@0:2:0
[ 42.404] (II) modeset(0): using default device
[ 42.421] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 42.421] (EE) Screen 1 deleted because of no matching config section.
[ 42.421] (II) UnloadModule: "modesetting"
[ 42.437] (II) modeset(0): Creating default Display subsection in Screen section
"screen0" for depth/fbbpp 24/32
[ 42.437] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[ 42.438] (==) modeset(0): RGB weight 888
[ 42.438] (==) modeset(0): Default visual is TrueColor
[ 42.438] (II) Loading sub module "glamoregl"
[ 42.438] (II) LoadModule: "glamoregl"
[ 42.438] (II) Loading /usr/local/lib/xorg/modules/libglamoregl.so
[ 42.943] (II) Module glamoregl: vendor="X.Org Foundation"
[ 42.944] compiled for 1.18.4, module version = 1.0.0
[ 42.944] ABI class: X.Org ANSI C Emulation, version 0.4
[ 42.944] (II) glamor: OpenGL accelerated X.org driver based.
[ 43.265] (II) glamor: EGL version 1.4:
[ 43.302] (II) modeset(0): glamor initialized
[ 43.316] (II) modeset(0): Output VGA-1 using monitor section monitor-intel
[ 43.316] (**) modeset(0): Option "PreferredMode" "1280x1024"
[ 43.316] (**) modeset(0): Option "Position" "0 0"
[ 43.316] (**) modeset(0): Option "Primary" "true"
[ 43.330] (II) modeset(0): Output HDMI-1 has no monitor section
[ 43.416] (II) modeset(0): Output DP-1 has no monitor section
[ 43.417] (II) modeset(0): Output HDMI-2 has no monitor section
[ 43.417] (II) modeset(0): Output DP-2 has no monitor section
[ 43.430] (II) modeset(0): EDID for output VGA-1
[ 43.431] (II) modeset(0): Manufacturer: HWP Model: 26e7 Serial#: 16843009
[ 43.431] (II) modeset(0): Year: 2008 Week: 46
[ 43.431] (II) modeset(0): EDID Version: 1.3
[ 43.431] (II) modeset(0): Analog Display Input, Input Voltage Level: 0.700/0.700 V
[ 43.431] (II) modeset(0): Sync: Separate
[ 43.431] (II) modeset(0): Max Image Size [cm]: horiz.: 38 vert.: 30
[ 43.431] (II) modeset(0): Gamma: 2.40
[ 43.431] (II) modeset(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
[ 43.431] (II) modeset(0): Default color space is primary color space
[ 43.431] (II) modeset(0): First detailed timing is preferred mode
[ 43.431] (II) modeset(0): redX: 0.639 redY: 0.342 greenX: 0.297 greenY: 0.614
[ 43.431] (II) modeset(0): blueX: 0.146 blueY: 0.067 whiteX: 0.312 whiteY: 0.328
[ 43.431] (II) modeset(0): Supported established timings:
[ 43.431] (II) modeset(0): 720x400@70Hz
[ 43.431] (II) modeset(0): 640x480@60Hz
[ 43.431] (II) modeset(0): 640x480@72Hz
[ 43.431] (II) modeset(0): 640x480@75Hz
[ 43.431] (II) modeset(0): 800x600@60Hz
[ 43.431] (II) modeset(0): 800x600@72Hz
[ 43.431] (II) modeset(0): 800x600@75Hz
[ 43.431] (II) modeset(0): 832x624@75Hz
[ 43.431] (II) modeset(0): 1024x768@60Hz
[ 43.431] (II) modeset(0): 1024x768@70Hz
[ 43.431] (II) modeset(0): 1024x768@75Hz
[ 43.431] (II) modeset(0): 1280x1024@75Hz
[ 43.431] (II) modeset(0): 1152x864@75Hz
[ 43.431] (II) modeset(0): Manufacturer's mask: 0
[ 43.431] (II) modeset(0): Supported standard timings:
[ 43.431] (II) modeset(0): #0: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
[ 43.431] (II) modeset(0): Supported detailed timing:
[ 43.431] (II) modeset(0): clock: 108.0 MHz Image Size: 380 x 300 mm
[ 43.431] (II) modeset(0): h_active: 1280 h_sync: 1328 h_sync_end 1440 h_blank_end 1688 h_border: 0
[ 43.431] (II) modeset(0): v_active: 1024 v_sync: 1025 v_sync_end 1028 v_blanking: 1066 v_border: 0
[ 43.431] (II) modeset(0): Ranges: V min: 50 V max: 77 Hz, H min: 24 H max: 83 kHz, PixClock max 145 MHz
[ 43.431] (II) modeset(0): Monitor name: HP L1950
[ 43.431] (II) modeset(0): Serial No: CNC846RVW9
[ 43.431] (II) modeset(0): EDID (in hex):
[ 43.431] (II) modeset(0): 00ffffffffffff0022f0e72601010101
[ 43.431] (II) modeset(0): 2e12010368261e8ceea150a3574c9d25
[ 43.431] (II) modeset(0): 115054adef8081800101010101010101
[ 43.431] (II) modeset(0): 010101010101302a009851002a403070
[ 43.431] (II) modeset(0): 13007c2c1100001e000000fd00324d18
[ 43.431] (II) modeset(0): 530e000a202020202020000000fc0048
[ 43.431] (II) modeset(0): 50204c313935300a20202020000000ff
[ 43.431] (II) modeset(0): 00434e43383436525657390a2020005a
[ 43.431] (II) modeset(0): Printing probed modes for output VGA-1
[ 43.431] (II) modeset(0): Modeline "1280x1024"x60.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz UeP)
[ 43.431] (II) modeset(0): Modeline "1280x1024"x75.0 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
[ 43.431] (II) modeset(0): Modeline "1152x864"x75.0 108.00 1152 1216 1344 1600 864 865 868 900 +hsync +vsync (67.5 kHz e)
[ 43.431] (II) modeset(0): Modeline "1024x768"x75.0 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync (60.0 kHz e)
[ 43.431] (II) modeset(0): Modeline "1024x768"x70.1 75.00 1024 1048 1184 1328 768 771 777 806 -hsync -vsync (56.5 kHz e)
[ 43.431] (II) modeset(0): Modeline "1024x768"x60.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz e)
[ 43.432] (II) modeset(0): Modeline "832x624"x74.6 57.28 832 864 928 1152 624 625 628 667 -hsync -vsync (49.7 kHz e)
[ 43.432] (II) modeset(0): Modeline "800x600"x72.2 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync (48.1 kHz e)
[ 43.432] (II) modeset(0): Modeline "800x600"x75.0 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync (46.9 kHz e)
[ 43.432] (II) modeset(0): Modeline "800x600"x60.3 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz e)
[ 43.432] (II) modeset(0): Modeline "640x480"x75.0 31.50 640 656 720 840 480 481 484 500 -hsync -vsync (37.5 kHz e)
[ 43.432] (II) modeset(0): Modeline "640x480"x72.8 31.50 640 664 704 832 480 489 492 520 -hsync -vsync (37.9 kHz e)
[ 43.432] (II) modeset(0): Modeline "640x480"x59.9 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz e)
[ 43.432] (II) modeset(0): Modeline "720x400"x70.1 28.32 720 738 846 900 400 412 414 449 -hsync +vsync (31.5 kHz e)
[ 43.445] (II) modeset(0): EDID for output HDMI-1
[ 43.531] (II) modeset(0): EDID for output DP-1
[ 43.532] (II) modeset(0): EDID for output HDMI-2
[ 43.532] (II) modeset(0): EDID for output DP-2
[ 43.532] (II) modeset(0): Output VGA-1 connected
[ 43.532] (II) modeset(0): Output HDMI-1 disconnected
[ 43.532] (II) modeset(0): Output DP-1 disconnected
[ 43.532] (II) modeset(0): Output HDMI-2 disconnected
[ 43.533] (II) modeset(0): Output DP-2 disconnected
[ 43.533] (II) modeset(0): Using user preference for initial modes
[ 43.533] (II) modeset(0): Output VGA-1 using initial mode 1280x1024 +0+0
[ 43.533] (II) modeset(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[ 43.533] (==) modeset(0): DPI set to (96, 96)
[ 43.533] (II) Loading sub module "fb"
[ 43.533] (II) LoadModule: "fb"
[ 43.533] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[ 43.596] (II) Module fb: vendor="X.Org Foundation"
[ 43.596] compiled for 1.18.4, module version = 1.0.0
[ 43.596] ABI class: X.Org ANSI C Emulation, version 0.4
[ 43.596] (==) Depth 24 pixmap format is 32 bpp
[ 43.717] (==) modeset(0): Backing store enabled
[ 43.717] (==) modeset(0): Silken mouse enabled
[ 43.717] (II) modeset(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 43.737] (==) modeset(0): DPMS enabled
[ 43.737] (WW) modeset(0): Option "PreferredMode" is not used
[ 43.737] (WW) modeset(0): Option "Position" is not used
[ 43.737] (WW) modeset(0): Option "Primary" is not used
[ 43.737] (II) modeset(0): [DRI2] Setup complete
[ 43.737] (II) modeset(0): [DRI2] DRI driver: i965
[ 43.737] (II) modeset(0): [DRI2] VDPAU driver: i965
[ 43.787] (--) RandR disabled
[ 43.808] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 43.808] (II) AIGLX: enabled GLX_ARB_create_context
[ 43.809] (II) AIGLX: enabled GLX_ARB_create_context_profile
[ 43.809] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[ 43.809] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 43.809] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 43.809] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[ 43.809] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[ 43.809] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[ 43.809] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 43.809] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[ 43.809] (II) AIGLX: Loaded and initialized i965
[ 43.809] (II) GLX: Initialized DRI2 GL provider for screen 0
[ 43.861] (II) modeset(0): Damage tracking initialized
[ 43.861] (II) modeset(0): Setting screen physical size to 338 x 270
[ 44.415] (II) config/devd: probing input devices...
[ 44.415] (II) config/devd: adding input device (null) (/dev/kbdmux)
[ 44.415] (II) LoadModule: "kbd"
[ 44.415] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[ 44.435] (II) Module kbd: vendor="X.Org Foundation"
[ 44.435] compiled for 1.18.4, module version = 1.9.0
[ 44.435] Module class: X.Org XInput Driver
[ 44.435] ABI class: X.Org XInput driver, version 22.1
[ 44.435] (II) Using input driver 'kbd' for 'kbdmux'
[ 44.435] (**) kbdmux: always reports core events
[ 44.435] (**) kbdmux: always reports core events
[ 44.435] (**) Option "Protocol" "standard"
[ 44.435] (**) Option "XkbRules" "base"
[ 44.435] (**) Option "XkbModel" "pc105"
[ 44.435] (**) Option "XkbLayout" "us"
[ 44.435] (**) Option "config_info" "devd:kbdmux"
[ 44.435] (II) XINPUT: Adding extended input device "kbdmux" (type: KEYBOARD, id 6)
[ 44.452] (II) config/devd: kbdmux is enabled, ignoring device atkbd0
[ 44.452] (II) config/devd: adding input device (null) (/dev/sysmouse)
[ 44.452] (II) LoadModule: "mouse"
[ 44.452] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[ 44.503] (II) Module mouse: vendor="X.Org Foundation"
[ 44.503] compiled for 1.18.4, module version = 1.9.3
[ 44.503] Module class: X.Org XInput Driver
[ 44.503] ABI class: X.Org XInput driver, version 22.1
[ 44.503] (II) Using input driver 'mouse' for 'sysmouse'
[ 44.504] (**) sysmouse: always reports core events
[ 44.504] (**) Option "Device" "/dev/sysmouse"
[ 44.504] (==) sysmouse: Protocol: "Auto"
[ 44.504] (**) sysmouse: always reports core events
[ 44.504] (==) sysmouse: Emulate3Buttons, Emulate3Timeout: 50
[ 44.504] (**) sysmouse: ZAxisMapping: buttons 4 and 5
[ 44.504] (**) sysmouse: Buttons: 5
[ 44.504] (**) Option "config_info" "devd:sysmouse"
[ 44.504] (II) XINPUT: Adding extended input device "sysmouse" (type: MOUSE, id 7)
[ 44.504] (**) sysmouse: (accel) keeping acceleration scheme 1
[ 44.504] (**) sysmouse: (accel) acceleration profile 0
[ 44.504] (**) sysmouse: (accel) acceleration factor: 2.000
[ 44.504] (**) sysmouse: (accel) acceleration threshold: 4
[ 44.504] (II) sysmouse: SetupAuto: hw.iftype is 4, hw.model is 0
[ 44.504] (II) sysmouse: SetupAuto: protocol is SysMouse
[ 44.504] (II) config/devd: device /dev/ums0 already opened
[ 61.013] (II) modeset(0): EDID vendor "HWP", prod id 9959
[ 61.013] (II) modeset(0): Using EDID range info for horizontal sync
[ 61.013] (II) modeset(0): Using EDID range info for vertical refresh
[ 61.013] (II) modeset(0): Printing DDC gathered Modelines:
[ 61.013] (II) modeset(0): Modeline "1280x1024"x0.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz eP)
[ 61.013] (II) modeset(0): Modeline "800x600"x0.0 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz e)
[ 61.013] (II) modeset(0): Modeline "640x480"x0.0 31.50 640 656 720 840 480 481 484 500 -hsync -vsync (37.5 kHz e)
[ 61.013] (II) modeset(0): Modeline "640x480"x0.0 31.50 640 664 704 832 480 489 492 520 -hsync -vsync (37.9 kHz e)
[ 61.013] (II) modeset(0): Modeline "640x480"x0.0 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz e)
[ 61.013] (II) modeset(0): Modeline "720x400"x0.0 28.32 720 738 846 900 400 412 414 449 -hsync +vsync (31.5 kHz e)
[ 61.013] (II) modeset(0): Modeline "1280x1024"x0.0 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
[ 61.013] (II) modeset(0): Modeline "1024x768"x0.0 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync (60.0 kHz e)
[ 61.013] (II) modeset(0): Modeline "1024x768"x0.0 75.00 1024 1048 1184 1328 768 771 777 806 -hsync -vsync (56.5 kHz e)
[ 61.013] (II) modeset(0): Modeline "1024x768"x0.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz e)
[ 61.013] (II) modeset(0): Modeline "832x624"x0.0 57.28 832 864 928 1152 624 625 628 667 -hsync -vsync (49.7 kHz e)
[ 61.013] (II) modeset(0): Modeline "800x600"x0.0 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync (46.9 kHz e)
[ 61.014] (II) modeset(0): Modeline "800x600"x0.0 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync (48.1 kHz e)
[ 61.014] (II) modeset(0): Modeline "1152x864"x0.0 108.00 1152 1216 1344 1600 864 865 868 900 +hsync +vsync (67.5 kHz e)
[ 66.313] (II) modeset(0): EDID vendor "HWP", prod id 9959
[ 66.313] (II) modeset(0): Using hsync ranges from config file
[ 66.313] (II) modeset(0): Using vrefresh ranges from config file
[ 66.313] (II) modeset(0): Printing DDC gathered Modelines:
[ 66.313] (II) modeset(0): Modeline "1280x1024"x0.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz eP)
[ 66.313] (II) modeset(0): Modeline "800x600"x0.0 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz e)
[ 66.313] (II) modeset(0): Modeline "640x480"x0.0 31.50 640 656 720 840 480 481 484 500 -hsync -vsync (37.5 kHz e)
[ 66.313] (II) modeset(0): Modeline "640x480"x0.0 31.50 640 664 704 832 480 489 492 520 -hsync -vsync (37.9 kHz e)
[ 66.313] (II) modeset(0): Modeline "640x480"x0.0 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz e)
[ 66.313] (II) modeset(0): Modeline "720x400"x0.0 28.32 720 738 846 900 400 412 414 449 -hsync +vsync (31.5 kHz e)
[ 66.313] (II) modeset(0): Modeline "1280x1024"x0.0 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
[ 66.313] (II) modeset(0): Modeline "1024x768"x0.0 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync (60.0 kHz e)
[ 66.313] (II) modeset(0): Modeline "1024x768"x0.0 75.00 1024 1048 1184 1328 768 771 777 806 -hsync -vsync (56.5 kHz e)
[ 66.313] (II) modeset(0): Modeline "1024x768"x0.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz e)
[ 66.313] (II) modeset(0): Modeline "832x624"x0.0 57.28 832 864 928 1152 624 625 628 667 -hsync -vsync (49.7 kHz e)
[ 66.313] (II) modeset(0): Modeline "800x600"x0.0 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync (46.9 kHz e)
[ 66.313] (II) modeset(0): Modeline "800x600"x0.0 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync (48.1 kHz e)
[ 66.313] (II) modeset(0): Modeline "1152x864"x0.0 108.00 1152 1216 1344 1600 864 865 868 900 +hsync +vsync (67.5 kHz e)
[ 100.890] (II) modeset(0): EDID vendor "HWP", prod id 9959
[ 100.890] (II) modeset(0): Using hsync ranges from config file
[ 100.890] (II) modeset(0): Using vrefresh ranges from config file
[ 100.890] (II) modeset(0): Printing DDC gathered Modelines:
[ 100.890] (II) modeset(0): Modeline "1280x1024"x0.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz eP)
[ 100.890] (II) modeset(0): Modeline "800x600"x0.0 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz e)
[ 100.890] (II) modeset(0): Modeline "640x480"x0.0 31.50 640 656 720 840 480 481 484 500 -hsync -vsync (37.5 kHz e)
[ 100.890] (II) modeset(0): Modeline "640x480"x0.0 31.50 640 664 704 832 480 489 492 520 -hsync -vsync (37.9 kHz e)
[ 100.890] (II) modeset(0): Modeline "640x480"x0.0 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz e)
[ 100.890] (II) modeset(0): Modeline "720x400"x0.0 28.32 720 738 846 900 400 412 414 449 -hsync +vsync (31.5 kHz e)
[ 100.891] (II) modeset(0): Modeline "1280x1024"x0.0 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
[ 100.891] (II) modeset(0): Modeline "1024x768"x0.0 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync (60.0 kHz e)
[ 100.891] (II) modeset(0): Modeline "1024x768"x0.0 75.00 1024 1048 1184 1328 768 771 777 806 -hsync -vsync (56.5 kHz e)
[ 100.891] (II) modeset(0): Modeline "1024x768"x0.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz e)
[ 100.891] (II) modeset(0): Modeline "832x624"x0.0 57.28 832 864 928 1152 624 625 628 667 -hsync -vsync (49.7 kHz e)
[ 100.891] (II) modeset(0): Modeline "800x600"x0.0 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync (46.9 kHz e)
[ 100.891] (II) modeset(0): Modeline "800x600"x0.0 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync (48.1 kHz e)
[ 100.891] (II) modeset(0): Modeline "1152x864"x0.0 108.00 1152 1216 1344 1600 864 865 868 900 +hsync +vsync (67.5 kHz e)

Große Fragezeichen (dmesg):
1: Failed to add WC MTRR for [0xd0000000-0xdfffffff]: -22; performance may suffer
2: Failed to add WC MTRR for [0xe0000000-0xefffffff]: -22; performance may suffer

Xorg.0.log:
1: (EE) Screen Screen0 doesn't exist: deleting placement
2: (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
2: (EE) Screen 1 deleted because of no matching config section

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 8192 x 8192
VGA-1 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 380mm x 300mm
1280x1024 60.02*+ 75.02
1152x864 75.00
1024x768 75.03 70.07 60.00
832x624 74.55
800x600 72.19 75.00 60.32
640x480 75.00 72.81 59.94
720x400 70.08
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
Providers: number : 1
Provider 0: id: 0x47 cap: 0xa, Sink Output, Sink Offload crtcs: 3 outputs: 5 associated providers: 0 name:modesetting
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#3
Ohne nun negativ klingen zu wollen, aber mehrere Monitore an unterschiedlichen Grafikkarten ist schon unter Linux maximal frickelig und geht auch da - wenn überhaupt - nur zwischen freien Treiber oder zwischen Nvidia-Karten, aber nicht gemischt. Ich glaub nicht, dass es unter FreeBSD hinzubekommen sein wird. :(
 

mr44er

Well-Known Member
Themenstarter #4
Ohne nun negativ klingen zu wollen
Wenn es so ist, wär mir auch schon geholfen, dann verböller ich da keine Zeit mehr dran. ;)

Mhm...ich dachte, drm-kmod besteht nur aus freien Treibern oder meinst du GPUs 'gleichen Typs'? Also 2x Intel oder 2x radeon.

Andere Überlegung...2x nvidia. Müssen die in etwa von gleichem Alter sein bzw. mischbar je Treibergeneration oder könnte ich nvidia-driver mit nvidia-driver-340 parallel nutzen?
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#5
Das ist ewig her, dass ich den Spaß versucht habe:
  • Unter Linux - was nicht für FreeBSD gelten muss - kann man alle freien Treiber miteinander kombinieren, wie man lustig ist. Da der X-Server in einem zentralen Framebuffer rendert, der dann über bliebiege Ausgänge ausgegeben werden kann. Das ist zumindest die Theorie. In der Praxis ist es wohl sehr hilfreich, wenn man den gleichen Treiber auf allen Karten hat. Also amdgpu, radeonsi, i915 und so weiter. Und bei Onboard-Karten muss man immer im Hinterkopf behalten, dass da eventuell noch das BIOS mitdenkt. Die Karte abschaltet, die Ausgänge deaktiviert und so weiter... Proprietäre Treiber, was ja nur noch Nvidia ist, kann generell nicht mit freien Treibern zusammenspielen, da sie nicht in den gemeinsamen Framebuffer schreiben können. Das ist auch der Grund, weshalb Optimus nur mit 2 X-Servern geht, einen Server mit je einem Framebuffer für jede Karte.
  • Mit Nvidia ging es zumindest in der Zeit vor KMS (also nvidia-modeset.ko unter FreeBSD) recht gut. Wie es nun ist, weiß ich nicht. Die Karten mussten allerdings gleich und ich meine bei Konsumermodellen (also nicht Quadro oder NVS, sondern Geforce) in der Lage sein per SLI miteinander zu kommunizieren. Das Stichwort dazu ist "Nvidia Base Mosaic". Bevor du da Hardware kaufst, klopf besser noch mal ab, ob das wirklich noch so funktioniert. Bei mit waren es zwei Geforce GT 450 aus der Fermi-Generation. Das war nicht gerade gestern. ;)
Wenn der Monitor grundsätzlich ein Signal bekommt, du aber nur schwarz siehst, würde ich stark vermuten, dass das Zusammenspiel der Karten mit dem zentralem Framebuffer nicht klappt. Der Ausgang wird aktiviert, aber er bekommt aus irgendwelchen Gründen kein Bild aus dem Framebuffer.
 

mr44er

Well-Known Member
Themenstarter #6
Danke für die Info, das hat mich weiter gebracht und ich kann Teilerfolg melden!

Ich habe /dev/fb0 und /dev/fb1

Der weitere Trick ist, dem modesetting-Treiber explizit das device zu sagen:

Code:
Section "Device"
        Option          "kmsdev" "/dev/dri/card0"
        Identifier      "Card0"
        Driver          "modesetting"
        BusID           "PCI:0:2:0"
EndSection

Section "Device"
        Option          "kmsdev" "/dev/dri/card1"
        Identifier      "Card1"
        Driver          "modesetting"
        BusID           "PCI:1:0:0"
EndSection
Mit einer forciert zugewiesenen config hatte ich es gestern noch hinbekommen, links und rechts zuzuweisen und das Bild hatte beim startx verheißungsvoll geflackert...und siehe da, ich konnte zumindest den Cursor von links nach rechts bewegen (von gpu1mon1 zu gpu2mon2). Jedoch war der Hintergrund schwarz, nur der Cursor war sichtbar.

Leider sieht xrandr immer nur einen provider. Ich muss das erstmal begreifen, wie die conf aussehen sollte. :confused:
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#7
Provider brauchst du da nicht, glaube ich. Provider sind für den Fall, dass eine Grafikkarte auf den Ausgang einer anderen Grafikkarte schreibt. Zum Beispiel der Monitor hängt an der Intel-GPU, das Bild soll aber von der Radeon generiert werden.
 

mr44er

Well-Known Member
Themenstarter #8
Zum Beispiel der Monitor hängt an der Intel-GPU, das Bild soll aber von der Radeon generiert werden.
Ahja, perfekt. Soll in dem Fall auch nicht sein, da gehts rein um ein paar Ausgänge mehr zu haben. :)
Die radeon ist so antik, dass wahrscheinlich die Intel hier schneller ist. :p

Hatte mich heute noch nicht kümmern können, aber bevor ich jetzt google mit falschen Begriffen füttere...
Mir sind die Begrifflichkeiten noch nicht klar und ich ackere jetzt mal xorg-manuals durch.
Screen, Monitor und Ausgang meint nicht das gleiche, ich muss das erstmal verstehen und aufdröseln.

Provider brauchst du da nicht, glaube ich.
Meine config hätte ich dann gerne in der Monitorverwaltung von KDE finalisiert...aber das wird wohl nicht funktionieren, weil genau das nur mit xrandr klappt.
 

mr44er

Well-Known Member
Themenstarter #9
Ich gebs auf, das frustriert enorm. ;)

Ich hab es soweit hinbekommen, dass auf dem dritten Monitor zwar ein extra Bild erscheint, welches aber trotzdem irgendwie im Hintergrund auf 0 0 positioniert wird, egal ob man mit virtual arbeitet, absolute oder zB. 'RightOf'. Man kommt zwar irgendwie mit der Maus auf mon3 hin, klickt man dort rechts, erscheint das Menü auf mon1.
Es spielt keine Rolle, in welcher Reihenfolge man die Kernemodule lädt, ebenfalls spielt es keine Rolle ob im BIOS IGP oder PEG auf primary steht.

Es hat noch nicht einmal der klassische Weg ordentlich funktioniert. 'DISPLAY=:0.1 konsole' hat zwar die Konsole geöffnet, sobald man diese aber angeklickt hat, schmierte das vom feinsten weg. :cool:
 

Wasp

Insektenspray-Gegner
#10
Das klingt ganz ähnlich wie meine Versuche unter Linux (Nvidia + onboard Intel). Nach ewigem Gefrickel, und dem Wissen, daß man sich trotz schwarzem Bildschirm (blind) einloggen kann, konnte ich das Zeug mittels **xrandr**(1) nicht ordentlich positionieren. **xrandr**(1) hat irgend einen komsichen Bug, bei dem man den Versatz nicht los wird bzw. die Screen-Größe nicht ordentlich einstellen kann. Eines von beidem war immer falsch eingestellt bzw. lies sich partout nicht umstellen.
 

mr44er

Well-Known Member
Themenstarter #11
Der Vollständigkeit halber:

ich nutze jetzt meine nvidia, die ich dafür gar nicht hernehmen wollte. Diese hat jedoch die benötigten drei Ausgänge und damit alles reibungslos in KDE klappt, das und nur das:

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1050 Ti"
Option "ForceCompositionPipeline" "1"
Option "ForceFullCompositionPipeline" "1"
EndSection

Firefox -> about:config -> layers.acceleration.force-enabled=true

Dann flutschen auch Videos in 4k. :D