• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

3c589 pcmcia nicht erkannt

Themenstarter #1
Hallo,

mir bereitet die PCMCIA - Unterstützung Probleme, da meine Netzkarte 3com 3589D (sollte lt doku unterstützt werden) nicht erkannt wird.
Auch eine Modemkarte sowie eine PCMCIA-ISDN Karte konnte nicht erkannt werden.
Leider konnte ich noch nichts dergleichen im Internet finden.
die Manpage von pcmcia sagt bei dem Problem, dass man die dmesg-Meldung hinsichtlich der Zeile bios0 vergleichen soll, bzw. dort fest-
stellen soll, ob ein Speicherkonflikt besteht. Leider sagen mir die Angaben bei bios0: ROM list nichts.
Nachtrag: ich hab bereits versucht, am UKC - Prompt mit "disable uhci" und "disable usb" "disable uhub"
den Konflikt zu beseitigen, es (das USB-System) wird dann auch nicht mehr angezeigt.
Kann mir jemand weiterhelfen ?

Vielen Dank !
binsi
#####################################################################
OpenBSD 3.2 (GENERIC) #25: Thu Oct 3 19:51:53 MDT 2002
deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium II ("GenuineIntel" 686-class, 512KB L2 cache) 234 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR
real mem = 66695168 (65132K)
avail mem = 56311808 (54992K)
using 839 buffers containing 3436544 bytes (3356K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(b3) BIOS, date 03/28/96, BIOS32 rev. 0 @ 0xeaf90
apm0 at bios0: Power Management spec V1.2
apm0: AC on, no battery
pcibios0 at bios0: rev. 2.1 @ 0xe8000/0x6c0
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfe840/96 (4 entries)
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371FB PCI-ISA" rev 0x00)
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0xbc00 0xcc000/0x1000 0xe2000/0x800 0xe7000/0x1000
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX" rev 0x02
pcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA, channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <TOSHIBA MK4006MAV>
wd0: 16-sector PIO, LBA, 3909MB, 7944 cyl, 16 head, 63 sec, 8007552 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TEAC, CD-224E, 1.0A> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01: irq 10
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x0000 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
"Intel 82371AB Power Mgmt" rev 0x02 at pci0 dev 7 function 3 not configured
vga1 at pci0 dev 8 function 0 "S3 ViRGE MXP" rev 0x03
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
cbb0 at pci0 dev 10 function 0 "Texas Instruments PCI1220 PCI-CardBus" rev 0x02: irq 10
cbb1 at pci0 dev 10 function 1 "Texas Instruments PCI1220 PCI-CardBus" rev 0x02: irq 10
maestro0 at pci0 dev 16 function 0 "ESS Maestro II" rev 0x00: irq 5
ac97: codec id 0x414b4d00 (Asahi Kasei AK4540 rev 0)
maestro0: maestro_read_codec() RW_DONE timed out.
maestro0: maestro_read_codec() PROGLESS timed out.
maestro0: maestro_read_codec() RW_DONE timed out.
maestro0: maestro_write_codec() PROGLESS timed out.
maestro0: maestro_read_codec() PROGLESS timed out.
maestro0: maestro_read_codec() RW_DONE timed out.
maestro0: maestro_write_codec() PROGLESS timed out.
maestro0: maestro_read_codec() PROGLESS timed out.
maestro0: maestro_read_codec() RW_DONE timed out.
maestro0: maestro_write_codec() PROGLESS timed out.
maestro0: maestro_read_codec() PROGLESS timed out.
maestro0: maestro_read_codec() RW_DONE timed out.
maestro0: maestro_write_codec() PROGLESS timed out.
audio0 at maestro0
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 1 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 2 device 0 cacheline 0x0, lattimer 0x20
pcmcia1 at cardslot1
biomask c440 netmask c440 ttymask d442
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
WARNING: / was not properly unmounted
#############################################
... ok, die letzte Zeile war meine Schuld ....:-)
 

kith

unfuck me!
Mitarbeiter
#2
hallo binsi,
ist das evt. eine 3c....589D? die suche im web und bei 3com.com ergab nichts unter einer 3589D.
kannst du uns vielleicht sagen wo genau du die information her hast dass die karte unterstuetzt wird?
was ist das fuer ein notebook?
wieviel hast du fuer diese karte bezahlt?

normalerweise solltest du die pcmcia nic einfach nur reintun und obsd sollte sie automatisch erkennen.

da ich noch nie probleme mit meinen pc karten hatte werde ich dir wahrscheinlich nicht sonderlich weiterhelfen koennen :(.

ps. mein dmesg sieht aehnlich wie deiner aus, ausser das da noch meine nic drin steht...

pps. irgendjemand anderes der damit erfahrung hat?
 
#3
Hi,

also laut OpenBSD HCL wird die Karte unterstuetzt:

http://www.openbsd.org/de/i386.html

PC Cards (PCMCIA (B) und CardBus (B) (C))

Ethernet Adapter, inklusive:

3Com EtherLink (ep) und EtherLink XL-basierende (xl) LAN PC Cards, inklusive:

3Com 3C556, 3C562
3Com 3C574TX, 3C[CX]FE574BT
3Com 3C589, 3C589B, 3C589C, 3C589D, 3C589E

..etc.

Ich selber habe gluecklicherweise auch nur Karten im Einsatz (AVM A1, Lucent Orinoco, 3C[CX3]FE575CT, Xircom) die auf Anhieb funzen.

Bei dir sieht es so aus als ob sich die Devices um IRQ 10 streiten.
Als "quick n dirty" Workaround wuerde ich mal versuchen im Bios das "PNP O/S" abzuschalten und wenn das Bios es kann gleich der Soundkarte IRQ 5 verpassen und wenn du USB nicht brauchst auch erstmal abschalten.
Dann bei der Installation von OBSD auf jeden Fall das Kabel vom NIC anschliessen, im Laufe der Install wirst du dann nach IP und GW und Typ des NIC gefragt.
Es kann sein das das BSD rummosert vonwegen "kann keine Karte finden" , einfach weiter installieren und mal guggen obs dann klappt.
 
Zuletzt bearbeitet:

asg

push it, don´t hype
#4
Ich kenn mich mit OpenBSD was die hardware angeht nicht sonderlich aus, aber ist die genannte Karte eine 32 Bit Karte, sprich CARDBUS? Und wenn ja, wird das von OBSD unterstützt?
 
Themenstarter #6
Hi,

danke für die Antworten.

Ich hab zwischenzeitlich die PCMCIA-Karte (sorry für den Tippfehler: es war natürlich eine 3C889D) mal mit meinem anderen Notebook (Siemens Amilo D8800) verwendet und OpenBSD gebootet. Dort wird sie korrekt erkannt. Das Laptop, wo ichs eigentlich einsetzen wollte, ist ein Billigteil, wo man im Bios ausser den LPTs und Coms nichts deaktivieren kann. Nach der Installation funzzt sie leider auch nicht.


Ich hoffte, dass man durch entsprechende Einträge in der config-Datei und neu kompilieren des Kernels mit den geänderten Einstellungen evtl. die Sache zum laufen bekommen kann.

Vermutlich liege ich da ja auch falsch (bin noch relativ neu in *BSD; war bislang eher bei Linux daheim)

Leider habe ich zu obiger Problematik noch sehr wenig über Openbsd-Kernelkompilieren im Netz gefunden.

Unter NetBSD wird diese Karte in diesem Notebook richtig erkannt und kann betrieben werden (habe ich gerade mal getestet). Insofern werd ich auf diesem Notebook dann mal NetBSD installieren, da ich in diesem Fall nicht an ein bestimmtes BSD gebunden bin.

Viele Grüsse und nochmal danke !

BINSI
 
Zuletzt bearbeitet:
Themenstarter #7
Hi !

das beruhigende ist, dass man an allen Unix und BSD - Systemen immer irgendetwas drehen kann, dass es läuft (im gegensatz zu M$)

Ein "disable pcibios" am UKC-Prompt brachte die Karte umgehend zum laufen.

Jetzt bleib ich doch bei OpenBSD. :-)

Grüsse an das Forum

Binsi