• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Access Point unter OpenBSD

improved

Well-Known Member
Themenstarter #1
Hallo,

ich habe auf meinem Soekris eine ath0 WLAN-Karte. Diese wird auch wunderbar erkannt. Leider bekomme ich keinen Access Point zum laufen.

/etc/hostname.ath0

Code:
inet 172.23.23.1 255.255.255.0 NONE media autoselect \
mediaopt hostap nwid OpenWLAN chan 11
Nach dem Booten schaut auch alles ok aus:
Code:
ath0: flags=8863<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:11:6b:61:77:77
        groups: wlan
        media: IEEE802.11 autoselect hostap (autoselect mode 11b hostap)
        status: active
        ieee80211: nwid WLAN chan 11 bssid 00:11:6b:61:77:77
        inet 172.23.23.1 netmask 0xffffff00 broadcast 172.23.23.255
        inet6 fe80::211:6bff:fe61:7777%ath0 prefixlen 64 scopeid 0x4
Wenn ich auf meinem Notebook Kismet starte sehe ich das WLAN-Netz der soekris-Box nicht. Ich kann einige Netze in der Nachbarschaft sehen aber nicht das sich mir 2 meter entfernte WLAN(soekris).

Jemand eine Idee?

Gruß

improved
 

CommanderZed

OpenBSD User
Mitarbeiter
#2
Hast du mal probiert, ob die Karte generell funktioniert, z.B. in dem du sie nicht in den AP-Modus setzt sondern auch nach anderen netzwerken scannen lässt?
 

zyon

Rule Zero
#3
guck mal ob irgendetwas in der los steht!

Edit: Vielleicht auch mal ein anderes Tool als Kismet nehem. Obwohl Kismet das finden müsste.
 
Zuletzt bearbeitet:

improved

Well-Known Member
Themenstarter #4

improved

Well-Known Member
Themenstarter #6
Code:
ath0: flags=8863<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:11:6b:61:77:77
        groups: wlan
        media: IEEE802.11 autoselect hostap (autoselect mode 11b hostap)
        status: active
        ieee80211: nwid WLAN chan 11 bssid 00:11:6b:61:77:77
        supported media:
                media autoselect
                media autoselect mediaopt ibss
                media autoselect mediaopt hostap
                media autoselect mediaopt monitor
                media autoselect mode 11b
                media autoselect mode 11b mediaopt ibss
                media autoselect mode 11b mediaopt hostap
                media autoselect mode 11b mediaopt monitor
                media DS1 mode 11b
                media DS1 mode 11b mediaopt ibss
                media DS1 mode 11b mediaopt hostap
                media DS1 mode 11b mediaopt monitor
                media DS2 mode 11b
                media DS2 mode 11b mediaopt ibss
                media DS2 mode 11b mediaopt hostap
                media DS2 mode 11b mediaopt monitor
                media DS5 mode 11b
                media DS5 mode 11b mediaopt ibss
                media DS5 mode 11b mediaopt hostap
                media DS5 mode 11b mediaopt monitor
                media DS11 mode 11b
                media DS11 mode 11b mediaopt ibss
                media DS11 mode 11b mediaopt hostap
                media DS11 mode 11b mediaopt monitor
                media DS1
                media DS1 mediaopt ibss
                media DS1 mediaopt hostap
                media DS1 mediaopt monitor
                media DS2
                media DS2 mediaopt ibss
                media DS2 mediaopt hostap
                media DS2 mediaopt monitor
                media DS5 
                media DS5 mediaopt ibss
                media DS5 mediaopt hostap
                media DS5 mediaopt monitor
                media DS11 
                media DS11 mediaopt ibss
                media DS11 mediaopt hostap
                media DS11 mediaopt monitor 
        inet 172.23.23.1 netmask 0xffffff00 broadcast 172.23.23.255
        inet6 fe80::211:6bff:fe61:7777%ath0 prefixlen 64 scopeid 0x4
Code:
wi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:60:b3:29:9a:4b
        media: IEEE802.11 autoselect (DS2)
        status: no network
        ieee80211: nwid IBSS chan 11 bssid 44:44:44:44:44:44 1dBm (auto)
                nwid t-com chan 7 bssid 00:15:0c:e8:b2:a9 17dB 22M privacy,pbcc,short_slottime
        inet6 fe80::260:b3ff:fe29:9a4b%wi0 prefixlen 64 scopeid 0x4
 
#7
Welchen Atheros Chipsatz hat denn die Karte. Mich wundert, dass mit ifconfig -m ath0 überall nur mode 11b angegeben wird. Ich hatte die gleiche Ausgabe mal mit einer Karte mit einem ar5213 chip gehabt. Prüfe mal in der dmesg.
 

improved

Well-Known Member
Themenstarter #8
Welchen Atheros Chipsatz hat denn die Karte. Mich wundert, dass mit ifconfig -m ath0 überall nur mode 11b angegeben wird. Ich hatte die gleiche Ausgabe mal mit einer Karte mit einem ar5213 chip gehabt. Prüfe mal in der dmesg.
dmesg | grep ath
ath0 at pci0 dev 10 function 0 "Atheros AR5212" rev 0x01: irq 11
ath0: AR5213 7.9 phy 4.5 rf2112a 5.6, FCC2A*, address 00:11:6b:61:77:77
 

Baseballbatboy

Cpt. Baseballbatboy
#10
Moin,

um Dich zu beruhigen: auch mein AP mit ath (AR5212) kann nur 11b. Warum? Ich habe keine Ahnung. Ich weiß auch nicht, ob es vorher auch so war. Aktuell läuft 4.1 auf dem AP. Ich wollte schon die ganze Zeit mal ein Update machen, war aber zu faul. Ich war ebenso zu faul, mich um eine Lösung des Problems zu bemühen, weil ich mit allen anderen Modi eine geringere Reichweite hatte (<- Moment mal, das fällt mir gerade auf: ich habe das schonmal getestet, also ging es; ach, wen juckts!)

Moinmoin
Baseballbatboy
 
#11
Moin improved
Ich hatte eine Karte von D-Link mit AR52513 gehabt. Das System ist mir bei der Aktivierung der Karte eingefroren, musste es immer wieder neu starten. Zum Glück habe ich die Karte beim Händler umgetauscht gekriegt. Mit einer syslink WMP54G V4.1 mit ralink chip läuft es sehr gut. Meinen AP habe ich als bridge laufen.

Gruss
 

improved

Well-Known Member
Themenstarter #12
jemand eine Idee warum ich mein Netz nicht finden kann? Ich starte den Hostap aber wenn ich von einem anderen PC scannen finde ich nix
 
Zuletzt bearbeitet:

Baseballbatboy

Cpt. Baseballbatboy
#13
Moin,

in den düsteren Tiefen meiner Erinnerung habe ich etwas wiedergefunden. Ich hatte mit meiner Atheros-Karte mal das Problem, dass die in einer anderen "regulatory domain" (ich meine so heißt das) senden wollte als die Gegenstelle. Heißt einfach nur, wenn ich das richtig verstanden habe, dass die Frequenzen der Kanäle etwas anders sind. Damals musste man den Treiber ein wenig modifizieren und neu kompilieren (war unter FreeBSD).

Eigentlich sollte das aber behoben sein. Aus Spaß könntest Du einfach mal verschiedene Kanäle durchprobieren (hast Du sicher schon).

Moinmoin
Baseballbatboy
 

Baseballbatboy

Cpt. Baseballbatboy
#15
Moin,

meine hostname.ath0 schaut so aus:

inet 10.0.1.254 255.255.255.0 NONE \
media DS11 mode 11b mediaopt hostap \
nwid "WLAN" chan 3

Unterschiede sind also die Punkte media und mode.

Außerdem könntest Du noch mit dem Parameter txpower spielen.

Hast du auch schon mal mit dem AP nach anderen Netzen gescannt?

Moinmoin
Baseballbatboy
 

improved

Well-Known Member
Themenstarter #16
Das scann auf dem AP klappt wunderbar:

Code:
 ifconfig -M ath0
ath0: flags=8863<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:11:6b:61:77:77
        groups: wlan
        media: IEEE802.11 autoselect hostap (autoselect mode 11b hostap)
        status: active
        ieee80211: nwid my_net chan 11 bssid 00:11:6b:61:77:77
                nwid "FRITZ!Box Fon WLAN" chan 11 bssid 00:04:0e:1d:01:55 4% 54M privacy,short_slottime
                nwid "FRITZ!Box Fon WLAN2" chan 11 bssid 00:04:0e:54:9d:7a 39% 54M privacy,short_slottime
                nwid WLAN-Lena chan 11 bssid 00:1a:4f:21:8c:20 34% 54M privacy,short_slottime
                lladdr 00:60:b3:29:9a:4b 107% 11M cache
        inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
        inet6 fe80::211:6bff:fe61:7777%ath0 prefixlen 64 scopeid 0x4
Aber als AP will das Teil irgendwie nicht, selbst mit deiner Config. Jemand noch idee?
 

s-tlk

Lion King Fan
#18
Hast du mal manuell versucht:
# ifconfig ath0 172.23.23.1 255.255.255.0 mediaopt hostap nwid wlan chan 11

Ich hab unter OpenBSD auch schon einige seltsame Wlanphänomene erlebt, da überrascht mich dieses hier jetzt nicht sonderlich.
 

improved

Well-Known Member
Themenstarter #19
Moin,

ist das

Code:
lladdr 00:60:b3:29:9a:4b 107% 11M cache
die MAC von Deinem Client?

Moinmoin
Baseballbatboy
Ja

Hast du mal manuell versucht:
# ifconfig ath0 172.23.23.1 255.255.255.0 mediaopt hostap nwid wlan chan 11
natürlich hab ich es mal maule versuche, nicht nur einmal. Mit gleichem Erfolg.

Ich hab unter OpenBSD auch schon einige seltsame Wlanphänomene erlebt, da überrascht mich dieses hier jetzt nicht sonderlich.
Kannst du laut sagen.

Irgendwie versteh ich das ganz auch nicht. Sobald ath0 up geht blicken die 2 Lampen an der ath0 karte synchron. Also so als ob alles ok ist. Auch läuft das scann nach anderen netzen. Bloß der hostap will irgendwie nicht.

Danke für jede Hilfe

improved
 

Baseballbatboy

Cpt. Baseballbatboy
#20
Moin,

das ist doch schonmal positiv, das heißt das zumindest der AP den Client sieht. Fehlt nur noch die Gegenrichtung. Mich wundert allerdings auch ein wenig die Angabe 107%. Sehr eigenartig.

Zuerst sollten wir aber den Kanal nochmal auf was sinnvolleres festklemmen. Kanal 11 scheint in Deiner Gegend ziemlich beliebt zu sein, also nehmen wir mal Kanal 3, der ist weit genug weg und damit keine weitere Fehlerquelle.

Es gibt dann noch bei ifconfig ein paar weitere Parameter. Auf dem AP mal:

Code:
ifconfig ath0 -nwflag hidenwid -powersave
Ebenso kannst Du den Client manuell auf die nwid und den Kanal einstellen und dann einfach mal per

Code:
dhclient wi0
Dir ne IP-Adresse organisieren. Oder die manuell einrichten und dann mal die Kommunikation versuchen.

Moinmoin
Baseballbatboy
 

condor

Well-Known Member
#21
ath0 at pci0 dev 12 function 0 "Atheros AR2413" rev 0x01: irq 9
ath0: AR2413 7.8 phy 4.5 rf 5.6, FCC2A*, address 00:1d:0f:af:98:88

Bei mir, habe auch alle oben genannten Vorschläge durchgeführt,
mein AP ist aber nicht auffindbar und findet selber auch nichts.

ifconfig Ausgabe sieht gleich aus.

Übrigends führt auch bei mir ein ändern der Einstellungen, nachdem das
Interface oben ist zu einem Freeze, der mir gerade auch gleich noch mein
Dateisystem zerschossen hat (waren wohl zu viele).
 
Zuletzt bearbeitet: