Apache nach PHP Änderungen tot

I.MC

Watt soll denn hier hin?
Hi,

seitdem die PHP Ports geändet wurden kann ich keine php Seiten mehr aufrufen:

Code:
### Zu ladene Module

LoadModule access_module libexec/apache2/mod_access.so
LoadModule auth_module libexec/apache2/mod_auth.so
LoadModule auth_anon_module libexec/apache2/mod_auth_anon.so
LoadModule auth_dbm_module libexec/apache2/mod_auth_dbm.so
LoadModule charset_lite_module libexec/apache2/mod_charset_lite.so
LoadModule include_module libexec/apache2/mod_include.so
LoadModule deflate_module libexec/apache2/mod_deflate.so
LoadModule log_config_module libexec/apache2/mod_log_config.so
LoadModule logio_module libexec/apache2/mod_logio.so
LoadModule env_module libexec/apache2/mod_env.so
LoadModule mime_magic_module libexec/apache2/mod_mime_magic.so
LoadModule cern_meta_module libexec/apache2/mod_cern_meta.so
LoadModule expires_module libexec/apache2/mod_expires.so
LoadModule headers_module libexec/apache2/mod_headers.so
LoadModule usertrack_module libexec/apache2/mod_usertrack.so
LoadModule unique_id_module libexec/apache2/mod_unique_id.so
LoadModule setenvif_module libexec/apache2/mod_setenvif.so
LoadModule ssl_module libexec/apache2/mod_ssl.so
LoadModule mime_module libexec/apache2/mod_mime.so
LoadModule status_module libexec/apache2/mod_status.so
LoadModule autoindex_module libexec/apache2/mod_autoindex.so
LoadModule asis_module libexec/apache2/mod_asis.so
LoadModule info_module libexec/apache2/mod_info.so
LoadModule cgi_module libexec/apache2/mod_cgi.so
LoadModule vhost_alias_module libexec/apache2/mod_vhost_alias.so
LoadModule negotiation_module libexec/apache2/mod_negotiation.so
LoadModule dir_module libexec/apache2/mod_dir.so
LoadModule actions_module libexec/apache2/mod_actions.so
LoadModule speling_module libexec/apache2/mod_speling.so
LoadModule userdir_module libexec/apache2/mod_userdir.so
LoadModule alias_module libexec/apache2/mod_alias.so
LoadModule rewrite_module libexec/apache2/mod_rewrite.so
LoadModule php4_module        libexec/apache2/libphp4.so


User www
Group www
ServerAdmin you-should@know-my-address.uga
ServerName blabla:80
UseCanonicalName Off
DocumentRoot "/usr/home/bla"
HostnameLookups Off
ErrorLog /var/log/httpd-error.log
LogLevel warn
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
CustomLog /var/log/httpd-access.log combined
ServerTokens Prod
ServerSignature Off
TypesConfig etc/apache2/mime.types
DefaultType text/plain
DirectoryIndex index.html index.htm index.php default.htm default.html
AccessFileName .htaccess #Geht nur wenn AllowOveride erlaubt ist
IndexOptions FancyIndexing FoldersFirst NameWidth=60 VersionSort SuppressIcon SuppressHTMLPreamble
IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t
AddType application/x-httpd-php .php
CheckSpelling On

hat wer ne Idee?
 
R

rosa

Guest
Ja hab ich, dazu hatten wir hier mindestens schon 2 Threads.

lang/php4 baut Dafault kein Apache Modul mehr.
 

I.MC

Watt soll denn hier hin?
Habe ich mittels make config aber aktiviert :-) und das php-Modul ist auch in dem Pfad, wie ein in der Config steht,
 

k3rn3lpanic

Unregistered User
Ist es u.U. moeglich, dass das PHP-Modul auf irgendwelche Shared Objects verweisst, die er aus irgendeinem Grund nicht finden kann? Das waere eine logische Erklaerung fuer das Phaenomaen. Mal in die Error-Logs vom Indianer geschaut? Wenn das Problem dann noch immer unklar sein sollte, kannst dem Apachen mal ein ktrace draufhaengen:
Code:
ktrace -f apache.out -p (pid_vom_httpd)
Die Datei apache.out kannst Du Dir anschliessend mit kdump angucken.
Zur allgemeinen Info: per ktrace lassen sich Kernel-Calls tracen. Das ist ganz hilfreich, wenn eine Datei nicht gefunden wird, das aber in keinen Error-Log geschrieben wird. Gleiches gilt fuer Shared Objects.

Ich hoffe, das hat Dich etwas weiter gebracht :)
 
R

rosa

Guest
und es gibt keine Errors (httpd-error.log)?
Was sacht php als cmd, funktioniert es da?
 

I.MC

Watt soll denn hier hin?
Es ging doch die ganze Zeit. Warum auch immer, aber es lag an meinem Client! Von jedem anderen Rechner aus geht es. Seltsam...

I.MC
 

Kamikaze

Warrior of Sunlight
Vielleicht antwortet dein Apache nicht an localhost sondern nur an seiner öffentlichen IP?
 
R

rosa

Guest
I.MC schrieb:
... aber es lag an meinem Client! Von jedem anderen Rechner aus geht es. Seltsam...

Das mag ich nun kaum glauben!
PHP ist eine Serverseitige-Geschichte. Da hat der Klient nix zu melden. Alles andere wäre auch aus dem Sicherheits-Aspekt ein kao Kriterium gegen PHP.
 
Oben