• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Asrock A300 Barebone / FreeBSD kompatible?

Themenstarter #1
Liebe BSD-Freunde,

da seit einiger Zeit von Asrock der A300 Barebone erschienen ist dachte ich mir ich könnte mal nach langer Zeit einen schönen kleinen PC zusammenbauen der auf FreeBSD läuft. Jetzt mal eine Frage an euch, was haltet Ihr von der folgenden Zusammenstellung:

https://geizhals.de/?cat=WL-1196405

Meint Ihr FreeBSd würde darauf laufen? Soweit ich es gesehen sollte es soweit laufen, aber ich bin mir unsicher.

Wie ist denn eure Erfahrung mit dem Ryzen Pro mit ECC Ram unter FreeBSD? Ich konnte leider im Internet nichts genaues finden. Mit der Zeit würde ich da noch 2 HDDs einbauen und mit ZFS laufen lassen.

Ich würden diesen PC als Entwickler Rechner einsetzten wollen mit kleineren Spiel Sessions.

Danke.

Gruß Daniel
 

mr44er

Well-Known Member
#2
Bin so gar nicht uptodate, was neue HW betrifft und habe nur am Rande mitbekommen, dass ein paar Ryzen in gewissen Szenarien zicken.

Ansonsten: ECC an sich immer bevorzugen (sicher dass das Board/CPU das kann?) und 'kritisch' bei FreeBSD war eigentlich immer nur der Grafik- und WLAN-Chip

Die anderen werden Gehaltvolleres beitragen können.
 

mr44er

Well-Known Member
#4
Also ich weiß nicht, wie es heutzutage ausschaut, aber ECC musste man sich bei Intel sehr teuer erkaufen. Sprich in Richtung Workstation- oder Server-CPU gehen.

AMD war da gerne etwas gönnerhafter und manche Consumerboards unterstützten das sogar, wenn es nicht angepriesen wurde. Soweit ich mich erinnern kann, müssen CPU, Board und eben RAM ECC unterstützen, damit es geht.
Und ich meine irgendwo aufgeschnappt zu haben, dass die Ryzen-Generation oft ECC unterstützt.

Aber schau da definitiv genau hin, bevor du enttäuscht bist und es nicht geht.
Zur Not das Rückgaberecht gebrauchen. ;)
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#5
Alle AMD Zen Prozessoren unterstützen ECC. Epyc und Ryzen Pro offiziell, zu dem normale Ryzen ist AMDs Aussage in etwa: "Die Hardware unterstützt ECC, wir validieren den ECC-Support des Speichercontrollers aber nicht und können daher nicht garantieren, dass es auch wirklich tut." In der Praxis scheitert es halt meist am Board, viele Desktop-Boards haben einfach keine ECC-Unterstützung. Zu dem Barebone schreibt Asrock hochoffiziell "Max. 32GB (non-ECC)". Also wird es sehr wahrscheinlich nicht gehen.

Außerdem musst du beachten, dass dass das Barebone den 2400G erst ab BIOS B0 unterstützt, das initiale BIOS aber A1 war. Wenn das Barebone nicht ab Werk das aktuelle BIOS aufgespielt hat, sondern mit A1 kommt, wird das System nicht starten. Ohne BIOS-Unterstützung kann das Mainboard die CPU nicht initialisieren, ohne initialisierte CPU lässt sich kein neues BIOS flashen... Ich würde beim Händler anfragen, was er dafür haben will sicherzustellen, dass das aktuelle BIOS drauf ist. Viele Händler bauen für kleines Geld eine kompatible CPU ein, flashen das BIOS und packen den Kram wieder ein.

Und habe im Hinterkopf, dass die Unterstützung für Radeon-GPUs unter FreeBSD recht bröselig ist. Ein Bild wirst du bekommen, mehr vielleicht nicht.
 
Themenstarter #6
Hallo Yamagi,

der Ryzon Pro den ich haben wollte ist seit heute eh nicht mehr verfügbar und wenn eh keine ECC unterstützung vorhanden ist, werde ich das Projekt ohne ECC RAM aufbauen. Nehme jetzt den normalen 2400G und die neueren Barebones werden angeblich mit den neuen BIOS geliefert. Ich werde es einfach mal ausprobieren und hier berichten.
 

mr44er

Well-Known Member
#11
Die Untersützung von Radeon-GPUs ist eigentlich nicht schlecht.
Wie es der Zufall will: Ich habe hier eine APU mit Radeon HD 7480D / Trinity 2 und mal kde5 mit drm-kmod ausprobiert.
'amdgpu' bringt arg verzerrtes Bild, nichts wirklich erkennbar, Farben wie LSD-Trip.
'radeonkms' funktioniert, Auflösung stimmt auch, schmiert aber mit ner kernel panic reproduzierbar (in variablen Zeitabständen) ab. Außerdem kann ich unter kde5 kein Fenster vom Hauptmonitor auf einen anderen ziehen.
Gegentest mit reingeschraubter nvidia: alles sahnig! ;)
 

holgerw

Well-Known Member
#12
Gegentest mit reingeschraubter nvidia: alles sahnig! ;)
Mit ATI/AMD kann ich keine Erfahrungen beisteuern, aber bei allen bisherigen Erfahrungen mit Intel GPU und Nvidia war Intel immer so la la, Nvidia immer in Ordnung mit FreeBSD. Auch Tearing kann man in den Griff bekommen. Wobei ich mit meinem Desktop PC selten Videos schaue.
 

cabriofahrer

Well-Known Member
#14
Also ich hatte neulich eine alte Kiste mit intergrierter amd HD3000-Grafik auf 12.0 upgegradet und radeonkms erfolgreich geladen, super Bild in maximaler Auflösung, nur leider kein vdpau. In der Vergangenheit hatte ich auch mit einer Radeon X800 Mobile und einer Radeon HD 4850 mit dem alten Treiber gute Erfahrungen. Andererseits klappte damals bei mir OpenGL 3 von KDE4 mit meiner Nvidia-Karte nicht, es gab immer einen Crash und ich musste KDE auf OpenGL 2.1 stellen, damit es funktionierte. Ich weiß nicht, inwieweit man KDE als zuverlässigen Testmaßstab nehmen kann.

Und klar, nvidia ist eben die beste Wahl, schließlich hat man einen proprietären Treiber vom Hersteller für FreeBSD.
 

mr44er

Well-Known Member
#16
Da bin ich auch gespannt, da ich leider hier nichts so neues rumfliegen habe, was 'amdgpu'-geeignet wäre.

Andererseits klappte damals bei mir OpenGL 3 von KDE4 mit meiner Nvidia-Karte nicht
Der Chip muss auch opengl3 können. Bei Karten von vor 2007 wirds kritisch.

Ich weiß nicht, inwieweit man KDE als zuverlässigen Testmaßstab nehmen kann.
Sowieso nicht. Das kde5 war gestern für mich das erste Mal ausprobiert. Funfact jetzt mit nvidia, was mit radeonkms funktionierte: kein Bild mehr beim standby-resume. :ugly: Hab' vergessen, dass man den Treiber mit acpi bauen muss, was ich gerade auch mache.
 
Zuletzt bearbeitet:

mr44er

Well-Known Member
#17
Nachtrag, gerade auch wegen dem Zirkus mit deinem Spielzeug und Intel vor ein paar Monaten:
i3-3220 mit HD 2500 hier jetzt ausprobiert. Das ist noch Ivy Bridge.
Ein Monitor am DVI, der andere am DisplayPort.

drm-kmod aus quarterly, alles sahnig mit kde5. Ich musste nicht einmal weiterhin was fummeln, absolut kein tearing bei Videos. Videos bei youtube laufen sogar bis inklusive 1440p@60 frames flüssig.:eek:
standby (s3) resume auch ohne Gebastel. :D
 
Themenstarter #19
So die Hardware ist heute gekommen, ist zusammengebaut. Ich erstelle gerade ein Stick mit nomadBSD zum ersten testen. :-)
 
Themenstarter #21
Es gab Lieferschwierigkeiten, aber in der Zwischenzeit ist alles zusammengebaut. Das mit dem Grafiktreiber klappt leider nicht. Ich benutze gerade den scfb treiber.
 

cabriofahrer

Well-Known Member
#23
Schade. Also doch lieber nvidia. Du solltest das Problem vielleicht dem zuständigen Team berichten. Probiere es mal mit dem "alten" Treiber ohne kms also "xf86-video-ati". Einfach "pkg install xf86-video-ati" und den Eintrag in der /etc/rc.conf zu kms auskommentieren und neustarten.
Ich habe drm-kmod auf einem alten HD3000-chip ausprobiert und die Videowiedergabe war nicht so gut wie mit dem alten Treiber unter FreeBSD 11.2. Bei höheren Auflösungen hat es teilweise geruckelt und das Bild hatte teilweise Verzerrungen. Mit xf86-video-ati-legacy ist es hingegen wieder wunderbar und flüssig.
 
Themenstarter #24
So wie ich es auf github sehe, gibt es auch Probleme mit neueren UEFI Versionen, aber es wird anscheinend daran gearbeitet. Mit dem scfb Treiber bekomme ich wenigstens ein Bild. Und Youtube Videos laufen auch auf 1080p Auflösung schnell genug ab. Der Sound und Netzwerk treiber werden mit FreeBSD 12p3 ohne Probleme unterstützt. Ich warte mal ab wenn eine neuere Version von drm-mod Treiber da ist, wo der Vega 11 supportet wird. Aber bis dahin kann ich erstmal normal arbeiten damit, mache aktuell eh nur Programmieren damit, zum zocken habe ich aktuell keine Zeit.

Gruß Daniel