Ati Radeon 9x00 Unterstützung

Hallo
ich bin neu in der BSD-Welt (komme von Linux) und hab mir vor kurzem FreeBSD-current (5.2.1) installiert. Da ich eine Radeon 9600 besitzte würde ich die gerne mit 3D (OpenGL) Beschleunigung benutzten. Dummerweise hat das DRI-Team ja nur Docs für Radeons bis zu 9200 (zumindestens was den 3d-Teil betrifft). Also hab ich einfach mal den Linux-Treiber von Ati installiert (Version 3.11.1) und 2D läuft nun unter FreeBSD mit den Ati Treibern. Meine Frage ist nun, ist es möglich das Linuxkernelmodule (den Teil mit dem verfügbaren Quellcode, nicht den Binaryteil) von ATI so umzuschreiben, das der FreeBSD-kernel damit klar kommt und DRI unterstützung besteht ?

cu Jon
 
Oben