Client DNS-Queries abgewöhnen

Miggo

Well-Known Member
Ich hab hier zwei Rechner A und B. Auf beiden läuft FreeBSD 5..1 Release, A hat über ISDN eine Anbindung ans Internet, ist über Ethernet mit B verbunden und dient diesem als Gateway. Das funktioniert auch alles. Lediglich bleibt B beim Starten hängen, wenn A nicht eingeschalten ist. Der Bootvorgang lässt sich zwar mit Strg-C bzw. Einwahl von A ins Internet fortsetzen, aber das ist auf Dauer auch keine befriedigende Lösung. Ich hab die ausgehenden Pakete auf A mitgesnifft und herausgefunden, dass B seinen Hostnamen (xxxx.localdomain) über die normalen DNS-Server versucht in eine IP aufzulösen, obwohl in der /etc/hosts folgender Eintrag vorhanden ist:
192.168.0.1 xxxx.localdomain
Normalerweise müsste er dann seine IP doch nur damit auflösen, oder hab ich einen Denkfehler drin?
P.S.: Die ausgehenden Pakete hatten die obige IP als Quelladresse. Also fragt er /etc/hosts doch ab?
 

CW

Netswimmer
Original geschrieben von Miggo
Ich hab hier zwei Rechner A und B. Auf beiden läuft FreeBSD 5..1 Release, A hat über ISDN eine Anbindung ans Internet, ist über Ethernet mit B verbunden und dient diesem als Gateway. Das funktioniert auch alles. Lediglich bleibt B beim Starten hängen, wenn A nicht eingeschalten ist. Der Bootvorgang lässt sich zwar mit Strg-C bzw. Einwahl von A ins Internet fortsetzen, aber das ist auf Dauer auch keine befriedigende Lösung. Ich hab die ausgehenden Pakete auf A mitgesnifft und herausgefunden, dass B seinen Hostnamen (xxxx.localdomain) über die normalen DNS-Server versucht in eine IP aufzulösen, obwohl in der /etc/hosts folgender Eintrag vorhanden ist:
192.168.0.1 xxxx.localdomain
Normalerweise müsste er dann seine IP doch nur damit auflösen, oder hab ich einen Denkfehler drin?
P.S.: Die ausgehenden Pakete hatten die obige IP als Quelladresse. Also fragt er /etc/hosts doch ab?

Tippe in deine /etc/resolv.conf folgendes ein:

lookup file bind

Dadurch wirst du deinen Rechner B anweisen, zuerst in die /etc/hosts zu gucken, bevor er seinen DNS-Server befragt.

Dadurch sollten die Probleme mit der unnötigen DNS-Abfrage verschwinden.

Wenn es nicht so sein sollte, schreibe wieder hier rein :)

Gruß

CW
 

Miggo

Well-Known Member
Danke für den Tip, aber hat leider nichts gebracht. Btw.: kann es sein, dass es diese Option bei FreeBSD gar nicht gibt? Weil die Internet-Suche mich immer nur auf Net- bzw. OpenBSD verweist und sich man resolv.conf auch darüber ausschweigt?
 

CW

Netswimmer
Original geschrieben von Miggo
Danke für den Tip, aber hat leider nichts gebracht. Btw.: kann es sein, dass es diese Option bei FreeBSD gar nicht gibt? Weil die Internet-Suche mich immer nur auf Net- bzw. OpenBSD verweist und sich man resolv.conf auch darüber ausschweigt?

Diese Option ist standard für alle BSDs. Sie ist zwar in der FBSD-Manpage zu resolv.conf nicht dokumentiert, doch sie funktioniert dort.

Bei einem anderen (ähnlichen) Thread habe ich schon mal diese Möglichkeit empfohlen, und dort hat es geklappt.

Kannst du vielleicht Logfiles der Maschine B zuschicken.

Denn eigentlich muss es klappen.

Außerdem kannst du in der rc.conf doch den Rechnernamen und die Domain eintragen.

Hast du das schon ausprobiert?

Hier der Link zu Manpage von rc.conf: http://www.freebsd.org/cgi/man.cgi?...ion=0&manpath=FreeBSD+4.8-RELEASE&format=html

CW
 

Miggo

Well-Known Member
Also in der rc.conf sind folgende Einträge:
[...]
hostname="Manfred.localdomain"
nisdomainname="NO"
defaultrouter="192.168.0.2" # Rechner A
/etc/hosts:
127.0.0.1 localhost.localdomain localhost
192.168.0.1 Manfred.localdomain Manfred
192.168.0.2 Michael.localdomain Michael

Wenn ich den defaultrouter in der rc.conf auskommentiere funktioniert alles wie gehabt.
In den Logs (messages und ppp) erscheinen keinerlei Meldungen.
 

CW

Netswimmer
Original geschrieben von Miggo
Also in der rc.conf sind folgende Einträge:
[...]
hostname="Manfred.localdomain"
nisdomainname="NO"
defaultrouter="192.168.0.2" # Rechner A

Baue doch mal in deine rc.conf noch den Eintrag über deine Netzwerkkarte ein.

So sieht die Syntax aus: ifconfig_<interface>="inet IP-NUMMER netmask NETZMASKE"

Alles weitere steht in der Manpage von rc.conf.

Mal sehen, ob er dann Ruhe gibt.

Benutzt du DHCP?

CW
 
Zuletzt bearbeitet:

berg

sportfreund
Ich hatte das gleiche Problem. Bei mir lags daran dass ich folgende Zeile im Kernel Konfigurationsfile nicht auskommentiert hatte bzw. noch den GENERIC Kernel verwendete...

options INET6 #IPv6 communications protocols


MfG
Berg
 
Zuletzt bearbeitet:

Miggo

Well-Known Member
Sorry, den Eintrag hab ich schon drin, jedoch nur nicht dazugeschrieben, da ich das als selbstverständlich ansah.
Sieht so aus (Realtek *g*):
ifconfig_rl0="inet 192.168.0.1 netmask 255.255.255.0 media 10baseT/UTP mediaopt full-duplex"
DHCP benutze ich nicht, da ich lediglich die zwei direkt verbundenen Rechner hier stehen habe.
@berg
Das letzte was ich beim Booten sehe ist:
Configuring syscons: keymap blanktime
(also nach dem kompletten probing und überprüfen bzw. mounten der Dateisysteme)
Wenn ich dann Strg-C drücke, geht es mit:
"Initial i386 initialization" weiter
 
Zuletzt bearbeitet:

CW

Netswimmer
Original geschrieben von Miggo

Das letzte was ich beim Booten sehe ist:
Configuring syscons: keymap blanktime

Folgendes steht in der rc.conf:

blanktime
(int) If set to ``NO'' then the default screen blanking
interval is used, otherwise it is set to value seconds.

CW
 

Miggo

Well-Known Member
Original geschrieben von berg
Ich hatte das gleiche Problem. Bei mir lags daran dass ich folgende Zeile im Kernel Konfigurationsfile nicht auskommentiert hatte bzw. noch den GENERIC Kernel verwendete...

options INET6 #IPv6 communications protocols


MfG
Berg

Das wars!! Hatte den erst frisch installiert und noch keine Lust gehabt, die Kernel-Config durchzugehen. Jetzt gehts nach einem Kernelneubau.
Danke euch!
 

CW

Netswimmer
Original geschrieben von Miggo
Das wars!! Hatte den erst frisch installiert und noch keine Lust gehabt, die Kernel-Config durchzugehen. Jetzt gehts nach einem Kernelneubau.
Danke euch!

Interessant!

Ich hatte mit OpenBSD und einer ähnlichen Konstellation (DNS-Maschine vorn, andere Maschinen dahinter) keine Probleme dieser Art.

Im OpenBSD-KernelConfig ist IPv6 ebenfalls als default dabei.

Wie dem auch sei ... viel Spaß noch :)

Gruß

CW
 
Oben