Cstrike server unter freebsd

Status
Für weitere Antworten geschlossen.

vampy

Member
Hallo,

ich hab gestern Nacht mein erstes FreeBSD System aufgesetzt und hatte auch vorher nix mit Linux zutun mittlerweile hab ich aber den CS Server fast zum laufen gebracht. Er hängt an irgendeiner Stelle oder so keine ahnung ob ich evtl Ports oder so freigeben muss aber die Firewall is deaktiviert. Der Server soll nur im Netwerk laufen ich kann ihn auch anpingen aber unter HLSW/CS find ich ihn nicht.

Hab hier nen Bild:

http://img386.imageshack.us/img386/3339/dsc00111wi3.jpg

mfg

vampy
 

vampy

Member
ihr seid aber nett.. hammer

ey elessar dein kommentar kannste dir mal fett innen *** stecken du ***.
 
Zuletzt bearbeitet von einem Moderator:

Elessar

Huldigt dem _/\_
Lieber Benutzer vampy,


vielen Dank für ihre Beleidigung gegenüber Personen des Moderatoren-Teams. Wir sind immer erfreut Ihre Wünsche zu einem Höchstmaß an Zufriedenheit zu erfüllen.

Wir möchten Sie jedoch in Zukunft bitten bei Ihren Anfragen korrekte Fakten anstatt Fehlinformationen zu nennen, andere wichtige Informationen die einer Bringschuld unterliegen nicht zu unterschlagen, und zu guter letzt bitte das überhaupt vorliegende Problem auf Betriebssystemebene zu schildern. Für Applikationsprobleme kommerzieller Anwendungen existieren Hotlines.

Betrachte dich hiermit als verwarnt. Freundlicher Umgangston ist nicht optional.
 

vampy

Member
Ui, was kommste dann mit so Kommentaren wie "Kauf dir Vista" an anstatt mir zu helfen? Egal nun weis niemand wieso der Sever net startet ? Normal müsste nach ner Zeit "Master server communication disabled" kommen und dann wär er UP. Tut sich aber nix ;/ Ich hab auch keinen Router...
 

jtsn

Well-Known Member
Das mit dem Server verrat ich Dir, wenn Du mir sagst, wie der Cstrike client unter FreeBSD läuft. ;-)

ciao, jtsn
 

vampy

Member
da kann ich dir leider nicht weiterhelfen ;/ hast schonmal gegoogelt ? ^^
wär aber sehr nett wenn du mir weiterhelfen würdest :)
 

mcas

Well-Known Member
Also dann wollen wir mal.
1. Wie hast du das installiert?
2. warum um alles in der Welt macht man sowas mit FreeBSD wenn man keine Ahnung hat?
3. Was sagt dir die Logdatei die in der vorletzten Zeile steht?
 

Yamagi

Possessed With Psi Powers
Teammitglied
So Jungs. Entweder ihr konzentriert euch nun auf das Thema und ich mache hier dicht!
 

strike

Active Member
Moin,

also eigentlich läuft HL sganz gut unter FreeBSD in der Linux-emu.
Lief bei mir 2 Jahre in nem Jail....allerdings hatte ich die LAN option nie getestet :-)
mfg
 

vampy

Member
1. CSTRIKE INSTALLATION:

Ich hab den Server nach /home/jvm/hlds installiert. Also hab ich das HLDS-Updatetool per FTP von meinem WINXP PC ins Verzeichnis hlds kopiert.
Danach hab ich es am FreeBSD System mit chmod u+x hldsupdatetool.bin ausführbar gemacht. So nun hab ichs mit ./hldsupdatetool.bin ausgeführt und die EULA mit "Ja"
beantwortet. Dann hab ich mit der Installation begonnen ./steam -command update -game cstrike -dir /home/jwm/hlds. Er hat auch 100% alle Dateien gezogen da ich es nochmal ausgeführt hat und er hat dann alle Dateien bestätigt.

2. Warum FreeBSD:

Weil ich schon länger mal in das OS einsteigen wollte. Ich weis das es verdammt schwer ist und ich eigentlich noch nix kapiere aber jeder fängt mal klein an und ich liebe die Herausforderung :D. Hab auch schon nen paar CS Serverhoster gesehen die FreeBSD benutzen.

3. Logdatei:

In der Logdatei steht nix brauchbares drin. Nur Uhrzeit wann der Server gestartet hat.

4. FreeBSD Konfiguration.

War ne 6.1 FreeBSD Standardinstallation. Unter Network Konfiguration hab ich AMD Flags, inetd und TCP Extensions aktiviert. Der SecureLevel is deaktiviert.


Ich hoffe das reicht wie gesagt ich kenn mich noch net so aus. Wenn ihr noch was wissen wollt nur zu ^^


mfg

vampy
 

vampy

Member
So ich hab ne neue Information die mich evtl weiterbringen könnte irgend nen CPU Fehler:

Also im roten Kasten hab ich mit ./hlds_run -binary ./hlds_i686 -game cstrike -insecure -nomaster +sv_lan 1 +maxplayers 16 +map de_dust2 -debug den Server gestartet.

Im blauen Kasten hab ich die Map gewechselt und dann kommt im gelben Kasten der Fehler der evtl den Server erst garnicht starten lässt.

http://img184.imageshack.us/img184/4620/freebsdcstriketb1.jpg

Das Log dazu:

L 01/02/2002 - 19:55:33: Log file started (file "logs/L0102010.log") (game "cstrike") (version "47/1.1.2.5/Stdio/3651")
L 01/02/2002 - 19:55:33: Loading map "de_dust2"
L 01/02/2002 - 19:55:33: Server cvars start
L 01/02/2002 - 19:55:33: Server cvar "_tutor_bomb_viewable_check_interval" = "0.5"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_debug_level" = "0"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_examine_time" = "0.5"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_hint_interval_time" = "10.0"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_look_angle" = "10"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_look_distance" = "200"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_message_character_display_time_coefficient" = "0.07"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_message_minimum_display_time" = "1"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_message_repeats" = "5"
L 01/02/2002 - 19:55:33: Server cvar "_tutor_view_distance" = "1000"
L 01/02/2002 - 19:55:33: Server cvar "allow_spectators" = "1"
L 01/02/2002 - 19:55:33: Server cvar "coop" = "0"
L 01/02/2002 - 19:55:33: Server cvar "deathmatch" = "1"
L 01/02/2002 - 19:55:33: Server cvar "decalfrequency" = "60"
L 01/02/2002 - 19:55:33: Server cvar "edgefriction" = "2"
L 01/02/2002 - 19:55:33: Server cvar "hostage_debug" = "0"
L 01/02/2002 - 19:55:33: Server cvar "hostage_stop" = "0"
L 01/02/2002 - 19:55:33: Server cvar "humans_join_team" = "any"
L 01/02/2002 - 19:55:33: Server cvar "max_queries_sec" = "3.0"
L 01/02/2002 - 19:55:33: Server cvar "max_queries_sec_global" = "30"
L 01/02/2002 - 19:55:33: Server cvar "max_queries_window" = "60"
L 01/02/2002 - 19:55:33: Server cvar "mp_allowmonsters" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_autokick" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_autoteambalance" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_buytime" = "0.25"
L 01/02/2002 - 19:55:33: Server cvar "mp_c4timer" = "35"
L 01/02/2002 - 19:55:33: Server cvar "mp_chattime" = "5"
L 01/02/2002 - 19:55:33: Server cvar "mp_consistency" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_fadetoblack" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_flashlight" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_footsteps" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_forcecamera" = "2"
L 01/02/2002 - 19:55:33: Server cvar "mp_forcechasecam" = "2"
L 01/02/2002 - 19:55:33: Server cvar "mp_fragsleft" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_freezetime" = "10"
L 01/02/2002 - 19:55:33: Server cvar "mp_friendlyfire" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_ghostfrequency" = "0.1"
L 01/02/2002 - 19:55:33: Server cvar "mp_hostagepenalty" = "13"
L 01/02/2002 - 19:55:33: Server cvar "mp_kickpercent" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_limitteams" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_logdetail" = "3"
L 01/02/2002 - 19:55:33: Server cvar "mp_logfile" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_logmessages" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_mapvoteratio" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_maxrounds" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_mirrordamage" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_playerid" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_roundtime" = "2.5"
L 01/02/2002 - 19:55:33: Server cvar "mp_startmoney" = "800"
L 01/02/2002 - 19:55:33: Server cvar "mp_timeleft" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_timelimit" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_tkpunish" = "0"
L 01/02/2002 - 19:55:33: Server cvar "mp_windifference" = "1"
L 01/02/2002 - 19:55:33: Server cvar "mp_winlimit" = "0"
L 01/02/2002 - 19:55:33: Server cvar "pausable" = "0"
L 01/02/2002 - 19:55:33: Server cvar "sv_accelerate" = "5"
L 01/02/2002 - 19:55:33: Server cvar "sv_aim" = "0"
L 01/02/2002 - 19:55:33: Server cvar "sv_airaccelerate" = "10"
L 01/02/2002 - 19:55:33: Server cvar "sv_airmove" = "1"
L 01/02/2002 - 19:55:33: Server cvar "sv_allowupload" = "1"
L 01/02/2002 - 19:55:33: Server cvar "sv_bounce" = "1"
L 01/02/2002 - 19:55:33: Server cvar "sv_cheats" = "0"
L 01/02/2002 - 19:55:33: Server cvar "sv_clienttrace" = "1"
L 01

mfg

vampy
 

vampy

Member
sorry für die nub frage aber woher bekomm ich den neuesten linux emulator und wie installier ich ihn ~~

Ich habs nach der Anleitung versucht:

FreeBSD requires an extra step; When installing, make certain you install the "Ports" collection. If you did not select this, then execute "pkg_add -r cvsup" as root, and if prompted, choose to install samples and examples. Then, open up the file "/usr/share/examples/cvsup/ports-supfile" with ee, (executed with the simple command "edit" in a default configuration,) and edit the line that resembles ...

*default host = CHANGE_THIS.FreeBSD.org

and change it to be...

*default host = cvsup4.FreeBSD.org

Be certain you do not edit the version of this text than includes a preceding "#" mark. Then, execute the command "cvsup /usr/share/examples/cvsup/ports-supfile" as root and let it sit until finished. Once done, execute "cd /usr/ports/emulators/linux_base-rh-9 && make install" and let it run for as long as it takes. Now edit the file "/etc/rc.conf" and add this line to the bottom.
________________________________________________________________________________________________________________


cvsup hab ich gesaugt aber wenn ich cvsup /usr/share/examples/cvsup/ports-supfile versuche sagt er mir das es den befehl cvsup net gibt.

mfg

vampy
 

Yamagi

Possessed With Psi Powers
Teammitglied
Was würdest du davon halten, einmal unser sehr gutes Handbuch zu lesen und vielleicht mal ein wenig im Wiki zu blättern? Dann würdest du sicher viel weniger unqualifizierte Fragen stellen und könntest dich in Grundlagen einarbeiten bevor du komplizierte Sachen versuchst... Btw. was spricht gegen DesktopBSD?
 

vampy

Member
nun hab ich das linux_base-fc-4_9 paket installiert selber fehler ich dreh bald durch hier...

Update: Ich versuche nun den linux_base-rh-9 Port zu installieren aber es kommt immer ne Fehlermeldung:
make: don't know how to make install. Stop

Und das erst seit nem Ports Update mit cvsup

help pls kein bock aufzugeben ich will den cs server zum laufen bekommen ;(
 
Zuletzt bearbeitet:
Status
Für weitere Antworten geschlossen.
Oben