• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Das Netzwerk konfigurieren

clearguy

Active Member
Themenstarter #1
Hallo,

in der installationseinleitung steht was von dhcp,doch windows schliest mich mit einem login und password ans Internet,ist das dasselbe?

Wenn ja wie finde ich das raus:
IPv4 address for fxp0 (or 'dhcp')? 199.185.137.55
DNS domain name? (e.g. 'bar.com') [my.domain] example.com
DNS nameserver? (IP address or 'none') [68.87.77.130 68.87.72.130] Enter
 

Frank D.

Well-Known Member
#2
Hallo,

bei der Installation wird abgefragt, ob Du eine statische IP vergeben willst oder ob OpenBSD eine IP-Adresse von einem DHCP-Server erhält.

Deine Frage verstehe ich nicht ganz: ist das OpenBSD-System Router, FW, Proxy und wie sind die Rechner (wohl zwei) im lokalen Netz verteilt (hintereinander oder im selben Segment) ? Eine kleine Skizze könnte Abhilfe schaffen.

Gruß

Frank
 
#8
Hallo Clearguy,

ich vermute mal du versuchst eine Netzinstallation durchzuführen (cd40.iso,oder die floppys) hast aber kein Netz.

Hast du ein Router oder irgendwas was als Gateway herhalten kann. So das du nur lokale IP , Gateway ... angeben must oder DHCP nutzen kannst und sich der router um die Interneteinwahl kümmert ?

Falls nicht würden mir spontan folgende Möglichkeiten einfallen:

- Offizielle Openbsd CD kaufen. (Sollte man wahrscheinlich sowieso tun wenn einen das System gefällt aber evtl. ist es zu früh das beurteilen zu können ;) )

- Eigene OpenBSD CD erstellen (Forensuche, und z.B. http://www.bsdforen.de/showthread.php?t=627 finden )

- Checken ob es irgendwie möglich ist pppoe vor der installation der Sets einzureichten (keine Ahnung, "escape to a shell by typing '!' " :confused: )
 
Zuletzt bearbeitet:

clearguy

Active Member
Themenstarter #9
Im Moment hab ich keine CD,nur Disketten.

Ich hab es versucht mit den Files für die Installation auf meiner Windows Partition unter c:\bsd\ ,doch es funktionniert nicht.

Ich werd versuchen die Files direkt auf einer des bsd Partitionen zu schreiben.
 

mapet

Active OpenBSD User
#10
obsd kann kein ntfs und windows weder disklabels noch ufs. empfehlenswert wäre es, wenn du dir cds runterlädst und brennst... also das .iso zum booten und dann die pakete auf eine zweite zum installieren.
 

mapet

Active OpenBSD User
#13
bei der installation man40.tgz mitinstallieren, und wenn das system dann gestartet hast findest du alles notwendige nach der eingabe von "man pppoe", wenn du sichergehen willst, die richtige manpage zu erwischen kannst du auch "man 4 pppoe" nehmen. das ist kernelseitiges pppoe, was besser funktioniert als das ausm userland. das beispiel kannst du fast 1 zu 1 übernehmen, musst natürlich noch deine zugangsdaten entsprechend eintragen.

viel erfolg ;)
 

franco98

NetBSDler aus Leidenschaft
#15
Ein Weg:

Zieh dir das komplette OpenBSD-4.0 vom FTP-Server, brenne es unter Windows auf eine CD, z.B. so /4.0/i386/...*tgz, boote dann wenn du willst von den Disketten und gib als Medium die CD dann an.
Das Netzwerk kannst du auch später in Ruhe installieren.

Gruß Frank
 

mapet

Active OpenBSD User
#17
und das ist bei der installation schon am start und wird vom rd-kernel unterstützt?

EDIT: es gibt auch befehle um mit msdos-dateisystemen umzugehen oder zu formatieren, wird nur trotzdem von abgeraten ;)
 
Zuletzt bearbeitet:
Themenstarter #19
Gut,Installation hat mit der CD geklappt,hab es so gar geschafft xdm zu starten :p

Ich werde jetzt mal versuchen dieses ppp Ding zu installieren.

Nur ein Problem,von wo krieg ich den Namen oder "Device" von meinem Modem unter OpenBSD? Denn den brauche ich für pppoe.conf .
 

mapet

Active OpenBSD User
#20
ich würde dir dringenst dazu raten, das kernel-pppoe zu benutzen. das userland solltest du nur nehmen, wenn du nen pppoe-server betreiben willst oder aus irgendwelchen gründen das kernel-pppoe bei dir nicht laufen sollte.
und wie ich bereits sagte, das beispiel aus "man 4 pppoe" kannst du nahezu 1 zu 1 übernehmen.

meine hostname.pppoe0 sieht so aus:
hostname.pppoe0 hat gesagt.:
~ $ cat /etc/hostname.pppoe0
inet 0.0.0.0 255.255.255.255 0.0.0.1 pppoedev sis1 authproto pap authname meinname authkey sagichnicht mtu 1488 up
!/sbin/route add default 0.0.0.1
die mtu-angabe brauche ich für arcor, weil die ne geringere haben (nach 5 wochen verbindungsabbrüchen wurd ich stutzig und die hotlinehuschen haben ja keinen plan von sowas).
sis1 ist meine karte, die am modem hängt. die braucht natürlich noch ein "up" in ihrer config:
hostname.sis1 hat gesagt.:
~ $ cat /etc/hostname.sis1
up
hth, marc
 
Themenstarter #21
Danke makenoob,nach einem Re-boot und ein paar "watchdog nfe0:timeout" hatte ich eine neue Internet Adresse^^

Wenn ich mir jetzt einen Browser installieren möchte muss ich ein Paket wieder auf eine CD brennen?

Kann ich mir einen anderen XServer als xdm installieren?
 

mapet

Active OpenBSD User
#22
schau dir bitte die FAQ zu ports and packages an. in der FAQ steht auch was zum Xserver. die doku von den bsds ist ausgesprochen gut, und die jungs von openbsd stecken da ne ganze menge zeit in ihre FAQ, manpages etc.
xdm ist nur der anmelde screen. du kannst jeden benutzen, allerdings ist gnome unter obsd quasi nicht zu gebrauchen (wenn sie es nicht mittlerweile verbessert haben).

weiterhin viel erfolg :)
 

CommanderZed

OpenBSD User
Mitarbeiter
#24
Hast du auch die namensauflösung eingestellt?

unter

/etc/resolv.conf musst du einen Nameserver eintragen, welcher das ist, sagt dir z.B. dein Provider. Bei T-Online ist es z.B. 194.25.2.129. Alternativ könntest du auch versuchen, einen "frei" nutzbaren nameserver zu finden, oder selbst einen nameserver auf deinem PC starten.

Zudem: Hast du die üblichen, grundsätzlichen tools, die es unter jedem OS gibt, zum testen der verbindung / der namensauflösung genutzt? (ping e.t.c.)
 
Themenstarter #25
Hast du auch die namensauflösung eingestellt?

unter

/etc/resolv.conf musst du einen Nameserver eintragen, welcher das ist, sagt dir z.B. dein Provider. Bei T-Online ist es z.B. 194.25.2.129. Alternativ könntest du auch versuchen, einen "frei" nutzbaren nameserver zu finden, oder selbst einen nameserver auf deinem PC starten.

Zudem: Hast du die üblichen, grundsätzlichen tools, die es unter jedem OS gibt, zum testen der verbindung / der namensauflösung genutzt? (ping e.t.c.)
Danke,ich habe den Nameserver eingetragen und konnte dann pkg_add mit einem FTp benutzen :D