Datensicherung auf externes NAS

DetoNAtor

Active Member
Moin,

ich hab meine Daten auf einem FreeBSD 6.3-Server in einem Raid. Ist ganz nett, aber da ich gerne Paranoia schiebe, möchte ich die geänderten Daten des nachts immer auf ein anderes NAS (anderer Raum, andere Etage) kopieren.
Sowas wie ein Archivflag kenne ich unter Unix nicht und rsync sollte auch nicht klappen, da ich auf dem Zielsystem nix installieren kann.

Hab ich 'ne Möglichkeit das zu realisieren?

Dank und Gruß,
DNA
 

dark_angel

Well-Known Member
NAS per SMB oder NFS in die BSD Kiste einbinden und mit nem beliebingen Script verschieben oder rsync benutzen (Server und Client sind dann halt die selben Kisten).
 

[moR-pH-euS]

Magnum P.I.
Du kannst ein kleines Shell-Script erstellen mit tar. Bei Tar kannst du angeben das nur Files die z.B. in den letzten 24 Std geändert wurden in das Tar-Archiv kommen sollen (Stichwort ctime, mtime). Und das Script dann halt per Cron jede Nacht ausführen lassen und eben das NAS per SMB oder NFS in die FreeBSD Kiste einbinden auf das das Tar-Archiv dann geschoben wird (wie es dark_angel bereits vorgeschlagen hat).
Musst halt mal in die man-page von tar schauen. Weiss jetzt nicht mehr wie das Flag heisst.
 

pit234a

Well-Known Member
aber rsync macht das alles schon und recht schön, es kennt die Option -u und nimmt dann nur neuere Files mit. So wird es von mal zu mal schneller.
Es kann auch wirklich sychronisieren und dabei überschüssige Files auf Server oder Client entfernen (oder vielleicht besser, Sender/Empfänger, weil es auch lokal funktioniert, ohne eigens Server aufzubauen). Außerdem kannst du auch Dateien unberücksichtigt lassen, also auch Ordner und damit verhindern, daß zu große Datenmengen übertragen werden (etwa, wenn dein Ordner ein mountpoint ist und du da mal was unbedacht eingebunden hast, dann würde das mit synchronisiert werden).
 

DetoNAtor

Active Member
Vermutlich nur samba und ftp. Ich will eine (im Zulauf befindliche) Fritzbox als NAS mißbrauchen. Ob man auf die Kiste selbst drauf kommt möchte ich fast ausschliessen.
 

pit234a

Well-Known Member
Fritzbox kenne ich nicht, aber ist das nicht eigentlich ein DSL-router?
Da bezweifele ich fast, daß der überhaupt was kann.
Wenn da etwa eine externe Disk angeschlossen wird, dann machst du das doch lieber gleich am Server direkt. Die kannst du dann ja auch nur Nachts sychronisieren lassen.
 

DetoNAtor

Active Member
Prinzipiell hast Du recht, aber so kann ich die Daten auf eine Platte in einem anderen Haus spiegeln, was in Sachen Datensicherheit deutlich besser ist als wenn ich die Platte an den gleichen Rechner dran pappe. Und die Box wäre ein System was sowieso immer an ist, also brauche ich keinen zweiten Rechner/NAS für's Backup.
 

Daemotron

Well-Known Member
Hast Du Dir schon mal duplicity bzw. ftplicity angeschaut? Damit sollte sich Dein Problem ebenfalls lösen lassen.

P. S. berichte mal von Deiner Erfahrung mit dem Homeserver, wenn Du ihn hast. Ich liebäugle nämlich auch grade damit...
 

morromett

Well-Known Member
Die FritzBox 7270 kann telnet. Und das kann man über ein analoges Telefon, das direkt an der Box angeschlossen und eingerichtet ist, ein- und ausschalten:
"#96*7*" telnetd an
"#96*8*" telnetd aus


Alternative: via The Construct ein Pseudo_update.Image mit dropbear (ssh-server) erstellen und dann ein ssh-client verwenden.
 

DetoNAtor

Active Member
Hallo nochmal,

Die Box hab ich jetzt, macht auch nen recht brauchbaren Eindruck. Leider krieg ich das Mounten der Platte nicht hin. Ich nehme jedoch an, das liegt an meiner Freebsd-Installation.
Es scheitert ein:
mount_smbfs //ftpuser:Kennwort@fritzbox/USBTOPARALLEL-ATABRIDGE-0-1 /mnt/backup
mit mount_smbfs: kldload(smbfs): Operation not permitted

Wenn ich kldload smbfs manuell als root probiere scheitert das auch mit "Operation not permitted".
Als root, und das wundert mich. Kann ich mich irgendwie an den Fehler ranhangeln?

Dank und Gruß,
DetoNAtor
 

[moR-pH-euS]

Magnum P.I.
Wenn du wirklich root bist, in welchem Secure-Level bist du denn?
Siehst du mit

# sysctl kern.securelevel

Wenn er -1 ist, ist das wirklich komisch das du als root keine Module laden kannst. Wenn er 1 oder 2 ist, befindet sich dein System in einem Zustand wo die Lademöglichkeit von Kernelmodulen und andere Dinge sehr restriktiv sind (auch für root).
 

pit234a

Well-Known Member
smb, also samba, als server oder client, gehören nicht zur Standardinstallation bei FreeBSD. Du mußt die entsprechenden Pakete erst installieren, in deinem Fall also den samba client.
Außerdem vielleicht auch in deiner /etc/inetd.conf entsprechendes eintragen.
Für die Kommunikation alla M$ werden auch weitere Dienste benötigt, wie etwa netbios und so was. Sieh dir mal die Dokumentation dazu an und finde heraus, ob du alles richtig gemacht hast.

Wenn diese fritzibox nur samba kann, bist du ja darauf angeweisen, BSD zu einem samba-Clienten zu machen. Ein Windoofer Rechner sollte das allerdings automatisch können (nehme ich an, weiß es aber nicht wirklich) und vielleicht solltest du so erst mal testen, ob deine Freigabe auch tatsächlich funktioniert, bevor du dir mit BSD viel Mühe gibst.
 

DetoNAtor

Active Member
Wenn diese fritzibox nur samba kann, bist du ja darauf angeweisen, BSD zu einem samba-Clienten zu machen. Ein Windoofer Rechner sollte das allerdings automatisch können (nehme ich an, weiß es aber nicht wirklich) und vielleicht solltest du so erst mal testen, ob deine Freigabe auch tatsächlich funktioniert, bevor du dir mit BSD viel Mühe gibst.

Alles was Du schriebst, war mir eigentlich klar. Mit XP kam ich auf die Freigabe drauf.

Das war's! Bevor ich die Kiste vor (uh?) 2 Jahren ans Netz genommen habe, hatte ich die noch weng abgedichtet. Jails, eingeschränkte Logins und so. Tja, und den Securelevel hab ich auch gesetzt. Und mittlerweile vergessen, weil das System nur alle halbe Jahre mal ein Zipperlein hat. Ich hab das Laden des Moduls gleich in die Loader.conf eingetragen. Nun komm ich erstmal weiter.

Danke moR-pH-euS.

Edit: Letztlich klappt das Mounten der Platte. Allerdings wird der Parameter "-I" benötigt.
mount_smbfs -I 192.168.0.100 //ftpuser:Kennwort@fritzbox/USBTOPARALLEL-ATABRIDGE-0-1 /mnt/backup
So. Jetzt kann ich mich endlich ans RSync setzen.
 
Zuletzt bearbeitet:
Oben