ddial funktioniert nicht.

suicide

Trucker Horst
Hi,
habe seit ein paar Wochen DSL, vorher hatte ich ein 56k modem, und mit der interneteinwahl hat alles funktioniert. Wenn ich disconnected wurde, wurde ich automatisch wieder eingewählt.
Seit ich DSL habe, funktioniert das aber nicht mehr, und ich kann mir einfach nicht erklären warum.

Hier ein Auszug aus meiner ppp.log:

Code:
Aug 21 14:31:43 narf ppp[219]: tun0: Phase: deflink: his = PAP, mine = none
Aug 21 14:31:43 narf ppp[219]: tun0: Phase: Pap Output: [USERNAME] ********
Aug 21 14:31:43 narf ppp[219]: tun0: Phase: Pap Input: SUCCESS ()
Aug 21 14:31:43 narf ppp[219]: tun0: Phase: deflink: Already in NETWORK phase
Aug 21 14:31:43 narf ppp[219]: tun0: Phase: deflink: lcp -> open
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: open -> lcp
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: Received NGM_PPPOE_CLOSE
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: Device disconnected
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: Disconnected!
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: lcp -> logout
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: Disconnected!
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: logout -> hangup
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: Connect time: 120 secs: 423 octets in, 181 octets out
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: 115377 packets in, 108540 packets out
Aug 21 14:33:42 narf ppp[219]: tun0: Phase:  total 5 bytes/sec, peak 69 bytes/sec on Sat Aug 21 14:31:44 2004
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: hangup -> opening
Aug 21 14:33:42 narf ppp[219]: tun0: Phase: deflink: Enter pause (3) for redialing.
Aug 21 14:33:45 narf ppp[219]: tun0: Phase: deflink: Connected!
Aug 21 14:33:45 narf ppp[219]: tun0: Phase: deflink: opening -> dial
Aug 21 14:33:45 narf ppp[219]: tun0: Phase: deflink: dial -> carrier
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: Received NGM_PPPOE_ACNAME (hook "erx")
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: Received NGM_PPPOE_SESSIONID
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: Received NGM_PPPOE_SUCCESS
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: deflink: carrier -> login
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: deflink: login -> lcp
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: deflink: his = PAP, mine = none
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: Pap Output: [USERNAME] ********
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: Pap Input: SUCCESS ()
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: deflink: Already in NETWORK phase
Aug 21 14:33:46 narf ppp[219]: tun0: Phase: deflink: lcp -> open
Aug 21 14:34:51 narf ppp[219]: tun0: Phase: Received NGM_PPPOE_ACNAME (hook "erx")
Aug 21 14:34:51 narf ppp[219]: tun0: Phase: Received NGM_PPPOE_SESSIONID
Aug 21 14:34:51 narf ppp[219]: tun0: Phase: Received NGM_PPPOE_SUCCESS
Aug 21 14:34:51 narf ppp[219]: tun0: Phase: deflink: carrier -> login
Aug 21 14:34:51 narf ppp[219]: tun0: Phase: deflink: login -> lcp
Aug 21 14:34:51 narf ppp[219]: tun0: Phase: bundle: Authenticate
Aug 21 14:34:51 narf ppp[219]: tun0: Phase: deflink: his = PAP, mine = none
Aug 21 14:34:51 narf ppp[219]: tun0: Phase: Pap Output: [USERNAME] ********
Aug 21 14:34:52 narf ppp[219]: tun0: Phase: Pap Input: SUCCESS ()
Aug 21 14:34:52 narf ppp[219]: tun0: Phase: deflink: lcp -> open
Aug 21 14:34:52 narf ppp[219]: tun0: Phase: bundle: Network

Dort hatte ich einen disconnect, danach ging das mit der automatischen einwahl wieder nicht, danach wählte ich mich dann "manuell" ein.
[USERNAME] steht natürlich für den richtigen Usernamen.

Meine ppp.conf:
Code:
default:
 #PPPoE
 set device PPPoE:bge0
 set speed sync
 set mru 1492
 set mtu 1492
 set ctsrts off
 enable lqr
 set log phase tun
 set ifaddr 10.0.0.1/0 10.0.0.2/0 0.0.0.0 0.0.0.0
 add default HISADDR
 enable dns
 set authname [USERNAME]
 set authkey [PASSWORT]
Wobei [USERNAME] und [PASSWORT] natürlich wieder den richtigen Angaben entsprechen ;)

Hier dann noch das Stück meiner rc.conf, welches für das wählen der pppoe verbindung zustängid ist:
Code:
ppp_enable="YES"
ppp_mode="ddial"
ppp_nat="YES"
ppp_profile="default"

Ich hoffe jemand weiß woran es liegen kann.
Direkte Einwahl nach dem disconnect ist laut Angaben des Providers problemlos möglich.
 

Styx

Universaldilettant
Bei mir lief DSL mit dieser ppp.conf und ddial immer einwandfrei:

Code:
default:
 set device PPPoE:interface
 set MTU 1492 
 set MRU 1492
 set dial
 set crtscts off
 set speed sync
 accept lqr
 disable deflate
 disable pred1
 disable vjcomp
 disable acfcomp
 disable protocomp
 set log Phase LCP IPCP CCP Warning Error Alert
 set ifaddr 10.0.0.1/0 10.0.0.2/0 0.0.0.0 0.0.0.0 
 add default HISADDR
 set login
 set authname "Benutzernamen" 
 set authkey "Passwort"
 enable dns

Grüße
Styx
 

suicide

Trucker Horst
Könnte eventuell am fehlenden "set dial" und "set login" gelegen haben, ich habe beides jetzt mal mit reingeschrieben.
Nun werde ich mal den nächsten disconnect abwarten.

Würde mich dann bloß wundern warum ppp einmal eine Verbindung herstellt, aber kein zweites mal.
 

suicide

Trucker Horst
So, eben hatte ich wieder eine Unterbrechnung, und es passiert immernoch das selbe, ich komme danach nicht mehr in's internet.

Hat sonst noch jemand irgendwelche ideen?
 

Styx

Universaldilettant
Hast Du schonmal überlegt, ob es ein technischer defekt ist? Vielelicht ist die Netzwerkkarte kaputt oder das DSL-Modem macht Schwierigkeiten. Es muss ja nicht immer eine falsche Einstellung sein.
 

suicide

Trucker Horst
Da es zum Beispiel unter Windows funktioniert, und die Hardware ja auch sonst wunderbar ihren Dienst erledigt gehe ich nicht von einem Defekt aus.
 

Lokadamus

Active Member
mmm...

Code:
default:
 set log Phase Chat LCP IPCP CCP tun command
 ident user-ppp VERSION (built COMPILATIONDATE)
# set device /dev/cuaa1
 enable dns				# request DNS info (for resolv.conf)

arcor:
 set device PPPoE:rl0
 set authname [Name]
 set authkey [Passwort]
 set dial
 set login

 set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
 add default HISADDR			# Add a (sticky) default route
Das ist meine ppp.conf, leg eine Sicherungskopie von deiner ppp.conf an und schmeiss dann mal die ganzen anderen Sachen raus, so dass du nur noch das hast, was ich auch habe. Frag mich nicht, wie es mit der Reihenfolge der einzelnen Befehle aussieht, meins funzt prima. Wenn du einen guten Provider hast, handeln sie gegenseitig aus, was sie brauchen ... wie beendet man eigentlich die Verbindung :confused: bisher hab ich einfach die PID gekillt und gut wars, aber das wird wohl nicht die Lösung gewesen sein, oder?
 
Zuletzt bearbeitet:
P

p.h.

Guest
Lokadamus schrieb:
Wenn du einen guten Provider hast
Mist, ich bin bei T-Offline. Na egal :)
Lokadamus schrieb:
wie beendet man eigentlich die Verbindung :confused: bisher hab ich einfach die PID gekillt und gut wars, aber das wird wohl nicht die Lösung gewesen sein, oder?
Naja, man kann natürlich per pppctl ein "quit" schicken, so man denn unbedingt will. Laut ppp(8) sind HUP, TERM & QUIT aber ebenso zum Beenden einer Verbindung gedacht. Außerdem gibt es noch INT, mit dem man die Verbindung auflegen kann. -ddial wird dann sofort eine neue aufbauen, -auto erst bei der nächsten Aufforderung. In allen anderen Modi verhält sich INT genau wie HUP, TERM & QUIT und beendet ebenfalls den PPP.
 

Lokadamus

Active Member
p.h. schrieb:
Mist, ich bin bei T-Offline. Na egal :)
mmm...

Nimm trotzdem mal meine, pass sie für dein Device an, werf Arcor raus und trag dort als Bezeichnung Terrorkom ein => "ppp -ddial terrorkom" und schau dann mal, was passiert. Vielleicht handeln sie dann ebenfalls alles aus, was relevant ist, ansonsten kann man im Logfile nachgucken, was nicht geklappt hat ...
 
P

p.h.

Guest
Danke, aber bei mir klappt alles wunderbar. Mein Abschnitt heißt übrigens "DSL", weil ich auch noch ein Modem-Fallback über T-Online drin habe.
 

dimi

Well-Known Member
so viel braucht man doch garnicht ... ( Tiscali DSL ) :

bsd# cat /etc/ppp/ppp.conf
default:
set device PPPoE:fxp0
set MTU 1492
set MRU 1492
set dial
set crtscts off
set speed sync
accept lqr
disable deflate
disable pred1
disable vjcomp
disable acfcomp
disable protocomp
enable dns
add default HISADDR
set login
set authname loginname@tiscali.de
set authkey password
bsd#
 

suicide

Trucker Horst
Ist zwar schon ein bisschen her, aber ich wollte dann doch noch mal Feedback geben, falls vielleicht in Zukunft jemand das selbe Problem haben sollte.

Leider konnte mir keine der hier angegebenen ppp.conf's helfen, aber ich umgehe das auftretende Problem jetzt indem ich ppp statt der ddial option einfach auto mitgebe.
Ist zwar nicht das selbe, funktioniert aber wunderbar (da sowieso die ganze Zeit ein IRC client läuft, der sich nach einem disconnect versucht wieder zu verbinden.).

Danke trotzdem an alle die versucht haben zu helfen.
 
Oben