Deutschschweizer Tastatur für IBM Thinkpad

muge

Active Member
Hallo

Ich kriege bei meiner FreeBSD 7.1 Installation einfach keine richtige Deutschschweizer Tastatur zum laufen. Die Umlaute fehlen alle (und noch einige andere Zeichen).

Ich habe mit sysinstall alle drei varianten versucht, alle mit demselben ergebniss.

kann mir da jemand helfen?

Die Installation ist sehr jung, 1 Tag, sonst ist nur noch X am laufen (habe das tastenproblem eigentlich erst unter X bemerkt)
 

Kamikaze

Warrior of Sunlight
Das Problem ist, dass X seine eigenen Tastatureinstellungen hat.

Führe mal:
# setxkbmap -layout ch

aus. Wenn das hilft musst du nur die Tastatureinstellung in deiner xorg.conf anpassen.
 

mousaka

getting older
Ich habe bei mir folgende Einstellungen in der xorg (keyboard section):
Code:
Option    "XkbModel"      "pc105"
Option    "XkbLayout"     "ch"
Option    "XkbRules"      "xorg"
Option    "XkbVariant"    "de_nodeadkeys"
Insbesondere die letzte Zeile war für die Sonderzeichen (z.B. @) entscheidend.

mousaka
 
Oben