• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

DVD Laufwerk geht nicht mehr

Lance

Well-Known Member
Themenstarter #1
Moin,

wie einige in meinem anderen Thread gelesen hatten, habe ich Probleme mit meinem DVD Laufwerk. Es taucht beim einlegen eines Rohlings (CD/DVD alles versucht) sowie einer normalen DVD nicht auf.

Wie immer unter einem Ubuntu das ich vom Stick gebootet hatte versucht, da klappt es und da kommt auch keine Fehlermeldung von dmesg! Ich bin daher der Meinung dass es kein Hardware Fehler ist, wenn es unter anderen Betriebssystemen funktioniert!

Aber trotzdem poste ich hier mal den Fehler, vielleicht weiss ja jemand was das sein könnte. In den anderen BSD Foren scheints bei denen die Hardware zu sein. Bzw hier hat einer im Prinzip das gleiche, aber leider offener Ausgang. (https://forums.freebsd.org/threads/700mb-cdrom-errors.58564/)

Code:
grep cd0
ses0: cd0,pass1 in 'Slot 01', SATA Slot: scbus1 target 0
cd0 at ahcich1 bus 0 scbus1 target 0 lun 0
cd0: <HL-DT-ST DVDRAM GU40N QX21> Removable CD-ROM SCSI device
cd0: Serial Number M42BC352157
cd0: 150.000MB/s transfers (SATA 1.x, UDMA6, ATAPI 12bytes, PIO 8192bytes)
cd0: 0MB (1 2048 byte sectors)
(cd0:ahcich1:0:0:0): READ(10). CDB: 28 00 00 00 00 00 00 00 01 00
(cd0:ahcich1:0:0:0): CAM status: SCSI Status Error
(cd0:ahcich1:0:0:0): SCSI status: Check Condition
(cd0:ahcich1:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal mode for this track)
(cd0:ahcich1:0:0:0): Error 6, Unretryable error
(cd0:ahcich1:0:0:0): cddone: got error 0x6 back
 

Lance

Well-Known Member
Themenstarter #2
So Leute, einen kleinen Hardware Fehler kann ich 1000% ausschliessen!

Habe mein Firmennotebook aktualisiert, gleicher Fehler! (gestern gings noch)
 

Columbo0815

Kaffeemann
Mitarbeiter
#3
Moin,

ich finde es sehr schwierig deinem Anliegen zu folgen. Geht es jetzt um GhostBSD (siehe "anderer Thread", vielleicht würde es Sinn machen, den hier zu verlinken) oder um FreeBSD (du verlinkst schließlich auf forums.freebsd.org)?
wie einige in meinem anderen Thread gelesen hatten, habe ich Probleme mit meinem DVD Laufwerk. Es taucht beim einlegen eines Rohlings (CD/DVD alles versucht) sowie einer normalen DVD nicht auf.
Was taucht nicht auf? Das Problem?

Dann sprichst du von einer Aktualisierung deines Firmennotebooks. Von was auf was hast du aktualisiert? Vielleicht finden wir ja Änderungen im Changelog/github/dergl., die dazu führen, dass dein DVD-Laufwerk nicht mehr funktioniert.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#5
Ich hatte letzt ähnliche Probleme mit einer gemischten Data/Audio CD (Die Siedler 2).
Kann es sein, dass die CD falsch herum ist? Also CD-Audio vorne, und Daten hinten. Meist hatte man ja das Gegenteil... Das würde auch das cd0: 0MB (1 2048 byte sectors) in Verbindung mit (cd0:ahcich1:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal mode for this track) erklären. CD-Audio Tracks sind halt keine Datentracks und müssen anders angesprochen werden.
 

Lance

Well-Known Member
Themenstarter #6
ich finde es sehr schwierig deinem Anliegen zu folgen.
Tut mir leid.

Da GhostBSD auf FreeBSD und nicht auf OpenBSD oder NetBSD basiert, mische ich das hier gelegentlich etwas. Sorry.

Was taucht nicht auf? Das Problem?
Laufwerk taucht nicht auf dem Desktop auf und ich kann auch nicht brennen, da angeblich kein geeignetes Medium vorhanden ist. Egal ob Rohling oder DVD oder Software Kauf-DVD / DVD mit reinen Datentracks. Dazu habe ich doch den Output von dmesg gepostet.

Ich habe einmal GhostBSD neu installiert auf dem einen auf dem anderen aktualisiert.
 

Kamikaze

Warrior of Sunlight
#7
Kann es sein, dass die CD falsch herum ist? Also CD-Audio vorne, und Daten hinten. Meist hatte man ja das Gegenteil... Das würde auch das cd0: 0MB (1 2048 byte sectors) in Verbindung mit (cd0:ahcich1:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal mode for this track) erklären. CD-Audio Tracks sind halt keine Datentracks und müssen anders angesprochen werden.
Bei mir definitiv nicht. Track 1 sind die Daten. Ich muss nochmal sehen ob ich das reproduzieren kann.
 

Kamikaze

Warrior of Sunlight
#8
Ich schließe das Laufwerk an, so weit alles normal:

Code:
ugen1.6: <Verbatim Verbatim 4K BD RW> at usbus1
umass0 on uhub0
umass0: <Verbatim Verbatim 4K BD RW, class 0/0, rev 3.10/1.cd, addr 12> on usbus1
umass0:  SCSI over Bulk-Only; quirks = 0x0100
umass0:0:0: Attached to scbus0
cd0 at umass-sim0 bus 0 scbus0 target 0 lun 0
cd0: <PIONEER BD-RW   BDR-UD04 1.11> Removable CD-ROM SCSI device
cd0: 400.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
cd0: quirks=0x10<10_BYTE_ONLY>
Ich lege die CD ein:

Code:
(cd0:umass-sim0:0:0:0): READ(10). CDB: 28 00 00 04 00 89 00 00 01 00
(cd0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(cd0:umass-sim0:0:0:0): SCSI status: Check Condition
(cd0:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal mode for this track)
(cd0:umass-sim0:0:0:0): Info: 0x40089
(cd0:umass-sim0:0:0:0): Error 6, Unretryable error
(cd0:umass-sim0:0:0:0): cddone: got error 0x6 back
Die Nachricht wiederholt sich viele male, könnte am automounter liegen.

Das /dev/cd0 Device existiert aber.
Mounten und lesen kann ich auch.
# cdcontrol info
Code:
Starting track = 1, ending track = 9, TOC size = 82 bytes
track     start  duration   block  length   type
-------------------------------------------------
    1   0:02.00  30:41.47       0  138122   data
    2  30:43.47   2:35.67  138122   11692  audio
    3  33:19.39   2:59.03  149814   13428  audio
    4  36:18.42   2:54.39  163242   13089  audio
    5  39:13.06   2:53.53  176331   13028  audio
    6  42:06.59   3:44.17  189359   16817  audio
    7  45:51.01   7:23.15  206176   33240  audio
    8  53:14.16   2:08.67  239416    9667  audio
    9  55:23.08   2:55.74  249083   13199  audio
  170  58:19.07         -  262282       -      -
Das sieht alles gut aus.

# cdcontrol play 2
Code:
cdcontrol: Device not configured
Das funktioniert leider nicht. Aber das Laufwerk bietet sich auch nicht per USB als Audio-Quelle an.. Eine direkte Leitung zur Sound Karte gibt es per USB natürlich nicht. Also kein Überraschung.

Aber die Daten sollte ich trotzdem abgreifen können. Ich habe k3b mit sysutils/bsdisks (statt hald) eingerichtet.

k3b zeigt mir das Device an, allerdings:
Code:
No medium information

Type:             Unknown (probably CD-ROM)
Capacity:         00:00:00 min (0 B)
Used Capacity:    00:00:00 min (0 B)
Remaining:        00:00:00 min (0 B)
Rewritable:       no
Appendable:       no
Empty:            no
Layers:           1
Sessions:         0
Schon mal nicht gut. Mit k3b taucht das hier immer wieder im dmesg auf (k3b scheint zu pollen):
Code:
(cd0:umass-sim0:0:0:0): READ(10). CDB: 28 00 00 04 00 89 00 00 01 00
(cd0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(cd0:umass-sim0:0:0:0): SCSI status: Check Condition
(cd0:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal mode for this track)
(cd0:umass-sim0:0:0:0): Info: 0x40089
(cd0:umass-sim0:0:0:0): Error 6, Unretryable error
(cd0:umass-sim0:0:0:0): cddone: got error 0x6 back
Ich schätze die SCSI Commands auf die Audio Tracks gehen schief. Nach einer Weile ändert sich die Anzeige in k3b auf "No medium present". Dann kann ich cd0 auch nicht mehr mounten. Das bleibt auch so, wenn ich k3b schließe.
 

Lance

Well-Known Member
Themenstarter #9
Problem scheint behoben mit einem automount Update da bei GhostBSD von gnome-mount /hald nach sysutils/automount / devd gewechselt wurde. :)

Das Firmennotebook geht jedenfalls wieder damit !

Kann mir aber nicht verkneifen dass man auch gerne mal testen darf bevor man Änderungen macht, möchte hier kein Betatester sein ;)