dvd::rip streikt

qfat

Well-Known Member
hy,
habe mir grad dvd::rip aus den ports gezogen und wollte gleich loslegen,
doch wenn ich "READ DVD table of contents" drücke (was zum rippen notwendig ist ;))
kommt immer:

Code:
Job 'Determine number of titles' failed.

Executed command: dr_exec tcprobe -H 10 -i /dev/acd0 && DVDRIP_SUCCESS

Last output was:


[fileinfo.c:118] file read error: Invalid argument
[tcprobe] unknown file type
[tcprobe] filetype/codec not yet supported by 'transcode'

was ist passiert?
habe es schon als root probiert und dasselbe ergebnis. :confused:
die dvd ist in ordnung, da ich sie mir ansehen kann.

info:
fbsd 5.2.1p1
transcode v0.6.12 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg
dvd::rip v. 0.50.16

thx

thx
 

Marco

Well-Known Member
Hi

Ich tippe auf einen nicht so einfachen Schreibschutz der DVD. Probiere es mal mit einer anderen die garantiert nicht schreibgeschützt ist.
 

qfat

Well-Known Member
naja ok werds probieren aber wäre dann ja nur ne notlösung.
schließlich saugt man sich keine gui um dann inner schell zu arbeiten ;)
 

qfat

Well-Known Member
ok es geht auch mit gui!
obwohl tcprobe auch nen device annehmen sollte gehts nur mit mountpoint.
aber es geht
 

qfat

Well-Known Member
*heul*
jetzt bleibt er später beim encoden stehen und sagt:

Code:
Job 'Transcoding video - title #1, pass 1' failed.

Executed command: mkdir -m 0775 -p '/usr/home/qfat/div/burn/dvd_database/iceage/tmp' && cd /usr/home/qfat/div/burn/dvd_database/iceage/tmp && dr_exec transcode -H 10 -a 1 -x vob,null -i /usr/home/qfat/div/burn/dvd_database/iceage/vob/001 -w 1111 -b 128,0,0 -s 1.339 --a52_drc_off -V  -f 25 -Y 12,0,12,0 -B 27,10,8 -R 1 -y xvid2,null -o /dev/null --print_status 20 && echo DVDRIP_SUCCESS 

Last output was:


transcode v0.6.12 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Couldn't find device name.
libdvdread: Can't open file VIDEO_TS.IFO.
[import_null.so] v0.2.0 (2002-01-19) (video) null | (audio) null
[import_vob.so] v0.6.0 (2003-10-02) (video) MPEG-2 | (audio) MPEG/AC3/PCM | (subtitle)
[export_null.so] v0.1.2 (2001-08-17) (video) null | (audio) null
[export_xvid2.so] v0.3.10 (2003-07-30) (video) XviD 0.9.x (aka API 2.1 series)  | (audio) MPEG/AC3/PCM
Cannot open "/usr/local/lib/transcode/libxvidcore.so.2"Failed to init XviD codec[transcode] warning : (encoder.c) video export module error: init failed
[transcode] (probe) suggested AV correction -D 2 (80 ms) | AV 80 ms | 0 ms
[transcode] auto-probing source /usr/home/qfat/div/burn/dvd_database/iceage/vob/001 (ok)
[transcode] V: import format    | MPEG-2  (V=vob|A=null)
[transcode] V: AV demux/sync    | (1) sync AV at initial MPEG sequence
[transcode] V: import frame     | 720x576  1.25:1  encoded @ 16:9
[transcode] V: new aspect ratio | 640x360  1.78:1 (-B)
[transcode] V: clip frame (->)  | 640x336
[transcode] V: bits/pixel       | 0.207
[transcode] V: decoding fps,frc | 25.000,0
[transcode] V: multi-pass       | (mode=1) writing data (pass 1) to divx4.log
[transcode] V: Y'CbCr           | YV12/I420
[transcode] A: import format    | 0x2000  AC3          [48000,16,2]  384 kbps
[transcode] A: export           | disabled
[transcode] V: encoding fps,frc | 25.000,3
[transcode] A: bytes per frame  | 7680 (7680.000000)
[transcode] A: adjustment       | 0@1000
[transcode] A: rescale stream   | 1.339
[transcode] V: IA32 accel mode  | 3dnow (3dnow mmxext mmx asm)
[transcode] V: video buffer     | 10 @ 720x576
[import_vob.so] tccat -i "/usr/home/qfat/div/burn/dvd_database/iceage/vob/001" -t vob -d 0 -S 0 | tcdemux -s 0x81 -x mpeg2 -S 0 -M 1 -d 0 | tcextract -t vob -a 0 -x mpeg2 -d 0 | tcdecode -x mpeg2 -d 0 -y yv12
[transcode] critical: failed to init encoder

habe schon xvid aus den ports installiert aber immer noch die meldung!
 

[moR-pH-euS]

Magnum P.I.
Cannot open "/usr/local/lib/transcode/libxvidcore.so.2"Failed to init XviD codec[transcode]

ist die libxvidcore.so.2 auch bei dir vorhanden unter dem pfad ? bzw. such mal mit find nach der datei...
 

Illuminatus

in geheimer Mission
zuerst muss xvid installiert sein, wenn im Anschluss daran transcode neu gebaut wird wird auch ein Ein/Ausgabemodul für xvid generiert.
Später sollte man noch eine ~/.xvid.cfg Datei haben. Diese liegt auch in /usr/local/lib/transcode als Beispiel vor (xvid*.cfg). Editiere diese im Abschnitt
Code:
[quality5]
init.cpu_flags = XVID_CPU_SSE2
Dies bringt auf P4 CPUs etwas mehr Performance. Ausserdem solltest du
im Register "Transcode" von dvd::rip bei "transcode Options"
Code:
--accel sse2 -Q 5,5
einfügen wenn es etwas schneller und schöner aussehen soll.
 

qfat

Well-Known Member
ich komme immer weiter danke illuminatus!
aber jetzt bleibe ich hier hängen:

Code:
Job 'Transcoding video - title #1, pass 1' failed.

Executed command: mkdir -m 0775 -p '/usr/home/qfat/div/burn/dvd_database/iceage/tmp' && cd /usr/home/qfat/div/burn/dvd_database/iceage/tmp && dr_exec  transcode -b 128,0,0 -f 25 -H 10 -i /usr/home/qfat/div/burn/dvd_database/iceage/vob/001 --accel sse2 -o /dev/null -Q 5,5 -R 1 --a52_drc_off -s 1.339 -V --print_status 20 -w 1111 -x vob,null -Y 12,0,12,0 -y xvid2,null -a 1 -B 27,10,8 && echo DVDRIP_SUCCESS 

Last output was:


transcode v0.6.12 (C) 2001-2003 Thomas Oestreich, 2003-2004 T. Bitterberg
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Couldn't find device name.
libdvdread: Can't open file VIDEO_TS.IFO.
[import_null.so] v0.2.0 (2002-01-19) (video) null | (audio) null
[import_vob.so] v0.6.0 (2003-10-02) (video) MPEG-2 | (audio) MPEG/AC3/PCM | (subtitle)
[export_null.so] v0.1.2 (2001-08-17) (video) null | (audio) null
[export_xvid2.so] v0.3.10 (2003-07-30) (video) XviD 0.9.x (aka API 2.1 series)  | (audio) MPEG/AC3/PCM
Illegal instruction (core dumped)
 
Oben