Ekiga erkennt mein Mikrophon nicht

drm

Well-Known Member
Hi,

da Skype ja nun von Microsoft gekauft wird und es auf OpenBSD (ich nutze 4.9) nur mit dem Linuxemulator läuft, wollte ich mal Ekiga probieren.

Hab mir also Version 3.2.7 als Paket installiert und mich angemeldet, soweit ging alles problemlos. Wenn ich den Testanruf starte, bekomme ich folgende Fehlermeldung:

Code:
Error while opening audio input device default

Only silence will be transmitted.

Unable to open the selected audio device for recording. In case it is a pluggable device it may be sufficient to reconnect it. If not, or if it still is not accessible, please check your audio setup, the permissions and that the device is not busy.

Auf der Kommandozeile erscheint dann die Meldung, und zwar mit allen verfügbaren Sound-devices:

Code:
sio_open failed


Das Mikro funktioniert aber, ich kann meine Stimme aufnehmen und abhören:

Code:
$ aucat -o myvoice.wav                                        
^C
$ aucat -i myvoice.wav

Hab zur Fehlermeldung per Google nichts gefunden, hat hier vielleicht jemand ne Idee?

Mixerctl:

Code:
$ mixerctl -a                                                                                                                                                                                                    
outputs.master=255,255
outputs.master.mute=off
outputs.mono=255
outputs.mono.mute=on
outputs.mono.source=mixerout
outputs.hp=255,255
outputs.hp.mute=off
inputs.spkr=255
inputs.spkr.mute=off
inputs.phone=191
inputs.phone.mute=on
inputs.mic=255
inputs.mic.mute=off
inputs.mic.preamp=on
inputs.mic.source=mic0
inputs.line=191,191
inputs.line.mute=on
inputs.cd=191,191
inputs.cd.mute=on
inputs.video=255,255
inputs.video.mute=off
inputs.aux=191,191
inputs.aux.mute=on
inputs.dac=191,191
inputs.dac.mute=off
record.source=mic
record.volume=255,255
record.volume.mute=off
outputs.extamp=off
outputs.spdif=off

Viele Grüße,
drm
 
Zuletzt bearbeitet:

Athaba

Libellenliebhaber
Du weisst schon, dass es ohnehin kaum möglich ist Skype noch böser zu machen? ;)
Ich kann dir zwar bei deinem konkreten Problem nicht helfen, wollte aber anmerken, dass Jitsi generell recht gute Erfahrungen gemacht habe.
 

Tronar

aus Überzeugung altmodisch
Hab mir also Version 3.2.7 als Paket installiert und mich angemeldet, soweit ging alles problemlos. Wenn ich den Testanruf starte, bekomme ich folgende Fehlermeldung:
Code:
Error while opening audio input device default
Das Mikro funktioniert aber, ich kann meine Stimme aufnehmen und abhören:
Ich habe ein ähnliches Problem mit der Sound-Ausgabe. Wenn ich "einfach so" Ekiga starte, bleibt es stumm. Es findet die /dev-Dateien nicht. Irgendwie sind manche Programme nicht zur Zusammenarbeit mit dem DEVFS zu bewegen, d. h. das System kann nicht überzeugt werden, die angeforderten Devices bereitzustellen. Was ich mache, ist ganz einfach: Ich starte ein anderes Sound-Programm, in meinem Fall so etwas wie »play nix.wav«, in Deinem Fall wohl aucat. Dann sind die Device nodes da, und erst dann starte ich Ekiga. Dann geht alles.

@Athaba: Benötigt Jitsi den Linux-Emulator?

EDIT: Sorry, habe übersehen, daß dies eine OpenBSD-Gruppe ist. Was ich sagte, gilt erst mal nur für FreeBSD. Vielleicht hilft's trotzdem.
 
Zuletzt bearbeitet:
Oben