• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

failover Netzwerkkonfiguration schlägt fehl

holgerw

Well-Known Member
Themenstarter #1
Hallo,

ich beziehe mich auf folgendes HowTo:
http://www.denkrobat.de/doku.php?id=failover_netzwerk-konfiguration
System: FreeBSD 11 stable
Name des Ethernet-Devices: em0
Ether: 11:22:33:44:55:66 (Beispiel)
Name des Wlan-Devices: ath0

Eine korrekt eingerichtete wpa_supplicant.conf ist vorhanden.

Einträge in der /etc/rc.conf:

Code:
ifconfig_em0="up"
cloned_interfaces="lagg0"
wlans_ath0="wlan0"
ifconfig_wlan0="WPA"
create_args_wlan0="wlanaddr 11:22:33:44:55:66 country DE regdomain ETSI"
ifconfig_lagg0="laggproto failover laggport em0 laggport wlan0 DHCP"
Am Netzwerkkabel in unserem Heimnetz wird die Verbindung ordentlich aufgebaut.

Aber über meinen Hotspot vom Smartphone haben alle Devices "... no carrier" und ich habe kein Internet.

Mit der gewöhnlichen Wlan-Konfiguration klappt es hingegen, über den Hotspot eine Verbindung zu beziehen:
Code:
wlans_ath0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"
Wo ist in der lagg-Device Konfiguration ein Fehler?

Viele Grüße,
Holger
 

Vril

Well-Known Member
#2
Code:
ifconfig_lagg0="laggproto failover laggport em0 laggport wlan0 DHCP
ifconfig_wlan0=WPA SYNCDHCP "
der Untrerschied zwischen DHCP und SYNDHCP besteht darin, dass bei SYNCDHCP auf langsame
Router gewartet wird, bis die ne IP schicken.

gerade Smartphones brauchen da schon'mal sehr lange...
 

Kamikaze

Warrior of Sunlight
Mitarbeiter
#3
Das funktioniert mit FreeBSD 11 nicht mehr. Sobald IPv6 Adressen aufs lagg Device kommen gibt es eine Panic.

Um so weit zu kommen, create_args_wlan0 sollte alles in ifconfig wlan0 stehen. Wlanaddr heißt ether und es fehlt das up.
 

holgerw

Well-Known Member
Themenstarter #4
Hallo,

der Untrerschied zwischen DHCP und SYNDHCP besteht darin, dass bei SYNCDHCP auf langsame
Router gewartet wird, bis die ne IP schicken.

gerade Smartphones brauchen da schon'mal sehr lange...
Walter, danke, das sorgt schonmal dafür, dass das System nun länger versucht, eine IP von dem Smartphone zu beziehen.

Das funktioniert mit FreeBSD 11 nicht mehr. Sobald IPv6 Adressen aufs lagg Device kommen gibt es eine Panic.

Um so weit zu kommen, create_args_wlan0 sollte alles in ifconfig wlan0 stehen. Wlanaddr heißt ether und es fehlt das up.
Oh, hatte ich es doch vermutet, ich kann mich dunkel an eine Diskussion vor Monaten erinneren, da ging es auch um Wlan und lagg, und darum, dass mit FreeBSD 11 da irgendwas anders ist, als noch mit FreeBSD 10.3.
Kannst Du mir das mal bezogen auf meine konkrete Situation erläutern? Bedenke bitte, dass so etwas für mich Neuland ist und Du vielleicht bei mir Sachen voraussetzt, die ich noch nicht genau weiß. Ich habe schon dermaßen viel herum probiert mit diversen Modifikationen. Ist das so korrekt?
Code:
ifconfig_em0="up"
cloned_interfaces="lagg0"
wlans_ath0="wlan0"
ifconfig_wlan0="up"
ifconfig_wlan0="WPA SYNCDHCP"
create_args_wlan0="ether 11:22:33:44:55:66 country DE regdomain ETSI"
ifconfig_lagg0="laggproto failover laggport em0 laggport wlan0 DHCP"
Viele Grüße,
Holger
 
#7
Was soll das machen? Du meinst ifconfig_wlan0.
Laut Manpage ist das korrekt für wlans:
If a wlans_<interface> variable is set, an wlan(4) interface
will be created for each item in the list with the wlandev
argument set to interface. Further wlan cloning arguments
may be passed to the ifconfig(8) create command by setting
the create_args_<interface> variable. One or more wlan(4)
devices must be created for each wireless devices as of
FreeBSD 8.0.
Rob
 

holgerw

Well-Known Member
Themenstarter #9
Hallo,

danke für Eure Hilfsbereitschaft.

Hast du es mal offizieller Anleitung versucht?
Ja, bin aber nicht sehr weit gekommen - ich weiß ja noch nicht einmal, ob die offizielle Anleitung überhaupt noch für FreeBSD 11 zutrifft.

Wow, das habe ich noch nie gesehen. Jetzt frage ich mich natürlich wofür das gut ist.
FreeBSD ist schon ziemlich spannend :)

Und da bleibe ich nun dran, ich möchte, das das auf meinem Notebook läuft, und zwar mit dem aktuellen FreeBSD stable.

Viele Grüße,
Holger
 

Rakor

Administrator
Mitarbeiter
#10
Ahoi, ich hab nochmal nachgesehen. Auf meinem Thinkpad mit FreeBSD 11 habe ich folgende Konfiguration am Laufen (und funktioniert). Ich habe allerdings ein v4-Only-System.

Code:
ifconfig_em0="up"
cloned_interfaces="lagg0"
wlans_wpi0="wlan0"
ifconfig_wlan0="WPA"
create_args_wlan0="wlanaddr AA:BB:CC:DD:EE:FF country DE regdomain ETSI"
ifconfig_lagg0="laggproto failover laggport em0 laggport wlan0 DHCP"
 
#11
Sobald die MAC eines Wireless-Adapters auf FreeBSD modifiziert wird, geht alles den Bach runter und es funktioniert nichts mehr. Der Fehler ist bekannt seit mehreren Jahren und keiner macht da was. Für Failover ändert man typischerweise die MAC.

Hier mein PR, der immer noch gilt: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=149516
Andere Leute: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=194857 https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=178986
Hier stehen am meisten Infos, vor allem von Adrian Chadd: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=213207
Deswegen hat hier jemand eine "tolle Idee" zum Workaround: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=148071
 

holgerw

Well-Known Member
Themenstarter #12
Hallo,

danke für Eure Hilfe.

Anhand der Bugreoorte von @nakal vermute ich mal, dass ich da erstmal nicht weiter komme, da ich einen Atheros-Wlanchip habe.

Das ist nicht schlimm, nun weiß ich wenigstens, warum die Anleitung von @Rakor bei ihm klappt (wip0) und bei mir nicht (ath0).

Den Würgarround, die Waln-MAC zu verwenden, werde ich in Ruhe mal testen.

Viele Grüße,
Holger
 

holgerw

Well-Known Member
Themenstarter #13
Korrekturen zu meinem vorigen Kommentar, sorry, das ist ja scheußlich beim Lesen:
Bugreorte / Bugreporte
wip0 / wpi0
Waln-MAC / wlan-MAC
 
#14
Ein Tipp noch. Bitte verschweigt nicht, dass Ihr Probleme mit Bugs hat. Bitte "me too"s an die passenden PRs dranhängen. Wenn ein PR erstmal als "Affects many" markiert wird, dann wird er schneller gelöst. Ich warte schon sehr lange auf einen Fix (über 6 Jahre!) und jetzt funktionieren nicht einmal Sachen aus dem Handbuch.