• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Fenstergröße von xterm konfigurieren

ralli

BSD Fanboy
Themenstarter #1
Ich benutze als Standardterminal xterm und wollte es mir individuell konfigurieren. Dazu habe ich mir im home Verzeichnis eine .Xdefaults angelegt mit folgendem Inhalt:

Code:
xterm*geometry: 640x480

XTerm*font:     10x20
XTerm*background:       LightYellow2
XTerm*foreground:       Black
XTerm.eightBitInput:    true
Xterm.eightBitOutput:   true
XTerm*multiScroll:      on
XTerm*jumpScroll:       on
XTerm*ScrollBar: on
XTerm*SaveLines: 30000
Xterm*rightScrollBar:   true

xterm*utf8: 1
Das hat auch (fast) alles funktioniert, allerdings reagiert er auf xterm*geometry: 640x480 überhaupt nicht. Ich möchte ein größeres xterm Window beim Starten als wie die standardmäßig eingestellte Grösse. Jetzt habe ich Tante Google befragt und im Forum gesucht, bin aber nicht fündig geworden und einer Lösung näher gekommen.
 

ralli

BSD Fanboy
Themenstarter #3
Danke Kamikaze, hat leider nicht funktioniert und nichts gebracht. Der Eintrag musste doch der .Xdefaults hinzugefügt werden?
 

ralli

BSD Fanboy
Themenstarter #4
Wenn ich in xterm die mittlere Maustaste drücke und aus dem Menu hide VT wIndow auswähle, dann kommt die von mir gewünschte Fenstergröße. Wie aber kann ich das dauerhaft einstellen? Hab mal
Code:
XTerm.VT100.hide:                       true
ausprobiert, funktioniert aber leider auch nicht.
 

ralli

BSD Fanboy
Themenstarter #5
Ach mein vorheriger Thread war natürlich Unsinn. Jetzt funktioniert es mit diesen Einträgen in der .Xdefaults. Ich habe dann ganz einfach das xterm Fenster auf die von mir gewünschte Grösse gezogen und fluxbox mitgeteilt, das es sich Fenstergröße und Fensterposition beim Schließen merken soll. Beim erneuten Start war dann alles so, wie ich es vorher eingestellt hatte.

Code:
 XTerm*background:       LightYellow2
 XTerm*foreground:       Black

 XTerm*scrollBar:                        false
 XTterm*utf8:                            2
 XTerm*termName:                         xterm-256color
 XTerm*faceName:                         xft:Dejavu Sans Mono:pixelsize=14

 ! http://invisible-island.net/xterm/xterm.faq.html#tiny_menus

 XTerm.VT100.geometry:                   120x50

 XTerm*saveLines:                        7777
 XTerm*metaSendsEscape:                  true
 XTerm*highlightSelection:               true
 XTerm*trimSelection:                    true
 XTerm*cutNewline:                       false
 XTerm*colorBDMode:                      true
 XTerm*colorBD:                          khaki
 XTerm*charClass: 3:48,35:48,37:48,43:48,45-47:48,64:48,95:48,126:48,35:48,58:48,63:48,61:48,44:48,38:48,59:48
 
 !colors
 !black
 XTerm*color0:                           #171717
 XTerm*color8:                           #737373
 !red
 XTerm*color1:                           #FF5E5E
 XTerm*color9:                           #FF7878
 !green
 XTerm*color2:                           #9CE82B
 XTerm*color10:                          #9ACD32
 !yellow
 XTerm*color3:                           #F0E68C
 XTerm*color11:                          #EEE8AA
 !blue
 XTerm*color4:                           #008AFF
 XTerm*color12:                          #4F98FF
 !magenta
 XTerm*color5:                           #E88CFF
 XTerm*color13:                          #EDA6FF
 !cyan
 XTerm*color6:                           #87CEFA
 XTerm*color14:                          #B0E2FF
 !white
 XTerm*color7:                           #DCDCCC
 XTerm*color15:                          #FFFFFF
Früher war das doch die .Xresources oder? Und bei freeBSD jetzt die .Xdefaults. Oder haben beide Dateien unterschiedliche Funktionen?
 
Gefällt mir: Neko

.not

Well-Known Member
#6
Die beiden Dateien haben die selbe Funktion, die Nutzung von .Xdefault ist allerdings was ich mich erinnern kann als Deprecated gekennzeichnet.
 

ralli

BSD Fanboy
Themenstarter #7
.not danke für den Tipp, ich hab es gerade umgestellt, aktualisiert und dann mit xrdb $HOME/.Xresources neu geladen.
 

ralli

BSD Fanboy
Themenstarter #8
Nachdem hier Yamagi und Kamikaze das rxvt-unicode Terminal favorisieren, habe ich auch kurzentschlossen dieses Terminal installiert.
 

ralli

BSD Fanboy
Themenstarter #9
Wenn ich das rxvt-unicode Terminal verlasse und später mal neu starte, sind die Befehle aus der vorherigen Sitzung verschwunden. Es wird also keine history gespeichert. Irgendwie ist hier noch was nicht richtig. Im Augenblick benutze ich nur eine minimalistische .Xresorces Datei mit folgendem Inhalt:
Code:
URxvt*foreground:       Black
URxvt*background:       LightYellow2

URxvt*font:             xft:Dejavu Sans Mono:pixelsize=14

URxvt*boldFont:         xft:Dejavu Sans Mono:pixelsize=14

URxvt.saveLines: 10000
Fehlt noch was Wichtiges für den grundsätzlichen Produktiveinsatz? Dann lasst es mich bitte wissen, ich bin ja noch am Lernen und setze Eure Erfahrungen und Empfehlungen gerne um.

Muss ich jetzt noch urxvt zum Standardterminal für freeBSD machen?

Entschuldigt bitte, das ich Euch mit solch banalen Dingen nerve, aber ich habe im Netz wirklich nichts dazu gefunden.
 

Kamikaze

Warrior of Sunlight
Mitarbeiter
#10
Die History ist Sache der Shell, nicht des Terminals.

Meine Optionen:
Code:
URxvt.depth:		32
URxvt.background:	rgba:0000/0000/0000/D000
URxvt.foreground:	#FFFFFF
URxvt.font:		xft:monospace:size=7.5
URxvt.scrollBar:	false
URxvt.saveLines:	65535
URxvt.geometry:		80x25


URxvt.skipScroll:	true
URxvt.pastableTabs:	true
URxvt.perl-ext-common:	default,-selection-popup,-option-popup
 

ralli

BSD Fanboy
Themenstarter #11
Danke Kamikaze. Jetzt habe ich recherchiert, aber nichts gefunden, wie die history für shells eingerichtet wird. Wenn ich mich mit urxvt mit su - als root einlogge, dann funktioniert ja die history. Dafür funktionieren Umlaute nicht oder die Entfernen Taste sowie die Backspace taste zicken. Ja, ich muss noch einiges Lernen.:)
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#12
Beim Einrichten der Shell kommt es natürlich darauf an, welche Shell du nutzt. Unter FreeBSD hat man oft (aber natürlich nicht immer) die "tcsh" als interaktive Shell. Meine Konfigurationsdatei dafür findet sich hier: https://github.com/Yamagi/dotfiles/blob/master/tcsh/tcshrc Vielleicht findet der eine oder andere darin einige schöne Dinge, die er sich abschreiben möchte. :) Dazu kommt noch ~/.login: https://github.com/Yamagi/dotfiles/blob/master/tcsh/login und ~/.logout: https://github.com/Yamagi/dotfiles/blob/master/tcsh/logout
 

Tronar

aus Überzeugung altmodisch
#14
Noch ein paar Bemerkungen zum Xterm, auch wenn Du inzwischen Rxvt zu bevorzugen scheinst:
Die Geometrie solcher textbasierter Fenster wird meist nicht in Pixel, sondern in Buchstaben angegeben. Das hast Du wahrscheinlich, angesichts Deines letzten Wertes 120x50, gemerkt.
Xterm besteht aus zwei Fenstern, einem VT100- und einem Tektronix-Fenster, von denen aber immer nur eines angezeigt wird. Deshalb ist es ganz sinnvoll, die Ressourcen spezifisch anzugeben: XTerm.VT100.Geometry: 120x50
Der Unterschied zwischen Groß- und Kleinschreibung, auf den Kamikaze hinwies, ist der, daß xterm der Name des Xterm-Fensters und XTerm ein Klassenname ist, der von mehreren Anwendungen (IIRC auch Rxvt) oder mehreren Fenstern derselben Anwendung, falls vorhanden, benutzt wird. Er ist also allgemeingültiger.

Ach ja, die Ressourcendatei sollte .Xresources heißen. Eine .Xdefaults war ursprünglich nicht definiert, vielmehr sollte es in Netzwerken eine .Xdefaults-dings und .Xdefaults-bums geben, die verwendet werden, je nachdem, ob das Heimatverzeichnis vom Rechner dings oder bums gemountet wurde; das ist also der rechnerabhängige Teil der X-Ressourcen.
Die meisten X-Server sind heute aber insoweit idiotensicher, daß sie .Xresources und .Xdefaults beide aufrufen.

So, jetzt ist das Gewitter direkt über mir, und ich werde ganz schnell submitten, bevor die Kiste abraucht. :rolleyes:
 

Neko

Well-Known Member
#16
Hallo,

danke der Post ist zwar sehr alt, hilft mir aber sehr weiter hoffe. Das es nachher dann funktioniert mit der Schriftgröße.

Da ich aktuell nicht wirklich was auf dem Bildschirm lesen kann.

Gruß Simon
 

pit234a

Well-Known Member
#17
Also, bei URxvt mache ich keine Settings.
In OpenBox habe ich eine Konfiguration in der rc.xml, die mir ein Fenster mit gewünschter Größe liefert. Das ist auf meine Bedürfnisse abgepasst und außer der Größe stelle ich nichts ansonsten ein. Die Versuche, die ich nicht mehr nutze, habe ich aber mal stehen gelassen:
Code:
    <application name="urxvt">
      <!--<position force="yes">
		<x>center</x>
		<y>center</y>
		</position>-->
      <size>
        <width>1200</width>
        <height>500</height>
      </size>
      <!--<maximized>Horizontal</maximized>-->
    </application>
Die Applikation selbst rufe ich mit einem Tastenkürzel auf und dafür habe ich ebenfalls einen Satz in der rc.xml:
Code:
    <keybind key="W-u">
      <action name="Execute">
        <startupnotify>
          <enabled>true</enabled>
          <name>SHELL</name>
        </startupnotify>
        <command>/usr/local/bin/urxvt -fg Yellow -bg Magenta -fade 30 -sh 45 -tr +vb -sb -sr -st -fn "xft:Courier New:pixelsize=14"</command>
      </action>
    </keybind>
Auch hier ist das Aussehen so abgestellt, dass es mir gefallen hat. Irgendwo habe ich dann noch Werte gesetzt, die ein inaktives Fenster deutlich schwächer darstellen lassen und was das alles im einzelnen macht, habe ich einfach so aus der man-page übernommen, wie ich es gelesen habe und für gut befand.
Mit den Schriften habe ich zunächst einfach 9x15 benutzt und war damit zufrieden. Irgendwann habe ich dann damit gespielt und mich auf das Courier New eingeschossen. Dabei gibt es natürlich wieder eine Menge Alternativen und je nach Vorliebe nahezu unendliche Möglichkeiten. Da sollte sich etwas für jeden Geschmack finden.
 

Tronar

aus Überzeugung altmodisch
#18
Mit der Schriftgröße hat pit234as Vorschlag freilich nichts zu tun, sondern mit der Fernstergröße. Die Schriftgröße mußt Du durch X-Ressourcen konfigurieren oder direkt auf der Kommandozeile. Letzteres geht laut Manpage so:
Code:
urxvt -fn "xft:Bitstream Vera Sans Mono:pixelsize=15"
Ersteres in der .Xresources:
Code:
URxvt*Font: 'xft:Bitstream Vera Sans Mono:pixelsize=15'
Mit serverseitigen Fonts funktioniert das ebenso. Dabei ist es sinnvoll, auch die fette Variante explizit mit aufzuführen, weil Urxvt die eventuell nicht selbst erraten kann:
Code:
urxvt -fn -dec-terminal-medium-r-normal--14-140-75-75-c-80-iso8859-1 -fb -dec-terminal-bold-r-normal--14-140-75-75-c-80-iso8859-1
bzw.
URxvt*font: -dec-terminal-medium-r-normal--14-140-75-75-c-80-iso8859-1
URxvt*boldFont: -dec-terminal-bold-r-normal--14-140-75-75-c-80-iso8859-1
Urxvt ist schon erheblich besser, als jenes klapprige Rxvt es vor geraumer Zeit noch war. Aber wenn man richtig zaubern will, kommt man an xterm halt doch nicht vorbei. Beispiel gefällig? Starte mal ein »xterm -ti vt382« und gib dort ein:
Code:
echo -e '\e[?1;3;256S'
zcat lena.sx.gz
... mit dem hier angehängten Lena-Testbild von Ghostscript. (Sorry, das Bild hatte ich zuerst vergessen.)
 

Anhänge

Neko

Well-Known Member
#19
Danke leider fehlt das Bild. :)

Dann würde ich das heute Nachmittag ausprobieren. Auch wenn ich vorher OpenBSD neuinstallieren muss.
Wollte gestern FreeBSD Live testen, dabei kam ein: Ich formatiere mal die Platte und installiere bei raus. :(

War so nicht geplant und ärgert mich ein wenig aber was soll es. Dann fange ich nachher nochmal an.