Firefox 1.0.3: Startseite "hijacked"

nintendo

Please don't sue us!!
Hallo,

Ich benutze Mozilla Firefox 1.0.3 unter FreeBSD 5.4 und habe ein kleines Problem mit dem Browser. Sobald ich Firefox starte öffnet sich eine Seite der University of Minnesota auf, die ich leider nicht als Startseite haben will.

Jeder mir bekannte Versuch sie als Startseite zu entfernen hat bisher nicht funktioniert. Ich habe in den Firefox Einstellungen gewühlt und bisher hat das Umstellen der Homepage in den General Options nichts gebracht. Ebenso habe ich die Cookies & Temp. Internetdateien entfernt aber die Seite bleibt.

Es ist halt ne blöde Sache, ich habe wohl unachtsam gesurft und vermutlich irgendetwas angeklickt, nun hab ich den Kack ;)
Irgendwelche Ideen wo man sonst noch schauen könnte? Bei Windows wärs ja wohl die Registry aber naja :rolleyes:
 

Illuminatus

in geheimer Mission
hi nintendo

grep'pe doch mal dein ~/.mozilla/firefox/nach Teilen der URL.
Desweiteren könntest du auch dein altes Profilverz. umbenenne, ein neues generieren lassen und deine wichtigsten Einstellungen/Bookmarks.. manuell übernehmen.

Die Fehlerursache für den hijack wäre interessanter. Ich wette du brauchst nicht alle Scripte und Schadfunktionen wie Flash ;)
 

nintendo

Please don't sue us!!
Hi Illuminatus,

danke Dir für die Tipps. Ich habe ~/.mozilla/firefox nach der URL durchsucht und die URL wurde nur in den Cache Directories gefunden. Diese habe ich geleert aber es zeigte leider keinen Erfolg.

Ich habe ebenfalls das ~/.mozilla Verzeichnis umbenannt, jedoch hatte es anscheinend keine Auswirkungen auf die Startseite gehabt: der Störenfried ist noch immer da. Eine Möglichkeit wäre noch die Reinstallation von Firefox, da das Problem anscheinend nicht gerade in den Usereinstellungen liegt (oder vielleicht doch?)

Nebenbei noch kurz erwähnt: Ich habe als FF-Extensions nur das Adblock v5-Extension am laufen, amsonsten ist der Browser "ungetuned".
 

nintendo

Please don't sue us!!
Ok ich habe eine Lösung zum Problem gefunden!

Und zwar hat sich da vermutlich ein Fehlerteufel ins xfce4 eingeschlichen (weiss leider nicht wie) aber auf jeden Fall wurde der Befehl "firefox %u" beim klicken auf den FF-Button ausgeführt.

Wenn ich nun den Befehl in der Console ausführe, bekomme ich die Meldung "/usr/X11R6/bin/firefox: WARN, target: /usr/home/nintendo/%u not an URI/file/dir"

Ich denke mal, Firefox googelt dabei automatisch und schnappt sich die erstbeliebige Seite mit dem Buchstaben "U" (in dem Falle, Univeristy of Minnesota). Sollte euch dasselbe passieren, dann schaut einfach in den Menüeinstellungen und überprüft den Befehl, mit dem das Programm gestartet wird auf weitere Parameter.

Danke für die Hilfe Illuminatus, nun geht's wieder! :D
 
Oben