• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Firefox mit pkgsrc bauen

Themenstarter #1
Hallo Forum,

ich bin neu hier und hoffe, Ihr könnt mir etwas helfen. Ich benutze seit einigen Jahren Linux, wollte nun aber mal etwas über den Tellerrand blicken und NetBSD ausprobieren, das ich nun zum Rumspielen auf einem alten Netbook installiert habe.

XFCE4 läuft bereits, jetzt möchte ich einen Firefox.

Da ich mit pkgin nur hoffnungslos veraltete Versionen liefert, möchte ich eine aktuelle Version mit pkgsrc compilieren lassen. Das scheitert aber am Herunterladen der benötigten Quellen, manche Pakete fehlen (siehe Log). Kann ich darauf Einfluss nehmen? Was ist jetzt der richtige Weg?

Danke schon mal!

make fetch-list | sh innerhalb von /usr/pkgsrc/www/firefox ergibt:


ftp: Can't LOOKUP `ftp6.NetBSD.org:http': hostname nor servname provided, or not known
ftp: Can't connect to `ftp6.NetBSD.org:http'
rust-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Trying [2001:470:a085:999::21]:80 ...
Requesting http://ftp.NetBSD.org/pub/pkgsrc/distfiles/rust-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Trying [2001:660:3302:282a:204:75ff:fe9f:9e11]:80 ...
Requesting http://ftp.fr.NetBSD.org/pub/pkgsrc/distfiles/rust-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Trying [2400:8500:1302:849:150:95:200:193]:443 ...
ftp: Can't connect to `2400:8500:1302:849:150:95:200:193:443': Verbindung wurde abgelehnt
Trying 150.95.200.193:443 ...
Requesting https://www.ryoon.net/pub/rust/rust-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Trying [2a04:4e42:1b::262]:80 ...
Requesting http://cdn.NetBSD.org/pub/pkgsrc/distfiles/rust-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Requesting http://ftp6.NetBSD.org/pub/pkgsrc/distfiles/rust-std-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-std-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Trying [2001:470:a085:999::21]:80 ...
Requesting http://ftp.NetBSD.org/pub/pkgsrc/distfiles/rust-std-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-std-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Trying [2001:660:3302:282a:204:75ff:fe9f:9e11]:80 ...
Requesting http://ftp.fr.NetBSD.org/pub/pkgsrc/distfiles/rust-std-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-std-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Trying [2400:8500:1302:849:150:95:200:193]:443 ...
ftp: Can't connect to `2400:8500:1302:849:150:95:200:193:443': Verbindung wurde abgelehnt
Trying 150.95.200.193:443 ...
Requesting https://www.ryoon.net/pub/rust/rust-std-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-std-1.31.1-i686-unknown-netbsd.tar.gz not fetched
Trying [2a04:4e42:1b::262]:80 ...
Requesting http://cdn.NetBSD.org/pub/pkgsrc/distfiles/rust-std-1.31.1-i686-unknown-netbsd.tar.gz
ftp: Error retrieving file `404 Not Found'
rust-std-1.31.1-i686-unknown-netbsd.tar.gz not fetched
 
Themenstarter #3
Ja, einige andere Pakete hat pkgin auch schon brav installiert. Das Problem ist, dass die aufgeführten Dateien auf den Servern dort einfach nicht liegen, obwohl sie es wohl sollten.
 

mr44er

Well-Known Member
#4
Die rust-1.31.1-i686-unknown-netbsd.tar.gz ist wirklich nicht vorhanden:

Code:
404 Not Found
pub/pkgsrc/distfiles/rust-1.31.1-i686-unknown-netbsd.tar.gz:

This item has not been found
Ich kenne NetBSD nicht, aber
Code:
rust-1.31.1-x86_64-unknown-netbsd.tar.gz 20-Dec-2018 17:51         174447kB
liegt dort.

https://forge.rust-lang.org/other-installation-methods.html#standalone
Da gibts nur noch x86_64-unknown-netbsd. Ich vermute mal, da wurde was umbenannt. Die 1.32.0 ist jetzt aktuell.

Anhand deines Logs hängts ja nur an rust, damit es mit den anderen Paketen weitergehen kann.
 

darktrym

Fahnenträger
#5
Hoffnungslose alte Dateien? Rust 1.31 ist vom 22.12, 1.32 vom 19.1. Ich kann's am Wochenende testen ob man explizit 1.31 für Firefox braucht, naja jedenfalls steht in der Makefile von Rust wo der Quellcode liegen soll. Aber Firefox setzt auf experimentielle Compilerversionen, die alle paar Wochen ihre Grammatik brechen. Scheiß gehypter Murks.
 

franco98

NetBSDler aus Leidenschaft
#6
@for(;;)

Baust du für i386, also 32bit Pakete? Im Makefile von rust (/usr/pkgsrc/lang/rust/Makefile) steht für jeden Port (sparc, i386, darwin,...) welches Quellpaket gesucht wird. Du müsstest es notfalls im Internet besorgen und dann in den distfiles Ordner kopieren - z.B in /usr/pkgsrc/distfiles, falls du das nicht in deiner mk.conf anders festgelegt hast.

Viel Erfolg! Ich baue immer alles aus pkgsrc, nehme den Firefox aber immer als ESR Version.

VG aus LE
Franco
 
Themenstarter #8
Vielen Dank!

In der pkgsrc-users Mailingliste habe ich den Tipp erhalten, lang/rust mit cvs update -D "3 months ago" -Pd lokal zurück zu setzen, weil es zu diesem Zeitpunkt noch einen 32-bit bootstrap gab. Damit hat der Bau jetzt geklappt, hat aber immerhin auch einen Tag, 3 Stunden und 55 Minuten dafür benötigt...

Beim nächsten Mal suche ich etwas intensiver nach fertigen Binärpaketen, @franco98 -- vielen Dank für den Tipp! Und ja, dieses alte Netbook benötigt 32-Bit-Pakete.

Momentan läuft make install von lang/rust, wenn das durch ist, versuche ich noch einmal, den Bau des Firefox zu starten. Mal sehen, wie lange das dann dauert ;)
 

franco98

NetBSDler aus Leidenschaft
#9
Dann dürfe es beim Firefox noch länger dauern, oder waren das die gemeinten 1 Tag und 3 Stunden und 55 Minuten? Warum baust du nicht die 32bit packages mit crosscompiling auf einer anderen, schnelleren x64 Maschine. Schon um auch das System unter stable aktuell zu halten. Die Pakete nimmst du dann für's Update auf dem NetBook.

VG aus LE
Franco
 
Themenstarter #10
So etwas habe ich schon befürchtet :) Diese Zeit war tatsächlich nur der Build von lang/rust.

Warum baust du nicht die 32bit packages mit crosscompiling auf einer anderen, schnelleren x64 Maschine. Schon um auch das System unter stable aktuell zu halten. Die Pakete nimmst du dann für's Update auf dem NetBook.
Das ist schnell erklärt: weil ich noch nicht weiß, wie das geht. :confused:
 
Themenstarter #13
Ja, den burn-in-Test hat das Gerät gut bestanden :) Der Gute hat aber auch eine 128 GB SSD und den maximalen RAM-Ausbau von stolzen 2 GB bekommen, quält sich also nicht ganz so sehr wie er das im Auslieferungszustand machen würde.

@franco98 Sehr gerne. In Virtualbox habe ich jetzt schon ein NetBSD 8.0/amd64 laufen, kernel und userland schon für i386 compilert. Wirklich erstaunlich, wie einfach und schnell das ging. Jetzt muss ich nur noch herausfinden, wie ich Pakete aus pkgsrc für i386 baue.

Der firefox, der nativ auf dem Netbook compiliert, ackert dagegen immer noch... Villariba und Villabacho lassen grüßen.
 

franco98

NetBSDler aus Leidenschaft
#14
@for(;;)

Dann bist du ja schon weiter und ich brauche dir den Kram mit dem kernel und userland bauen nicht erklären. Wichtig ist das Erzeugen der tools in /usr/src.

z.B.: sudo ./build.sh -m i386 tools

===> Tools built to /usr/src/obj/tooldir.NetBSD-8.0_STABLE-amd64
===> build.sh ended: Sun Jan 27 07:35:54 UTC 2019
===> Summary of results:
build.sh command: ./build.sh -m i386 tools
build.sh started: Sun Jan 27 07:15:35 UTC 2019
NetBSD version: 8.0_STABLE
MACHINE: i386
MACHINE_ARCH: i386
Build platform: NetBSD 8.0_STABLE amd64
HOST_SH: /bin/sh
No $TOOLDIR/bin/nbmake, needs building.
Bootstrapping nbmake
MAKECONF file: /etc/mk.conf
TOOLDIR path: /usr/src/obj/tooldir.NetBSD-8.0_STABLE-amd64
DESTDIR path: /usr/src/obj/destdir.i386
RELEASEDIR path: /usr/src/obj/releasedir
Created /usr/src/obj/tooldir.NetBSD-8.0_STABLE-amd64/bin/nbmake
Updated makewrapper: /usr/src/obj/tooldir.NetBSD-8.0_STABLE-amd64/bin/nbmake-i386
Tools built to /usr/src/obj/tooldir.NetBSD-8.0_STABLE-amd64
build.sh ended: Sun Jan 27 07:35:54 UTC 2019

Du hast dann ein tooldir mit den cross-comping tools. Das sollte bei dir ja schon da sein.

Pkgsrc packages bauen ist noch was anderes. Ich habe folgenden Link:

https://www.netbsd.org/gallery/presentations/riastradh/asiabsdcon2015/pkgsrc-cross-paper.pdf

Leider habe ich i.M. wenig Zeit, du musst dich schon mal belesen.

Viel Erfolg...