Flashplugin will nicht

E

ex-user_4198

Guest
Hallo Leute

Ich hab gerade versucht Flash 10 Plugin zu installieren und in Firefox zu integrieren. Leider bis jetzt ohne Erfolg.
Mein System ist FreeBSD 8.1 mit neustem Flash 10 Plugin.

Ich hab mich natrülich an diese Anleitung gehalten.
http://www.freebsd.org/doc/de/books/handbook/desktop-browsers.html

1. nspluginwrapper gebaut
2. linux-f10-flashplugin gebaut
3. Link setzen
4. nspluginwrapper -v -a -i
5. mount -t linprocfs linproc /usr/compat/linux/proc
und in fstab eingetragen.
6. Firefox neu gestartet und "about:plugins" eingeben.
Leider wird kein Plugin aufgelistet.

Hab ich irgendwas falsch gemacht?
danke welkin
 

Fusselbär

Makefile Voyeur
1. nspluginwrapper gebaut
2. linux-f10-flashplugin gebaut
3. Link setzen
4. nspluginwrapper -v -a -i
5. mount -t linprocfs linproc /usr/compat/linux/proc
und in fstab eingetragen.

Sollte man nicht besser zuerst den Linuxator fertig parat machen,
bevor man Linux Programme installiert?
Also erst das mounten vom linprocfs usw. erledigen,
bevor man an die Installation und das über Wrapper zugänglich machen
des Linux Adobe Flash Plugin rangeht?
 
E

ex-user_4198

Guest
$nspluginwrapper -i pfad_zum_plugin

Meinst du so?
nspluginwrapper -i /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so

Bekomm ich als User folge Meldung:
nspluginwrapper: no appropriate viewer found for /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so
 

Fusselbär

Makefile Voyeur
Mal einige Einträge bezüglich Linuxator greppen:
grep linux /etc/rc.conf
Code:
linux_enable="YES"
grep linux /etc/sysctl.conf
Code:
hw.snd.compat_linux_mmap=1
compat.linux.osrelease=2.6.16
grep linux /etc/fstab
Code:
linprocfs       /usr/compat/linux/proc  linprocfs       rw      0       0
So sieht das bei mir auf FreeBSD 8.1-STABLE i386 aus.
Als ich den Linux Adobe Flash Player und den Wrapper dafür installiert hatte
lief der Linuxator längst. Den Wrapper habe ich dann für meinen User
so als User installiert:
Code:
nspluginwrapper -v -a -i
Danach den Firefox neustarten und der Linux Adobe Flash Player taucht in den Firefox Plugins auf.
 

nyko

Member
Hallo, ich habe das gleiche Problem. Habe mich auch genau an die Anleitung auf Freebsd.org gehalten. Java hab ich hin bekommen aber das Flashplugin will einfach nicht. Komisch ist, das dies schon die 2. Installation ist die ich mache. Bei der ersten lief alles reibungslos. Hat jemand eine Ahnung was es sein könnte? (benutze auch Firefox 3.6)
 

Styx

Universaldilettant
Eine Beschreibung dessen, was du bisher gemacht hast könnte bei der Fehlersuche helfen ;)
 

nyko

Member
Bis jetzt habe ich die Ports
- emulators/linux_base-f10
- www/nspluginwrapper
- www/linux-f10-flashplugin10
installiert.

Danach habe ich den Link
ln -s /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so \
/usr/local/lib/browser_plugins/
angelegt und als User
nspluginwrapper -v -a -i
eingegeben. Und zum Schluss habe ich
mount -t linprocfs linproc /usr/compat/linux/proc
eingehängt und diesen auch in fstab eingetragen.
Ich denke nicht, dass es an der 3.6 Version hängt, da ich es ja schon bei einer früheren Installation zum laufen bekam.
 

auge

Well-Known Member
... probier mal als USER

% nsplugingwrapper -i /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so

das sollte dir ' ~/.mozilla/plugins/npwrapper.libflashplayer.so'
erstellen.

was sagt about:config
 

nyko

Member
hey, danke für die Hilfe, aber ich hab mein FreeBSD einfach nochmal neu installiert. Habe dann die Anleitung nochmal durchgearbeitet und nun gehts komischer Weise
 

Elwood

Naiver Mutmaßlicher
OT: Immer diese Holzhackermehtoden :D
Auf meiner "Workstation" habe ich glaub ich 1997 oder so das letzte mal FreeBSD "neu installiert". Klar.. die Hardware ist öfter mal erneuert worden, aber die Originalinstallation + Updates und neuen Releases läuft hier immer noch. Immer putzig, wenn man noch Dateien von 1994 in irgendeiner Ecke entdeckt.
 

Kamikaze

Warrior of Sunlight
Sagt doch nichts. Mein FreeBSD ist dank dump auch schon auf der 3. Festplatte und hat sich von 5.3/i386 zu einem 8.2-stable/amd64 gemausert.
 

Elwood

Naiver Mutmaßlicher
Ne, wie Kami schon schreibt... Das System wandert von einer zur nächsten Platte via dump/tar und Konsorten. Hab da auch schon alles durch :D
 
Oben