• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

[Frage] A7N8X onboard Sound

Themenstarter #1
Hi,

ich habe letzte Woche FreeBSD 5.2 RELEASE auf meinem Desktop PC als
zweites BS installiert, und wenn möglich will ich nicht all zu oft Rebooten,
um alternativ WinXP hoch zu fahren.

Hardware:
> Mainboard - Asus A7N8X deluxe
> Sound - Onboard 5.1

Was mich im Moment stört ist, das ich unter FreeBSD nur Stereo Sound habe.
Da ich aber ein 5.1 Boxensystem am Rechner hängen habe, weil ich den PC
auch als Musikanlage und DVD-Player nutze, kommt der Sound nur auf den
beiden vorderen Boxen und führt dazu, dass die Hinteren Boxen (stört nicht so sehr)
und die Bassbox + Center nicht gehn.
Mir fehlen quasi die Bässe und der Raumklang, das wäre nicht so schlimm wenn
wenigstens die Bässe gehen würden, weil es doch das Hörverknügen stark mindert ... :(

Ich hab hier im forum gelesen, dass es möglich wäre das Stereosignal vieleicht
auch auf die anderen Boxen zu legen, bin daraus aber nicht wirklich Schlau
geworden.

Weiterhin bin ich auch auf eine wohl kostenpflichtige Möglichkeit gestossen,
wobei ich nicht weis in wie fern diese funtkioniert.

Gut ich könnte über Weichen ausserhalb der Soundkarte das Signal direkt splitten,
aber das müsste ich dann jedesmal zurück bauen, wenn ich unter WinXP eine
DVD mit Surroundsound hören möchte und ist nicht wirklich eine Lösung die
mir gefällt.

Deshalb meine Frage an Euch, vieleicht kann mir jemand einen Tip geben oder
so ... ich weis zwar das es da im moment etwas Mau aussieht ...
aber das mit dem Sound ist eigentlich der einzigste Punkt den ich an
FreeBSD als Desktop System zu bemängeln habe ;)

Gruss Jimbo :)
 

thomasf

Well-Known Member
#2
Also die kommerzielle Lösung habe ich noch nicht getestet (OSS meinst du?) Und ansonsten kann ich dir zumindest bestätigen,das es diebezüglich scheinbar wirklich mau aussieht. Ich selber habe einen 6-channel-Onboard nforce2 Chip(soundstorm), dem ich auch nur Stereo entlocken kann. Und Bass fehlt dann da auch.
 

cat1510

Well-Known Member
#3
Ähm kurze Frage, wie sieht das denn mit den Network Controllern aus, wenn Ihr schon keinen Sound rausbekommt?
Ich kann keinen von beiden onboard benutzen.
Haber aber auch das A7N8X-E Deluxe.

MFG

CAT
 

scup

Well-Known Member
#4
Hallo cat1510,

habe das selbe Mainboard, aber ich konnte bei der Installation die 3com Schnittstelle wählen.

War bei /usr/sbin/sysinstall in der Netzwerkkonfiguration die erste Karte.
 

cat1510

Well-Known Member
#5
Ähm ich hab an meinem Board keine 3com Schnittstelle?!?!
Der eine 10/100 Chip ist von MCP-T southbridge integrated controller MAC + Realtek 8201BL LAN PHY. Was immer das auch heissen mag.
Und das andere Interface ist ein Marvell 88E8001 Gigabit LAN.
Ich benutze FBSD 5.2.1 mit GENERIC Kernel.
Mein Dmesg sagt, dass er einen Network Controller gefunden hat aber keinen driver attach'en kann.

Im Sysinstall habe ich nur loop und slip interface.
 

auge

Well-Known Member
#6
in /etc/sysctl.conf

hw.snd.pcm0.vchans=4

bzw sysctl hw.snd...... , werden jetzt 4 Kanäle benutzt?

setzt natürlich voraus das du pcm benutzt.
 
#7
Original geschrieben von cat1510
Ähm kurze Frage, wie sieht das denn mit den Network Controllern aus, wenn Ihr schon keinen Sound rausbekommt?
Ich kann keinen von beiden onboard benutzen.
Haber aber auch das A7N8X-E Deluxe.

MFG

CAT
guckst du hier:
http://www.bsdforen.de/forums/showthread.php?s=&threadid=3212&highlight=nvidia+freebsd

ich habe ein a7n8x-x (die sparversion :D), benutze allerdings weder die onboard-nic noch den sound, da ich damals gleich meine 3-com und soundblaster eingebaut habe; aber in dem link steht ja drin wie du sie zum laufen bekommen solltest...
 
Themenstarter #8
So mal wieder hochgeschoben, nach dem wir heute bei einem Kumpel unter NetBSD Surround Sound hinbekommen haben um 5.1 DVD ordentlich zu schauen, wollte ich es nochmal bei meinem FreeBSD 5.2.1 probieren.

System: Asus A7N8X-delux mit nvidia nforce2 Onboard 5.1 Sound

Ergebnisse:

http://www.opensound.com/freebsd.html nun für private Nutzung frei :)
"... OSS is now free for home/personal use (runs in "unregistered mode" but no longer times out during evaluation). License is still required for commercial, educational and personal use with services ..."

Ich also device pcm wieder aus Kernel entfernt und den OSS Sound installiert

Tests mit 5.1 DVD in mplayer mit 5.1 Soundanlage:

mplayer -ao oss:/dev/dsp -channels 2 dvd:// ... VL+VR ...OK
mplayer -ao oss:/dev/dsp -channels 4 dvd:// ... VL+VR HL+HR ...OK (aber kein Bass und kein Center)
mplayer -ao oss:/dev/dsp -channels 6 dvd:// ... 5.1 ... Fehlerhaft (Knacken in den Boxen)

Da ich im Moment eine Weiche Nutze um vom Stereosignal einen Kanal für meine Bassbox abzweige, wende ich das nun bei 4 channel support an und habe Surround mit improvisierten Bass, was dass DVD Hörverknügen extrem steigert :)

Soviel zu einem kleinen Zwischenergebniss :)

Wer noch weitere Tips hat ruhig her damit, weil im Moment geht das nur für Medien die von Haus aus Mehrkanalton mitbringen. Denn normale Stereo Musikdateien habe ich noch nicht geschafft von 2 Kanal auf 4 oder 6 Kanal zu emulieren :(

Gruss
Tigion