• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD 12.1 auf Apple MacPro 1.1: Tastatur funktioniert unter X plötzlich nicht mehr

Doalwa

Well-Known Member
Themenstarter #1
Hallo zusammen,

ich habe seit längerer Zeit auf meinem Mac Pro 1.1 FreeBSD 12.1 laufen.

Seit dem letzten pkg update && pkg upgrade Zyklus funktioniert meine Tastatur unter Xorg plötzlich nicht mehr, bzw. produziert sie sehr seltsame Ergebnisse.

Als DE nutze ich KDE Plasma, das Verhalten ist aber das gleiche wenn ich einfach nur startx mit twm ausprobiere.

Aus irgendeinem Grund habe ich ein sehr Stranges Keyboard-Layout. Die Enter-Taste funktioniert überhaupt nicht mehr, drücke ich beispielsweise die taste a erscheint als Ausgabe

;restart;3^;

Die Taste m wiederum produziert Ausgaben wie

;4B

oder auch nach mehrmaligem Betätigen

;;4A

Habe keinen Anhaltspunkt, was dies verursacht.

In der Konsole oder per SSH funktioniert die Tastatur einwandfrei.

Falls es eine Rolle spielt, ich nutze eine Logitech K330...mit einer testweise angeschlossenen Cherry USB-Tastatur tritt aber das gleiche Verhalten auf.

Irgendjemand eine Idee, was hier los sein könnte?

Gruß,
Dominik
 

Columbo0815

Kaffeemann
Mitarbeiter
#2
Es gibt ein paar Threads zu dem Thema (wenn ich richtig liege). Prüfe mal, ob das Paket xf86-input-libinput installiert ist. Evtl. hat es mit der Umstellung von Xorg auf udev zu tun.

Das jetzt mal auf die Schnelle. Vielleicht reicht dir das schon.
 

Zirias

Well-Known Member
#4
Ich bin über das Problem im Zusammenhang mit der systemweiten Konfiguration der Tastaturbelegung gestolpert, da hat man ja üblicherweise sowas in der Art:
Code:
#/usr/local/etc/X11/xorg.conf.d/keyboard-de-nodeadkeys.conf
Section "InputClass"
    Identifier    "KeyboardDefaults"
    Driver        "keyboard"
    MatchIsKeyboard    "on"
    Option        "XkbLayout" "de"
    Option        "XkbVariant" "nodeadkeys"
EndSection
Da muss die Zeile mit "Driver" raus, dann geht es wieder.
 

Doalwa

Well-Known Member
Themenstarter #5
Ich bin über das Problem im Zusammenhang mit der systemweiten Konfiguration der Tastaturbelegung gestolpert, da hat man ja üblicherweise sowas in der Art:
Code:
#/usr/local/etc/X11/xorg.conf.d/keyboard-de-nodeadkeys.conf
Section "InputClass"
    Identifier    "KeyboardDefaults"
    Driver        "keyboard"
    MatchIsKeyboard    "on"
    Option        "XkbLayout" "de"
    Option        "XkbVariant" "nodeadkeys"
EndSection
Da muss die Zeile mit "Driver" raus, dann geht es wieder.
Vielen Dank, habe die "Driver" Zeile aus meiner Config entfernt, es geht wieder :-)