• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD 12: Probleme beim Brennen?

pit234a

Well-Known Member
Themenstarter #1
Auf zwei Rechnern, die von früheren Versionen auf FreeBSD 12.0-RELEASE gehoben wurden, hatte ich Probleme, ein ISO zu brennen.
Dazu benutzte ich xfburn, k3b und einen Befehl mit cdrecord direkt, den ich der Fehlerausgabe von k3b entnommen hatte. Auf einem PC wurde eine DVD gebrannt, die aber nicht funktionierte, auf dem anderen gab es eine Fehlermeldung, cdrecord könne mit "dieser Version des Betriebssystems nicht arbeiten" oder so in der Art. Ich hatte weder Muße, noch Zeit, genauer hinzusehen. Das Brennen aus einem anderen OS funktionierte, das ISO ist also nicht verdächtig.
Nun denke ich mir, dass vielleicht andere Leute noch mehr CD/DVDs brennen müssen, als ich das gelegentlich mal tue und dass dann, wenn ein grundsätzlicher Fehler in 12 bekannt ist, der schon irgendwo aufgetreten sein müsste.
Wie ist das bei euch?
Wenn bei euch alles problemlos läuft, muss ich halt doch Zeit investieren und nachsehen, was bei mir nicht stimmt.
 

waldbaer59

Well-Known Member
#2
Hallöchen,

ich habe mich vorhin mal ein Stündchen im kalten Souterrain-Zimmer aufgehalten, wo meine FreeBSD-Maschine steht. Das Upgrade auf 12.0 hat mir offensichtlich u.a. den Automount von USB-Sticks und noch das Eine oder Andere verhagelt. Da ist also Nachbesserung angesagt... *hmpf*

Und - um auf dein Thema zu kommen - das Brennen ist aktuell auch nicht so 'ganz ohne'.
1.) Brasero listet meinen Brenner nicht und will nur Image-Dateien erzeugen.
2.) K3B findet meinen Brenner, aber bricht sofort ab weil nix im Puffer sei. Müsste ich mal probieren, ob aus Ports bauen hilft.
3.) xfburn brennt problemlos. Die CD lässt sich auch auf meiner Linux-Maschine anstandslos lesen.

Also scheint es im Prinzip zu gehen (auch mit einem LG BlueRay Brenner). Nur offensichtlich hat es ein paar Stellen, wo Nacharbeiten angesagt sind.

VLG
Stephan
 

waldbaer59

Well-Known Member
#3
Noch eine Korrektur: auch mit Brasero funktioniert es. Ich habe vergessen, dass ich bei mir das Device mitgeben muss. K3b nutze ich aktuell ohnehin nicht mehr.
 

pit234a

Well-Known Member
Themenstarter #4
Habe eben eine CD als Daten-Medium mit xfburn gebrannt und das funktionierte ebenfalls.

Nun weiß ich nicht, ob ich mal weiter testen möchte, was denn genau geht und was nicht. Offenbar sind keine generellen Probleme bekannt und ich scheue mich immer, Rohlinge unnötig zu verbrennen. Deshalb startete ich diese Anfrage ja auch.

Mein anfängliches Problem war ein ISO, das zu einer DVD gebrannt werden sollte und das funktionierte nur mit Fehlern oder war unbrauchbar, obwohl es keine Fehlermeldungen gab. Das ISO und die HW sind unverdächtig, weil das Brennen mit gleicher HW und einem anderen OS funktionierte. Das gleiche ISO hatte zuvor mit 11.x bereits aus FreeBSD (mit k3b) erfolgreich zu einer DVD gebrannt.
Deshalb lag der Verdacht nahe, dass sich irgendwas mit 12 geändert hat.

Mit xfburn gerade probiert eine DVD aus Daten zu brennen und das misslang.
Vielleicht gehen CDs und DVDs nicht?

Bei Gelegenheit werde ich vielleicht weiter sehen.
 

pit234a

Well-Known Member
Themenstarter #5
Eine DVD misslang gerade eben mit xfburn und vielleicht macht das den Unterschied?
Wahrscheinlich werde ich nochmal genauer hinsehen müssen.
 

waldbaer59

Well-Known Member
#7
Ich werde morgen mal probieren, ob bei meiner Kiste eine DVD funktioniert. Einen Rohling gebe ich dran ...
Melde mich dann nochmal.

VLG
Stephan
 

Andy_m4

Well-Known Member
#8
Offenbar sind keine generellen Probleme bekannt und ich scheue mich immer, Rohlinge unnötig zu verbrennen.
Wobei es zumindest bei einem Preis von unter 20 Cent pro DVD-R Rohling jetzt ein verschmerzbarer Verlust ist.

Ich selbst hab aber kaum noch CD/DVDs im Einsatz. Irgendwie lässt sich heute fast alles via Netz und Flashmedien abdecken. Zumal die Kapazität auch heutzutage nicht mehr wirklich attraktiv ist. Was bleibt sind irgendwelche Legacy-Anwendungen.
 

waldbaer59

Well-Known Member
#9
Es hat 'natürlich' mal wieder länger gedauert, bis ich dazu gekommen bin, den versprochenen Test zu machen *hmpf*. Eine Daten-DVD habe ich vorhin problemlos brennen können (brasero). Das ist also auch hier ok. Vielleicht sollte ich mal eine herunter geladene ISO brennen. Da muss ich aber zunächst schauen, warum meine Netzwerkkarte so vergleichsweise langsam ist. Das ist - abgesehen vom Automount von USB-Sticks u.dgl. - noch meine einzige Baustelle unter 12.0 (kein Wunder, wenn ich noch nicht viel eingerichtet habe ;) ).

VLG
Stephan
 

pit234a

Well-Known Member
Themenstarter #10
Also, ich habe nun meinen (eh begrenzten) Vorrat an DVDs soeben verbrannt und zwar von der Konsole mittels growifs. Das sollte ja sein, was alle GUIS auch verwenden.
Eine Daten-DVD konnte ich zusammenstellen, ein ISO daraus machen, dann brennen und auch auf anderen Systemen benutzen. Den Zwischenschritt über das ISO ging ich ganz bewusst, ich erzeugte es nämlich mit k3b, um zu sehen, dass dieser Teil funktioniert.
ISOs mit Betriebssystemen wurden (angeblich) erfolgreich gebrannt, funktionierten aber auf meinen einen derzeit freien Testsystem allesamt nicht. Nun waren das ältere ISOs, weshalb ich auch ein aktuelles Knoppix downloadete und das sha256 checkte. Das ISO war sauber, die DVD nicht und funktionierte anschließend auch nicht.
Vor meinen Versuchen mit growifs von der Konsole, hatte ich vergleichbare Ergebnisse mit XFBURN.
Ich muss mal sehen, ob ich vielleicht noch irgendwo an anderer Stelle einige weitere Rohlinge finden kann, um mit anderem System und anderer HW gegen zu checken.
Weil das aber bei mir auf zwei 12.0-RELEASE-Systemen quasi zeitgleich und identisch aufgetreten ist, vermute ich tatsächlich entweder den großen Zufall (schlechte Charge an DVD-Rohlingen zB), oder einen neuen Fehler in einer SW.
Deshalb nochmal großen Dank an @waldbaer59 für die Unterstützung. Es ist ja nun kein brennendes Problem ;) und ich selbst bin auch deshalb recht zurückhaltend mit meinen eigenen Versuchen. Es gibt ja immer eine große Menge an möglichen Ursachen, die nacheinander ausgeschlossen sein wollen.

Achso, Vielleicht als eine Art Referenz: ftp://ftp.uni-kl.de/pub/linux/knoppix-dvd/KNOPPIX_V8.2-2018-05-10-DE.iso hatte ich eigens zum Test mit meinem letzten Rohling runtergeladen und die sha256 dazu ist: 5620f0a1ceee81094888b0d37dbaa9677c3b7d35d3416689139857fd21c24270
 
H

holgerw

Guest
#11
Eine DVD misslang gerade eben mit xfburn und vielleicht macht das den Unterschied?
Wahrscheinlich werde ich nochmal genauer hinsehen müssen.
Hallo Pit,

mit xfburn habe ich unter FreeBSD 12.0-Release-p1 ein bootonly-iso von FreeBSD 12.0 sauber auf eine CD brennen können und mit diesem Medium ist es mir auch möglich, FreeBSD 12 zu booten.

DVD-Rohlinge habe ich leider nicht zur Hand, sonst hätte ich die DVD-iso von FreeBSD 12 versucht zu brennen.

Vielleicht hilft Dir diese Information schon ein wenig weiter.
 

pit234a

Well-Known Member
Themenstarter #12
Hallo Pit,

mit xfburn habe ich unter FreeBSD 12.0-Release-p1 ein bootonly-iso von FreeBSD 12.0 sauber auf eine CD brennen können und mit diesem Medium ist es mir auch möglich, FreeBSD 12 zu booten.

DVD-Rohlinge habe ich leider nicht zur Hand, sonst hätte ich die DVD-iso von FreeBSD 12 versucht zu brennen.

Vielleicht hilft Dir diese Information schon ein wenig weiter.
Es ist eines der Dinge, die ich selbst noch nicht probiert habe und deshalb jedenfalls Dank für die Rückmeldung.
Musik- und Daten-CDs mit xfburn sind auch bei mir gelaufen.
 

mr44er

moderater Moderator
Mitarbeiter
#13
Code:
Used versions
-----------------------
cdrecord: 3.1

cdrecord
-----------------------
scsidev: '/dev/cd1'
devname: '/dev/cd1'
scsibus: -2 target: -2 lun: -2
cdrecord: Invalid argument. Open by 'devname' not supported on this OS. Cannot open or use SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
Cdrecord-ProDVD-ProBD-Clone 3.01 (amd64-unknown-freebsd12.0) Copyright (C) 1995-2015 Joerg Schilling
TOC Type: 0 = CD-DA
Da ist was anderes im Argen...

1557408506823.png


'cdrecord -scanbus'
Code:
...
scsibus7:
        7,0,0   700) 'LITE-ON ' 'COMBO LTC-48161H' 'KH0F' Removable CD-ROM
        7,1,0   701) *
        7,2,0   702) *
        7,3,0   703) *
        7,4,0   704) *
        7,5,0   705) *
        7,6,0   706) *
        7,7,0   707) *
1557408553881.png


So klappts! ;)

Ich habe jetzt aber immer noch das Problemchen, dass der Brenner am Ende blockiert (bleibt optisch an der LED im Brennmodus) und somit auch nicht die frisch gebackenen Brötchen auswirft. Ich teste das jetzt noch mit dem dritten und vierten Brenner.

Das ist ein alter IDE-Brenner, den ich per IDE2USB-Adapter eingehängt habe. Evtl. hat das damit zu schicken?
 
Zuletzt bearbeitet:

pit234a

Well-Known Member
Themenstarter #14
Mein System ist seit einigen Wochen nicht mehr aktualisiert (ich brauche gerade Virtualbox und will einfach nichts riskieren) und deshalb weiß ich nicht, wie aktuell meine Versionen sind.
jedenfalls hatte ich (nach meiner Meinung) alle relevanten Einstellungen ok, aber immer Abbruch mit cdrecord, entweder mit k3b oder als Kommando direkt.
k3b ist dann wichtig für mich, wenn ich die Bootoptionen setzen will (um etwa eine bootbare Windows-DVD zu bauen, was damals mein großes Problem war). Inzwischen nutze ich auf die Schnelle xfburn und wenn ich k3b brauche, erzeuge ich damit nur noch isos, die ich dann aus der Konsole mit growisofs brenne. Ist zwar ein Schritt mehr, funktioniert aber.
 

mr44er

moderater Moderator
Mitarbeiter
#15
Also mit einem intern angeschlossenen SATA-Brenner klappts am Ende mit dem Auswurf...alles automatisch. :) Ich schieb das jetzt einfach mal auf die Chinaplastik von dem Adapter.

Ist anscheinend kein großes Hexenwerk, liegt nicht an den Berechtigungen und auch nicht an k3b. Die Bezeichnung '/dev/cd0' wird einfach nicht mehr von cdrecord angenommen, stattdessen einfach die Bus-Adresse angeben, die man mit 'cdrecord -scanbus' oder 'camcontrol devlist' rausbekommt.
Von der console aus das so als Parameter mitgeben sollte klappen, dementsprechend habe ich das auch k3b beigebracht.

Die große Preisfrage jetzt....was macht xfburn, dass es ohne Anpassung klappt? Evtl. ist es so aktuell, dass es direkt die Busadresse übergibt?
 

pit234a

Well-Known Member
Themenstarter #16
stattdessen einfach die Bus-Adresse angeben, die man mit 'cdrecord -scanbus' oder 'camcontrol devlist'
ich glaube, dass ich das in meinen versuchen von der Konsole aus gemacht hatte, aber immer wieder gleiche Fehler erhalten hatte.
Wenn ich dran denke und nächste Woche mal wieder Updates gemacht sind, probiere mal wieder was rum.
 

mr44er

moderater Moderator
Mitarbeiter
#17
K3B findet meinen Brenner, aber bricht sofort ab weil nix im Puffer sei.
Fehlermeldung, cdrecord könne mit "dieser Version des Betriebssystems nicht arbeiten"
Das war auch der Effekt bei mir.


Ich habe jetzt mal ein paar CDs gebrannt seit Ewigkeiten und wahrscheinlich noch nie mit diesem einen Brenner. Habe ein paar auf Halde und einfach mal zugegriffen.
Dazu noch ein paar Fragen in die Runde:
Mir fiel auf, dass er am Anfang tlw. mal mit 40x anfängt, mal mit 24x, mal mit 16x. Immer unterschiedlich. Dieses Verhalten kenne ich und kommt ab und an vor. Ich vermute, dass es an der unterschiedlichen Rohlingqualität liegt? Jedenfalls waren alle zehn Rohlinge aus einer Packung, bis 52x geeignet und der Brenner kann wahrscheinlich nur 40x. -> HL-DT-ST DVDRAM GH41N -> Habe auf die Schnelle keine specs gefunden, ist ja auch nicht so wichtig.
ABER was ich nicht kenne ist, dass während dem Brennvorgang runtergeregelt wird. Also 1/3 wird mit 40x gebrannt und dann z.B. wurde auf 16x runtergeregelt.
Das habe ich noch nie gesehen. Womit hängt das zusammen? Staubkrümel/buffer underrun?

Zweite Frage:
Was sind die Unterschiede von cdrdao, cdrecord und cdrskin? Letzteres ist ja nicht in den cdrtools enthalten...und k3b hat es im popup 'empfohlen'.