FreeBSD 5.1: Sendmail-Start dauert zu lange

ChipTango

New Member
Hallo BSDForen-Gemeinde,

nach meiner Installation der Mini-CD FreeBSD 5.1 läuft der Start von Sendmail (Beim Booten oder Restart von sendmail) extrem langsam ab (5-6 Minuten passiert garnix und nur geringe Festplattenaktivität). Die Konfiguration ist nicht verändert worden.

Weiß jemand, woran das liegen kann? Ich hab keine Ahnung, wo ich anfangen soll zu suchen.

Gruß,
Daniel
 

marzl

Well-Known Member
guck mal in deine /etc/host datei.
is dort dein rechnername drin? mit ip? :)

sendmail hängt meist wenn er den namen nicht auflösen kann.
 

ChipTango

New Member
Jo, iss vorhanden.
/etc/hosts
127.0.0.1 localhost.planets.vpn localhost
192.168.10.1 neptun.planets.vpn neptun
192.168.10.1 neptun.planets.vpn.

Ich hab allerdings mittlerweile ein bisschen an den Dateien /etc/mail/local-host-names, /etc/mail/access und /etc/mail/aliases rumgefummelt, damit sendmail auch Mail von meiner dynamischen Adresse (dyndns.org mit ddclient als Updater) akzeptiert.

Das Problem ist allerdings schon vor meinen Eingriffen da gewesen.

Gruß,
Daniel
 

d4mi4n

volksoperator on duty
hängt der an nem router dran? bei mir wars so daas ich innder rc.conf den routerr nnicht angegebenn hab :o)
 

Miggo

Well-Known Member
Original geschrieben von meyermann
Hatte mal ähnliches Problem mit 5.1,
hatte sich erledigt nachdem sämliche IPv6 Unterstützung
aus dem Kernel entfernt war.
Dito. Das dürfte mit hoher Wahrscheinlichkeit daran liegen. Bei mir wars auch danach erledigt, da mein Computer vorher immer DNS-Anfragen gestartet und auf deren Timeout gewartet hat.
 

ChipTango

New Member
Hmmm...
Im mailllog steht ein 'gethostbyaddr(IPv6:::1) failed: 1' vor dem Starteintrag von Sendmail.....
Es schaut so aus, als hättet ihr recht....

Was muß ich denn dann alles rausschmeißen aus der Kernel-Config?
Gibt's nicht auch 'ne Methode, IPv6 im Sendmail auszuschalten? Auf 'nem anderen Rechner kann ich nämlich keinen Kernel kompilieren wg. eines Hardwareproblems :-(

Gruß,
Daniel
 

Miggo

Well-Known Member
Vielleicht die lokalen Computer auch mit IPv6 in die /etc/hosts eintragen? Würde ich zumindest vielleicht mal versuchen.
Falls du neukompilieren willst muss folgendes raus:
options INET6
 

Alexco

Well-Known Member
Bei mir startet sendmail mit
ipv6_enable="NO"
in /etc/rc.conf recht zügig. Allerdings hatte ich davor auch keine Probleme...
Versuch macht klug...
 
Oben