• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD 5.4: Load average bei 1.00 aber nichts los

asg

push it, don´t hype
Themenstarter #1
Nabend,

eben habe ich festgestellt das auf einem Server in der Firma, FreeBSD 5.4-STABLE, Dual XEON 3.06 GHz, 2GB RAM, der Load bei 1.00 liegt. Und dies bei gerade mal 20 Prozessen die auf dem Server laufen (die üblichen, sshd, getty, cron, usbd,...).

Da frage ich mich was mir das den hohen Load verursacht, die Kiste müsste sich ja langweilen.

Any hints?
 

xbit

Well-Known Member
#2
Hi,

ich bin mir nicht 100%ig sicher, aber vielleicht Festplatten I/O ueber laengere Zeit bei Hardware Problemen? Vielleicht laeuft auch ein Prozess mit 100% CPU Last seit geraumer Zeit.

HTH
 

asg

push it, don´t hype
Themenstarter #4
Der macht nichts. Also wirklich nichts. Ich hatte alle Dienste abgeschalten. Load bleibt bei Konstant 1.xx.
Bisher dachte ich immer, he, da greifen knapp 100 User drauf zu und rufen xfce4 auf, inkl. OO.org und FireFox, wird schon passen. Aber auch ohne das jemand angemeldet ist, keine Dienste aktiv, der Load bleibt der gleiche.

So, die Kiste ist ne SMP Kiste. 2xXEON. Ich habe, SMP natürlich im Kernelo aktiviert. Dabei ist dann auch HTT aktiv.
Und DAS scheint das Problem zu sein. Ohne SMP im Kernel rennt die Kiste auf einer CPU und der Load liegt da wo er sein soll, bei 0.0x.
Mit SMP und HTT ist der Load minmial immer auf 1.xx.

Ok, wie kann man denn HTT abschalten?
Ein
Code:
machdep.hlt_logical_cpus=1
brachte nichts.
Ein
Code:
sysctl -a hw.ncpu
hw.ncpu: 4
sagt mir dann immer noch das 4 CPUs im System bekannt sind.
Welcher Schalter fehlt mir denn da? Also, nur HTT-Support ausschalten, nicht SMP.
Das habe ich noch nicht versucht, und evtl. liegt da ja das Problem.
 

k33n

knochenbrecher
#7
Wie aktuell ist dein Stable?

/usr/src/UPDATING

---schnipp----
20050513: p1 FreeBSD-SA-05:09.htt
Add a knob for disabling/enabling HTT. Default off due to information
disclosure on multi-user systems.
---schnapp----


gruss k33n
k33n
 

asg

push it, don´t hype
Themenstarter #8
@Maledictus, k33n
Ja, HTT sollte per default "off" sein.
Ich habe in der /boot/loader.conf:
Code:
machdep.hlt_logical_cpus=1
Und kein
Code:
machdep.hyperthreading_allowed
stehen. Was auch immer für zweitere "on" und "off" ist.

Im kernel selbst nur
Code:
options         SMP
eingetragen. Bzw. habe ich die Einträge
Code:
options         MPTABLE_FORCE_HTT       # Enable HTT CPUs with the MP Table
options         NO_MIXED_MODE           # Disable use of mixed mode
wieder rausgenommen.

Warum auch immer da gerade HT am rennen ist.
Naja, ist ja auch nur eine Vermutung das dies das Problem mit dem Load sein könnte. Stelle ich SMP gänzlich ab, als weg mit der Option im Kernel, dann ist der Load ja ok.