• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD 6.1 Installation / xorgcfg Grafikartendatenbank fehlt

Themenstarter #1
Ich habe mir das Buch FreeBSD 6 Unleashed mit der FreeBSD version 6.1 gekauft.

Vor Jahren hatte ich schon einmal BSD installiert und problemlos.

Momentan suche eine Serverlösung und daher wollte ich es erneut mit FreeBSD probieren.

Die Installation verläuft bis zu dem Punkt "Setting up the X window System" problemlos.

Der Befehl Xorg -configure erkennt auch sämtliche Hardware. In der xorg.conf.new konnte ich keine Fehler erkennen. Jedoch der Xserver startet nicht mit dem Befehl Xorg -config xorg.conf.new. Der Monitor sagt, dass ich eine falsche frequenz habe. Ich habe es mit zwei verschiedenen Monitoren probiert, bei Beiden klappt es nicht.

Nun zur Hardware:

Nvidia FX5500 256MB
Acer 22" 16:10

Beide werden von Xorg -configure erkannt.

nicht weiter schlimm und ich startete xorgcfg -textmode.

Auch alles verständlich bis zum Punkt "grafikarten". In der Modelldatenbank gab es nur zwei Einträge, vmware und ati. Das sollte laut Buch anders sein. Bei den Monitoren bin ich auch verunsichert da mein Monitor 22" hat und eine Auflösung von 1680 x 1050. So etwas stand nicht zur Auswahl.

Beide werden von Xorg -configure erkannt.

Was mache ich falsch? Hat jemand ähnliche Erfahrung?
 

Manga

Well-Known Member
#2
Wenn mich nicht alles täuscht, unterstützt der Standardtreiber nur max 1024x768.
Lad Dir den Treiber von Nvidia runter, damit sollte es gehen.
 
Themenstarter #4
Habe die Ports installiert, xconfig und settings über sysinstall und nvidia-treiber über make install.

Keine Fehlermeldung.

Ich vermute, das es auch nicht an der Grafikkate liegt sondern an dem Montor. Denn ich bekomme keine Fehlermeldung sondern nur einen schwarzen Bildschirm und mein Monitor sagt Frequenz nicht unterstützt.

Selbst nach dem ich die ports installiert habe, konnte ich in der Grafikkartendatenbank unter xorgcfg -textmode nvidia nicht finden. Laut Buch sollte das nicht so sein.
 

xbit

Well-Known Member
#5
Der NVidia Treiber von xorg unterstuetzt auch hoehere Aufloesungen. Zumindest rennt der bei mir mit 1280x1024. ;)
Aber das Phaenomen hatte ich auch. In der 'xorgcfg -textmode' Variante konnte ich auch nur zwischen 'ati' und 'vmware' als Treiber waehlen, obwohl alle installiert waren.
Also einfach den Treiber in der xorg.cfg anpassen. ;)

Ist Dein Monitor ein LCD? Mir hat es dort geholfen, eine Frequenz einzustellen, da sonst die Aufloesung nicht gewaehlt werden kann. Vielleicht hilft das weiter.

Hier die Zeilen fuer die Section "Monitor".
Code:
HorizSync    31.5 - 64.3
VertRefresh  50.0 - 70.0
 

mousaka

getting older
#6
Auszug aus xorg.conf
Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync    30-107
        VertRefresh  48-120
EndSection
Hast du bei dir die Zeilen HorizSync und VertRefresh eingetragen? Die Werte musst du für deinen Monitor anpassen.

Hast du schon mal nvidia-xconfig ausprobiert? Dies sollte dir eine neue xorg.conf erstellen.

mousaka
 
Themenstarter #7
Habe nvidia-xconfig ausprobiert und die Zeilen mit dem u.g. Code ergänzt.


Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync    30-82
        VertRefresh  56-76
EndSection
Hier ist ein Link zu dem Monitor Model von Acer:
http://www.acer.de/acereuro/page9.do?sp=page4&dau34.oid=19158&UserCtxParam=0&GroupCtxParam=0&dctx1=9&CountryISOCtxParam=DE&LanguageISOCtxParam=de&ctx3=-1&ctx4=Deutschland&crc=1923308034

Ich habe noch immer das gleiche Problem das der Monitor die Frequenz nicht unterstützt.
 
Themenstarter #9
Nein macht kein Unterschied.

ich habe mir den logfile angeschaut.

Kann das Problem an der Mode liegen.

Des Weiteren auffällig ist:

FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount ist 2, should be 1; f
 

Kamikaze

Warrior of Sunlight
Mitarbeiter
#10
Die Forensuche sollte den ein oder anderen Link zu einem Modeline Generator zu Tage fördern. Damit lassen sich solche Probleme meist beheben.
 
Themenstarter #11
Habe die Output des Modeline Generator in xorg.conf eingebaut.

X -config /etc/X11/xorg.conf ergab das gleiche Problem...Frequenzen nicht unterstütz.

Hier die Modeline

Modeline "1680x1050@60" 154.20 1680 1712 2296 2328 1050 1071 1081 1103

Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync    30-82
        VertRefresh  56-76
        Modeline "1680x1050@60" 154.20 1680 1712 2296 2328 1050 1071 1081 1103
        Option      "DPMS"
EndSection
Einer der Angaben für den Modeline Generator ist Dot Clock Frequency. Ich bin mir nicht sicher welche ich habe.

Der Generator gibt mir eine Warnung:

Dot clock above maximum of 5MHz!
 

d4mi4n

volksoperator on duty
#13
auch wenn die auflösung da nicht steht kannst du sie einfach angeben, oder später in die corg.conf eintragen. Vorrausgesetzt du nutzt den nvidia treiber aus den ports.
 
Themenstarter #14

r2d2

Well-Known Member
#15
probier doch ma:
Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 82.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1680x1050"
    EndSubSection
EndSection
 
Themenstarter #16
Noch immer das Gleiche Problem: Frequenzen nicht unterstützt.

Habe ein grep (WW) aus der logdatei genommen; folgendes Ergebnis:

1 Eintrag:

(WW) The directory "/usr/X11R6/lib/X11/fonts/CID/" does not exist.

Keine error (EE).
 
Themenstarter #20
Ja, ich verwende den nvidia Treiber. Während der installation wurde der Treiber direkt von der nvidia Seite runtergeladen.

Da ich den GUI noch nicht konfiguiriert habe, weis ich nicht wie ich die beiden Dateien posten könnte.

Beide grep (WW) oder (EE) ergaben außer den vorangegangenen Post nichts.

Könnte die schnurrlose optische Maus Probleme erzeugen?
 
#21
Bin ja nur Anwender und faul, aber wenn X -configure die Graphikkarte erkennt, fasse ich den Abschnitt in der xorg.conf nicht mehr an. Wahrscheinlich entgeht mir dann Tuning und damit Leistung, aber ich kenn' mich zu wenig aus.

HTH
 
Themenstarter #23
Also, es hat doch geklappt, bin aber nur halb glücklich....

Habe in der subsection "Display" einfach noch eine line mit Modes drangehangen und zwar

Modes "1680x1050" "1024x768"

Anscheinend kann in meinem Fall X nur mit einer Auflösung von "1024x768" gestartet werden, denn ohne "1024x768" heißt es: Frequenzen werden nicht unterstützt.

Wie genau kann mir der Modeline Generator dort weiterhelfen. Unter Windows XP konnte ich ja auch eine Auflösung von "1680x1050" einstellen.
 

Henry

Active Member
#24
Hatte mal das gleiche unter Linux. Habe dann in irgendeinem Forum (Debian oder Ubuntu) den Hinweis gefunden, dass die max. Aufloesung durch einen Eintrag in einer Bootdatei bestimmt / limitiert wird. (unabhaengig von Xorg.conf). Weiss aber jetzt leider nicht mehr welche das war.

Gruss
 
Themenstarter #25
HENRY! spanned was du da schreibst...

Egal.. ich habe die Ausflösung jetzt auf 1280x1024 und es funktioniert. Ist natürlich nicht toll wenn man ein Monitor hat der 1680x1050 kann.

Wichtig war die Modes und die DefaultDepth anzugeben.

Ich habe das Thema aber noch nicht abgehakt und werde heute abend in einem englisch-sprachigen Forum das Thema angehen.

Wenn sich was ergibt, werde ich hier was posten.