• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD 8.0 IPv6

sebast

Well-Known Member
Themenstarter #1
Hallo zusammen,

mein Provider hat mir jetzt ein IPv6 Netz zur Verfügung gestellt, was etwas komisch aufgebaut ist.
Ich habe ein /64 bekommen aber mein Gateway liegt nicht im gleichen Netz sondern ist in einem /59. Fragt mich jetzt nicht, wie ein Provider so etwas machen kann.

Für Linux gibt es auch eine Anleitung. Es wird eine extra Route mit der Gateway IP auf das eth0 gelegt und schon kann das Gateway benutzt werden.

Code:
ip -6 route add <IPv6 Gateway> dev eth0
ip -6 route add default via <IPv6 Gateway>
Also habe ich versucht dieses bei FreeBSD zu reproduzieren mit

Code:
route -n add -host -inet6 <IPv6 Gateway> -iface re0
route –n add –inet6 default <IPv6 Gateway>
Leider kann ich die Gateway IP nicht erreichen...
 

Crest

rm -rf /*
Mitarbeiter
#3
Trage in /etc/rc.conf
Code:
ipv6_default_interface="re0"
ein und berichte vom Ergebnis. Wieso zu Hölle verteilt der Provider nur in /64 pro Vertrag? Wenigstens nen /56 wäre nett.
 

sebast

Well-Known Member
Themenstarter #4
Also ich habe jetzt das Gateway auf re0 gesetzt.

Leider geht es nicht...

Code:
ping6: sendmsg: Operation not permitted
ping6: wrote ipv6.l.google.com 16 chars, ret=-1
Ich habe kein Problem damit, wenn mir der Provider nur ein /64 gibt aber wenn das Gateway in einem anderen Netz ist.
 

Florian88

Well-Known Member
#5
Kannst du mal bitte ein ifconfig re0 und ein netstat -r posten?

Ich habe kein Problem damit, wenn mir der Provider nur ein /64 gibt aber wenn das Gateway in einem anderen Netz ist.
Verstehe ich das richtig:
Du hast ein /64 bekommen, dass du auf dein internes Interface des Routers legen kannst und eine IP-Addresse mit einem /59 Präfix das du auf dein externes Interface legst um das Gateway zu erreichen?
 

sebast

Well-Known Member
Themenstarter #6
Nicht ganz.

Ich habe ein /64 für den Server bekommen aber das Gateway liegt in einem /59. Also auserhalb vom eigentlichen /64.

Code:
re0:
	inet6 2a01:4f8:110:42c1::2 prefixlen 64
Code:
default                           00:1d:92:39:32:b3             US          re0
2a01:4f8:110:42c0::1              00:1d:92:39:32:b3             UHS         re0
2a01:4f8:110:42c1::/64            link#1                        U           re0
2a01:4f8:110:42c1::2              link#1                        UHS         lo0
Eine Vermutung ist noch, dass ich ggf. die Gateway IP fest mit ndp definieren muss. Also den Neighbor fest einstelle. Ich sehe die Local IP vom Gateway aber der rechner vesteht es anscheint nicht richtig…

Das Problem kenne ich z.B. zwischen Cisco Router und einer ASA Firewall. Dort muss ich auch den neighbor fest definieren…

Ich kenne bis jetzt keinen Provider, der dieses so macht. Gut das es nur ein Spielserver ist…
Meistens bekomm ich immer ein /64 als Transfernetz und ein /48 für meine Hardware dahinter oder für einzelne Server ein /64 aber das Gateway ist die erste IP-Adresse aus dem Netz.

Mit meinem IPv6 Tunnel hatte ich nie so ein Problem….
 
Zuletzt bearbeitet:

sebast

Well-Known Member
Themenstarter #8
So habe jetzt noch einmal etwas getestet und mit „pointtopoint“ geht es auch nicht. Ich habe schon nach einer Funktion gesucht, wie ich den neighbor manuell setzen kann. Leider habe ich dazu nichts passendes gefunden. Mit ndp kann ich mir eine Liste ausgeben lassen und angeblich auch bearbeiten aber die Manpage ist da etwas komisch geschrieben.
 

MuffiXXL

Well-Known Member
#10
Das istn stinknormaler Point-toPoint-Link. Bei IPv6 verstehe ich zwar den Sinn hinter ptp nicht, bei IPv4 ist das ja durchaus nützlich...
Unter Solaris habe ich so ein teil letztens konfiguriert. Musste ien bisschen mit route rumspielen, aber dann lief das recht flott. Schau mal bei Hetzner ins Wiki, die beschreiben das relativ gut.

Edit: Da war ich wohl zu spät.
 

sebast

Well-Known Member
Themenstarter #11
Habe ja die doku aus dem wiki genommen und auf FreeBSD abgewandelt. Warum es aber nur geht, wenn ich den neighbor definiere weiß ich nicht.

Wenn ich ein Ping sende, sendet mein Rechner sogenannte neighbor Pakete mit raus aber die werden vom Router nicht verarbeitet.