• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD auf Strato mit Qemu - Vorkonfiguration?

Benedikt

Well-Known Member
Themenstarter #1
Hallo zusammen,

Hier sind doch sicherlich einige, die schonmal einen Server per Qemu installiert haben, so wie das bei Strato hin und wieder gemacht wird.

Ich hab das gleiche vor und wollte von euch wissen, ob ich mir ein Qemu-Image erzeugen kann, das ich komplett aufsetze (also sämtliche Software installieren) und dann für die Installation verwende.

Dann würde ich mir viel Zeit sparen beim Umstieg, da ich den Server bis zum Schluss laufen lassen könnte und dann das vorinstallierte Image draufspiele.

Ginge das oder scheitert das an der Partitionierung der physischen Festplatten?

Danke für eure Hilfe!!!!
 

Benedikt

Well-Known Member
Themenstarter #3
Ach dein Blog ist das :)

Ja, den Beitrag habe ich schon gelesen, aber war mir nicht sicher ob das nicht aufwändiger ist als Qemu.

Mein Ziel ist es FreeBSD 7.1 AMD64 auf einen MR5 von Strato zu installieren.

Dann hab ich gleich ne Frage zu dem abgebildeten Patch:
Wann und wo muss ich den wie anwenden? Ich habe mit Patches fast noch nie etwas zu tun gehabt. Kannst du mir hierzu den Konsolenbefehl sagen? Das wäre super.

Ich schau mir das mit deinem Vorschlag mal an, vielleicht ist es in der Tat einfacher, aber es gibt nicht soviele Dokus und Infos hab ich den Eindruck, oder ich habe falsch gesucht.

Vielen Dank für den Hinweis!!!
 

steinex

Well-Known Member
#4
Im Prinzip tut der Patch nichts weiter als in der Datei "mfsbsd-1.0-beta2/scripts/rootpw" nach dem echo folgende Zeile einzufügen:
Code:
echo 'ttyd0   "/usr/libexec/getty std.57600"  dialup  on insecure' > /etc/ttys
Ansonsten kann ich dazu nicht viel sagen, ausser das Qemu für mich nie wirklich in Frage kam. Einfach ein fremdes Image benutzen wollte ich nicht (bin etwas paranoid was das angeht) und selbst eins bauen ist halt wirklich Arbeit. :-)

Schaus dir mal an, würde mich über ne Rückmeldung freuen.

Ciao,
Frank
 

Benedikt

Well-Known Member
Themenstarter #5
Ich werds mal mit deiner Variante probieren. Mehr wird mir nicht übrig bleiben.

AMD64 wird auch unterstützt, also sollte das funktionieren.

Danke dir. Wenn ich fragen habe, schick ich dir ne Nachricht, ist das ok? Am Wochenende solls losgehen.
 

Benedikt

Well-Known Member
Themenstarter #7
Frank, in einem anderen HowTo habe ich folgende Netzwerkeinstellungen gefunden:

hostname="h1447235.stratoserver.net"
network_interfaces="lo0 em0"
defaultrouter="85.214.64.1"
ifconfig_em0="inet 85.214.105.194 netmask 255.255.192.0 broadcast 85.214.105.255"
static_routes="net1 net2"
route_net1="-net 85.214.64.1 -interface em0 -iface -cloning"
route_net2="-host 85.214.105.194 -interface lo0 -iface"

Was hälst du davon? Musstest du auch Routen hinzufügen? In der rc.local löscht er dann folgende Route raus:

route delete -net 85.214.105/18

Braucht man das oder reicht dein Setting aus IP und Defaultrouter aus?
 

steinex

Well-Known Member
#8
Das sind diese wirren Netzwerkeinstellungen bei Strato, über die ich im Blog bereits sprach - wie ich hinterher herausfand sind diese nicht notwendig, IP und defaultrouter reichen völlig.
 

Benedikt

Well-Known Member
Themenstarter #10
Ich hab noch ein paar Fragen, die aus deinem Blog-Eintrag leider nicht hervor gehen:

- Wie kopiere ich das Image-File auf den Server? Per SFTP auf /dev/sda?
- Ich reboote den Server, dann ist das mfsBSD im RAM, richtig?

Was kommt dann? Dann starte ich sysinstall und installiere ganz normal FreeBSD?

Sorry für die blöden Fragen, aber ich will nicht mitten drin aufhören und fragen wie das läuft.

Danke für deine Hilfe!!!

EDIT: *nag* Ich hab das Handbuch gefunden :-) Da ist alles sehr gut dokumentiert. Sorry.
 
Zuletzt bearbeitet:

Benedikt

Well-Known Member
Themenstarter #12
Ich habe es mehrfach geschafft mfsBSD zu starten, aber wenn ich die FEstplatte formatieren will beschwert er sich, dass er nicht auf "/var" bsp mounten kann.

Was mache ich falsch?
Muss ich in den Options was setzen? Die Slices erstellen funktioniert, aber danach der Schritt mit den Mountpoints nicht mehr...

Ich bitte dringend um Hilfe!!