• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD DSL

Themenstarter #1
Hallo!


Mein FreeBSD-Rechner kann keine PPP-Verbindung herstellen.
FreeBSD Version ist 9.0-Release, DSL-Provider ist Congstar.

Das Verbinden geht ganz am Anfang schief noch bevor
Zugangsdaten abgefragt werden.

Im PPP-Log steht:
tun0: Phase: deflink: Connected!
tun0: Phase: deflink: opening -> dial
tun0: Phase: deflink: dial -> carrier
tun0: Phase: deflink: Disconnected
tun0: Phase: deflink: carrier hangup
tun0: Phase: deflink: Connect time: 5 secs: 0 octects inm 0 octects out
tun0: Phase: total 0 bytes/sec, peak 0 bytes/sec on Sat Jul 18 12:39:29 2020
tun0: Phase: deflink: hangup -> opening
tun0: Phase: deflink: Enter Pause (30) for redialing

wiederholt sich dann alle 30 Sekunden.

Kann mir jemand helfen?

Tschüß
 

Zirias

Well-Known Member
#2
ppp ist Teil von base, erster Reflex wäre also grundsätzlich: aktualisiere mal auf eine nicht-antike Version.

Abgesehen davon wären natürlich Details wie z.B. der (anonymisierte) Inhalt von /etc/ppp/ppp.conf hilfreich.

"Kleingedrucktes": Die älteste aktuell noch gepflegte Version ist 11.3, allerdings endet der Support da auch Ende September. Sinnvollerweise hat man aktuell die Wahl zwischen 11.4 und 12.1. Es ist zwar möglich, nicht mehr gepflegte Systeme "halbwegs" sicher zu betreiben -- aber ausgerechnet mit so einem System eine direkte Internetverbindung aufbauen zu wollen ist wirklich eine ganz schlechte Idee...
 

Rosendoktor

Well-Known Member
#3
Ich kenne jetzt Congstar und deren technische Spezifikationen nicht. Bisher kenne ich es von allen DSL Providern aber so, dass die Verbindung über PPPoE (PPP over Ethernet) lief und eine entsprechende Konfiguration des PPP Daemons erforderte.

Unter FreeBSD hab' ich da keine Erfahrung (mein DSL Router läuft mit Debian), stelle aber bei einem FreeBSD Server sowas wie eine "indirekt direkte" Internetverbindung her, über einen l2tp Tunnel mit eigenen öffentlichen Adressen. Verwendet wird dazu der mpd5, wesentlich besser als der ppp aus dem base System, und der beherrscht soweit ich gesehen habe auch PPPoE. Falls ich mit FreeBSD so wie Du eine DSL Verbindung herstellen wollte würde ich es damit versuchen. Du solltest dazu Beispielkonfigurationen im Netz finden.
 

Zirias

Well-Known Member
#4
Sorry, aber das ist unnötig. Der ppp in base kann PPPoE, funktioniert hier einwandfrei*. Ich weiß jetzt natürlich nicht auswendig, ob er das in grauer Vorzeit (9.0!) auch schon konnte...

* sowas in der ppp.conf genügt:
Code:
telekom:
 set device PPPoE:<interface>
 set authname <login>
 set authkey <password>
 set dial
 set login
 add default HISADDR
(<interface> ist das netzwerkinterface, auf dem das DSL modem erreichbar ist, z.B. em0 ...)

edit: Übrigens, FALLS die Konfiguration richtig ist und der ppp in FreeBSD 9 tatsächlich auch schon PPPoE korrekt kann -- es besteht immer auch die Möglichkeit, dass der ISP gerade selbst ein Problem hat. Ich habe Donnerstag Nacht ziemlich genau ein Log dieser Struktur bei mir gesehen, nach 15 Minuten war der Spuk wieder vorbei und die Internetverbindung war wieder da :) Trotzdem würde ich dringend davon abraten, eine Internetverbindung auf einem veralteten System aufzubauen...
 
Zuletzt bearbeitet von einem Moderator:

Zirias

Well-Known Member
#5
Hm, die ganzen Zeilen nach "telekom:" waren ein space eingerückt, mein letzter Edit scheint das kaputtgemacht zu haben, und jetzt kann ich es nicht mehr editieren. Bin mir nicht sicher, ob die Einrückung überhaupt relevant ist für ppp.conf -- aber das ist jedenfalls n Bug in der Forensoftware hier ;)
 
D

das.chaos

Guest
#6
In etwa so:

Code:
default:
   set device PPPoE:<nic>
   set MTU 1492
   set MRU 1492
   set dial
   set timeout 0
   set crtscts off
   set spped sync

   disable lqr
   disable deflate
   disable pred1
   disable vjcomp
   disable acfcomp
   disable protocomp

   set log Phase LCP IPCP CCP Warning Error Alert
   set ifaddr 10.0.0.1/0 10.0.0.2/0 0.0.0.0 0.0.0.0

   add default HISADDR

   set login

<label>:
   set authname <zensiert>@<provider>.<tld>
   set authkey <zensiert>
Wobei die <nic> oftmals ein vlanN Device ist.
 
Themenstarter #7
Hallo!

Also: DSL mit FreeBSD hat bis 2019 funktioniert. Dann kam ein Schrieb von O2 (O2 can't do), daß auf tolle neue Technik umgestellt wird. Ab dem Umstellungsdatum funktionierte es nicht mehr. Ich bin dann zu Congstar gewechselt, nur um dann festzustellen, daß es dort auch nicht funktioniert.

Das war die ppp.conf

> default:
> set log Phase Chat tun command
> set device PPPoE:nfe0
> set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.255 0.0.0.0

>congstar:
> set authname [mein Benutzername]
> set authkey [mein Passwort]
> set dial
> set login
> add default HISADDR

ich habe dann diese Anleitung ausprobiert:
https://netzhansa.blogspot.com/2010/02/telekom-vdsl-mit-freebsd.html

dementsprechend steht in ppp.conf nun

> set device PPPoE:vlan0

und in rc.conf:

> cloned_interface="vlan0"
> ifconfig_vlan0="vlan 7 vlandev nfe0"

Ich bekamm dann erst neinen neuen Fehler nämlich
> ppp: tun0: Chat: Failed to open device

Wenn ich dann ppp stoppe und vlan0 von mit
ifconfig vlan0 create vlan 7 vlandev nfe0
neu anlege, dann bekomme ich den alten Fehler wieder.

Tschüß
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#9
Es gibt leider nicht den einen Telekomanschluss. Das betrifft auch Reseller.

Nicht alle Telekomanschlüsse brauchen den VLAN-Tag. Das kann man im Zweifel einfach ausprobieren. Wenn sie ihn brauchen, ist bei der Telekom selbst VLAN 7 normales Internet und VLAN 8 ist Magenta-TV. Reseller nutzen teilweise andere VLAN IDs.

Der Nutzername darf nur mitgeschickt werden, wenn die Authentifizierung über Nutzername und Kennwort erfolgt. In dem Fall muss der Nutzername bei der Telekom selbst und den meisten Resellern wie hier erklärt angegeben werden: https://telekomhilft.telekom.de/t5/...hl-ueber-einen-Router-herstellen/ta-p/3654990 Liegen mehrere PPPoE-Verbindungen auf einem Anschluss, werden die Mitbenutzernummern beginnend bei 0001 hochgezählt. Das ist auch dann notwendig, wenn die Verbindungen bei verschiedenen Anbietern gebucht sind.
Erfolgt die Authentifizierung über die TAL, werden weder Nutzername noch Kennwort mitgeschickt, sonst funktioniert es nicht. Der Login schlägt sonst immer fehl. Authentifizierung über die TAL kann bei der Telekom im Kundencenter eingestellt werden (heißt "Passwortlose Verbindung" oder so ähnlich), bei Resellern ist es meist vorgegeben. Authentifizierung über die TAL sollte man wenn möglich abschalten, denn wenn der unterbezahlte Techniker im Anschlusskasten die falschen Drähte umsteckt, lädt der nette Nachbar vielleicht seine Kinderpornografie über deine Leitung.
 
Themenstarter #10
Hallo!

Das Gerät in der TAE-Dose ist eine FritzBox 7430, aber ich habe es auch schon mit einem DSL-Modem (Allnet) probiert, es ändert sich nichts. Tatsächlich wird im Log immer dasselbe angezeigt. Egal ob an der Box, am Modem oder sogar wenn gar nichts angeschlossen ist! PPP versucht also nicht mal mit einer Gegenstelle Kontakt aufzunehmen, geschweigedenn Benutzerdaten zu übertragen.

Tschüß
 

mr44er

moderater Moderator
Mitarbeiter
#11
Anders stumpf gefragt:
Kann sich die Fritzbox selbst mit den Daten einwählen, so als Test? Hab das nicht 100% rauslesen können, ob du das getestet hast. Wenn sich die Fritzbox schon selbst nicht einwählen kann, ist die Kuh woanders auf dem Eis. ;)
'nfe' ist sehr alte Hardware -> Sind die Kabel ok? Kann es vielleicht sein, dass es noch ein altes crossover-Kabel ist und mit 'neuem Gerät' versagt das auto-sensing?
Weiteres random:
bin nicht sicher, ob sich jede Fritzbox auf pppoe-passthrough umstellen lässt
waren deine beiden Testgeräte auf pppoe-passthrough eingestellt?
bei meinem kleinen Lokal-ISP gibt/braucht es kein VLAN-tag
 
Themenstarter #12
Hallo!

Die FritzBox kann sich einwählen, die Benutzerdaten sind auch in Ordnung, es hat ja wie schon erwähnt früher funktioniert, vor der Technikumstellung. Und die Windoof-Kiste kommt ja ins Netz, wie könnte ich hier sonst schreiben :)

Im Log steht ja nur "0 octets in 0 octets out" Benutzerdaten werden also gar nicht übertragen /geprüft.
Log ist übrigens dasselbe, wenn weder FritzBox noch Modem angeschlossen sind! Es geht also schon ganz, ganz am Anfang schief.

Tschüß
 
Themenstarter #14
Hallo!

Da nfe0 vorher richtig war und die Netzwerkkarte immernoch dieselbe ist,
warum sollte es dann nicht mehr richtig sein?

Hat jemand eine Idee, wie ich wenigstens an etwas aussagekräftigere Fehlemeldungen kommen kann?
Im Log steht ja immer dasselbe, selbst wenn gar nichts angeschlossen ist. So erfahre ich ja nicht
was schiefgeht.

Tschüß
 

CommanderZed

OpenBSD User
Mitarbeiter
#15
Hmmm die Anleitung die du verlinkst ist von 2010, dein Release ist ja von 2012 für mich als absoluter FreeBSD laie - villeicht lohnt sich erstmal Update, in dem vill. das ein oder andere gefixt wurde?
 

PMc

Well-Known Member
#16
Aussagekräftige Fehlermeldung ist schwierig. Das kracht an der Stelle, wo es das Netz öffnet, und irgendwie gibt es keine PPPoE kommunikation - das kann dann halt alle Ursachen haben von Kabelbruch bis zu Provider down.

Als bei mir vlan Tagging kam, sah es auch genau so aus. sogar die 5 Sekunden stimmen überein. vlan eingeschaltet und es ging. Da muss man halt beim Provider anrufen und fragen welche nummer die richtige ist (und das kann mittelprächtig unterhaltsam werden - vergleichbar mit einem Postzusteller, der nicht weiß was ein Briefkasten ist).

Ansonsten würde ich einfach mal tcpdump auf der Leitung laufen lassen - das geht ja, das ist ja ethernet. Da sieht man dann zumindest ob überhaupt was passiert. (tcpdump -Ai vlan0)