FreeBSD friert ein | Linux wacht nicht immer aus suspend auf

pillow

Well-Known Member
Hallo

hab mir vor einiger Zeit einen Mini zugelegt

leider "friert" FreeBSD 13.1 mit xfce4 ein, die Maus lässt sich noch bewegen, Fenster nicht verschieben, Menüs Programme lassen sich nicht klicken.
Wenn ich auf ein TTY wechsle kann der Mini mit den command line tools genutzt werden.

auf einem TTY läuft taif -f /var/log/messages leider gibt es keine Meldung zu diesem Ereignis aus.



Bei diversen Linux Installationen konnte ich folgendes beobachten

ein journalctl -f das mir auf einen anderen Rechner ausgegeben wird, zeigt keine Meldungen zum Ereignis

ein erneutes verbinden über ssh auf die "eingefrorene" Maschine lässt manchmal diese aufwachen

ein genervtes intensives Tastatur gehämmere :grumble:bringt die Maschine manchmal auch wieder an den Start

journalctl -f gibt keine Meldung aus .

ein Filtern der log mit journalctl nach Datum Uhrzeit zeigt kein Ereignis an

nach einem Linux Neustart sieht die anzeige erst mal so aus :eek:
nach einem Win10 Start und einem weiterem Neustart ist die Monitoranzeige 100% o.k.
beim Spielen keinerlei Grafik Probleme.

FreeBSD 13.1 verhält sich unter Windows 10 in einer VirtualBox wie oben beschrieben .


Nachtrag : Standard Partitionierung OHNE swap
danke fürs lesen
 

Anhänge

  • IMG-20220623-WA0000.jpg
    IMG-20220623-WA0000.jpg
    842,7 KB · Aufrufe: 91
Zuletzt bearbeitet:

pillow

Well-Known Member
Hi

Nachtrag
Wenn Linux sich entschließt doch wieder aufzuwachen ist die Monitorauflösung auf die höchste Auflösung umgestellt

schönen Tag noch
 

mr44er

moderater Moderator
Teammitglied
nach einem Win10 Start und einem weiterem Neustart ist die Monitoranzeige 100% o.k.
Schon mal gut, aber andererseits sind die Maschine/Treiber auch oft nur auf genau dieses OS optimiert, damit das klappt.

Grob aus dem Bauch raus würde ich mich im BIOS mal zu allen Einstellungen bezüglich standby/sleep umschauen. Je tiefer der Modus, desto geringer ist die Erfolgswahrscheinlichkeit mit anderen Systemen. Manchmal reichts einfach nur S4 statts S5 maximal zu fahren oder GPU+Keyboard auszuklammern.

Da hilft nur frustiges Rumprobieren, jede Kiste reagiert anders und es reicht manchmal auch schon ein gestecktes USB-Gerät, um alles zu versauen.

Hier gibts ein paar Hinweise: https://wiki.freebsd.org/SuspendResume
 

cabriofahrer

Well-Known Member
Ich glaube vor Jahren mal etwas über Probleme mir Suspend/Resume bei FreeBSD im Zusammenhang mit Radeon-Grafik gelesen. Da konnte man mit irgendwelchen Einträgen etwas erreichen. Vielleicht mal zu dieser Thematik suchen.
 

ath0

Well-Known Member
Hallo

hab mir vor einiger Zeit einen Mini zugelegt

leider "friert" FreeBSD 13.1 mit xfce4 ein, die Maus lässt sich noch bewegen, Fenster nicht verschieben, Menüs Programme lassen sich nicht klicken.
Wenn ich auf ein TTY wechsle kann der Mini mit den command line tools genutzt werden.

auf einem TTY läuft taif -f /var/log/messages leider gibt es keine Meldung zu diesem Ereignis aus.

FreeBSD 13.1 verhält sich unter Windows 10 in einer VirtualBox wie oben beschrieben .
Also AMD Graphic und FreeBSD hat in der Vergangenheit nicht so die besten Ergebnisse gebracht, da meine letzt ATI ne gammel passiv gekühlte für meinen Server (weil es sonst nicht startet) ist und die auch schon ü 10 Jahre alt ist, kann ich zum Aktuellen Stand nichts sagen. Aber so wie du es Beschreibst ist dein Problem wohl genau hier zu suchen. Welchen Treiber nutzt du und wie ist x configuriert? Gibts im Xorg.0.log was das weiter hilft?
 

pillow

Well-Known Member
hi,

hat mich jetzt doch nicht in ruhe gelassen, i.M. habe ich Freebsd 13.1in einer VirtualBox laufen mit win 10, das Ergebnis ist dasselbe :-(


ciao
 

Anhänge

  • Xorg.0.log.txt
    52,2 KB · Aufrufe: 54

Sickboy

Müßiggänger
Habe seit 13.1 Probleme mit suspend/resume auf dem ThinkPad. Hast du mal FreeBSD 13.0 ausprobiert?
 

pillow

Well-Known Member
hi

Jetzt hab ich nochmals nachgedacht , wenn Freebsd weiter auf TTY* läuft könnte die Desktop-Umgebung der Verursacher sein, nachdem ich xfce deinstalliert habe und i3 am start habe läuft der kleine jetzt 1Tag ohne einzufrieren.

@Sickboy die 13er unterstützt die Netzwerkkarte (Intel(R) Ethernet Controller I225-V) leider nicht.

Wenn alles so weiter läuft werde ich FreeBSD nochmals auf die SSD schreiben und weiter Berichten.

danke
 

bsd4me

Well-Known Member
Tja, könnte und wird sicherlich ein Hardwareproblem sein. Ich habe FreeBSD 13.1 unter xfce4 auf einem Lenovo Laptop W530 und mehreren PC's am laufen - ohne Probleme ;-) Vielleicht ist das ähnlich kompliziert wie mit meinem Samsung Android Handy, auf dem auf einmal keine Tastatur mehr auf dem Touchscreen war. Anmelden per Passwort war nicht mehr möglich. Und ich hatte viel probiert: soft reset mehrmals, Samsang angeschrieben und die haben mir Tipps gegeben, die alle nichts gebracht haben. Geholfen hat ein USB Adapter, womit ich eine USB Tastatur anschliessen konnte und schwupps, war das Problem in Kürze weg. Ich habe einfach eineige Caches gelöscht, auch von dieser Tastatur App. Doof ist das schon. Und der Service von Samsung schien auch nicht die meiste Ahnung zu haben... Naja, jetzt geht es wieder - und das ist schön :-) Dir alles Gute und viel Erfolg! Grüsslies, Norbert
 

Yamagi

Possessed With Psi Powers
Teammitglied
Ein offensichtliches Problem ist, dass Xorg den generischen Vesa-Treiber nutzt. Dabei müsste die integrierte Radeon-GPU durch DRM unterstützt sein.
 
Oben