• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD mit aktuellen NVIDIA Treibern...

ludi

Well-Known Member
Themenstarter #1
Hi,

Vorwort:

das HOWTO-FreeBSD-NVIDIA deshalb, weil ich selbst drei (faule) Tage damit beschäftigt war, meine GeForce FX 5200 NVIDIA Grafikkarte für FreeBSD zu installieren.
(Grund: FreeBSD5.1 kennt nur die "FX 5800" und den generic "nv" Treiber, somit war X für diese Grafikkarte, bzw. den Chipsatz nicht möglich).

Es ist im Allgemeinen auch sehr ratsam die offiziellen NVIDIA Treiber zu installieren, da "nv" generisch ist und nicht alle "Features" der Karte lädt.

Ich gehe davon aus, du hast FreeBSD 4.8+ installiert und bisweilen liegen keine größeren Systemfehler vor.

Schreibfehler koennen, sollten aber nicht vorkommen. Der Inhalt ist bzgl. des techn. Fortschritts relativ.

Mein System (eine der Boxen):

subzero# uname -a
FreeBSD subzero 5.1-RELEASE-p2 FreeBSD 5.1-RELEASE-p2 #1: Mon Aug 25 21:03:24 CEST 2003 root@subzero:/usr/src/sys/i386/compile/MYKERNEL i386

Siehe auch: (sec-01) der /1.0-4365/README.txt, welche Kernel Typen unterstützt sind...oder bald werden?


HOWTO:

1. Es bedarf einer Intakten Internetverbindung um an die aktuellen Treiber von NVIDIA zu gelangen. Blah, die aktuellen Treiber direkt vom Silicon Hersteller:

http://www.nvidia.com/object/linux.html

Siehe unter:

Free BSD
Latest Version: 1.0-4365

2. Thema RTFM, tut das also,
http://download.nvidia.com/freebsd/1.0-4365/README.txt

und startet derweil den download des Treiber Tarballs,
NVIDIA-FreeBSD-x86-1.0-4365.tar.gz

3. Ausziehen und Poppen:

$> tar -xfvz NVIDIA*
$> cd /NVIDIA*4365
$> make setup

So, anbei wird empfohlen den AGP Support zu laden,

$> edit /etc/rc.conf
agp_load="YES"

$> reboot

Die Installation verläuft reibungslos und es sollte ein reboot folgen um die Treibermodule in den Kernel zu laden. (Module nvidia.ko)

4. Prüfen der Kernel-Boot-Meldung mit dmesg:

$> head /var/log/dmesg.today

oder:

$> dmesg | more


...
Preload elf module "/boot/kernel/nvidia.ko" at 0x...HEXADRESSE
...

JA? Gut, weiter.

5. X :),

5a, Sicherheiten:

$> cat /vat/log/dmesg.today |grep nvidia

Output so aussehen:

Preload elf module "/boot/kernel/nvidia.ko" at 0x...HEXADRESSE
nvidia0: <GeForce FX 5200> mem 0x...HEXADDRESSE, 0x...HEXADDRESSE-HEXADDRESSE irq 11

Somit wurde eure Karte vom System erkannt und ist bereit.
Ich empfehle den "irq wert" (11 in meinem Falle) zu merken!

5b, Ja:

Entweder: &> xf86cfg -textmode
Oder: $> xf86cfg

Ich empfehle zuerst _ohne_ Option "-textmode" zu versuchen, es wird sich zeigen ob die Karte soweit einwandfrei funktionstüchtig ist und ihr könnt den X Server per GUI konfigurieren.

-Für Schäden am Monitor oder an der Grafikkarte übernehme ich keine Haftung-

Geklappt?

Nein, dann _mit_ Option "-textmode"

So, Mouse, Keyboard sollten eingerichtet sein - schon bevor wir überhaupt HIER sind.

Device, unser Card-type (Card0) wird sein der "FREETYPE".

Driver, wird sein "nvidia" _nicht_ "nv", damit spricht ihr die neuen Treiber an!

Screen0, ...konfiguriert euren pers. Screen.

Ihr habt fertig. Schreibt die XF86Config (/root/XF86Config.new) und ersetzt die alte im Verzeichnis /etc/X11/XF86Config .

$> mv /etc/X11/XF86Config /etc/X11/XF86Config.bak
$> cp /root/XF86Config.new /etc/X11/XF86Config
$>
$> startx

Gibt es Probleme mit dem Screen (Screen0), macht einmal folgendes:

Bei mir hat es geklappt nachdem ich im Expert Modus unter xf86cfg den richtigen IRQ Wert eingegeben habe (in meinem Falle wieder 11, siehe oben) und schreibt die XF86Config.new nocheinmal.

Es sollte nun ein Eintrag über die BusID der Karte stattgefunden haben, in der XF86Config.new:

Section "Device"
...

BusID "PCI:1:0:0"
...


Die Karte ist da und hoffentlich alle gut versorgt ... mit Bier. :)

Gruß,

aaa
 
#2
Auch für die Version 1.0-4365 gibt es mittlerweile einen Port, der die Installation automatisiert. Statt manueller Installation würde ich den vorziehen.
 

Ihlow

Active Member
#4
Jo, ich hab das jetzt alles mal ausprobiert, er hat auch meine Karte erkannst und alles, nur wenn ich dann wieder startx mache, is die farbtiefe und auflösung auf minimal eingestellt. hab aber eigentlich nichts anderes weiter verändert
 
Zuletzt bearbeitet:

Ihlow

Active Member
#5
OK, die Frabtiefe hat sich jetzt gebessert, aber die auflösung ist immernoch minimal. nach startx kommt auch ein kurzer nvidia screen, dann fluxbox.

>>>hat sich erledigt!
 
Zuletzt bearbeitet: