• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD und deutsche Tastatur in xterm

darktrym

Fahnenträger
Themenstarter #1
Vorneweg, keine Sorge ich bin nicht zu FreeBSD gewechselt. Gestern wurde mir mal wieder sichtbar wie grausam die Konfiguraton sein kann und obwohl 3 Leuten daran saßen kamen wir nicht zu einer zufriedenstellenden Lösung.
Ausgangspunkt war ein Thinkpad T430 mit FreeBSD 11 und deutscher Tastatur. In der Konsole war das Layout bereits richtig(de.acc oder so) eingestellt. Nun dachten wir NetBSDler man müsse einfach eine xorg.conf erzeugen und die üblichen Zeilen für dt. Tastatur hinzufügen, weit gefehlt.
Zusehen war ein teils verzögerter X-Start mit teils deutscher Tastatur aber Umlaute und einige Zweitbelegungen waren nicht integriert wohl aber qwertz und Pipe. Statt den Zeichen kamen Scancode in xterm, umschalten einige Modi brachte keine Besserung. Das Setzen der Tasturbelegung ad hoc via setxkbmap brachte ebenfalls keine Besserung.
Hat jemand das schon mal ausprobiert und eine Lösung dafür?

PS: Hallo Neko.
 
R

ralli

Guest
#2
Hmm, seltsam. Ich benutze FreeBSD 11 mit dem Mate Desktop und habe in der Konsole und auch in xterm deutsche Umlaute. Allerdings starte ich immer mit startx und einer selbst angelegten .xinitrc:

Code:
export LANG=de_DE.UTF-8
setxkbmap de
xset -b
xrandr -s 1280x720
exec mate-session
Eine xorg.conf erstelle ich nie manuell, sondern lasse sie mit nvidia-xconfig erstellen. Hier der Inhalt:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 375.26  (root@110amd64-quarterly-job-03)  Sat Feb 25 20:04:45 UTC 2017

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
In meiner rc.conf ist

Code:
keymap="de"
eingetragen.

Vielleicht hilft es Dir weiter.
 

darktrym

Fahnenträger
Themenstarter #3
Keymap in der rc.conf sollte doch nur Einfluss auf die Konsole haben. Und "de" alleine brachte wie schon gesagt keine Besserung.

@Neko: Teste mal die vorgeschlagenen Einstellungen.
 

darktrym

Fahnenträger
Themenstarter #5
Hätte die Zeile funktioniert, hätte ich auch keinen Thread dafür eröffnen müssen. Aber setxkbmap akzeptiert auch nicht existente Optionen ohne Feedback.