• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Frisch installiertes NetBSD bootet nach Neustart nicht

ralli

BSD Fanboy
Themenstarter #1
Gestern wollte ich mal NetBSD ausprobieren. Ich verwendete die Version 7.02. Die Installation selbst verlief auch reibungslos. Allerdings bootet NetBSD nach dem notwendigen Neustart nicht. Es gibt die Fehlermeldung, das kein BS installiert sei. Schreibt er den MBR nicht selbst nach der Patitionierung? Ich habe ganze HD gewählt. Es ist kein zweites BS auf der Platte. Dann habe ich mit Gparted nachgeschaut, das boot Flag war gesetzt. Woran könnte das liegen?
 
#2
https://www.netbsd.org/docs/guide/en/chap-misc.html

Sysinst, the NetBSD installation program usually installs the NetBSD boot manager on the hard disk. The boot manager can also be installed or reconfigured at a later time, if needed, with the fdisk command. For example:

# fdisk -B wd0



If NetBSD doesn't boot from the hard disk, you can boot it from the installation floppy and start the kernel on the hard disk. Insert the installation disk and, at the boot prompt, give the following command:

> boot wd0a:netbsd

Copy-paste vom Link, wenn das klappt fehlt evtl. der Bootmanager? Nur eine Idee
 

ralli

BSD Fanboy
Themenstarter #4
So da bin ich wieder. Das war gut gemeint, hat aber leider nicht geklappt. Deshalb habe ich das Vorhaben ad akta gelegt. Es war der dritte Anlauf. Beim ersten Mal vor drei Jahren hatte ich komische Kästchen in den Wörtern. Beim zweiten Mal erkannte er mein CD Laufwerk nicht und nun beim dritten Mal sagt er nach einem Neustart, das kein OS (MBR) vorhanden ist. Das ist eine traurige Bilanz und ich glaube nicht, das es an mir liegt.
 
#5
Habe für openbsd deutlich mehr Anläufe gebraucht, hätte alles auf Anhieb funktioniert hätte ich immernoch keine Ahnung vom System. Im Nachhinein lags immer an meiner Unwissenheit
 

holgerw

Well-Known Member
#6
Hallo @ralli,

ich hatte vor kurzem mal aus Neugier NetBSD ausprobiert, weil ich eine Basis für kodi brauchte, und NetBSD + kodi ist bei mir noch nicht ad Acta gelegt, auch wenn zur Zeit kodi nicht ordentlich baut unter NetBSD. FreeBSD ist leider mit der Intel-Grafik auf meinem alten TP R500 Notebook zu zähflüssig und NetBSD ist da im Vergleich sehr flüssig.

Die drei Mal, die ich es bisher installiert hatte, ergaben bei mir immer ordentlich bootbare Systeme, und was NetBSD betrifft, bin ich doch blutiger Anfänger :D

Magst Du nochmal im Detail beschreiben, wie Du es installiert hast?

Viele Grüße,
Holger
 

ralli

BSD Fanboy
Themenstarter #7
Danke für Eure Unterstützung. Den Installationsvorgang finde ich im großen und ganzen selbsterklärend. Er ist ja menugesteuert und dürfte nur Neulingen Fragen aufwerfen. Der Fehler ist bestimmt beim Einrichten der Festplatte zu suchen. Er fragt ja ab, ob der neueste MBR verwendet werden soll und nach der Partitionierung (ich habe keine Aufteilung vorgenommen), werden die vorgenommenen Einstellungen ja gesichert. Gelabelt habe ich nichts und von den angezeigten Bereichen den ersten (a) genommen und als bootbar gekennzeichnet. Das war auch unter Gparted ersichtlich. Allerdings stand in Gparted ein Aufrufezeichen oder Warnhinweis ohne weitere Erläuterung. Ich bin ein wenig gefrustet. Es wäre wünschenswert, wenn die Macher von NetBSD auch eine Installationsroutine wie beim FreeBSD Installer hin bekämen. Das bekommen auch Einsteiger ohne Vorkenntnisse hin. Weiß jemand, ob ich NetBSD auch in Virtualbox installieren kann und ob das funktioniert? Dann könnte ich den Ablauf besser beschreiben.
 

darktrym

Fahnenträger
#8
Ich hatte letztens vier(!) Anläufe gebraucht um auf einem X121e NetBSD zu installieren. 2x Bootloader nicht korrekt, 2x hat er einige Partitionen wie Root nicht mehr gefunden. Den Spaß mit Force hatte ich auch, weil er das im Installer nicht tut. Ich würde sagen, Sysinst hat die besten Jahren schon lange hinter sich.
Für eine Dual-Boot Konfiguration auf meinem T510 hat es bisher nicht gereicht. Sysinst, der Achtzigerjahreporno. War früher gut, will man heute aber nicht sehen.
 

ralli

BSD Fanboy
Themenstarter #9
Gut zu hören @darktrym , denn ich verweifelte schon an mir. Hier gibt es sicherlich technisch versiertere User als ich, obwohl ich mittlerweile auch schon über 42 Jahre EDV Erfahrung verfüge und deshalb auch nicht ganz unbedarft bin. Ja ich habe tatsächlich 1974 angefangern in der mittleren Datentechnik und noch mit Lochkarten gearbeitet. Die werden die jüngeren unter uns nicht mehr kennen. Im übrigen ist das Thema NetBSD für mich erledigt. Mehr möchte ich mich dazu nicht mehr äußern.
 

darktrym

Fahnenträger
#10
Kurz zur Diagnose. Er bootet also nicht den Kernel sondern bleibt weit davor hängen. Liegt zu 99% daran das er meint etwas vorzufinden wo nix ist. Nulle mal die vorderen Bereiche.
Das schlimme ist nicht das es nicht funktioniert sondern das es manchmal doch funktioniert.

Ach und eine Beschreibung wie Sysinst darunter ausschaut zum gruseln:
The installer currently uses a "homegrown" (similar to CUA) text based interface, thus being easy to use over serial console as well as on a framebuffer console.

The current installer code is partly written in plain C, but in big parts uses C fragments embedded into its own definition language, preprocessed by the "menuc" tool into plain C code and linked against libterminfo.
 

ralli

BSD Fanboy
Themenstarter #11
Ganz genau so scheint es zu sein @darktrym. Ich habe es ja nirgends mehr installiert, weil ich nur einen Rechner habe und auch arbeitsfähig bleiben muß.
 

ralli

BSD Fanboy
Themenstarter #12
Jetzt habe ich mir die wenigen youtubes Videos angeschaut, die eine NetBSD Installation zeigen. Die machen auch nichts anderes, als ich es gemacht habe. Dann habe ich Virtualbox installiert und ein i386 iso Images von NetBSD gezogen, um es in der VM zu installieren. Virtualbox unterstützt bei BSD nur 32 Bit Versionen. Funktioniert aber auch nicht. Komme nach dem Booten des Kernels nicht mal bis zum Installer, weil er einfach abbricht. Samstag bekomme ich meine neue 1TB HD, mal sehen, ob ich noch Lust auf einen weiteren Installationsversuch habe.
 

ralli

BSD Fanboy
Themenstarter #14
Hmm, schon komisch, aber bei mir werden unter Virtualbox beim Einrichten einer BSd Virtualisierung für FreeBSD, OpenBSD und NetBSD nur 32 Bit Möglichkeiten angezeigt. Wie auch immer, es funktioniert bei mir einfach nicht.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#15
Virtualbox kann nur 64-Bit Gäste starten, wenn die CPU Hardwarevirtualisierung per Intel VT-x oder AMD SVM unterstützt. Ich fürchte, dass dein alter Pentium 4 das nicht tut.
 

ralli

BSD Fanboy
Themenstarter #16
@Yamagi , obwohl mein Rechner bereits eine 64 Bit CPU hat. Ich habe ja auch ein 64 Bit FreeBSD Version hier installiert. Wie auch immer, wie ich bereits schrieb, ist für mich das Thema erledigt. Es war ja auch nur reine Neugier, die mich veranlaßte, das mal auszuprobieren. Von FreeBSD rücke ich eh nicht ab, das läuft bei mir mit dem KDE Desktop einwandfrei und ich bin zufrieden.