• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FTPD Problem: kein "active mode" Zugriff moeglich

rarnold

OpenBSD advanced beginner
Themenstarter #1
Moin,

Vorher: Habe diverse Google Anfragen ohne erfolg gestartet und RTFM
kenn ich auch schon ;-)

Nach einer Neuinstallation (Plattencrash nach Stromausfall) habe ich
ein komplettes OBSD 3.7 System neu aufgesetzt (unter partieller Verwendung
alter OBSD 3.6 etc/conf-files - > mit Diff gecheckt) und LAMP und
Apache erfolgreich konfiguriert und getestet.

Der FTPD (inetd.conf) von OBSD 3.7 verhaelt sich jedoch
"ploetzlich" merkwuerdig: Vorher konnte ich mit WS_FTP problemlos
im Standard-Mode (Passive Mode disabled) per Port 21 zugreifen.
Nun laesst mein OBSD 3.7 FTPD dies nicht mehr zu.

excerpt aus inetd.conf
ftp stream tcp nowait root /usr/libexec/ftpd ftpd -UllS

Mfg

Ronald Arnold
ivdk.org
 

rarnold

OpenBSD advanced beginner
Themenstarter #3
lsof | grep "pf" oder ps aux | grep "pf" ist negativ und auch die Datei /etc/pf existiert
nicht. Daher gehe ich davon das PF (packet filter) NICHT laeuft.

Mir wuerde schon ein Tipp reichen, wo ich nachhaken koennte, z.B. sysctl o.ae.
 
#4
rarnold hat gesagt.:
Der FTPD (inetd.conf) von OBSD 3.7 verhaelt sich jedoch
"ploetzlich" merkwuerdig: Vorher konnte ich mit WS_FTP problemlos
im Standard-Mode (Passive Mode disabled) per Port 21 zugreifen.
Nun laesst mein OBSD 3.7 FTPD dies nicht mehr zu.
Funktioniert es denn im passive mode? Was sagt ein telnet auf port 21 vom Client? Ansonsten versuch es am Client mal mit dem Command Line FTP Client um eine gescheite Fehlermeldung zu bekommen... Hm, ansonsten - Config von inetd nicht neu geladen nach dem Ändern von inetd.conf?

HTH,
Andreas
 

rarnold

OpenBSD advanced beginner
Themenstarter #5
Hallo Absi,

der Tipp mit der Kommandozeile (z.B. aus Windoof heraus) enthuellt, dass es sich um ein
spezifisches Problem zwischen dem OBSD 3.7 FTPD und WS_FTP LE 5.08 handelt.
Gelegentlich klappt ein FTP transfer zwischen WS_FTP und OBSD auch im active mode,
meisten erhalte ich aber Fehler beim Zugriff auf das remote user directory. Unter WS_FTP
muss ich also den "passive mode" aktivieren.
Als Clients-FTP Tests auf der Kommandozeile im "active mode" waren jedoch erfolgreich.
Dank an das Forum und Euch fuer eure schnelle Hilfe!

Ciao Ronaldo