• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

gdesklets broken?

s-tlk

Lion King Fan
Themenstarter #1
hi,
habe mir heute ein neues system aufgesetzt (fbsd 5.4 release) und wollte mein fluxbox ein wenig mit gdesklets aufmöbeln. und dabei ist mir aufgefallen das über 2/3 der psi displays nicht gehen. als ich mal eins gefunden haben das ging und den daemon beendet und anschließend neu gestartet habe, brach er mit der folgenden fehlermeldung ab:

Code:
==========================================================[05/18/05-23:04:29]===
=== Error in the core! Please report this bug!

[EXC]anydbm.error:
[EXC]db type could not be determined
in /usr/X11R6/lib/gdesklets/gdesklets-daemon: line 114 ?
in /usr/X11R6/lib/gdesklets/gdesklets-daemon: line 101 _gdesklets_main
in /usr/X11R6/lib/gdesklets/utils/ErrorFormatter.py: line 119 _new_imp
in /usr/X11R6/lib/gdesklets/main/Starter.py: line 2 ?
in /usr/X11R6/lib/gdesklets/utils/ErrorFormatter.py: line 119 _new_imp
in /usr/X11R6/lib/gdesklets/config/DaemonConfigger.py: line 1 ?
in /usr/X11R6/lib/gdesklets/utils/ErrorFormatter.py: line 119 _new_imp
in /usr/X11R6/lib/gdesklets/config/StateSaver.py: line 112 ?
in /usr/X11R6/lib/gdesklets/config/StateSaver.py: line 35 __init__
in /usr/local/lib/python2.4/shelve.py: line 231 open
in /usr/local/lib/python2.4/shelve.py: line 212 __init__
in /usr/local/lib/python2.4/anydbm.py: line 80 open
[---]/usr/local/lib/python2.4/anydbm.py
[---]   75             mod = _defaultmod
[---]   76         else:
[---]   77             raise error, "need 'c' or 'n' flag to open new db"
[---]   78     elif result == "":
[---]   79         # db type cannot be determined
[ERR]>  80         raise error, "db type could not be determined"
[---]   81     else:
[---]   82         mod = __import__(result)
[---]   83     return mod.open(file, flag, mode)


Exception exceptions.AttributeError: "DbfilenameShelf instance has no attribute 'writeback'" in
hat einer von euch eine ahnung was damit los ist?
 

s-tlk

Lion King Fan
Themenstarter #2
*push*
hat hier keiner eine idee?
habe nochmal etwas rum gegooglet, aber immer nur dieses oder ähnliche probleme gefunden, nur halt ohne lösung. einen ansatz bzw. eine mögliche fehlerquelle habe ich gefunden und zwar könnten die abhängikeiten probleme machen. wenn sich einige libs zanken. obwohl das system frisch installiert ist (nur fluxbox und firefox drauf) und erste wenige tage alt.

wenn das alles nicht hilft dann werde ich wohl auf idesk umsatteln.
hat wirklich keiner ähnliche erfahrungen gemacht?
 
#3
Servus!

Hatte das selbe Problem. Versuch folgendes:
  • Schau unter ~/.gdesklets/ nach einer Datei namens states[irgend`ne laufende Nummer].db.db
  • lösche diese Datei (Dann gehen Die allerdings die Positionsdaten Deiner desklets flöten)

Hat bei mir das Problem gelöst.
Ist dann vor jedem Neustart nötig... :zitter:
 

JPK

Well-Known Member
#4
Mhh, wenn ich es noch recht in erinnerung hab, liegt eines der Probleme, daran, dass sie gedesklet in der aktuellen version so umgestalltet haben. Und somit keine Sensoren mehr verwenden! Und die gdesklets in den ports bestehen ja meist daraus.

Und das andre problem hab ich leider auch bemerkt und keine lösung gefunden, und somit erstmal gdesklet von meinem system gebant! :(

mfg
JPK
 

s-tlk

Lion King Fan
Themenstarter #5
ich bilde mir ja das ich ein bisschen was vom programmieren verstehe, aber das was die da gebaut haben, da blickt man echt nicht durch! und ich hab auch kein bock mich nächte lang durch deren code salat zu wühlen, um die fehler aus zubügeln.

Also: idesk. ich komme. :)

@ mephisto
das war echt der fehler! ich bin nämlich immer hin gegangen und hab das ganze .gdesklets verzeichnis gelöscht. Aber das ist besser, wenn auch das nervt immer die position den sch... dingern neu zu zuweisen.

@euch beide
danke!
jedenfalls weiß ich jetzt das es nicht an mir liegt.

abschließend kann ich nur noch eins sagen:
tschüss gdesklets!!!

:D
 

JPK

Well-Known Member
#6
hehe, np, also auf der WS hab ich mir noch nichts weiter installiert!

Nur auffem Lapi, da läuft auch das idesk und torsmo.

Mehr brauch ich net! ;)