• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

GDM - deutsches Tastaturlayout

Sadakazu

Well-Known Member
Themenstarter #1
Moin moin...
Ich hab grad probleme den gdm das deutsche Tastaturlayout zu verpassen....
In einem Thread aus 2009 hatte ich gefunden das in der datei /etc/profile einige de_DE einstellungen geschrieben werden müssen und evtl noc gdm_lang="de_DE_ISO-8859-1" in die /etc/rc.conf geschrieben werden soll...

Hab ich beides gemacht, aber die Tastatur ist trotzdem noch auf englisch...

Einmal eingeloggt am Gnome 3 Desktop ist alles aber wie gewünscht auf Deutsch... (auch Sprache)

Woran kann es jetzt noch liegen?
 

Illuminatus

in geheimer Mission
#2
Was passiert wenn du in der /usr/local/etc/X11/xorg.conf.d/keyboard-de-oss.conf

Code:
Section    "InputClass"
    Identifier    "KeyboardDefaults"
    Driver        "keyboard"
    MatchIsKeyboard    "on"
    Option        "XkbLayout" "de"
    Option        "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
einträgst und X/gdm neu startest?
 

Sadakazu

Well-Known Member
Themenstarter #3
Keine Veränderung....
Davon abgesehen.... keyboard-de-oss.conf gabs auch gar nicht auf dem rechner...
Habe sie also neu angelegt..
gdm ist vollständig noch auf englisch.... also nicht nur Tastaturlayout sondern auch die Sprachausgabe.... (datum steht zb Thu 07.06.. oder unter dem Benutzernamen steht not listet...)
 
#4
Trage
Code:
LANG="de_DE.UTF-8"
LC_CTYPE="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
in /usr/local/etc/gdm/locale.conf ein.

Nachtrag: Wobei ich jetzt nicht prüfen kann, ob da nur die Sprache auf deutsch umgestellt wird oder auch das Tastaturlayout...
 

Sadakazu

Well-Known Member
Themenstarter #5
Wurd nur die sprache umgestellt... aber auch nur die Messages...
aber wir nähren uns dem ziel :D
warum eigentlich uft-8 und nicht iso-8859-1?
 

pit234a

Well-Known Member
#6
Wurd nur die sprache umgestellt... aber auch nur die Messages...
aber wir nähren uns dem ziel :D
warum eigentlich uft-8 und nicht iso-8859-1?
ohne Columbo0815 vorgreifen zu wollen: das ist nur ein Beispiel, evtl aus seiner eignen Conf.
Wenn du andere Einstellungen für dein System gewählt hast, solltest du die hier natürlich entsprechend konsistent setzen.
Das ist, nebenbei bemerkt und als Reaktion auf einen anderen Thread, ein typischer Fall dafür, wo eine zentrale Einstellung vielleicht viel einfacher wäre, als die jeweilige Konfiguration in Dateien für die jeweiligen Programme.

Das ist eben der Knackpunkt am Beitrag von Columbo0815. Er erklärt, dass zusätzlich zu den Systemweiten Einstellungen, die es ja für das System FreeBSD und die jeweiligen Shells gibt, außerdem auch für manche Anwendungen nochmal separate Konfigurationen existieren und er zeigt, wo diese im Fall von gdm liegen. Also nicht nur FreeBSD, nicht nur die shells, nicht nur der X-Server und das Desktop-Environment, auch einzelne Anwendungen in ihren jeweiligen Konfigurationen wollen gesetzt werden.
Nun ist aber nicht für alle Anwendung jede Einstellung möglich oder besser gesagt, für manche gibt es nicht alle möglichen Übersetzungen und deshalb kann es durchaus sein, dass man mit seiner Wunscheinstellung auch scheitert.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#7
Year, eine Charset-Diskussion! :) UTF-8, da sich das Encoding in der Unix/Linux-Welt leider durchgesetzt hat und es inzwischen überall genutzt wird. Etwas anderes zu nutzen ist daher mit größeren Schmerzen verbunden und nicht mehr unbedingt praktikabel. Ich bin zwar immer noch der Meinung, dass man damals in den sauren Apfel hätte beißen sollen und UTF-16 oder gleich UTF-32 nehmen, schon allein da UTF-8 unnötig kompliziert ist, aber man hat sich nunmal für den einfachen Weg entschieden...
 

Sadakazu

Well-Known Member
Themenstarter #8
Naja, ich kann auch alles auf UTF-8 Umstellen... ist ja kein thema... so viel an Configs ist da ja noch nicht aufgelaufen....
Davon aber einmal ab, steht im FreeBSD Handbuch halt alles mit iso-8859-15 beschrieben... da hatte ich mich halt dran gehalten....

Was BSD angeht bin ich auch noch recht neu... bin die letzten Jahre halt mit Linux so dahingedümpelt und wollt mich jetzt mal an BSD versuchen ;)

So, aber mal ein kurzes Update...
Die gesamte Sprachausgabe des GDM ist jetzt in deutsch....
Allerdings ist das Tastaturlayout immernoch in englisch.....
 

Sadakazu

Well-Known Member
Themenstarter #9
ARRRRR und Edit funktioniert hier nur 15 Minuten -.-" *nerv*
Wo wir aber grad dabei sind die Tastaturlayouts herauszufummeln...
Mal nebenbei ne andere frage.... kann man das Layout der Tastatur auch schon irgendwo in der /boot/default/loader.conf mit angeben... ich hab die Festplatte mit ZFS verschlüsselt (spielerei halt) und auch da nervt mich das mit der englischen Tastatur ein bisschen ;)
Hab eben im Handbuch im Kapitel Bootvorgang nachgelesen aber nichts gefunden, auch die Manpage zur loader.conf bringt mich da nicht weiter...
Oder wird das Tastatur Layout tatsächlich erst nach dem einlesen der rc.conf übernommen? :confused:
 

pit234a

Well-Known Member
#10
Es gibt (gab mal) eine Anleitung zum Setzen der Tastatur für den Single-User Mode. Das wäre, was du finden müsstest um die Tastatur schon vor Einlesen der rc.conf zu ändern.

In einem Desktop-System gibt es wohl drei Möglichkeiten, die Tastatur zu setzen. Wenigstens. Zu jeder Tastatur gehört dann auch ein passender charset. Meist möchte man ja nicht mit einer DE-Tastatur Französische oder chinesische Zeichen produzieren, aber manchmal vielleicht eben doch.
die rc.conf setzt die Tastatur zunächst mal für FreeBSD. Da hat man dann die HW der Tastatur zu bestimmen und kann wählen, ob DE oder was anderes.
Der zugehörige ZeichenSatz wird allgemein in der /etc/login.conf gesetzt, wobei hier Gruppen gebildet werden können, welche durch Eintrag in der /etc/master.passwd dann einzelnen Usern zugeordnet werden können.
Zusätzlich können einzelne Programme und die shells ebenfalls gesetzt werden.
Eine zweite "Schicht" stellt dann der X-Server dar, der die gleiche Tastatur benutzt aber nicht automatisch die gleichen Einstellungen wählt. Er muss evtl explizit wieder gesagt bekommen, dass er eine DE-Tastatur hat. In der Regel benutzen die DM die Einstellungen für den X-Server
Ein DesktopEnvironment kann dann wieder eine eigene Einstellung haben. Diese kann es an seine Programme übergeben, aber manchmal schafft es nicht, diese auch an fremde Programme weiter zu reichen und dann gibt es auch noch Programme, die erst ein eigenes Sprachpaket installiert haben wollen, bevor sie reagieren können.

Wie gdm das macht, davon habe ich keinen Schimmer.
Grundsätzlich solltest du ein Setting nach dem Anderen durcharbeiten und alle sinnvoll, möglichst gleich setzen.
Erfolg für GDM muss das dann nicht unbedingt haben.
 

Sadakazu

Well-Known Member
Themenstarter #11
Sagt mal... kann es nicht auch sein das es irgendwie einfach nur ein Bug ist?
ich hab grad mal geguckt welche gdm version installiert ist.... 3.16.4 ist grad bei mir drauf...
Auf irgend ner Arch Linux seite hatte ich gelesen, das es da wohl auch probleme gab nachdem auf 3.14 upgedatet wurde.....seit dem geht bei Arch wohl auch die deutsche tastatur nicht mehr....
Auf der Gnomeseite find ich auch nix in der Doku über gmd und tastatureinstellungen... außer... man soll sie nicht manuell ändern, da gdm sich die einstellungen angeblich merkt..... oO
 

Sadakazu

Well-Known Member
Themenstarter #12
Auf wunsch vom irc channel... hier ein paar configs...

/etc/rc.conf
Code:
hostname="freebsd"
keymap="german.iso.kbd"
ifconfig_em0="DHCP"
sshd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
zfs_enable="YES"

dbus_enable="YES"
hald_enable="YES"

gdm_enable="YES"
gdm_lang="de_DE.UTF8"

gnome_enable="YES"

vboxguest_enable="YES"
vboxservice_enable="YES"
/etc/profile
Code:
export LANG=de_DE.UTF-8
export LC_CTYPE=de_DE.UTF-8
export LC_COLLATE=de_DE.UTF-8
export MM_CHARSET=UTF-8
export LC_TYPE=de_DE.UTF-8
export LC_MESSAGES=de_DE.UTF-8
export LC_MONETARY=de_DE.UTF-8
export LC_NUMERIC=de_DE.UTF-8
export LC_TIME=de_DE.UTF-8
export CHARSET=UTF-8
export LC_ALL=de_DE.UTF-8
/usr/local/etc/X11/xorg.conf.d/keyboard-de-oss.conf
Code:
Section  "InputClass"
  Identifier  "KeyBoardDefaults"
  Driver  "keyboard"
  MatchIsKeyboard "on"
  Option  "Xkblayout"  "de"
  Option  "XkbOptions"  "terminate:ctrl_alt_bksp"
EndSection
/usr/local/etc/gdm/locale.conf
Code:
LANG=de_DE.UTF-8
LC_CTYPE=de_DE.UTF-8
LC_COLLATE=de_DE.UTF-8
MM_CHARSET=UTF-8
LC_TYPE=de_DE.UTF-8
LC_MESSAGES=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
CHARSET=UTF-8
LC_ALL=de_DE.UTF-8
/usr/local/etc/hal/fdi/policy/10-keymap.fdi
Code:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
  <match key="info.capabilities" contains="input.keymap">
  <append key="info.callouts.add"
type="strlist">hal-setup-keymap</append>
  </match>

  <match key="info.capabilities" contains="input.keys">
  <merge key="input.xkb.rules" type="string">base</merge>

  <!-- If we're using Linux, we use evdev by default (falling back
to
  keyboard otherwise). -->
  <merge key="input.xkb.model" type="string">keyboard</merge>
  <match
key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
  string="Linux">
  <merge key="input.xkb.model" type="string">evdev</merge>
  </match>

  <merge key="input.xkb.layout" type="string">de</merge>
  <merge key="input.xkb.variant" type="string" />
  </match>
  </device>
</deviceinfo>
 

Sadakazu

Well-Known Member
Themenstarter #13
Nachträglich nochmal eine xorg.conf, die aber dummerweise nicht funktioniert... Bildschirm bleibt schwarz....
Code:
Section "ServerLayout"
   Identifier  "X.org Configured"
   Screen  0  "Screen0" 0 0
   InputDevice  "Mouse0" "CorePointer"
   InputDevice  "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath  "/usr/local/lib/xorg/modules"
   FontPath  "/usr/local/share/fonts/misc/"
   FontPath  "/usr/local/share/fonts/TTF/"
   FontPath  "/usr/local/share/fonts/OTF/"
   FontPath  "/usr/local/share/fonts/Type1/"
   FontPath  "/usr/local/share/fonts/100dpi/"
   FontPath  "/usr/local/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver  "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver  "mouse"
   Option    "Protocol" "auto"
   Option    "Device" "/dev/sysmouse"
   Option    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier  "Monitor0"
   VendorName  "Monitor Vendor"
   ModelName  "Monitor Model"
EndSection

Section "Device"
  ### Available Driver options are:-
  ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
  ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
  ### <percent>: "<f>%"
  ### [arg]: arg optional
   Identifier  "Card0"
   Driver  "vboxvideo"
   BusID  "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device  "Card0"
   Monitor  "Monitor0"
   SubSection "Display"
     Viewport  0 0
     Depth  1
   EndSubSection
   SubSection "Display"
     Viewport  0 0
     Depth  4
   EndSubSection
   SubSection "Display"
     Viewport  0 0
     Depth  8
   EndSubSection
   SubSection "Display"
     Viewport  0 0
     Depth  15
   EndSubSection
   SubSection "Display"
     Viewport  0 0
     Depth  16
   EndSubSection
   SubSection "Display"
     Viewport  0 0
     Depth  24
   EndSubSection
EndSection
 

Fusselbär

Makefile Voyeur
#15
Mal ein paar Vorschläge:
Die /etc/profile ergänzen mit dem Eintrag:
Code:
LANG=de_DE; export LANG
Die fdi Datei für die Tastatur vereinfachen, etwa so:
Code:
cat /usr/local/etc/hal/fdi/policy/x11-input.fdi

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keyboard">
      <merge key="input.x11_options.XkbModel" type="string">pc105</merge>
      <merge key="input.x11_options.XkbLayout" type="string">de</merge>
      <merge key="input.x11_options.XkbVariant" type="string">nodeadkeys</merge>
    </match>
  </device>
</deviceinfo>
Die verwende ich so bei mir hier. Ist aber eine alte Installation, die ganz Traditionsbewusst noch mit ISO-Codierung läuft. nodeadkeys ist Geschmackssache.
Und bitte keine zwei fdi Dateien für die Tastatur verwenden. Das wurde schon ausprobiert und es lief nicht gut:
http://www.gentooforum.de/artikel/1...a92d09a4ef2a6d1322406cc03762355105#post135331
 

Sadakazu

Well-Known Member
Themenstarter #17
@foxit frag mich nicht wo ich die zeile her hatte... glaub sogar hier ausm forum.... änder ich gleich und teste es auch.... ^^
@Fusselbär die vorschläge funktionierten beide nicht... hab erst mit der profile ausprobiert.. und dann mit fdi.... aber ... ohne erfolg....
@Illuminatus ....
Code:
[  13.605]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[  13.605] X Protocol Version 11, Revision 0
[  13.605] Build Operating System: FreeBSD 10.1-RELEASE-p36 amd64
[  13.605] Current Operating System: FreeBSD bsdtutorial 10.2-RELEASE-p18 FreeBSD 10.2-RELEASE-p18 #0: Sat May 28 08:53:43 UTC 2016  root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
[  13.606] Build Date: 05 June 2016  06:08:57AM
[  13.606]
[  13.606] Current version of pixman: 0.34.0
[  13.606]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  13.606] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  13.606] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jun  9 15:22:37 2016
[  13.607] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[  13.608] (==) No Layout section.  Using the first Screen section.
[  13.608] (==) No screen section available. Using defaults.
[  13.608] (**) |-->Screen "Default Screen Section" (0)
[  13.608] (**) |  |-->Monitor "<default monitor>"
[  13.608] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  13.608] (==) Automatically adding devices
[  13.608] (==) Automatically enabling devices
[  13.608] (==) Not automatically adding GPU devices
[  13.614] (==) FontPath set to:
   /usr/local/share/fonts/misc/,
   /usr/local/share/fonts/TTF/,
   /usr/local/share/fonts/OTF/,
   /usr/local/share/fonts/Type1/,
   /usr/local/share/fonts/100dpi/,
   /usr/local/share/fonts/75dpi/
[  13.614] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[  13.614] (II) The server relies on devd to provide the list of input devices.
   If no devices become available, reconfigure devd or disable AutoAddDevices.
[  13.614] (II) Loader magic: 0x801510
[  13.614] (II) Module ABI versions:
[  13.614]    X.Org ANSI C Emulation: 0.4
[  13.614]    X.Org Video Driver: 19.0
[  13.614]    X.Org XInput driver : 21.0
[  13.614]    X.Org Server Extension : 9.0
[  13.614] (--) PCI:*(0:0:2:0) 80ee:beef:0000:0000 rev 0, Mem @ 0xe0000000/134217728, BIOS @ 0x????????/65536
[  13.614] (II) LoadModule: "glx"
[  13.617] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[  13.627] (II) Module glx: vendor="X.Org Foundation"
[  13.627]    compiled for 1.17.4, module version = 1.0.0
[  13.627]    ABI class: X.Org Server Extension, version 9.0
[  13.627] (==) AIGLX enabled
[  13.627] (==) Matched vboxvideo as autoconfigured driver 0
[  13.627] (==) Matched fbdev as autoconfigured driver 1
[  13.627] (==) Matched vesa as autoconfigured driver 2
[  13.627] (==) Assigned the driver to the xf86ConfigLayout
[  13.627] (II) LoadModule: "vboxvideo"
[  13.628] (II) Loading /usr/local/lib/xorg/modules/drivers/vboxvideo_drv.so
[  13.628] (II) Module vboxvideo: vendor="Oracle Corporation"
[  13.628]    compiled for 1.17.0, module version = 1.0.1
[  13.629]    Module class: X.Org Video Driver
[  13.629]    ABI class: X.Org Video Driver, version 19.0
[  13.629] (**) Load address of symbol "VBOXVIDEO" is 0x8059116b0
[  13.629] (II) LoadModule: "fbdev"
[  13.629] (WW) Warning, couldn't open module fbdev
[  13.629] (II) UnloadModule: "fbdev"
[  13.629] (II) Unloading fbdev
[  13.629] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  13.629] (II) LoadModule: "vesa"
[  13.629] (II) Loading /usr/local/lib/xorg/modules/drivers/vesa_drv.so
[  13.630] (II) Module vesa: vendor="X.Org Foundation"
[  13.630]    compiled for 1.17.4, module version = 2.3.4
[  13.630]    Module class: X.Org Video Driver
[  13.630]    ABI class: X.Org Video Driver, version 19.0
[  13.630] (II) VBoxVideo: guest driver for VirtualBox: vbox
[  13.630] (II) VESA: driver for VESA chipsets: vesa
[  13.630] (--) Using syscons driver with X support (version 2.0)
[  13.630] (++) using VT number 9

[  13.630] (WW) Falling back to old probe method for vesa
[  13.630] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[  13.631] (II) VBoxVideo(0): VirtualBox guest additions video driver version 4.3.38_OSEr106717
[  13.631] (II) Loading sub module "ramdac"
[  13.631] (II) LoadModule: "ramdac"
[  13.631] (II) Module "ramdac" already built-in
[  13.631] (II) Loading sub module "fb"
[  13.631] (II) LoadModule: "fb"
[  13.631] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[  13.633] (II) Module fb: vendor="X.Org Foundation"
[  13.633]    compiled for 1.17.4, module version = 1.0.0
[  13.633]    ABI class: X.Org ANSI C Emulation, version 0.4
[  13.633] (II) Loading sub module "shadowfb"
[  13.633] (II) LoadModule: "shadowfb"
[  13.633] (II) Loading /usr/local/lib/xorg/modules/libshadowfb.so
[  13.633] (II) Module shadowfb: vendor="X.Org Foundation"
[  13.633]    compiled for 1.17.4, module version = 1.0.0
[  13.633]    ABI class: X.Org ANSI C Emulation, version 0.4
[  13.633] (II) Loading sub module "vgahw"
[  13.633] (II) LoadModule: "vgahw"
[  13.633] (II) Loading /usr/local/lib/xorg/modules/libvgahw.so
[  13.634] (II) Module vgahw: vendor="X.Org Foundation"
[  13.634]    compiled for 1.17.4, module version = 0.1.0
[  13.634]    ABI class: X.Org Video Driver, version 19.0
[  13.634] (II) Loading sub module "dri"
[  13.634] (II) LoadModule: "dri"
[  13.634] (II) Module "dri" already built-in
[  13.634] (II) VBoxVideo(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[  13.634] (==) VBoxVideo(0): Depth 24, (--) framebuffer bpp 32
[  13.634] (--) VBoxVideo(0): Virtual size is 32766x32766 (pitch 32766)
[  13.634] (**) VBoxVideo(0):  Built-in mode "800x600": 29.3 MHz (scaled from 0.0 MHz), 36.4 kHz, 60.0 Hz
[  13.634] (II) VBoxVideo(0): Modeline "800x600"x0.0  29.31  800 802 804 806  600 602 604 606 (36.4 kHz b)
[  13.634] (**) VBoxVideo(0):  Built-in mode "800x600": 29.3 MHz (scaled from 0.0 MHz), 36.4 kHz, 60.0 Hz
[  13.634] (II) VBoxVideo(0): Modeline "800x600"x0.0  29.31  800 802 804 806  600 602 604 606 (36.4 kHz b)
[  13.634] (II) VBoxVideo(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0
[  13.634] (==) VBoxVideo(0): RGB weight 888
[  13.634] (==) VBoxVideo(0): Default visual is TrueColor
[  13.634] (==) VBoxVideo(0): Using gamma correction (1.0, 1.0, 1.0)
[  13.634] (==) VBoxVideo(0): DPI set to (96, 96)
[  13.634] (II) UnloadModule: "vesa"
[  13.634] (II) Unloading vesa
[  13.634] (--) Depth 24 pixmap format is 32 bpp
[  14.025] drmOpenDevice: node name is /dev/dri/card0
[  14.025] Failed to change owner or group for file /dev/dri! 2: No such file or directory
[  14.025] Failed to change owner or group for file /dev/dri/card0! 2: No such file or directory
[  14.025] drmOpenDevice: open result is -1, (No such file or directory)
[  14.025] Failed to change owner or group for file /dev/dri/card0! 2: No such file or directory
[  14.026] drmOpenDevice: open result is -1, (No such file or directory)
[  14.026] drmOpenDevice: Open failed
[  14.026] drmOpenDevice: node name is /dev/dri/card0
[  14.026] Failed to change owner or group for file /dev/dri! 2: No such file or directory
[  14.026] Failed to change owner or group for file /dev/dri/card0! 2: No such file or directory
[  14.026] drmOpenDevice: open result is -1, (No such file or directory)
[  14.026] Failed to change owner or group for file /dev/dri/card0! 2: No such file or directory
[  14.026] drmOpenDevice: open result is -1, (No such file or directory)
[  14.026] drmOpenDevice: Open failed
[  14.026] [drm] failed to load kernel module "vboxvideo"
[  14.026] (EE) [drm] drmOpen failed.
[  14.026] (EE) VBoxVideo(0): DRIScreenInit failed, disabling DRI.
[  14.026] (II) VBoxVideo(0): visual configurations initialized
[  14.028] (II) VBoxVideo(0): Requested monitor count: 1
[  14.028] (II) VBoxVideo(0): Output VGA-0 has no monitor section
[  14.028] (II) VBoxVideo(0): Output VGA-0 has no monitor section
[  14.028] (II) VBoxVideo(0): Printing probed modes for output VGA-0
[  14.028] (II) VBoxVideo(0): Modeline "1904x959"x60.0  110.59  1904 1906 1908 1910  959 961 963 965 (57.9 kHz Pb)
[  14.028] (II) VBoxVideo(0): Modeline "2560x1600"x60.0  247.26  2560 2562 2564 2566  1600 1602 1604 1606 (96.4 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "2560x1440"x60.0  222.63  2560 2562 2564 2566  1440 1442 1444 1446 (86.8 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "2048x1536"x60.0  190.04  2048 2050 2052 2054  1536 1538 1540 1542 (92.5 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "1920x1600"x60.0  185.59  1920 1922 1924 1926  1600 1602 1604 1606 (96.4 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "1920x1080"x60.0  125.50  1920 1922 1924 1926  1080 1082 1084 1086 (65.2 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "1600x1200"x60.0  116.21  1600 1602 1604 1606  1200 1202 1204 1206 (72.4 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "1680x1050"x60.0  106.82  1680 1682 1684 1686  1050 1052 1054 1056 (63.4 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "1400x1050"x60.0  89.08  1400 1402 1404 1406  1050 1052 1054 1056 (63.4 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "1280x1024"x60.0  79.47  1280 1282 1284 1286  1024 1026 1028 1030 (61.8 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "1024x768"x60.0  47.83  1024 1026 1028 1030  768 770 772 774 (46.4 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "800x600"x60.0  29.31  800 802 804 806  600 602 604 606 (36.4 kHz b)
[  14.028] (II) VBoxVideo(0): Modeline "640x480"x60.0  18.84  640 642 644 646  480 482 484 486 (29.2 kHz b)
[  14.028] (II) VBoxVideo(0): Output VGA-0 connected
[  14.028] (II) VBoxVideo(0): Using exact sizes for initial modes
[  14.028] (II) VBoxVideo(0): Output VGA-0 using initial mode 1904x959
[  14.028] (II) VBoxVideo(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  14.028] (II) VBoxVideo(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  14.035] (==) VBoxVideo(0): DPMS enabled
[  14.035] (--) RandR disabled
[  14.038] (II) AIGLX: Screen 0 is not DRI2 capable
[  14.038] (EE) AIGLX: reverting to software rendering
[  14.367] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[  14.367] (II) AIGLX: Loaded and initialized swrast
[  14.367] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[  14.367] (II) VBoxVideo(0): Setting screen physical size to 503 x 253
[  14.547] (II) config/devd: probing input devices...
[  14.547] (II) config/devd: adding input device (null) (/dev/kbdmux)
[  14.547] (**) kbdmux: Applying InputClass "KeyBoardDefaults"
[  14.547] (**) kbdmux: Applying InputClass "KeyBoardDefaults"
[  14.547] (II) LoadModule: "kbd"
[  14.547] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[  14.548] (II) Module kbd: vendor="X.Org Foundation"
[  14.548]    compiled for 1.17.4, module version = 1.8.1
[  14.548]    Module class: X.Org XInput Driver
[  14.548]    ABI class: X.Org XInput driver, version 21.0
[  14.548] (II) Using input driver 'kbd' for 'kbdmux'
[  14.548] (**) kbdmux: always reports core events
[  14.548] (**) kbdmux: always reports core events
[  14.548] (**) Option "Protocol" "standard"
[  14.548] (**) Option "XkbRules" "base"
[  14.548] (**) Option "XkbModel" "pc105"
[  14.548] (**) Option "XkbLayout" "de"
[  14.548] (**) Option "XkbOptions" "terminate:ctrl_alt_bksp"
[  14.548] (**) Option "config_info" "devd:kbdmux"
[  14.548] (II) XINPUT: Adding extended input device "kbdmux" (type: KEYBOARD, id 6)
[  14.576] (II) config/devd: kbdmux is enabled, ignoring device atkbd0
[  14.576] (II) config/devd: adding input device (null) (/dev/sysmouse)
[  14.576] (II) LoadModule: "mouse"
[  14.577] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[  14.578] (II) Module mouse: vendor="X.Org Foundation"
[  14.578]    compiled for 1.17.4, module version = 1.9.1
[  14.578]    Module class: X.Org XInput Driver
[  14.578]    ABI class: X.Org XInput driver, version 21.0
[  14.578] (II) Using input driver 'mouse' for 'sysmouse'
[  14.579] (**) sysmouse: always reports core events
[  14.579] (**) Option "Device" "/dev/sysmouse"
[  14.579] (==) sysmouse: Protocol: "Auto"
[  14.579] (**) sysmouse: always reports core events
[  14.579] (==) sysmouse: Emulate3Buttons, Emulate3Timeout: 50
[  14.579] (**) sysmouse: ZAxisMapping: buttons 4 and 5
[  14.579] (**) sysmouse: Buttons: 5
[  14.579] (**) Option "config_info" "devd:sysmouse"
[  14.579] (II) XINPUT: Adding extended input device "sysmouse" (type: MOUSE, id 7)
[  14.579] (**) sysmouse: (accel) keeping acceleration scheme 1
[  14.579] (**) sysmouse: (accel) acceleration profile 0
[  14.579] (**) sysmouse: (accel) acceleration factor: 2.000
[  14.579] (**) sysmouse: (accel) acceleration threshold: 4
[  14.579] (II) sysmouse: SetupAuto: hw.iftype is 4, hw.model is 0
[  14.579] (II) sysmouse: SetupAuto: protocol is SysMouse
[  14.611] (II) config/devd: adding input device Mouse (/dev/psm0)
[  14.611] (II) Using input driver 'mouse' for 'Mouse'
[  14.611] (**) Mouse: always reports core events
[  14.611] (**) Option "Device" "/dev/psm0"
[  14.611] (==) Mouse: Protocol: "Auto"
[  14.611] (**) Mouse: always reports core events
[  14.644] (==) Mouse: Emulate3Buttons, Emulate3Timeout: 50
[  14.644] (**) Mouse: ZAxisMapping: buttons 4 and 5
[  14.644] (**) Mouse: Buttons: 5
[  14.644] (**) Option "config_info" "devd:psm0"
[  14.644] (II) XINPUT: Adding extended input device "Mouse" (type: MOUSE, id 8)
[  14.644] (**) Mouse: (accel) keeping acceleration scheme 1
[  14.644] (**) Mouse: (accel) acceleration profile 0
[  14.644] (**) Mouse: (accel) acceleration factor: 2.000
[  14.644] (**) Mouse: (accel) acceleration threshold: 4
[  14.650] (II) Mouse: SetupAuto: hw.iftype is 3, hw.model is 10
[  14.650] (II) Mouse: SetupAuto: protocol is ExplorerPS/2
[  15.018] (II) Mouse: ps2EnableDataReporting: succeeded
[  15.019] (II) config/devd: adding input device (null) (/dev/vboxguest)
[  15.019] (II) LoadModule: "vboxmouse"
[  15.020] (II) Loading /usr/local/lib/xorg/modules/input/vboxmouse_drv.so
[  15.022] (II) Module vboxmouse: vendor="Oracle Corporation"
[  15.022]    compiled for 0.0.0, module version = 1.0.0
[  15.022]    Module class: X.Org XInput Driver
[  15.022]    ABI class: X.Org XInput driver, version 21.0
[  15.022] (**) Load address of symbol "VBOXMOUSE" is 0x820214cc0
[  15.022] (II) Using input driver 'vboxmouse' for 'vboxguest'
[  15.023] (**) vboxguest: always reports core events
[  15.023] (**) Option "Device" "/dev/vboxguest"
[  15.023] (**) vboxguest: Device: "/dev/vboxguest"
[  15.023] (**) Option "config_info" "devd:vboxguest"
[  15.023] (II) XINPUT: Adding extended input device "vboxguest" (type: MOUSE, id 9)
[  15.023] (**) vboxguest: (accel) keeping acceleration scheme 1
[  15.023] (**) vboxguest: (accel) acceleration profile 0
[  15.023] (**) vboxguest: (accel) acceleration factor: 2.000
[  15.024] (**) vboxguest: (accel) acceleration threshold: 4
[  15.024] (II) vboxguest: On.
[  15.024] (WW) fcntl(10, O_ASYNC): Inappropriate ioctl for device
EDIT
Nein die änderung von de_DE.UTF8 auf de_DE.UTF-8 hat auch nix gebracht ^^
 

Fusselbär

Makefile Voyeur
#18
Laut dem /var/log/Xorg.0.log hat der X-Server die Konfiguration aus der /usr/local/etc/X11/xorg.conf.d/keyboard-de-oss.conf übernommen:
Code:
Section  "InputClass"
  Identifier  "KeyBoardDefaults"
  Driver  "keyboard"
  MatchIsKeyboard "on"
  Option  "Xkblayout"  "de"
  Option  "XkbOptions"  "terminate:ctrl_alt_bksp"
EndSection
Der Abschnitt im /var/log/Xorg.0.log dazu:
Code:
[  14.547] (II) config/devd: probing input devices...
[  14.547] (II) config/devd: adding input device (null) (/dev/kbdmux)
[  14.547] (**) kbdmux: Applying InputClass "KeyBoardDefaults"
[  14.547] (**) kbdmux: Applying InputClass "KeyBoardDefaults"
[  14.547] (II) LoadModule: "kbd"
[  14.547] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[  14.548] (II) Module kbd: vendor="X.Org Foundation"
[  14.548]    compiled for 1.17.4, module version = 1.8.1
[  14.548]    Module class: X.Org XInput Driver
[  14.548]    ABI class: X.Org XInput driver, version 21.0
[  14.548] (II) Using input driver 'kbd' for 'kbdmux'
[  14.548] (**) kbdmux: always reports core events
[  14.548] (**) kbdmux: always reports core events
[  14.548] (**) Option "Protocol" "standard"
[  14.548] (**) Option "XkbRules" "base"
[  14.548] (**) Option "XkbModel" "pc105"
[  14.548] (**) Option "XkbLayout" "de"
[  14.548] (**) Option "XkbOptions" "terminate:ctrl_alt_bksp"
[  14.548] (**) Option "config_info" "devd:kbdmux"
hal wird nicht benutzt, sondern devd, daher wird die fdi Datei den X-Server wohl eher weniger kümmern.
 

Sadakazu

Well-Known Member
Themenstarter #19
Das die keyboard-de-oss.conf übernommen wurde hab ich auch gesehen als ich das log durchgegangen bin...
Aber wenn xorg eine DE tastatur zugewiesen bekommen hat, warum ignoriert gdm die tastatur und benutzt us?
 
#20
Das die keyboard-de-oss.conf übernommen wurde hab ich auch gesehen als ich das log durchgegangen bin...
Aber wenn xorg eine DE tastatur zugewiesen bekommen hat, warum ignoriert gdm die tastatur und benutzt us?
Nur eine Vermutung: gdm3 gehört zu gnome. gnome hat (wie zB xfce auch) eine Konfig, die die Settings von X überschreibt (warum auch immer). Würdest du nun gnome nutzen, könntest du gdm konfigurieren. Da du keines nutzt, werden die Defaulteinstellungen (=englisch) verwendet.
 
#21
Moin !

Das Problem mit dem Tastaturlayout ist auch bei Linux vorhanden !


Bei Kubuntu mit KDE5 und SDDM Kann man auch die Oberfläche auf deutsch stellen ,
jedoch bleibt die Tastatur Englisch !

Abhilfe : In die /usr/share/sddm/scripts/Xsetup folgenden Eintrag hinzufügen ---> setxkbmap de ,
Neustart --> alles deutsch


Bei Void-Linux mit LightDM auch , Oberfläche Deutsch , Tastatur Englisch !

Abhilfe : In die lightdm.conf ,
[SeatDefaults]
display-setup-script=setxkbmap de
Neustart --> alles deutsch



Als ich KDE4 unter FreeBSD mit "kdm" benutzt hatte , war es das gleiche Spielchen !
Leider weiss ich nicht mehr genau wie die Datei hiess und wo Sie lag , aber ich glaube
es war /usr/local/etc/kdm und die Datei war Xressouces !

Auf jeden Fall musste ich auch diese um den Eintrag "setxkbmap de" erweitern und erst
dann hatte ich die Deutsche Tastatur !



Fazit : Auch GDM wird ja irgenwelche " X-setup-dateien" einlesen !
Man muss Sie nur finden ! :huth:


Mit Slim und FreeBSD verhält es sich ebenso ! Habe mal versucht Slim die
deutsche Tastatur beizubringen , leider nicht geschafft !

Gruss
 

Sadakazu

Well-Known Member
Themenstarter #22
@Columbo0815 ... ich sagt doch.... Gnome3 ist vollständig auf deutsch.... auch die BSD Konsole (system Konsole) ist auf deutsch.... NUR gdm nicht... und wie @bluescreen schon sagte ist das problem auch bei Linux vorhanden....
Also erhärtet sich mein Verdacht, das es an gdm selber liegt...
Bei Arch ist das Problem halt schon seit der gdm version 3.14 bei mir aktuell installiert ist 3.16.4

das mit setxkbmap de hatte ich übrigens auch schon versucht, aber hat auch nicht geklappt....
bzw ich hatte irgendwo gefunden das... puh ja keine ahnung muss ich suchen..... xD ist aber in irgend einer datei auch noch mit eingetragen.... glaub irgendwo bei /usr/local/etc/X11/xinit/*

EDIT:
Das will ich jetzt wissen... ich lad mir fix Debian runter... die verwenden ja auch Gnome3 und gdm
wenns da geht aber bei allen anderen nicht...... dann weiß ich auch nicht xD
 

pit234a

Well-Known Member
#23
der dunkle Bildschirm ist ein Zeichen, dass X funktioniert (wahrscheinlich), denn das ist nun mal das Default-Testbild.

Welches Tastatur-Layout du in X hast (also außerhalb von GNOME3), müsstest du halt testen, ohne GNOME3 zu starten. Vielleicht hast du OpenBox installiert? Wenn nicht, geht das sehr schnell. Dann mal einfach sehen, was in einer OpenBox-Sitzung geht, etwa in einem X-Terminal.

Wenn die Tastatur auf der Konsole korrekt ist und unter X korrekt ist und unter GNOME3 korrekt ist und nur unter GDM nicht und wenn du dann keine Konfiguration finden kannst (weil vielleicht keine existiert oder sie Bestandteil von GNOME2 ist und deshalb bei dir nicht installiert wurde), dann würde ich auch meinen, dass es mit gdm einfach nicht geht.

Ich wollte das eigentlich auch mal testen und gdm flott installieren, schreckte dann aber vor der Vielzahl an Abhängigkeiten zurück. Stattdessen habe ich dann flux mal XDM genommen und probiert und der nimmt ohne zu Murren meine Deutsche Tastatur mit Umlauten etc.
 

pit234a

Well-Known Member
#24
oh, man muss natürlich nicht OpenBox installieren. Ich vergaß.
Ohne jede Änderungen startet ein einfaches startx ja den TWM mit einigen Fenstern und Anwendungen und da kann man natürlich auch testen. Dazu darf GDM dann nicht gestartet werden.