Geht wirklich kein Client Zugriff auf einen SMB V2 File Server?

hbauer

Member
Ich versuche mit einem FreeBSD Rechner auf einen SMB V2 Share zuzugreifen.

Zu meiner großen Verwunderung scheint das aktuelle nicht zu gehen. SMB1 ging wohl mal aber für SMBV2/V3 scheint es noch nicht einmal Pläne zu geben.

smbnetfs habe versucht komme aber nicht weiter.

Gibt es jemanden der hier erfolgreich war oder ist das wirklich nicht möglich? Ich bin einer vielzahl von "vagen" Hinweisen nachgegangen und bräuchte jetzt nur noch jemanden der es wirklich hinbekommen hat.

Ich bin eigentlich recht glücklich mit meinem FreeBSD Client aber wenn ich das nicht hinbekomme muss ich wohl wieder zu LInux zurückgehen.
 

Columbo0815

Kaffeemann
Teammitglied
Moin,

laut MOUNT_SMBFS (8) heißt es: "mount_smbfs offers support for SMB/CIFS/SMB1. It does not support newer versions of the protocol like SMB2 and SMB3. SMB2 and SMB3 are supported by software available in the ports(7) collection.". Gefunden habe ich noch: https://wiki.freebsd.org/MateuszPiotrowski/AccessingSmbSharesWithSambaClient

Daraus schließe ich, dass du dir Samba installieren musst, auch wenn du keinen smb_server sondern nur einen Client betreiben willst. Eine "Krücke", mit der ich leben könnte.

HTH!
 

hbauer

Member
Vielen Dank für den Hinweis. smbclient als eine Art ftp client erlaubt natürlich den Zugriff. Ich muss meine Frage präzisieren.

Das Ziel ist das normale mounten eines Shares.
 

midnight

OpenBSD & FreeBSD
Das gleiche Problem hatte ich auch auf der Arbeit. Nun habe ich es umschifft, indem ich jetzt KDE Plasma 5 nutze. Das war zuerst etwas ungewohnt, aber inzwischen habe ich mich angepasst und daran gewoehnt. KDE hat gvfs gut im System integriert. In Dolphin kann ich einfach mit smb://server_name/share_name auf die Daten des Windows-Servers zugreifen, als waeren sie lokal. Ich kann Dokumente, Grafiken und PDF's oeffnen, in Thunderbird an die Email anhaengen usw. Gnome konnte ich auf der Arbeit noch nicht testen. Ich gehe aber davon aus, dass es dort aehnlich ist. Unter Xfce4 habe ich Thunar mit gvfs nicht dazu gebracht, dass die Dokumente direkt vom Server geoeffnet werden.
 
Zuletzt bearbeitet:

mr44er

moderater Moderator
Teammitglied

Hatte das auch schon im Einsatz. Wichtig ist, dass man die Pfade lieber doppelt prüft und dem Mountvorgang einige Bedenksekunden gönnt.
 

Andy_m4

Well-Known Member
Aber nur um sicherzugehen. Wir reden von SMB V2 mit smbnetfs?
fusefs-smbnetfs macht selbst eigentlich gar kein SMB, sondern nutzt die vorhandene Samba-Lib (heißt irgendwie libsmbclient.so.0 oder so) aus dem Paket samba412 (oder welche Version auch immer). Da wo auch dieser von Dir angesprochene FTP-like Client drin ist. Sprich: Wenns damit klappt, solltest Du es auch mit fusefs-smbnetfs hinkriegen.
 

midnight

OpenBSD & FreeBSD
Du kannst es ja einfach mal ausprobieren, z.B.:

Code:
$ mkdir $HOME/windows_share
# pkg install fusefs-smbnetfs
# cat /etc/fstab
...
//hbauer@SERVERNAME/share_name /home/hbauer/windows_share smbfs rw 0 0
...

# cat /etc/nsmb.conf
...
[SERVERNAME:HBAUER]
charsets=UTF-8:UTF-8
nbns=192.168.1.1
workgroup=WORKGROUP
password=1234
...

SERVERNAME usw. musst Du natuerlich entsprechend anpassen.
 

hbauer

Member
Hallo Midnight, vielen dank für den Ansatz. Da ich kein KDE haben möchte versuche ich jetzt weiter mit smbnetfs von einem FreeBSD 12.2 Rechner aus das SMB V2 Laufwerk zu mounten. Das sind meine Schritte die ich durchgeführt haben.

Code:
sudo pkg install fusefs-smbnetfs
vi /etc/rc.conf
kld_list="/boot/modules/i915kms.ko acpi_ibm fuse"
fusefs_enable="YES"

sysctl vfs.usermount
vfs.usermount: 1

mkdir .smb
cp /usr/local/etc/smb4.conf .smb/smb.conf
cp /usr/local/share/doc/smbnetfs-0.6.1/smbnetfs.conf .smb
echo 'auth freenas sonos sonos' > .smb/smbnetfs.auth
chmod 600 .smb/smbnetfs.auth

mkdir freenas
smbnetfs freenas

Leider werden im Verzeichnis Freenas auch nach einiger Wartezeit keine Shares angeboten.

Code:
ls freenas
total 0

Auf der Seite von Freenas müsste eigentlich alles stimmen. Ich kann die Laufwerke von Linux / Mac Rechner mounten. Von meinem FreeBSD Client sehe ich auch Freigaben für den Benutzer Sonos. Der Benutzer Sonos ist ein zulässiger Benutzer mit einem Kennwort das auch Share sehen darf.

Code:
smbclient -L freenas -U sonos
Enter WORKGROUP\sonos's password:

        Sharename       Type      Comment
        ---------       ----      -------
        IPC$            IPC       IPC Service (FreeNAS Server)
        sonos           Disk
        bilder          Disk
        .....
        .....
        .....
SMB1 disabled -- no workgroup available

Im Log kann ich auch keine hilfreiche Information finden

Code:
52484->reconfigure_read_config_file: reading file: /home/hbauer/.smb/smbnetfs.auth
52484->stat_workaround_add_name_internal: name=.directory, case_sensitive=1, depth=3
52484->stat_workaround_add_name_internal: name=.git, case_sensitive=1, depth=3
52484->stat_workaround_add_name_internal: name=HEAD, case_sensitive=1, depth=3
52484->stat_workaround_add_name_internal: name=desktop.ini, case_sensitive=0, depth=3
52484->stat_workaround_add_name_internal: name=autorun.inf, case_sensitive=1, depth=1
52484->stat_workaround_add_name_internal: name=.xdg-volume-info, case_sensitive=1, depth=1
52904->event_scan_smb_root: reading group list
52904->samba_get_ctx: name='/'
52904->samba_get_ctx: ctx_total=15, list=(/[1], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0])
52904->process_start_new_smb_conn: starting new child with pid=52965, fd=6
srv(52965)->smb_conn_srv_listen: process query=7, query_len=10
52904->samba_release_ctx: ctx->name=/[1]
52904->samba_release_ctx: ctx_total=15, list=(/[0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0], [0])


Hat jemand eine Idee was ich vergessen haben könnte?
 

medV2

Well-Known Member
Zeig mal deine smbnetfs.conf, aber ich denke deine Auth Direktive ist falsch.
Die sollte so aussehen:

auth "IP/Share" "User" "password"

Anstatt IP kannst du auch den netbiosname nehmen aber nimm lieber die IP wenn möglich um da Fehler auszuschließen.
 

hbauer

Member
die smbnetfs. ist standard. Das einzige was ich auskommentiert habe ist das Loglevel und -file

Code:
grep -v  ^# smbnetfs.conf

smbnetfs_debug          9
log_file                "/tmp/smbnetfs.log"
include                 "smbnetfs.auth"

Deinen Änderungsvorschlag in der smbnetfs.auth habe ich ohne Erfolg ausprobiert.

Code:
auth "192.168.1.18/sonos" "sonos" "sonos"

Nach meinem Verständnis wird damit das Kennwort nur auf auf den einen Share angewendet und nicht auf andere Shares auf dem Server. Anyway die Änderung bringt auch keine Vorteile.
 

midnight

OpenBSD & FreeBSD
Ich habe das gerade auf der Arbeit getestet. Bei mir funktioniert es unter FreeBSD 13.0.

Code:
# pkg install fusefs-smbnetfs
# mkdir /smb
# echo "-oallow_other /smb fusefs rw,allow_other,failok,uid=105,late,direct_io,mountprog=/usr/local/bin/smbnetfs" >> /etc/fstab
# echo "vfs.usermount=1" >> /etc/sysctl.conf.local
# cat /etc/rc.conf
...
kld_list="[...] fusefs.ko"
fusefs_enable="YES"
...
$ mkdir ~/.smb
$ cat ~/.smb/smbnetfs.conf
smbnetfs_debug 9
log_file "/tmp/smbnetfs.log"
$ mount | grep fuse
/dev/fuse on /smb (fusefs)
$ ls -l /smb
total 0
$ cd /smb/username:userpassword@192.168.1.1/Windows_Share
$ du -sh
 34G    .
 
Zuletzt bearbeitet:

hbauer

Member
wow. Da habe ich wohl irgenwo eine Menge Doku übersehen. Ich war bisher davon ausgegangen das die im Netzwerk gefundenen Shares nach einiger Zeit angezeigt werden. Deswegen bin ich wegen einem leeren Verzeichnis davon ausgegangen das etwas noch nicht stimmt.

Also ich kann jetzt auch mit der Syntax

Code:
more .smb/smbnetfs.auth
auth "nasname" "user" "password"

in

Code:
~/smb/nasmane

die Shares sehen, in Verzeichnisse wechseln und die Datein bearbeiten.

Super, vielen Dank
 
Oben